Internet Small Computer System Interface (iSCSI) Parameters

Created

  • 2003-04-16

Last Updated

  • 2014-04-08

Available Formats


iSCSI authentication methods

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Number Authentication Method Reference
0 Reserved
1 CHAP RFC 7143
2 SRP RFC 7143
3 KRB5 RFC 7143
4 SPKM1 (OBSOLETE) RFC 7143
5 SPKM2 (OBSOLETE) RFC 7143
6-255 Reserved (Not assigned by IANA) RFC 7143
256-65535 Unassigned

iSCSI digests

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Number Digest Reference
0 Reserved RFC 7143
1 CRC32c RFC 7143
2-255 Reserved (Not assigned by IANA) RFC 7143
256-65535 Unassigned

SRP_GROUP key values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3723: Securing Block Storage Protocols over IP

Note

When a MODP group is used with SRP, the generator (g) value differs from the usual generator of 2. Consult the appropriate reference for the correct generator to use.

Available Formats

Key Value Group Description Reference
SRP-768 768 bit SRP group RFC 3723
SRP-1024 1024 bit SRP group RFC 3723
SRP-1280 1280 bit SRP group RFC 3723
SRP-1536 1536 bit SRP group RFC 3723
SRP-2048 2048 bit SRP group RFC 3723
MODP-3072 3072 bit MODP group RFC 3723
MODP-4096 4096 bit MODP group RFC 3723
MODP-6144 6144 bit MODP group RFC 3723
MODP-8192 8192 bit MODP group RFC 3723

iSCSI Opcodes

Registration Procedure(s)

  • Standards Action to define the semantics of the opcode; Expert Review to select the specific opcode(s)

Expert(s)

  • Unassigned

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Note

Namespace details: Numerical values that can fit in one octet with most significant two bits (bits 0 and 1) already designated by RFC 7143, bit 0 being reserved and bit 1 for immediate delivery. Bit 2 is designated to identify the originator of the opcode. Bit 2 = 0 for initiator and Bit 2 = 1 for target.

Note

Reserved to IANA:

0x07-0x0f, 0x13-0x1b (initiator codes)
0x27-0x2f, 0x33-0x3b (target codes)

Reserved to IANA for allocation only if no opcode pair is available:

0x11, 0x12, 0x1f (initiator codes)
0x30 (target codes)

Available Formats

Opcode Originator Operation Name Reference
0x00 Initiator NOP-Out RFC 7143
0x01 Initiator SCSI Command RFC 7143
0x02 Initiator SCSI Task Management Function Request RFC 7143
0x03 Initiator Login Request RFC 7143
0x04 Initiator Text Request RFC 7143
0x05 Initiator SCSI Data-Out RFC 7143
0x06 Initiator Logout Request RFC 7143
0x10 Initiator SNACK Request RFC 7143
0x1c-0x1e Initiator Vendor-specific codes RFC 7143
0x20 Target NOP-In RFC 7143
0x21 Target SCSI Response RFC 7143
0x22 Target SCSI Task Management Function Response RFC 7143
0x23 Target Login Response RFC 7143
0x24 Target Text Response RFC 7143
0x25 Target SCSI Data-In RFC 7143
0x26 Target Logout Response RFC 7143
0x31 Target Ready To Transfer (R2T) RFC 7143
0x32 Target Asynchronous Message RFC 7143
0x3c-0x3e Target Vendor-specific codes RFC 7143
0x3f Target Reject RFC 7143

iSCSI Login/Text Keys

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7145: Internet Small Computer System Interface (iSCSI) Extensions for the Remote Direct Memory Access (RDMA) Specification
  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Key Reference
AuthMethod RFC 7143
DataDigest RFC 7143
DataPDUInOrder RFC 7143
DataSequenceInOrder RFC 7143
DefaultTime2Retain RFC 7143
DefaultTime2Wait RFC 7143
ErrorRecoveryLevel RFC 7143
FirstBurstLength RFC 7143
HeaderDigest RFC 7143
ImmediateData RFC 7143
InitialR2T RFC 7143
InitiatorAlias RFC 7143
InitiatorName RFC 7143
InitiatorRecvDataSegmentLength RFC 7145
iSCSIProtocolLevel RFC 7144
iSERHelloRequired RFC 7145
MaxAHSLength RFC 7145
MaxBurstLength RFC 7143
MaxConnections RFC 7143
MaxOutstandingR2T RFC 7143
MaxOutstandingUnexpectedPDUs RFC 7145
MaxRecvDataSegmentLength RFC 7143
RDMAExtensions RFC 7145
SendTargets RFC 7143
SessionType RFC 7143
TaggedBufferForSolicitedDataOnly RFC 7145
TargetAddress RFC 7143
TargetAlias RFC 7143
TargetName RFC 7143
TargetPortalGroupTag RFC 7143
TargetRecvDataSegmentLength RFC 7145
TaskReporting RFC 7143
X#NodeArchitecture RFC 7143

iSCSI Asynchronous Events

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Event Number
(one octet)
Description Reference
0 SCSI Async Event RFC 7143
1 Logout Request RFC 7143
2 Connection drop notification RFC 7143
3 Session drop notification RFC 7143
4 Negotiation Request RFC 7143
5 Task termination RFC 7143
6-247 Unassigned
248-254 Vendor-unique RFC 7143
255 Vendor-unique RFC 7143

iSCSI Task Management Function Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

TMF Code
(7 bits)
Description Reference
1 ABORT TASK RFC 7143
2 ABORT TASK SET RFC 7143
3 CLEAR ACA RFC 7143
4 CLEAR TASK SET RFC 7143
5 LOGICAL UNIT RESET RFC 7143
6 TARGET WARM RESET RFC 7143
7 TARGET COLD RESET RFC 7143
8 TASK REASSIGN RFC 7143
9 QUERY TASK RFC 7144
10 QUERY TASK SET RFC 7144
11 I_T NEXUS RESET RFC 7144
12 QUERY ASYNCHRONOUS EVENT RFC 7144
13-127 Unassigned

iSCSI Login Response Status Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Status Class
(one octet)
Description Reference
0x00 Success RFC 7143
0x01 Redirection RFC 7143
0x02 Initiator Error RFC 7143
0x03 Target Error RFC 7143
0x04-0x0e Unassigned
0x0f Vendor-Unique RFC 7143
0x10-0xff Unassigned

Status-Detail for Status-Class=0x00

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Status Class
(fixed)
Status Code
(one octet)
Description Reference
0x00 0x00 Success RFC 7143
0x00 0x01-0xff Unassigned

Status-Detail for Status-Class=0x01

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Status Class
(fixed)
Status Code
(one octet)
Description Reference
0x01 0x01 Target moved temporarily RFC 7143
0x01 0x02 Target moved permanently RFC 7143
0x01 0x03-0xff Unassigned

Status-Detail for Status-Class=0x02

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Status Class
(fixed)
Status Code
(one octet)
Description Reference
0x02 0x00 Initiator error RFC 7143
0x02 0x01 Authentication failure RFC 7143
0x02 0x02 Authorization failure RFC 7143
0x02 0x03 Not found RFC 7143
0x02 0x04 Target removed RFC 7143
0x02 0x05 Unsupported version RFC 7143
0x02 0x06 Too many connections RFC 7143
0x02 0x07 Missing parameter RFC 7143
0x02 0x08 Can't include in session RFC 7143
0x02 0x09 Session type not supported RFC 7143
0x02 0x0a Session does not exist RFC 7143
0x02 0x0b Invalid during login RFC 7143
0x02 0x0c-0xff Unassigned

Status-Detail for Status-Class=0x03

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Status Class
(fixed)
Status Code
(one octet)
Description Reference
0x03 0x00 Target error RFC 7143
0x03 0x01 Service unavailable RFC 7143
0x03 0x02 Out of resources RFC 7143
0x03 0x03-0xff Unassigned

iSCSI Reject Reason Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7143: Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)

Available Formats

Reason Code
(one octet)
Description Reference
0x01 Reserved RFC 7143
0x02 Data digest error RFC 7143
0x03 SNACK Reject RFC 7143
0x04 Protocol Error RFC 7143
0x05 Command not supported RFC 7143
0x06 Immediate command reject RFC 7143
0x07 Task in progress RFC 7143
0x08 Invalid data ack RFC 7143
0x09 Invalid PDU field RFC 7143
0x0a Long op reject RFC 7143
0x0b "Deprecated reason code" RFC 7143
0x0c Waiting for Logout RFC 7143
0x0d-0xff Unassigned

iSER Opcodes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7145: Internet Small Computer System Interface (iSCSI) Extensions for the Remote Direct Memory Access (RDMA) Specification

Available Formats

Value Description Reference
0x1 iSCSI control-type PDU RFC 7145
0x2 iSER Hello Message RFC 7145
0x3 iSER HelloReply Message RFC 7145
0x4-0xf Unassigned

iSCSI Protocol Level

Registration Procedure(s)

  • Expert Review and Standards Action

Expert(s)

  • Unassigned

Reference

  • RFC 7144: Internet Small Computer System Interface (iSCSI) SCSI Features Update

Available Formats

Value Description Reference
0 No version claimed RFC 7144
1 RFC7143 RFC 7143
2 RFC7144 RFC 7144
3-31 Unassigned

iSCSI Task Management Function Response Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7144: Internet Small Computer System Interface (iSCSI) SCSI Features Update

Available Formats

Value Operation Name Reference
0 Function complete RFC 7143
1 Task does not exist RFC 7143
2 LUN does not exist RFC 7143
3 Task still allegiant RFC 7143
4 Task allegiance reassignment not supported RFC 7143
5 Task management function not supported RFC 7143
6 Function authorization failed RFC 7143
7 Function succeeded RFC 7144
8-254 Unassigned
255 Function rejected RFC 7143