IS-IS PDU Registry

Created

  • 2011-03-02

Last Updated

  • 2017-10-24

Note

For IS-IS registries and value ranges maintained via the "Expert Review" RFC 8126 registration procedure, guidance for IESG-designated experts can be found in RFC 7370.

Available Formats


IS-IS PDU Registry

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7176: Transparent Interconnection of Lots of Links (TRILL) Use of IS-IS

Available Formats

Value Description Reference
0-9 Unassigned
10 FS-LSP RFC 7356
11 FS-CSNP RFC 7356
12 FS-PSNP RFC 7356
13-14 Unassigned
15 L1-LAN-HELLO-PDU ISO-10589
16 L2-LAN-HELLO-PDU ISO-10589
17 P2P-HELLO-PDU ISO-10589
18 L1-LSP-PDU ISO-10589
19 Unassigned
20 L2-LSP-PDU ISO-10589
21-22 Unassigned
23 MTU-PROBE-PDU RFC 7176
24 L1-CSNP-PDU ISO-10589
25 L2-CSNP-PDU ISO-10589
26 L1-PSNP-PDU ISO-10589
27 L2-PSNP-PDU ISO-10589
28 MTU-ACK-PDU RFC 7176
29-31 Unassigned

LSP Flooding Scope Identifier Registry

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Chris Hopps, Hannes Gredler, Les Ginsberg

Reference

  • RFC 7356: IS-IS Flooding Scope Link State PDUs (LSPs)

Note

Values 1 - 63 are reserved for PDUs which use standard TLVs and standard sub-TLVs. Values 64 - 127 are reserved for PDUs which use extended TLVs and extended sub-TLVs.

Available Formats

Value Description FS LSP ID Format/TLV Format IIH Announce P2P IIH Announce L1LAN IIH Announce L2LAN Reference
0 Reserved RFC 7356
1 Level 1 Circuit Flooding Scope Extended/Standard y y n RFC 7356
2 Level 2 Circuit Flooding Scope Extended/Standard y n y RFC 7356
3 Level 1 Flooding Scope Extended/Standard y y n RFC 7356
4 Level 2 Flooding Scope Extended/Standard y n y RFC 7356
5 Domain Flooding Scope Extended/Standard y y y RFC 7356
6-63 Unassigned
64 Level 1 Circuit Flooding Scope Extended/Extended y y n RFC 7356
65 Level 2 Circuit Flooding Scope Extended/Extended y n y RFC 7356
66 Level 1 Flooding Scope Extended/Extended y y n RFC 7356
67 Level 2 Flooding Scope Extended/Extended y n y RFC 7356
68 Domain Flooding Scope Extended/Extended y y y RFC 7356
69-127 Unassigned