JSON Object Signing and Encryption (JOSE)
Created
- 2015-01-23
Last Updated
- 2026-09-29
Available Formats
JSON Web Signature and Encryption Header Parameters
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
- RFC 7515: JSON Web Signature (JWS)
Note
Registration requests should be sent to the mailing list described in RFC 7515. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Header Parameter Name | Header Parameter Description | Header Parameter Usage Location(s) | Change Controller | Reference |
|---|---|---|---|---|
| alg | Algorithm | JWS | IESG | RFC 7515, Section 4.1.1 |
| jku | JWK Set URL | JWS | IESG | RFC 7515, Section 4.1.2 |
| jwk | JSON Web Key | JWS | IESG | RFC 7515, Section 4.1.3 |
| kid | Key ID | JWS | IESG | RFC 7515, Section 4.1.4 |
| x5u | X.509 URL | JWS | IESG | RFC 7515, Section 4.1.5 |
| x5c | X.509 Certificate Chain | JWS | IESG | RFC 7515, Section 4.1.6 |
| x5t | X.509 Certificate SHA-1 Thumbprint | JWS | IESG | RFC 7515, Section 4.1.7 |
| x5t#S256 | X.509 Certificate SHA-256 Thumbprint | JWS | IESG | RFC 7515, Section 4.1.8 |
| typ | Type | JWS | IESG | RFC 7515, Section 4.1.9 |
| cty | Content Type | JWS | IESG | RFC 7515, Section 4.1.10 |
| crit | Critical | JWS | IESG | RFC 7515, Section 4.1.11 |
| alg | Algorithm | JWE | IESG | RFC 7516, Section 4.1.1 |
| enc | Encryption Algorithm | JWE | IESG | RFC 7516, Section 4.1.2 |
| zip | Compression Algorithm | JWE | IESG | RFC 7516, Section 4.1.3 |
| jku | JWK Set URL | JWE | IESG | RFC 7516, Section 4.1.4 |
| jwk | JSON Web Key | JWE | IESG | RFC 7516, Section 4.1.5 |
| kid | Key ID | JWE | IESG | RFC 7516, Section 4.1.6 |
| x5u | X.509 URL | JWE | IESG | RFC 7516, Section 4.1.7 |
| x5c | X.509 Certificate Chain | JWE | IESG | RFC 7516, Section 4.1.8 |
| x5t | X.509 Certificate SHA-1 Thumbprint | JWE | IESG | RFC 7516, Section 4.1.9 |
| x5t#S256 | X.509 Certificate SHA-256 Thumbprint | JWE | IESG | RFC 7516, Section 4.1.10 |
| typ | Type | JWE | IESG | RFC 7516, Section 4.1.11 |
| cty | Content Type | JWE | IESG | RFC 7516, Section 4.1.12 |
| crit | Critical | JWE | IESG | RFC 7516, Section 4.1.13 |
| epk | Ephemeral Public Key | JWE | IESG | RFC 7518, Section 4.6.1.1 |
| apu | Agreement PartyUInfo | JWE | IESG | RFC 7518, Section 4.6.1.2 |
| apv | Agreement PartyVInfo | JWE | IESG | RFC 7518, Section 4.6.1.3 |
| iv | Initialization Vector | JWE | IESG | RFC 7518, Section 4.7.1.1 |
| tag | Authentication Tag | JWE | IESG | RFC 7518, Section 4.7.1.2 |
| p2s | PBES2 Salt Input | JWE | IESG | RFC 7518, Section 4.8.1.1 |
| p2c | PBES2 Count | JWE | IESG | RFC 7518, Section 4.8.1.2 |
| iss | Issuer | JWE | IESG | RFC 7519, Section 4.1.1 |
| sub | Subject | JWE | IESG | RFC 7519, Section 4.1.2 |
| aud | Audience | JWE | IESG | RFC 7519, Section 4.1.3 |
| b64 | Base64url-Encode Payload | JWS | IESG | RFC 7797, Section 3 |
| ppt | PASSporT extension identifier | JWS | IESG | RFC 8225, Section 8.1 |
| url | URL | JWE, JWS | IESG | RFC 8555, Section 6.4.1 |
| nonce | Nonce | JWE, JWS | IESG | RFC 8555, Section 6.5.2 |
| svt | Signature Validation Token | JWS | IETF | RFC 9321 |
| iheSSId | The iheSSId header parameter's value shall specify the SubmissionSet.uniqueId as per https://profiles.ihe.net/ITI/TF/Volume3/ch-4.2.html#4.2.3.3.12. | JWS | IHE ITI | https://profiles.ihe.net/ITI/DSGj/Volume3/ch-5.10.html#5.10 |
| jwt | This header contains a JWT. Processing rules MAY depend on the typ header value of the respective JWT. | JWS | OpenID Foundation Digital Credentials Protocols Working Group | OpenID for Verifiable Presentations 1.0, Section 12 |
| client_id | This header contains a Client Identifier. A Client Identifier is used in OAuth to identify a certain client. It is defined in RFC 6749, Section 2.2. | JWS | IETF | RFC 6749 |
| trust_chain | OpenID Federation Trust Chain | JWS | OpenID Foundation Artifact Binding Working Group | OpenID Federation 1.0, Section 4.3 |
| peer_trust_chain | OpenID Federation Peer Trust Chain | JWS | OpenID Foundation Artifact Binding Working Group | OpenID Federation 1.0, Section 4.4 |
| ek | A base64url-encoded encapsulated secret, as defined in draft-ietf-hpke-hpke-03, Section 5 | JWE | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 4.1 |
| psk_id | A base64url-encoded key identifier (kid) for the pre-shared key, as defined in draft-ietf-hpke-hpke-03, Section 5.1.2 | JWE | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 4 |
JSON Web Signature and Encryption Algorithms
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
- RFC 7518: JSON Web Algorithms (JWA)
- RFC 9864, Section 4.3.1: Fully-Specified Algorithms for JSON Object Signing and Encryption (JOSE) and CBOR Object Signing and Encryption (COSE)
Note
Registration requests should be sent to the mailing list described in RFC 7518. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Algorithm Name | Algorithm Description | Algorithm Usage Location(s) | JOSE Implementation Requirements | Change Controller | Reference | Algorithm Analysis Document(s) |
|---|---|---|---|---|---|---|
| HS256 | HMAC using SHA-256 | alg | Required | IESG | RFC 7518, Section 3.2 | n/a |
| HS384 | HMAC using SHA-384 | alg | Optional | IESG | RFC 7518, Section 3.2 | n/a |
| HS512 | HMAC using SHA-512 | alg | Optional | IESG | RFC 7518, Section 3.2 | n/a |
| RS256 | RSASSA-PKCS1-v1_5 using SHA-256 | alg | Recommended | IESG | RFC 7518, Section 3.3 | n/a |
| RS384 | RSASSA-PKCS1-v1_5 using SHA-384 | alg | Optional | IESG | RFC 7518, Section 3.3 | n/a |
| RS512 | RSASSA-PKCS1-v1_5 using SHA-512 | alg | Optional | IESG | RFC 7518, Section 3.3 | n/a |
| ES256 | ECDSA using P-256 and SHA-256 | alg | Recommended+ | IESG | RFC 7518, Section 3.4 | n/a |
| ES384 | ECDSA using P-384 and SHA-384 | alg | Optional | IESG | RFC 7518, Section 3.4 | n/a |
| ES512 | ECDSA using P-521 and SHA-512 | alg | Optional | IESG | RFC 7518, Section 3.4 | n/a |
| PS256 | RSASSA-PSS using SHA-256 and MGF1 with SHA-256 | alg | Optional | IESG | RFC 7518, Section 3.5 | n/a |
| PS384 | RSASSA-PSS using SHA-384 and MGF1 with SHA-384 | alg | Optional | IESG | RFC 7518, Section 3.5 | n/a |
| PS512 | RSASSA-PSS using SHA-512 and MGF1 with SHA-512 | alg | Optional | IESG | RFC 7518, Section 3.5 | n/a |
| none | No digital signature or MAC performed | alg | Optional | IESG | RFC 7518, Section 3.6 | n/a |
| RSA1_5 | RSAES-PKCS1-v1_5 | alg | Recommended- | IESG | RFC 7518, Section 4.2 | n/a |
| RSA-OAEP | RSAES OAEP using default parameters | alg | Recommended+ | IESG | RFC 7518, Section 4.3 | n/a |
| RSA-OAEP-256 | RSAES OAEP using SHA-256 and MGF1 with SHA-256 | alg | Optional | IESG | RFC 7518, Section 4.3 | n/a |
| A128KW | AES Key Wrap using 128-bit key | alg | Recommended | IESG | RFC 7518, Section 4.4 | n/a |
| A192KW | AES Key Wrap using 192-bit key | alg | Optional | IESG | RFC 7518, Section 4.4 | n/a |
| A256KW | AES Key Wrap using 256-bit key | alg | Recommended | IESG | RFC 7518, Section 4.4 | n/a |
| dir | Direct use of a shared symmetric key | alg | Recommended | IESG | RFC 7518, Section 4.5 | n/a |
| ECDH-ES | ECDH-ES using Concat KDF | alg | Recommended+ | IESG | RFC 7518, Section 4.6 | n/a |
| ECDH-ES+A128KW | ECDH-ES using Concat KDF and "A128KW" wrapping | alg | Recommended | IESG | RFC 7518, Section 4.6 | n/a |
| ECDH-ES+A192KW | ECDH-ES using Concat KDF and "A192KW" wrapping | alg | Optional | IESG | RFC 7518, Section 4.6 | n/a |
| ECDH-ES+A256KW | ECDH-ES using Concat KDF and "A256KW" wrapping | alg | Recommended | IESG | RFC 7518, Section 4.6 | n/a |
| A128GCMKW | Key wrapping with AES GCM using 128-bit key | alg | Optional | IESG | RFC 7518, Section 4.7 | n/a |
| A192GCMKW | Key wrapping with AES GCM using 192-bit key | alg | Optional | IESG | RFC 7518, Section 4.7 | n/a |
| A256GCMKW | Key wrapping with AES GCM using 256-bit key | alg | Optional | IESG | RFC 7518, Section 4.7 | n/a |
| PBES2-HS256+A128KW | PBES2 with HMAC SHA-256 and "A128KW" wrapping | alg | Optional | IESG | RFC 7518, Section 4.8 | n/a |
| PBES2-HS384+A192KW | PBES2 with HMAC SHA-384 and "A192KW" wrapping | alg | Optional | IESG | RFC 7518, Section 4.8 | n/a |
| PBES2-HS512+A256KW | PBES2 with HMAC SHA-512 and "A256KW" wrapping | alg | Optional | IESG | RFC 7518, Section 4.8 | n/a |
| A128CBC-HS256 | AES_128_CBC_HMAC_SHA_256 authenticated encryption algorithm | enc | Required | IESG | RFC 7518, Section 5.2.3 | n/a |
| A192CBC-HS384 | AES_192_CBC_HMAC_SHA_384 authenticated encryption algorithm | enc | Optional | IESG | RFC 7518, Section 5.2.4 | n/a |
| A256CBC-HS512 | AES_256_CBC_HMAC_SHA_512 authenticated encryption algorithm | enc | Required | IESG | RFC 7518, Section 5.2.5 | n/a |
| A128GCM | AES GCM using 128-bit key | enc | Recommended | IESG | RFC 7518, Section 5.3 | n/a |
| A192GCM | AES GCM using 192-bit key | enc | Optional | IESG | RFC 7518, Section 5.3 | n/a |
| A256GCM | AES GCM using 256-bit key | enc | Recommended | IESG | RFC 7518, Section 5.3 | n/a |
| EdDSA | EdDSA signature algorithms | alg | Deprecated | IETF | RFC 9864, Section 2.2 | RFC 8032 |
| RS1 | RSASSA-PKCS1-v1_5 with SHA-1 | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| RSA-OAEP-384 | RSA-OAEP using SHA-384 and MGF1 with SHA-384 | alg | Optional | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | n/a |
| RSA-OAEP-512 | RSA-OAEP using SHA-512 and MGF1 with SHA-512 | alg | Optional | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | n/a |
| A128CBC | AES CBC using 128 bit key | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| A192CBC | AES CBC using 192 bit key | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| A256CBC | AES CBC using 256 bit key | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| A128CTR | AES CTR using 128 bit key | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| A192CTR | AES CTR using 192 bit key | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| A256CTR | AES CTR using 256 bit key | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| HS1 | HMAC using SHA-1 | JWK | Prohibited | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI | draft-irtf-cfrg-webcrypto-algorithms-00 |
| ES256K | ECDSA using secp256k1 curve and SHA-256 | alg | Optional | IESG | RFC 8812, Section 3.2 | SEC2 |
| ML-DSA-44 | ML-DSA-44 as described in US NIST FIPS 204 | alg | Optional | IETF | RFC 9964 | FIPS-204 |
| ML-DSA-65 | ML-DSA-65 as described in US NIST FIPS 204 | alg | Optional | IETF | RFC 9964 | FIPS-204 |
| ML-DSA-87 | ML-DSA-87 as described in US NIST FIPS 204 | alg | Optional | IETF | RFC 9964 | FIPS-204 |
| Ed25519 | EdDSA using the Ed25519 parameter set in Section 5.1 of RFC 8032 | alg | Optional | IETF | RFC 9864, Section 2.2 | RFC 8032 |
| Ed448 | EdDSA using the Ed448 parameter set in Section 5.2 of RFC 8032 | alg | Optional | IETF | RFC 9864, Section 2.2 | RFC 8032 |
| HPKE-0 | Integrated Encryption with HPKE using DHKEM(P-256, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and AES-128-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-1 | Integrated Encryption with HPKE using DHKEM(P-384, HKDF-SHA384) KEM, HKDF-SHA384 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-2 | Integrated Encryption with HPKE using DHKEM(P-521, HKDF-SHA512) KEM, HKDF-SHA512 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-3 | Integrated Encryption with HPKE using DHKEM(X25519, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and AES-128-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-4 | Integrated Encryption with HPKE using DHKEM(X25519, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and ChaCha20Poly1305 AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-5 | Integrated Encryption with HPKE using DHKEM(X448, HKDF-SHA512) KEM, HKDF-SHA512 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-6 | Integrated Encryption with HPKE using DHKEM(X448, HKDF-SHA512) KEM, HKDF-SHA512 KDF, and ChaCha20Poly1305 AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-7 | Integrated Encryption with HPKE using DHKEM(P-256, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 | draft-ietf-hpke-hpke-03, Section 6.1 |
| HPKE-0-KE | Key Encryption with HPKE using DHKEM(P-256, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and AES-128-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 | draft-ietf-hpke-hpke-03, Section 5 |
| HPKE-1-KE | Key Encryption with HPKE using DHKEM(P-384, HKDF-SHA384) KEM, HKDF-SHA384 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 | draft-ietf-hpke-hpke-03, Section 5 |
| HPKE-2-KE | Key Encryption with HPKE using DHKEM(P-521, HKDF-SHA512) KEM, HKDF-SHA512 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 | draft-ietf-hpke-hpke-03, Section 5 |
| HPKE-3-KE | Key Encryption with HPKE using DHKEM(X25519, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and AES-128-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 | draft-ietf-hpke-hpke-03, Section 5 |
| HPKE-5-KE | Key Encryption with HPKE using DHKEM(X448, HKDF-SHA512) KEM, HKDF-SHA512 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 | draft-ietf-hpke-hpke-03, Section 5 |
| HPKE-7-KE | Key Encryption with HPKE using DHKEM(P-256, HKDF-SHA256) KEM, HKDF-SHA256 KDF, and AES-256-GCM AEAD | alg | Optional | IETF | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 | draft-ietf-hpke-hpke-03, Section 5 |
JSON Web Encryption Compression Algorithms
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
- RFC 7518: JSON Web Algorithms (JWA)
Note
Registration requests should be sent to the mailing list described in RFC 7518. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
JSON Web Key Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
Note
Registration requests should be sent to the mailing list described in RFC 7518. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| "kty" Parameter Value | Key Type Description | JOSE Implementation Requirements | Change Controller | Reference |
|---|---|---|---|---|
| EC | Elliptic Curve | Recommended+ | IESG | RFC 7518, Section 6.2 |
| RSA | RSA | Required | IESG | RFC 7518, Section 6.3 |
| oct | Octet sequence | Required | IESG | RFC 7518, Section 6.4 |
| OKP | Octet string key pairs | Optional | IESG | RFC 8037, Section 2 |
| AKP | Algorithm Key Pair | Optional | IETF | RFC 9964 |
JSON Web Key Elliptic Curve
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
Note
Registration requests should be sent to the mailing list described in RFC 7518. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Curve Name | Curve Description | JOSE Implementation Requirements | Change Controller | Reference |
|---|---|---|---|---|
| P-256 | P-256 Curve | Recommended+ | IESG | RFC 7518, Section 6.2.1.1 |
| P-384 | P-384 Curve | Optional | IESG | RFC 7518, Section 6.2.1.1 |
| P-521 | P-521 Curve | Optional | IESG | RFC 7518, Section 6.2.1.1 |
| Ed25519 | Ed25519 signature algorithm key pairs | Optional | IESG | RFC 8037, Section 3.1 |
| Ed448 | Ed448 signature algorithm key pairs | Optional | IESG | RFC 8037, Section 3.1 |
| X25519 | X25519 function key pairs | Optional | IESG | RFC 8037, Section 3.2 |
| X448 | X448 function key pairs | Optional | IESG | RFC 8037, Section 3.2 |
| secp256k1 | SECG secp256k1 curve | Optional | IESG | RFC 8812, Section 3.1 |
JSON Web Key Parameters
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
Note
Registration requests should be sent to the mailing list described in RFC 7517. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Parameter Name | Parameter Description | Used with "kty" Value(s) | Parameter Information Class | Change Controller | Reference |
|---|---|---|---|---|---|
| kty | Key Type | * | Public | IESG | RFC 7517, Section 4.1 |
| use | Public Key Use | * | Public | IESG | RFC 7517, Section 4.2 |
| key_ops | Key Operations | * | Public | IESG | RFC 7517, Section 4.3 |
| alg | Algorithm | * | Public | IESG | RFC 7517, Section 4.4 |
| kid | Key ID | * | Public | IESG | RFC 7517, Section 4.5 |
| x5u | X.509 URL | * | Public | IESG | RFC 7517, Section 4.6 |
| x5c | X.509 Certificate Chain | * | Public | IESG | RFC 7517, Section 4.7 |
| x5t | X.509 Certificate SHA-1 Thumbprint | * | Public | IESG | RFC 7517, Section 4.8 |
| x5t#S256 | X.509 Certificate SHA-256 Thumbprint | * | Public | IESG | RFC 7517, Section 4.9 |
| crv | Curve | EC | Public | IESG | RFC 7518, Section 6.2.1.1 |
| x | X Coordinate | EC | Public | IESG | RFC 7518, Section 6.2.1.2 |
| y | Y Coordinate | EC | Public | IESG | RFC 7518, Section 6.2.1.3 |
| d | ECC Private Key | EC | Private | IESG | RFC 7518, Section 6.2.2.1 |
| n | Modulus | RSA | Public | IESG | RFC 7518, Section 6.3.1.1 |
| e | Exponent | RSA | Public | IESG | RFC 7518, Section 6.3.1.2 |
| d | Private Exponent | RSA | Private | IESG | RFC 7518, Section 6.3.2.1 |
| p | First Prime Factor | RSA | Private | IESG | RFC 7518, Section 6.3.2.2 |
| q | Second Prime Factor | RSA | Private | IESG | RFC 7518, Section 6.3.2.3 |
| dp | First Factor CRT Exponent | RSA | Private | IESG | RFC 7518, Section 6.3.2.4 |
| dq | Second Factor CRT Exponent | RSA | Private | IESG | RFC 7518, Section 6.3.2.5 |
| qi | First CRT Coefficient | RSA | Private | IESG | RFC 7518, Section 6.3.2.6 |
| oth | Other Primes Info | RSA | Private | IESG | RFC 7518, Section 6.3.2.7 |
| k | Key Value | oct | Private | IESG | RFC 7518, Section 6.4.1 |
| crv | The subtype of key pair | OKP | Public | IESG | RFC 8037, Section 2 |
| d | The private key | OKP | Private | IESG | RFC 8037, Section 2 |
| x | The public key | OKP | Public | IESG | RFC 8037, Section 2 |
| ext | Extractable | * | Public | W3C Web Application Security Working Group | https://www.w3.org/TR/WebCryptoAPI |
| iat | Issued At, as defined in RFC 7519 | * | Public | OpenID Foundation Artifact Binding Working Group | OpenID Federation 1.0, Section 8.7.2 |
| nbf | Not Before, as defined in RFC 7519 | * | Public | OpenID Foundation Artifact Binding Working Group | OpenID Federation 1.0, Section 8.7.2 |
| exp | Expiration Time, as defined in RFC 7519 | * | Public | OpenID Foundation Artifact Binding Working Group | OpenID Federation 1.0, Section 8.7.2 |
| revoked | Revoked Key Properties | * | Public | OpenID Foundation Artifact Binding Working Group | OpenID Federation 1.0, Section 8.7.2 |
| pub | Public key | AKP | Public | IETF | RFC 9964 |
| priv | Private key | AKP | Private | IETF | RFC 9964 |
JSON Web Key Use
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
- RFC 7517: JSON Web Key (JWK)
Note
Registration requests should be sent to the mailing list described in RFC 7517. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Use Member Value | Use Description | Change Controller | Reference |
|---|---|---|---|
| sig | Digital Signature or MAC | IESG | RFC 7517, Section 4.2 |
| enc | Encryption | IESG | RFC 7517, Section 4.2 |
JSON Web Key Operations
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
- RFC 7517: JSON Web Key (JWK)
Note
Registration requests should be sent to the mailing list described in RFC 7517. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Key Operation Value | Key Operation Description | Change Controller | Reference |
|---|---|---|---|
| sign | Compute digital signature or MAC | IESG | RFC 7517, Section 4.3 |
| verify | Verify digital signature or MAC | IESG | RFC 7517, Section 4.3 |
| encrypt | Encrypt content | IESG | RFC 7517, Section 4.3 |
| decrypt | Decrypt content and validate decryption, if applicable | IESG | RFC 7517, Section 4.3 |
| wrapKey | Encrypt key | IESG | RFC 7517, Section 4.3 |
| unwrapKey | Decrypt key and validate decryption, if applicable | IESG | RFC 7517, Section 4.3 |
| deriveKey | Derive key | IESG | RFC 7517, Section 4.3 |
| deriveBits | Derive bits not to be used as a key | IESG | RFC 7517, Section 4.3 |
JSON Web Key Set Parameters
Registration Procedure(s)
- Specification Required
Expert(s)
- Sean Turner, Mike Jones, Filip Skokan
Reference
- RFC 7517: JSON Web Key (JWK)
Note
Registration requests should be sent to the mailing list described in RFC 7517. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org.
Available Formats
| Parameter Name | Parameter Description | Change Controller | Reference |
|---|---|---|---|
| keys | Array of JWK Values | IESG | RFC 7517, Section 5.1 |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| IESG | iesg&ietf.org | |
| IETF | iesg&ietf.org | |
| IHE ITI | https://www.ihe.net | 2025-02-27 |
| OpenID Foundation Artifact Binding Working Group | openid-specs-ab&lists.openid.net | 2024-08-20 |
| OpenID Foundation Digital Credentials Protocols Working Group | openid-specs-digital-credentials-protocols&lists.openid.net | 2025-08-13 |
| W3C Web Application Security Working Group | public-webappsec&w3.org | 2024-10-16 |