JSContact

Created

  • 2023-10-27

Last Updated

  • 2026-09-22

Available Formats


JSContact Version

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Note

Notice of a potential new registration MUST be sent to the Calext mailing list for review, per Section 3.3.1 of RFC 9553. (This list is not monitored by IANA.)

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Major Version Highest Minor Version Reference
1 0 RFC 9553
2 0 RFC 9982

JSContact Properties

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Note

Notice of a potential new registration MUST be sent to the Calext mailing list for review, per Section 3.3.1 of RFC 9553. (This list is not monitored by IANA.)

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Property Name Property Type Property Context Intended Usage Since Version Until Version Change Controller Reference/Description
@type String Address, AddressComponent, Anniversary, Author, Card, Calendar, CryptoKey, Directory, EmailAddress, LanguagePref, Link, Media, Name, NameComponent, Nickname, Note, OnlineService, Organization, OrgUnit, PartialDate,PersonalInfo, Phone, Pronouns, Relation, SchedulingAddress, SpeakToAs, Timestamp, Title common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.5.1.2, 2.8.1, 2.8.3, 2.1.1, 2.4.1, 2.6.1, 2.6.2, 2.3.1, 2.3.4, 2.6.3, 2.6.4, 2.2.1.1, 2.2.1.2, 2.2.2, 2.8.3, 2.3.2, 2.2.3, 2.2.3, 2.8.1, 2.8.4, 2.3.3, 2.2.4, 2.1.8, 2.4.2, 2.2.4, 2.8.1, 2.2.5
address String EmailAddress common 1.0 IETF RFC 9553, Section 2.3.1
addressBookIds not applicable Card reserved 1.0 IETF RFC 9610
addresses Id[Address] Card common 1.0 IETF RFC 9553, Section 2.5.1.1
anniversaries Id[Anniversary] Card common 1.0 IETF RFC 9553, Section 2.8.1
author Author Note common 1.0 IETF RFC 9553, Section 2.8.3
blobId not applicable Media reserved 1.0 IETF RFC 9610
calendars Id[Calendar] Card common 1.0 IETF RFC 9553, Section 2.4.1
calendarScale String PartialDate common 1.0 IETF RFC 9553, Section 2.8.1
components AddressComponent[] Address common 1.0 IETF RFC 9553, Section 2.5.1.1
components NameComponent[] Name common 1.0 IETF RFC 9553, Section 2.2.1.2
contexts String[Boolean] Address, Calendar, CryptoKey, Directory, EmailAddress, LanguagePref, Link, Media, Nickname, OnlineService, Organization, Phone, Pronouns, SchedulingAddress common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.4.1, 2.6.1, 2.6.2, 2.3.1, 2.3.4, 2.6.3, 2.6.4, 2.2.2, 2.3.2, 2.2.3, 2.3.3, 2.2.4, 2.4.2; Also see Sections 1.4.4, 1.5.1 of RFC 9553
coordinates String Address common 1.0 IETF RFC 9553, Section 2.5.1.1
countryCode String Address common 1.0 IETF RFC 9553, Section 2.5.1.1
created UTCDateTime Card, Note common 1.0 IETF RFC 9553, Section 2.1.3, 2.8.3
date PartialDate|Timestamp Anniversary common 1.0 IETF RFC 9553, Section 2.8.1
day UnsignedInt PartialDate common 1.0 IETF RFC 9553, Section 2.8.1
defaultSeparator String Address, Name common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.2.1.1
directories Id[Directory] Card common 1.0 IETF RFC 9553, Section 2.6.2
emails Id[EmailAddress] Card common 1.0 IETF RFC 9553, Section 2.3.1
extra not applicable not applicable reserved 1.0 IETF RFC 9553, Section 1.7.3.1
features String[Boolean] Phone common 1.0 IETF RFC 9553, Section 2.3.3
full String Address, Name common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.2.1.1
grammaticalGender String SpeakToAs common 1.0 IETF RFC 9553, Section 2.2.4
id not applicable Card reserved 1.0 IETF RFC 9610
isOrdered Boolean Address, Name common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.2.1.1
keywords String[Boolean] Card common 1.0 IETF RFC 9553, Section 2.8.2
kind String AddressComponent, Anniversary, Calendar, Card, CryptoKey, Directory, Link, Media, NameComponent, PersonalInfo, Title common 1.0 IETF RFC 9553, Section 2.5.1.2, 2.8.1, 2.4.1, 2.1.4, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.2.1.2, 2.8.4, 2.2.5
label String Calendar, CryptoKey, Directory, EmailAddress, Link, Media, OnlineService, PersonalInfo, Phone, SchedulingAddress common 1.0 IETF RFC 9553, Section 2.4.1, 2.6.1, 2.6.2, 2.3.1, 2.6.3, 2.6.4, 2.3.2, 2.8.4, 2.3.3, 2.4.2; Also see Sections 1.4.4, 1.5.2 of RFC 9553
language String Card, LanguagePref common 1.0 IETF RFC 9553, Section 2.1.5, 2.3.4
level String PersonalInfo common 1.0 IETF RFC 9553, Section 2.8.4
links Id[Link] Card common 1.0 IETF RFC 9553, Section 2.6.3
listAs UnsignedInt Directory, PersonalInfo common 1.0 IETF RFC 9553, Section 2.6.2, 2.8.4
localizations String[PatchObject] Card common 1.0 IETF RFC 9553, Section 2.7.1
media Id[Media] Card common 1.0 IETF RFC 9553, Section 2.6.4
mediaType String Calendar, CryptoKey, Directory, Link, Media common 1.0 IETF RFC 9553, Section 2.4.1, 2.6.1, 2.6.2, 2.6.3, 2.6.4; Also see Section 1.4.4 of RFC 9553
members String[Boolean] Card common 1.0 IETF RFC 9553, Section 2.1.6
month UnsignedInt PartialDate common 1.0 IETF RFC 9553, Section 2.8.1
name Name Card common 1.0 IETF RFC 9553, Section 2.2.1.1
name String Author, Nickname, Organization, OrgUnit, Title common 1.0 IETF RFC 9553, Section 2.8.3, 2.2.2, 2.2.3, 2.2.3, 2.2.5
nicknames Id[Nickname] Card common 1.0 IETF RFC 9553, Section 2.2.2
note String Note common 1.0 IETF RFC 9553, Section 2.8.3
notes Id[Note] Card common 1.0 IETF RFC 9553, Section 2.8.3
number String Phone common 1.0 IETF RFC 9553, Section 2.3.3
onlineServices Id[OnlineService] Card common 1.0 IETF RFC 9553, Section 2.3.2
organizationId String Title common 1.0 IETF RFC 9553, Section 2.2.5
organizations Id[Organization] Card common 1.0 IETF RFC 9553, Section 2.2.3
personalInfo Id[PersonalInfo] Card common 1.0 IETF RFC 9553, Section 2.8.4
phones Id[Phone] Card common 1.0 IETF RFC 9553, Section 2.3.3
phonetic String AddressComponent, NameComponent common 1.0 IETF RFC 9553, Section 2.5.1.2, 2.2.1.2
phoneticScript String Address, Name common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.2.1.1
phoneticSystem String Address, Name common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.2.1.1
place Address Anniversary common 1.0 IETF RFC 9553, Section 2.8.1
pref UnsignedInt Address, Calendar, CryptoKey, Directory, EmailAddress, LanguagePref, Link, Media, Nickname, OnlineService, Phone, Pronouns, SchedulingAddress common 1.0 IETF RFC 9553, Section 2.5.1.1, 2.4.1, 2.6.1, 2.6.2, 2.3.1, 2.3.4, 2.6.3, 2.6.4, 2.2.2, 2.3.2, 2.3.3, 2.2.4, 2.4.2; Also see Sections 1.4.4, 1.5.3 of RFC 9553
preferredLanguages String[LanguagePref] Card common 1.0 IETF RFC 9553, Section 2.3.4
prodId String Card common 1.0 IETF RFC 9553, Section 2.1.7
pronouns Id[Pronouns] SpeakToAs common 1.0 IETF RFC 9553, Section 2.2.4
relatedTo String[Relation] Card common 1.0 IETF RFC 9553, Section 2.1.8
relation String[Boolean] Relation common 1.0 IETF RFC 9553, Section 2.1.8
schedulingAddresses Id[SchedulingAddress] Card common 1.0 IETF RFC 9553, Section 2.4.2
service String OnlineService common 1.0 IETF RFC 9553, Section 2.3.2
sortAs String[String] Name common 1.0 IETF RFC 9553, Section 2.2.1.1
sortAs String Organization, OrgUnit common 1.0 IETF RFC 9553, Section 2.2.3, 2.2.3
speakToAs SpeakToAs Card common 1.0 IETF RFC 9553, Section 2.2.4
timeZone String Address common 1.0 IETF RFC 9553, Section 2.5.1.1
titles Id[Title] Card common 1.0 IETF RFC 9553, Section 2.2.5
uid String Card common 1.0 IETF RFC 9553, Section 2.1.9; RFC 9982, Section 4
units OrgUnit[] Organization common 1.0 IETF RFC 9553, Section 2.2.3
updated UTCDateTime Card common 1.0 IETF RFC 9553, Section 2.1.10
uri String Author, Calendar, CryptoKey, Directory, Link, Media, OnlineService, SchedulingAddress common 1.0 IETF RFC 9553, Section 2.8.3, 2.4.1, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.3.2, 2.4.2; Also see Section 1.4.4 of RFC 9553
user String OnlineService common 1.0 IETF RFC 9553, Section 2.3.2
utc UTCDateTime Timestamp common 1.0 IETF RFC 9553, Section 2.8.1
value String AddressComponent, NameComponent, PersonalInfo common 1.0 IETF RFC 9553, Section 2.5.1.2, 2.2.1.2, 2.8.4
vCardName String Any JSContact object common 1.0 IETF RFC 9555, Section 2.15.3
vCardParams String[String|String[]] Any JSContact object common 1.0 IETF RFC 9555, Section 2.15.2
vCardProps JCardProp[] Card common 1.0 IETF RFC 9555, Section 2.15.1
version String Card common 1.0 IETF RFC 9553, Section 2.1.2
year UnsignedInt PartialDate common 1.0 IETF RFC 9553, Section 2.8.1

JSContact Types

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Note

Notice of a potential new registration MUST be sent to the Calext mailing list for review, per Section 3.3.1 of RFC 9553. (This list is not monitored by IANA.)

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Type Name Intended Usage Since Version Until Version Change Controller Reference/Description
Address common 1.0 IETF RFC 9553, Section 2.5.1.1
AddressComponent common 1.0 IETF RFC 9553, Section 2.5.1.2
Anniversary common 1.0 IETF RFC 9553, Section 2.8.1
Author common 1.0 IETF RFC 9553, Section 2.8.3
Boolean common 1.0 IETF RFC 9553, Section 1.3.2
Calendar common 1.0 IETF RFC 9553, Section 2.4.1
Card common 1.0 IETF RFC 9553, Section 2
CryptoKey common 1.0 IETF RFC 9553, Section 2.6.1
Directory common 1.0 IETF RFC 9553, Section 2.6.2
EmailAddress common 1.0 IETF RFC 9553, Section 2.3.1
Id common 1.0 IETF RFC 9553, Section 1.4.1
Int common 1.0 IETF RFC 9553, Section 1.4.2
JCardProp common 1.0 IETF RFC 9555, Section 2.15.1
LanguagePref common 1.0 IETF RFC 9553, Section 2.3.4
Link common 1.0 IETF RFC 9553, Section 2.6.3
Media common 1.0 IETF RFC 9553, Section 2.6.4
Name common 1.0 IETF RFC 9553, Section 2.2.1.1
NameComponent common 1.0 IETF RFC 9553, Section 2.2.1.2
Nickname common 1.0 IETF RFC 9553, Section 2.2.2
Note common 1.0 IETF RFC 9553, Section 2.8.3
Number common 1.0 IETF RFC 9553, Section 1.3.2
OnlineService common 1.0 IETF RFC 9553, Section 2.3.2
Organization common 1.0 IETF RFC 9553, Section 2.2.3
OrgUnit common 1.0 IETF RFC 9553, Section 2.2.3
PartialDate common 1.0 IETF RFC 9553, Section 2.8.1
PatchObject common 1.0 IETF RFC 9553, Section 1.4.3
PersonalInfo common 1.0 IETF RFC 9553, Section 2.8.4
Phone common 1.0 IETF RFC 9553, Section 2.3.3
Pronouns common 1.0 IETF RFC 9553, Section 2.2.4
Relation common 1.0 IETF RFC 9553, Section 2.1.8
Resource reserved 1.0 IETF RFC 9553, Section 1.4.4
SchedulingAddress common 1.0 IETF RFC 9553, Section 2.4.2
SpeakToAs common 1.0 IETF RFC 9553, Section 2.2.4
String common 1.0 IETF RFC 9553, Section 1.3.2
Timestamp common 1.0 IETF RFC 9553, Section 2.8.1
Title common 1.0 IETF RFC 9553, Section 2.2.5
UnsignedInt common 1.0 IETF RFC 9553, Section 1.4.2
UTCDateTime common 1.0 IETF RFC 9553, Section 1.4.5

JSContact Enum Values

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Note

Notice of a potential new registration MUST be sent to the Calext mailing list for review, per Section 3.3.1 of RFC 9553. (This list is not monitored by IANA.)

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Property Name Context Since Version Until Version Change Controller Reference
contexts Address 1.0 IETF RFC 9553
contexts Calendar, CryptoKey, Directory, EmailAddress, LanguagePref, Link, Media, Nickname, OnlineService, Organization, Phone, Pronouns, SchedulingAddress 1.0 IETF RFC 9553
features Phone 1.0 IETF RFC 9553
grammaticalGender SpeakToAs 1.0 IETF RFC 9553
kind AddressComponent 1.0 IETF RFC 9553
kind Anniversary 1.0 IETF RFC 9553
kind Calendar 1.0 IETF RFC 9553
kind Card 1.0 IETF RFC 9553
kind Directory 1.0 IETF RFC 9553
kind Link 1.0 IETF RFC 9553
kind Media 1.0 IETF RFC 9553
kind NameComponent 1.0 IETF RFC 9553
kind PersonalInfo 1.0 IETF RFC 9553
kind Title 1.0 IETF RFC 9553
level PersonalInfo 1.0 IETF RFC 9553
phoneticSystem Address, Name 1.0 IETF RFC 9553
relation Relation 1.0 IETF RFC 9553

JSContact Enum Values for contexts (Context: Address)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
billing 1.0 IETF RFC 9553, Section 2.5.1.1
delivery 1.0 IETF RFC 9553, Section 2.5.1.1
private 1.0 IETF RFC 9553, Section 1.5.1
work 1.0 IETF RFC 9553, Section 1.5.1

JSContact Enum Values for contexts (Context: Calendar, CryptoKey, Directory, EmailAddress, LanguagePref, Link, Media, Nickname, OnlineService, Organization, Phone, Pronouns, SchedulingAddress)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
private 1.0 IETF RFC 9553, Section 1.5.1
work 1.0 IETF RFC 9553, Section 1.5.1

JSContact Enum Values for features (Context: Phone)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
fax 1.0 IETF RFC 9553, Section 2.3.3
main-number 1.0 IETF RFC 9553, Section 2.3.3
mobile 1.0 IETF RFC 9553, Section 2.3.3
pager 1.0 IETF RFC 9553, Section 2.3.3
text 1.0 IETF RFC 9553, Section 2.3.3
textphone 1.0 IETF RFC 9553, Section 2.3.3
video 1.0 IETF RFC 9553, Section 2.3.3
voice 1.0 IETF RFC 9553, Section 2.3.3

JSContact Enum Values for grammaticalGender (Context: SpeakToAs)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
animate 1.0 IETF RFC 9553, Section 2.2.4
common 1.0 IETF RFC 9553, Section 2.2.4
feminine 1.0 IETF RFC 9553, Section 2.2.4
inanimate 1.0 IETF RFC 9553, Section 2.2.4
masculine 1.0 IETF RFC 9553, Section 2.2.4
neuter 1.0 IETF RFC 9553, Section 2.2.4

JSContact Enum Values for kind (Context: AddressComponent)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
apartment 1.0 IETF RFC 9553, Section 2.5.1.2
block 1.0 IETF RFC 9553, Section 2.5.1.2
building 1.0 IETF RFC 9553, Section 2.5.1.2
country 1.0 IETF RFC 9553, Section 2.5.1.2
direction 1.0 IETF RFC 9553, Section 2.5.1.2
district 1.0 IETF RFC 9553, Section 2.5.1.2
floor 1.0 IETF RFC 9553, Section 2.5.1.2
landmark 1.0 IETF RFC 9553, Section 2.5.1.2
locality 1.0 IETF RFC 9553, Section 2.5.1.2
name 1.0 IETF RFC 9553, Section 2.5.1.2
number 1.0 IETF RFC 9553, Section 2.5.1.2
postcode 1.0 IETF RFC 9553, Section 2.5.1.2
postOfficeBox 1.0 IETF RFC 9553, Section 2.5.1.2
region 1.0 IETF RFC 9553, Section 2.5.1.2
room 1.0 IETF RFC 9553, Section 2.5.1.2
separator 1.0 IETF RFC 9553, Section 2.5.1.2
subdistrict 1.0 IETF RFC 9553, Section 2.5.1.2

JSContact Enum Values for kind (Context: Anniversary)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
birth 1.0 IETF RFC 9553, Section 2.8.1
death 1.0 IETF RFC 9553, Section 2.8.1
wedding 1.0 IETF RFC 9553, Section 2.8.1

JSContact Enum Values for kind (Context: Calendar)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
calendar 1.0 IETF RFC 9553, Section 2.4.1
freeBusy 1.0 IETF RFC 9553, Section 2.4.1

JSContact Enum Values for kind (Context: Card)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
application 1.0 IETF RFC 9553, Section 2.1.4
device 1.0 IETF RFC 9553, Section 2.1.4
group 1.0 IETF RFC 9553, Section 2.1.4
individual 1.0 IETF RFC 9553, Section 2.1.4
location 1.0 IETF RFC 9553, Section 2.1.4
org 1.0 IETF RFC 9553, Section 2.1.4

JSContact Enum Values for kind (Context: Directory)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
directory 1.0 IETF RFC 9553, Section 2.6.2
entry 1.0 IETF RFC 9553, Section 2.6.2

JSContact Enum Values for kind (Context: Link)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
contact 1.0 IETF RFC 9553, Section 2.6.3

JSContact Enum Values for kind (Context: Media)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
logo 1.0 IETF RFC 9553, Section 2.6.4
photo 1.0 IETF RFC 9553, Section 2.6.4
sound 1.0 IETF RFC 9553, Section 2.6.4

JSContact Enum Values for kind (Context: NameComponent)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
credential 1.0 IETF RFC 9553, Section 2.2.1.2
generation 1.0 IETF RFC 9553, Section 2.2.1.2
given 1.0 IETF RFC 9553, Section 2.2.1.2
given2 1.0 IETF RFC 9553, Section 2.2.1.2
separator 1.0 IETF RFC 9553, Section 2.2.1.2
surname 1.0 IETF RFC 9553, Section 2.2.1.2
surname2 1.0 IETF RFC 9553, Section 2.2.1.2
title 1.0 IETF RFC 9553, Section 2.2.1.2

JSContact Enum Values for kind (Context: PersonalInfo)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
expertise 1.0 IETF RFC 9553, Section 2.8.4
hobby 1.0 IETF RFC 9553, Section 2.8.4
interest 1.0 IETF RFC 9553, Section 2.8.4

JSContact Enum Values for kind (Context: Title)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
role 1.0 IETF RFC 9553, Section 2.2.5
title 1.0 IETF RFC 9553, Section 2.2.5

JSContact Enum Values for level (Context: PersonalInfo)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
high 1.0 IETF RFC 9553, Section 2.8.4
low 1.0 IETF RFC 9553, Section 2.8.4
medium 1.0 IETF RFC 9553, Section 2.8.4

JSContact Enum Values for relation (Context: Relation)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
acquaintance 1.0 IETF RFC 9553, Section 2.1.8
agent 1.0 IETF RFC 9553, Section 2.1.8
child 1.0 IETF RFC 9553, Section 2.1.8
colleague 1.0 IETF RFC 9553, Section 2.1.8
contact 1.0 IETF RFC 9553, Section 2.1.8
co-resident 1.0 IETF RFC 9553, Section 2.1.8
co-worker 1.0 IETF RFC 9553, Section 2.1.8
crush 1.0 IETF RFC 9553, Section 2.1.8
date 1.0 IETF RFC 9553, Section 2.1.8
emergency 1.0 IETF RFC 9553, Section 2.1.8
friend 1.0 IETF RFC 9553, Section 2.1.8
kin 1.0 IETF RFC 9553, Section 2.1.8
me 1.0 IETF RFC 9553, Section 2.1.8
met 1.0 IETF RFC 9553, Section 2.1.8
muse 1.0 IETF RFC 9553, Section 2.1.8
neighbor 1.0 IETF RFC 9553, Section 2.1.8
parent 1.0 IETF RFC 9553, Section 2.1.8
sibling 1.0 IETF RFC 9553, Section 2.1.8
spouse 1.0 IETF RFC 9553, Section 2.1.8
sweetheart 1.0 IETF RFC 9553, Section 2.1.8

JSContact Enum Values for phoneticSystem (Context: Address, Name)

Expert(s)

  • Michael Douglass, Mario Loffredo, Robert Stepanek

Reference

  • RFC 9553: JSContact: A JSON Representation of Contact Data

Available Formats

Range Registration Procedures
Major version change required Standards Action
All other assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
ipa 1.0 IETF RFC 9553, Section 1.5.4
jyut 1.0 IETF RFC 9553, Section 1.5.4
piny 1.0 IETF RFC 9553, Section 1.5.4

JSContact Profiles

Expert(s)

  • Unassigned

Reference

  • RFC 10050: Protocol-Specific Profiles for JSContact
Range Registration Procedures
Reference updates Expert Review
New assignments Specification Required
Enum Value Since Version Until Version Change Controller Reference/Description
No registrations at this time.