Kerberos V GSS-API Mechanism Parameters
Created
- 2012-01-06
Last Updated
- 2014-03-03
Available Formats
Kerberos V GSS-API Mechanism Extension Types
Expert(s)
- Unassigned
Reference
- RFC 6542: Kerberos Version 5 Generic Security Service Application Program Interface (GSS-API) Channel Binding Hash Agility
Available Formats
| Range | Registration Procedures |
|---|---|
| 0x00000000 - 0x000003FF | IETF Review |
| 0x00000400 - 0xFFFFF3FF | Specification Required |
Kerberos V GSS-API Token Type Identifiers
Registration Procedure(s)
- Expert Review
Expert(s)
- Sam Hartman
Reference
- RFC 4121: The Kerberos Version 5 Generic Security Service Application Program Interface (GSS-API) Mechanism: Version 2
- RFC 7055: A GSS-API Mechanism for the Extensible Authentication Protocol
Available Formats
| ID | Description | Reference |
|---|---|---|
| 00 00 - 00 FF | Unassigned | |
| 01 00 | KRB_AP_REQ | RFC 4121, Section 4.1 |
| 01 01 | MIC | RFC 1964 |
| 01 02 | Context deletion | RFC 1964 |
| 01 03 - 01 FF | Unassigned | |
| 02 00 | KRB_AP_REP | RFC 4121, Section 4.1 |
| 02 01 | Wrap | RFC 1964 |
| 02 02 - 02 FF | Unassigned | |
| 03 00 | KRB_ERROR | RFC 4121, Section 4.1 |
| 03 01 - 04 00 | Unassigned | |
| 04 01 | exported name tokens | RFC 2743 |
| 04 02 | exported composite name tokens | RFC 6680 |
| 04 03 | Unassigned | |
| 04 04 | MIC tokens | RFC 4121, Section 4.2.6.1 |
| 04 05 - 05 03 | Unassigned | |
| 05 04 | wrap tokens | RFC 4121, Section 4.2.6.2 |
| 05 05 - 06 00 | Unassigned | |
| 06 01 | GSS-EAP initiator context token | RFC 7055, Section 5 |
| 06 02 | GSS-EAP acceptor context token | RFC 7055, Section 5 |
| 06 03 - 5F FF | Unassigned | |
| 60 00 - 60 FF | Reserved | RFC 4121 |
| 61 00 - FF FF | Unassigned |