KeyTable

Created

  • 2014-01-28

Last Updated

  • 2025-09-26

Available Formats


KeyTable Protocols

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 7210: Database of Long-Lived Symmetric Cryptographic Keys
Protocol Name Protocol-Specific Info Reference
No registrations at this time.

KeyTable KDFs

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 7210: Database of Long-Lived Symmetric Cryptographic Keys

Available Formats

KDF Description Reference
none No KDF is used with this key
AES-128-CMAC AES-CMAC using 128-bit keys RFC 4493
HMAC-SHA-1 HMAC using the SHA-1 hash RFC 2104
HMAC-SHA-256 HMAC using the SHA-256 hash RFC 6234

KeyTable AlgIDs

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 7210: Database of Long-Lived Symmetric Cryptographic Keys

Available Formats

AlgID Description Reference
AES-128-CMAC AES-CMAC using 128-bit keys RFC 4493
AES-128-CMAC-96 AES-128-CMAC truncated to 96-bit RFC 5926
HMAC-SHA-1-96 HMAC SHA-1 truncated to 96-bits RFC 2104