Layer Two Tunneling Protocol "L2TP"

Created

  • 2003-03

Last Updated

  • 2024-09-02

Note

Unless otherwise noted, the registrations in this registry are applicable in the context of the IETF Vendor ID RFC 2661.

Available Formats


Control Message Attribute Value Pairs

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3438: Layer Two Tunneling Protocol (L2TP) Internet Assigned Numbers Authority (IANA) Considerations Update

Note

To maximize extensibility while still permitting interoperability, a uniform method for encoding message types and bodies is used throughout L2TP. This encoding will be termed AVP (Attribute-Value Pair).

Available Formats

Attribute Type Description Reference
0 Message Type AVP Also, see Message Type AVP values below RFC 2661
1 Result Code AVP Also, see Result Code AVP values below RFC 2661
2 Protocol Version AVP RFC 2661
3 Framing Capabilities AVP Also, see Framing Field definition below RFC 2661
4 Bearer Capabilities AVP Also, see Bearer Field definition below RFC 2661
5 Tie Breaker AVP RFC 2661
6 Firmware Revision AVP RFC 2661
7 Host Name AVP RFC 2661
8 Vendor Name AVP RFC 2661
9 Assigned Tunnel ID AVP RFC 2661
10 Receive Window Size AVP RFC 2661
11 Challenge AVP RFC 2661
12 Q.931 Cause Code AVP RFC 2661
13 Response AVP RFC 2661
14 Assigned Session ID AVP RFC 2661
15 Call Serial Number AVP RFC 2661
16 Minimum BPS AVP RFC 2661
17 Maximum BPS AVP RFC 2661
18 Bearer Type AVP Also, see Bearer Field definition below RFC 2661
19 Framing Type AVP Also, see Framing Field definition below RFC 2661
20 Reserved RFC 2661
21 Called Number AVP RFC 2661
22 Calling Number AVP RFC 2661
23 Sub-Address AVP RFC 2661
24 (Tx) Connect Speed BPS AVP RFC 2661
25 Physical Channel ID AVP RFC 2661
26 Initial Received LCP CONFREQ AVP RFC 2661
27 Last Sent LCP CONFREQ AVP RFC 2661
28 Last Received LCP CONFREQ AVP RFC 2661
29 Proxy Authen Type AVP Also, see Proxy Authen Type AVP Values below RFC 2661
30 Proxy Authen Name AVP RFC 2661
31 Proxy Authen Challenge AVP RFC 2661
32 Proxy Authen ID AVP RFC 2661
33 Proxy Authen Response AVP RFC 2661
34 Call Errors AVP RFC 2661
35 ACCM AVP RFC 2661
36 Random Vector AVP RFC 2661
37 Private Group ID AVP RFC 2661
38 Rx Connect Speed AVP RFC 2661
39 Sequencing Required AVP RFC 2661
40 Rx Minimum BPS RFC 3301
41 Rx Maximum BPS RFC 3301
42 Service Category Also, see Service Category AVP Flag Fields below RFC 3301
43 Service Name RFC 3301
44 Calling Sub-Address RFC 3301
45 VPI/VCI Identifier RFC 3301
46 PPP Disconnect Cause Code Also, see PPP Disconnect Cause Code Values below RFC 3145
47 CCDS AVP RFC 3308
48 SDS AVP RFC 3308
49 LCP Want Options RFC 3437
50 LCP Allow Options RFC 3437
51 LNS Last Sent LCP Confreq RFC 3437
52 LNS Last Received LCP Confreq RFC 3437
53 Modem On-Hold Capable AVP RFC 3573
54 Modem On-Hold Status AVP RFC 3573
55 PPPoE Relay AVP RFC 3817
56 PPPoE Relay Response Capability AVP RFC 3817
57 PPPoE Relay Forward Capability AVP RFC 3817
58 Extended Vendor ID AVP RFC 3931
59 Message Digest RFC 3931
60 Router ID RFC 3931
61 Assigned Control Connection ID RFC 3931
62 Pseudowire Capabilities List RFC 3931
63 Local Session ID RFC 3931
64 Remote Session ID RFC 3931
65 Assigned Cookie RFC 3931
66 Remote End ID RFC 3931
67 Application Code RFC 3931
68 Pseudowire Type RFC 3931
69 L2-Specific Sublayer RFC 3931
70 Data Sequencing RFC 3931
71 Circuit Status RFC 3931
72 Preferred Language RFC 3931
73 Control Message Authentication Nonce RFC 3931
74 Tx Connect Speed RFC 3931
75 Rx Connect Speed RFC 3931
76 Failover Capability RFC 4951
77 Tunnel Recovery RFC 4951
78 Suggested Control Sequence RFC 4951
79 Failover Session State RFC 4951
80 Multicast Capability RFC 4045
81 New Outgoing Sessions RFC 4045
82 New Outgoing Sessions Acknowledgement RFC 4045
83 Withdraw Outgoing Sessions RFC 4045
84 Multicast Packets Priority RFC 4045
85 Frame-Relay Header Length RFC 4591
86 ATM Maximum Concatenated Cells AVP RFC 4454
87 OAM Emulation Required AVP RFC 4454
88 ATM Alarm Status AVP Also, see ATM Alarm Status AVP Values below RFC 4454
89 Attachment Group Identifier RFC 4667
90 Local End Identifier RFC 4667
91 Interface Maximum Transmission Unit RFC 4667
92 FCS Retention RFC 4720
93 Tunnel Switching Aggregator ID AVP draft-ietf-l2tpext-tunnel-switching-06
94 Maximum Receive Unit (MRU) AVP RFC 4623
95 Maximum Reassembled Receive Unit (MRRU) AVP RFC 4623
96 VCCV Capability AVP RFC 5085
97 Connect Speed Update AVP RFC 5515
98 Connect Speed Update Enable AVP RFC 5515
99 TDM Pseudowire AVP RFC 5611
100 RTP AVP RFC 5611
101 PW Switching Point AVP RFC 6073
102 S-BFD Target Discriminator ID RFC 7886
103 ECN Capability RFC 9601
104-65535 Unassigned

Message Type AVP (Attribute Type 0) Values

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3438: Layer Two Tunneling Protocol (L2TP) Internet Assigned Numbers Authority (IANA) Considerations Update

Control Connection Management

Available Formats

Value Description Reference
0 (reserved)
1 (SCCRQ) Start-Control-Connection-Request
2 (SCCRP) Start-Control-Connection-Reply
3 (SCCCN) Start-Control-Connection-Connected
4 (StopCCN) Stop-Control-Connection-Notification
5 (reserved)
6 (HELLO) Hello
20 (ACK) Explicit Acknowledgement RFC 3931

Call Management

Available Formats

Value Description Reference
7 (OCRQ) Outgoing-Call-Request
8 (OCRP) Outgoing-Call-Reply
9 (OCCN) Outgoing-Call-Connected
10 (ICRQ) Incoming-Call-Request
11 (ICRP) Incoming-Call-Reply
12 (ICCN) Incoming-Call-Connected
13 (reserved)
14 (CDN) Call-Disconnect-Notify

Link Status

Available Formats

Value Description Reference
15 (WEN) WAN-Error-Notify
16 (SLI) Set-Link-Info
17 (MDMST) Modem Status RFC 3573

PPPoE Relay

Available Formats

Value Description Reference
18 (SRRQ) Service Relay Request Message RFC 3817
19 (SRRP) Service Relay Reply Message RFC 3817

Multicast Management

Available Formats

Value Description Reference
23 (MSRQ) Multicast-Session-Request RFC 4045
24 (MSRP) Multicast-Session-Response RFC 4045
25 (MSE) Multicast-Session-Establishment RFC 4045
26 (MSI) Multicast-Session-Information RFC 4045
27 (MSEN) Multicast-Session-End-Notify RFC 4045

Failover Management

Available Formats

Value Description Reference
21 (FSQ) Failover Session Query RFC 4951
22 (FSR) Failover Session Response RFC 4951

Access Line Information Attributes

Available Formats

Value Description Reference
28 (CSUN) Connect-Speed-Update-Notification RFC 5515
29 (CSURQ) Connect-Speed-Update-Request RFC 5515

Result Code AVP (Attribute Type 1) Values

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3438: Layer Two Tunneling Protocol (L2TP) Internet Assigned Numbers Authority (IANA) Considerations Update

Result Code values for the StopCCN message

Available Formats

Value Message Description Reference
0 Reserved
1 General request to clear control connection
2 General error--Error Code indicates the problem
3 Control channel already exists
4 Requester is not authorized to establish a control channel
5 The protocol version of the requester is not supported Error Code indicates highest version supported
6 Requester is being shut down
7 Finite State Machine error
8 Control connection due to mismatching CCDS value RFC 3308

Result Code values for the CDN message

Available Formats

Value Message Description Reference
0 Reserved
1 Call/Session disconnected due to loss of carrier
2 Call/Session disconnected for the reason indicated in error code
3 Call/Session disconnected for administrative reasons
4 Call/Session failed due to lack of appropriate facilities being available (temporary condition)
5 Call/Session failed due to lack of appropriate facilities being available (permanent condition)
6 Invalid destination
7 Call failed due to no carrier detected
8 Call failed due to detection of a busy signal
9 Call failed due to lack of a dial tone
10 Call was not established within time allotted by LAC
11 Call was connected but no appropriate framing was detected
12 Disconnecting call due to mismatching SDS value RFC 3308
13 Session not established due to losing tie breaker (L2TPv3) RFC 3931
14 Session not established due to unsupported PW type (L2TPv3) RFC 3931
15 Session not established, sequencing required without valid L2-Specific Sublayer (L2TPv3). RFC 3931
16 Finite state machine error or timeout. RFC 3931
17 FR PVC was deleted permanently (no longer provisioned) RFC 4591
18 FR PVC has been INACTIVE for an extended period of time RFC 4591
19 Mismatched FR Header Length RFC 4591
20 HDLC Link was deleted permanently (no longer provisioned) RFC 4349
21 HDLC Link has been INACTIVE for an extended period of time RFC 4349
22 Session not established due to other LCCE can not support the OAM Cell Emulation RFC 4454
23 Mismatching interface MTU RFC 4667
24 Attempt to connect to non-existent forwarder RFC 4667
25 Attempt to connect to unauthorized forwarder RFC 4667
26 Loop Detected draft-ietf-l2tpext-tunnel-switching-06
27 Attachment Circuit bound to different PE RFC 6074
28 Attachment Circuit bound to different remote Attachment Circuit RFC 6074
29 Unassigned
30 Return code to indicate connection was refused because of TDM PW parameters. The error code indicates the problem. RFC 5611
31 Sequencing not supported RFC 6073

Result Code values for the MSEN message

Available Formats

Value Message Description Reference
0 Reserved
1 No multicast traffic for the group RFC 4045
2 Session terminated for the reason indicated in the error code RFC 4045
3 No more receivers RFC 4045
4 No more receivers (filter-mode change) RFC 4045

General Error Codes

Available Formats

Value Message Description Reference
0 No general error
1 No control connection exists yet for this LAC-LNS pair
2 Length is wrong
3 One of the field values was out of range or reserved field was non-zero
4 Insufficient resources to handle this operation now
5 The Session ID is invalid in this context
6 A generic vendor-specific error occurred in the LAC
7 Try another. If LAC is aware of other possible LNS destinations, it should try one of them. This can be used to guide an LAC based on LNS policy, for instance, the existence of multilink PPP bundles.
8 Session or tunnel was shutdown due to receipt of an unknown AVP with the M-bit set (see section 4.2). The Error Message SHOULD contain the attribute of the offending AVP in (human readable) text form.
9 Try another directed. If an LAC or LNS is aware of other possible destinations, it should inform the initiator of the control connection or session. The Error Message MUST contain a comma-separated list of addresses from which the initiator may choose. If the L2TP data channel runs over IPv4, then this would be a comma-separated list of IP addresses in the canonical dotted-decimal format (e.g., "192.0.2.1, 192.0.2.2, 192.0.2.3") in the UTF-8 charset RFC 3629 using the Default Language RFC 2277. If there are no servers for the LAC or LNS to suggest, then Error Code 7 should be used. For IPv4, the delimiter between addresses MUST be precisely a single comma and a single space. For IPv6, each literal address MUST be enclosed in "[" and "]" characters, following the encoding described in RFC 2732.
10 Next hop unreachable. This identifies an error condition explicitly in the multi-TSA environment. draft-ietf-l2tpext-tunnel-switching-06
11 Next hop busy. This identifies an error condition explicitly in the multi-TSA environment. draft-ietf-l2tpext-tunnel-switching-06
12 TSA busy. This identifies an error condition explicitly in the multi-TSA environment. draft-ietf-l2tpext-tunnel-switching-06

TDM PW Specific error codes, to be used with 30 result code for the CDN message

Available Formats

Value Message Description Reference
0 Reserved RFC 5611
1 Bit Rate values disagree. RFC 5611
2 Different trunk types in the case of trunk-specific CESoPSN with CAS. RFC 5611
3 Requested payload size too big or too small. RFC 5611
4 RTP header cannot be generated. RFC 5611
5 Requested timestamp clock frequency cannot be generated. RFC 5611

Proxy Authen Type AVP (Attribute Type 29) Values

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 2661: Layer Two Tunneling Protocol "L2TP"

Available Formats

Value Description Reference
0 Reserved RFC 2661
1 Textual username/password exchange RFC 2661
2 PPP CHAP RFC 2661
3 PPP PAP RFC 2661
4 No Authentication RFC 2661
5 Microsoft CHAP Version 1 (MSCHAPv1) RFC 2661
6 Reserved
7 EAP draft-ietf-l2tpext-proxy-authen-ext-eap-00

Service Category AVP (Attribute Type 42) Flag Field

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3301: Layer Two Tunnelling Protocol (L2TP): ATM access network extensions

Note

The Attribute Value field is a 16-bit field.

Available Formats

Value Description Reference
0x0001 S-bit (real-time) RFC 3301

PPP Disconnect Cause Code (Attribute Type 46) Values

Reference

  • RFC 3145: L2TP Disconnect Cause Information

Available Formats

Range Registration Procedures
0-32767 IESG Approval
32768-65279 First Come First Served
65280-65535 Reserved for Private or Experimental Use

Global Errors

Available Formats

Value Description
0 No information available
1 Administrative disconnect.
2 Link Control Protocol (LCP) renegotiation at LNS disabled; LNS expects proxy LCP information, LAC did not send it.
3 Normal Disconnection, LCP Terminate-Request sent. Valid Direction values are: 1: LCP Terminate-Request sent by peer 2: LCP Terminate-Request sent by local
4 Compulsory encryption required by a PPP peer was refused by the other. Valid Direction values are: 1: Required by local; refused by peer 2: Required by peer; refused by local

LCP Errors

Available Formats

Value Description
5 FSM (Finite State Machine) Timeout error. (PPP event "TO-".)
6 No recognizable LCP packets were received.
7 LCP failure: Magic Number error; link possibly looped back.
8 LCP link failure: Echo Request timeout.
9 Peer has unexpected Endpoint-Discriminator for existing Multilink PPP (MP) bundle.
10 Peer has unexpected MRRU for existing MP bundle.
11 Peer has unexpected Short-Sequence-Number option for existing MP bundle.
12 Compulsory call-back required by a PPP peer was refused by the other. Valid Direction values are: 1: Required by local; refused by peer 2: Required by peer; refused by local

Authentication Errors

Available Formats

Value Description
13 FSM Timeout error.
14 Peer has unexpected authenticated name for existing MP bundle.
15 PPP authentication failure: Authentication protocol unacceptable. Valid Direction values are: 1: All local authentication protocols were rejected by the peer. 2: All authentication protocols requested by peer were unacceptable or unimplemented locally.
16 PPP authentication failure: Authentication failed (bad name, password, or secret). Valid Direction values are: 1: Authentication of peer identity by local system. 2: Authentication of local identity by peer system.

Network Control Protocol (NCP) Errors

Available Formats

Value Description
17 FSM Timeout error.
18 No NCPs available (all disabled or rejected); no NCPs went to Opened state. (Control Protocol Number may be zero only if neither peer has enabled NCPs.)
19 NCP failure: failed to converge on acceptable addresses. Valid Direction values are: 1: Too many Configure-Naks received from peer. 2: Too many Configure-Naks sent to peer.
20 NCP failure: user not permitted to use any addresses. Valid Direction values are: 1: Local link address not acceptable to peer. 2: Remote link address not acceptable to local system.
21-32767 Unassigned (by IESG Approval)
32768-65279 Unassigned (First Come First Served)
65280-65535 Private or Experimental Use

ATM Alarm Status AVP (Attribute Type 88) Values

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 4454: Asynchronous Transfer Mode (ATM) over Layer 2 Tunneling Protocol Version 3 (L2TPv3)

Circuit Status Reason values for the SLI message

Available Formats

Value Description Reference
0 Reserved RFC 4454
1 No alarm or alarm cleared (default for Active Status) RFC 4454
2 Unspecified or unknown Alarm Received (default for Inactive Status) RFC 4454
3 ATM Circuit received F1 Alarm on ingress LCCE RFC 4454
4 ATM Circuit received F2 Alarm on ingress LCCE RFC 4454
5 ATM Circuit received F3 Alarm on ingress LCCE RFC 4454
6 ATM Circuit received F4 Alarm on ingress LCCE RFC 4454
7 ATM Circuit received F5 Alarm on ingress LCCE RFC 4454
8 ATM Circuit down due to ATM Port shutdown on Peer LCCE RFC 4454
9 ATM Circuit down due to loop-back timeout on ingress LCCE RFC 4454

General ATM Alarm failures

Available Formats

Value Description Reference
0 Reserved RFC 4454
1 No Alarm type specified (default) RFC 4454
2 Alarm Indication Signal (AIS) RFC 4454
3 Remote Defect Indicator (RDI) RFC 4454
4 Loss of Signal (LOS) RFC 4454
5 Loss of pointer (LOP) RFC 4454
6 Loss of framer (LOF) RFC 4454
7 loopback cells (LB) RFC 4454
8 Continuity Check (CC) RFC 4454

VCCV Capability AVP (Attribute Type 96) Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5085: Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for Pseudowires

Note

Bit numbering: In this sub-registry, the most significant (high order) bit is labeled Bit 7, and the least significant (low order) bit is labeled Bit 0, see parenthetical "Value".


L2TPv3 Control Channel (CC) Types

Available Formats

Bit (Value) Description Reference
0 (0x01) L2-Specific Sublayer with V-bit set RFC 5085
1 (0x02) Reserved RFC 5085
2 (0x04) Reserved RFC 5085
3 (0x08) Reserved RFC 5085
4 (0x10) Reserved RFC 5085
5 (0x20) Reserved RFC 5085
6 (0x40) Reserved RFC 5085
7 (0x80) Reserved RFC 5085

L2TPv3 Connectivity Verification (CV) Types

Available Formats

Bit (Value) Description Reference
0 (0x01) ICMP Ping RFC 5085
1 (0x02) Reserved RFC 5085
2 (0x04) BFD IP/UDP-encapsulated, for PW Fault Detection only RFC 5885
3 (0x08) BFD IP/UDP-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling RFC 5885
4 (0x10) BFD PW-ACH-encapsulated, for PW Fault Detection only RFC 5885
5 (0x20) BFD PW-ACH-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling RFC 5885
6 (0x40) S-BFD IP/UDP-encapsulated, for PW Fault Detection only RFC 7885
7 (0x80) S-BFD L2SS-encapsulated, for PW Fault Detection only RFC 7885

Bearer Field definition

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 2661: Layer Two Tunneling Protocol "L2TP"

Note

The Bearer field is used by the Bearer Capabilities and Bearer Type AVPs. It is a 32-bit bit field, with current defined bit values of:

Available Formats

Value Meaning Reference
0x00000001 D-bit (Digital access requested) RFC 2661
0x00000002 A-bit (Analogue access requested) RFC 2661
0x00000004 B-bit (ATM Bearer support) RFC 3301

Framing Field definition

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 2661: Layer Two Tunneling Protocol "L2TP"

Note

The Framing field is used by the Framing Capabilities and Framing Type AVPs. It is a 32-bit bit field, with current defined bit values of:

Available Formats

Value Meaning Reference
0x00000001 S-bit (synchronous framing) RFC 2661
0x00000002 A-bit (asyncronous framing) RFC 2661

Leading Bits of the L2TP AVP Header

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 2661: Layer Two Tunneling Protocol "L2TP"
  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

There are six bits at the beginning of the L2TP AVP header. L2TPv2 and L2TPv3 share a common registry for the definitions of the six leading bits.

Available Formats

Value Description Reference
Bit 0 Mandatory Bit, "M-bit" RFC 2661; RFC 3931
Bit 1 Hidden Bit, "H-bit" RFC 2661; RFC 3931
Bit 2 Reserved RFC 2661; RFC 3931
Bit 3 Reserved RFC 2661; RFC 3931
Bit 4 Reserved RFC 2661; RFC 3931
Bit 5 Reserved RFC 2661; RFC 3931

Leading Bits of the L2TP Message Header

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 2661: Layer Two Tunneling Protocol "L2TP"
  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

There are 12 bits at the beginning of the L2TP Message Header. L2TPv2 and L2TPv3 share a common registry for the definitions of the 12 leading bits.

Available Formats

Value Description Reference
Bit 0 Message Type, "T-bit" RFC 2661; RFC 3931
Bit 1 Length Field is Present, "L-bit" RFC 2661; RFC 3931
Bit 2 Reserved RFC 2661; RFC 3931
Bit 3 Reserved RFC 2661; RFC 3931
Bit 4 Sequence Numbers Present, "S-bit" RFC 2661; RFC 3931
Bit 5 Reserved RFC 2661; RFC 3931
Bit 6 Offset Field is Present RFC 2661
Bit 7 Priority Bit, "P-bit" RFC 2661
Bit 8 B (Fragmentation) bit RFC 4623
Bit 9 E (Fragmentation) bit RFC 4623
Bit 10 Reserved RFC 2661; RFC 3931
Bit 11 Reserved RFC 2661; RFC 3931

L2TPv3 Pseudowire Types

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

The Pseudowire Type (PW Type, Section 5.4) is a two-octet value used in the Pseudowire Type AVP and Pseudowire Capabilities List AVP defined in Section 5.4.3. There are no specific pseudowire types assigned within this document. Each pseudowire-specific document must allocate its own PW types from IANA as necessary.

Available Formats

Range Registration Procedures
0-32767 Expert Review
32768-65535 First Come First Served
Value Description Reference Registration Date
0x0001 Frame Relay DLCI Pseudowire Type RFC 4591
0x0002 ATM AAL5 SDU VCC transport RFC 4454
0x0003 ATM Cell transparent Port Mode RFC 4454
0x0004 Ethernet VLAN Pseudowire Type RFC 4719
0x0005 Ethernet Pseudowire Type RFC 4719
0x0006 HDLC Pseudowire Type RFC 4349
0x0009 ATM Cell transport VCC Mode RFC 4454
0x000A ATM Cell transport VPC Mode RFC 4454
0x000B Unassigned
0x000C MPEG-TS Payload Type (MPTPW) "Data-Over-Cable Service Interface Specifications: Downstream External PHY Interface Specification CM-SP-DEPI-I01-050805", DOCSIS, August 2005 2006-01-30
0x000D Packet Streaming Protocol (PSPPW) "Data-Over-Cable Service Interface Specifications: Downstream External PHY Interface Specification CM-SP-DEPI-I01-050805", DOCSIS, August 2005 2006-01-30
0x000E-0x0010 Unassigned
0x0011 Structure-agnostic E1 circuit RFC 5611
0x0012 Structure-agnostic T1 (DS1) circuit RFC 5611
0x0013 Structure-agnostic E3 circuit RFC 5611
0x0014 Structure-agnostic T3 (DS3) circuit RFC 5611
0x0015 CESoPSN basic mode RFC 5611
0x0016 Unassigned
0x0017 CESoPSN TDM with CAS RFC 5611

Circuit Status Bits

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

The Circuit Status field is a 16 bit mask, with the two high order bits assigned.

Available Formats

Value Description Reference
Bit 9 S (Standby) bit RFC 5641
Bit 10 E (Local PSN-facing PW (egress) Tx Fault) bit RFC 5641
Bit 11 I (Local PSN-facing PW (ingress) Rx Fault) bit RFC 5641
Bit 12 T (Local AC (egress) Tx Fault) bit RFC 5641
Bit 13 R (Local AC (ingress) Rx Fault) bit RFC 5641
Bit 14 N (New) bit [use deprecated] RFC 3931; RFC 5641
Bit 15 A (Active) bit RFC 3931

Default L2-Specific Sublayer bits

Reference

  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

The Default L2 Specific Sublayer contains 8 bits in the low-order portion of the header. Reserved bits may be assigned by IETF Review RFC 8126.

Available Formats

Value Description Reference
Bit 0 V (VCCV) bit RFC 5085
Bit 1 S (Sequence) bit RFC 3931
Bit 2 B (Fragmentation) bit RFC 4623
Bit 3 E (Fragmentation) bit RFC 4623
Bit 4 Reserved RFC 3931
Bit 5 Reserved RFC 3931
Bit 6 Reserved RFC 3931
Bit 7 Reserved RFC 3931

L2-Specific Sublayer Type

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

The L2-Specific Sublayer Type is a 2 octet unsigned integer. Additional values may be assigned by Expert Review RFC 8126.

Available Formats

Value Description Reference Registration Date
0 No L2-Specific Sublayer RFC 3931
1 Default L2-Specific Sublayer present RFC 3931
2 ATM-Specific Sublayer present RFC 4454
3 MPT-Specific Sublayer "Data-Over-Cable Service Interface Specifications: Downstream External PHY Interface Specification CM-SP-DEPI-I01-050805", DOCSIS, August 2005 2006-01-30
4 PSP-Specific Sublayer "Data-Over-Cable Service Interface Specifications: Downstream External PHY Interface Specification CM-SP-DEPI-I01-050805", DOCSIS, August 2005 2006-01-30

Data Sequencing Level

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Carlos Pignataro (primary), Ignacio Goyret (secondary)

Reference

  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

Note

The Data Sequencing Level is a 2 octet unsigned integer Additional values may be assigned by Expert Review RFC 8126.

Available Formats

Value Description Reference
0 No incoming data packets require sequencing. RFC 3931
1 Only non-IP data packets require sequencing. RFC 3931
2 All incoming data packets require sequencing. RFC 3931

ATM-Specific Sublayer bits

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4454: Asynchronous Transfer Mode (ATM) over Layer 2 Tunneling Protocol Version 3 (L2TPv3)

Available Formats

Bit Description Reference
Bit 0 V (VCCV) bit RFC 5085
Bit 1 S (Sequence) bit RFC 4454
Bit 2 B (Fragmentation) bit RFC 4454
Bit 3 E (Fragmentation) bit RFC 4454
Bit 4 T (Transport type) bit RFC 4454
Bit 5 G (EFCI) bit RFC 4454
Bit 6 C (CLP) bit RFC 4454
Bit 7 U (Command/Response) bit RFC 4454