Lightweight Directory Access Protocol (LDAP) Parameters

Created

  • 2003-08-27

Last Updated

  • 2017-12-04

Available Formats


Internet Directory Numbers (iso.org.dod.internet.directory [1.3.6.1.1.])

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)
  • RFC 2578: Structure of Management Information Version 2 (SMIv2)

Note

Directory OIDs are assigned to RFCs for their use in identifying directory (and possibly other) objects in accordance with BCP 64 RFC 4520. The referenced RFC should be consulted for information about these assignments.

Available Formats

Decimal Name Description Reference
0 Reserved Reserved for future use IANA
1 nisSchema Network Info Service Schema RFC 2307
2 NameForm Naming Plan RFC 2377
3 AuxObject Auxiliary Object Class RFC 2377
4 vendorName Vendor Name RFC 3045
5 vendorVersion Vendor Version RFC 3045
6 pcimSchema Policy Core Information Model LDAP Schema RFC 3703
7 LCUP LDAP Client Update Protocol RFC 3928
8 cancelOp LDAP Cancel Operation RFC 3909
9 pcelsSchema PCELS Schema RFC 4104
10 uddi Universal Description, Discovery & Integration RFC 4403
11 vPIM Voice Messaging Directory Service RFC 4237
12 assertion Assertion Control RFC 4528
13 ReadEntry Read Entry Controls RFC 4527
14 increment LDAP Modify-Increment RFC 4525
15 x509 x.509 Certificates RFC 4523
16 uuid entryUUID RFC 4530
17 LBURP LDAP Bulk Update/Replication Protocol RFC 4373
18 ASN1 module LDAP ASN.1 Module RFC 4511
19 turn LDAP Turn Operation RFC 4531
20 entryDN LDAP entryDN Operational Attribute RFC 5020
21 txn LDAP Transactions RFC 5805
22 dontUseCopy LDAP Don't Use Copy Control RFC 6171
23 xmpp LDAP schema for XMPP RFC 8284

Protocol Mechanisms

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Note

Legend:
C => Control
E => Extension
F => Feature
N => Unsolicited Notice

Available Formats

Object Identifier Type Description Reference
1.2.826.0.1.3344810.2.3 C Matched Values Control RFC 3876
1.2.840.113556.1.4.319 C LDAP Simple Paged Results Control RFC 2696
1.2.840.113556.1.4.473 C Sort Request RFC 2891
1.2.840.113556.1.4.474 C Sort Response RFC 2891
1.3.6.1.1.7.1 C LCUP Sync Request Control RFC 3928
1.3.6.1.1.7.2 C LCUP Sync Update Control RFC 3928
1.3.6.1.1.7.3 C LCUP Sync Done Control RFC 3928
1.3.6.1.1.8 E Cancel Operation RFC 3909
1.3.6.1.1.12 C Assertion Control RFC 4528
1.3.6.1.1.13.1 C LDAP Pre-read Control RFC 4527
1.3.6.1.1.13.2 C LDAP Post-read Control RFC 4527
1.3.6.1.1.14 F Modify-Increment RFC 4525
1.3.6.1.1.21.1 E Start Transaction Extended Request RFC 5805
1.3.6.1.1.21.2 C Transaction Specification Control RFC 5805
1.3.6.1.1.21.3 E End Transaction Extended Request RFC 5805
1.3.6.1.1.21.4 N Aborted Transaction Notice RFC 5805
1.3.6.1.4.1.1466.101.119.1 E Dynamic Refresh RFC 2589
1.3.6.1.4.1.1466.20037 E StartTLS RFC 4511; RFC 4513
1.3.6.1.4.1.4203.1.5.1 F All Op Attrs RFC 3673
1.3.6.1.4.1.4203.1.5.2 F OC AD Lists RFC 4529
1.3.6.1.4.1.4203.1.5.3 F True/False filters RFC 4526
1.3.6.1.4.1.4203.1.5.4 F Language Tag Options RFC 3866
1.3.6.1.4.1.4203.1.5.5 F Language Range Options RFC 3866
1.3.6.1.4.1.4203.1.9.1.1 C LDAP Content Synchronization Control RFC 4533
1.3.6.1.4.1.4203.1.10.1 C Subentries RFC 3672
1.3.6.1.4.1.4203.1.11.1 E Modify Password RFC 3062
1.3.6.1.4.1.4203.1.11.3 E Who am I? RFC 4532
1.3.6.1.1.17.1 E StartLBURPRequest LDAP ExtendedRequest message RFC 4373
1.3.6.1.1.17.2 E StartLBURPResponse LDAP ExtendedResponse message RFC 4373
1.3.6.1.1.17.3 E EndLBURPRequest LDAP ExtendedRequest message RFC 4373
1.3.6.1.1.17.4 E EndLBURPResponse LDAP ExtendedResponse message RFC 4373
1.3.6.1.1.17.5 E LBURPUpdateRequest LDAP ExtendedRequest message RFC 4373
1.3.6.1.1.17.6 E LBURPUpdateResponse LDAP ExtendedResponse message RFC 4373
1.3.6.1.1.17.7 F LBURP Incremental Update style OID RFC 4373
1.3.6.1.1.19 E LDAP Turn Operation RFC 4531
2.16.840.1.113730.3.4.2 C ManageDsaIT RFC 3296
2.16.840.1.113730.3.4.15 C Authorization Identity Response Control RFC 3829
2.16.840.1.113730.3.4.16 C Authorization Identity Request Control RFC 3829
2.16.840.1.113730.3.4.18 C Proxy Authorization Control RFC 4370
1.3.6.1.1.22 C LDAP Don't Use Copy Control RFC 6171

Object Identifier Descriptors

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Note

Legend:
A => Attribute Type
C => DIT Content Rule
E => LDAP URL Extension
F => Family
M => Matching Rule
N => Name Form
O => Object Class
R => Administrative Role
* => The registration is historic in nature

Available Formats

Range Registration Procedures
x- Private Use (can not be registered)
e- Reserved for Experiments, First Come First Served
All others Expert Review
Name Type OID Reference
accessControlInnerArea R 2.5.23.3 RFC 3672
accessControlSpecificArea R 2.5.23.2 RFC 3672
account O 0.9.2342.19200300.100.4.5 RFC 4524
add A Reserved for LDIF RFC 2849
administrativeRole A 2.5.18.5 RFC 3672
administratorsAddress A 1.3.6.1.4.1.1466.101.120.1 Mark Wahl
algorithmIdentifierMatch M 2.5.13.40 RFC 4523
alias O 2.5.6.1 RFC 4512
aliasedEntryName A 2.5.4.1 X.501
aliasedObjectName A 2.5.4.1 RFC 4512
allComponentsMatch M 1.2.36.79672281.1.13.6 RFC 3687
altServer A 1.3.6.1.4.1.1466.101.120.6 RFC 4512
applicationEntity O 2.5.6.12 RFC 2256
applicationProcess O 2.5.6.11 RFC 4519
aRecord A 0.9.2342.19200300.100.1.26 RFC 1274
associatedDomain A 0.9.2342.19200300.100.1.37 RFC 4524
associatedInternetGateway A 1.3.6.1.4.1.453.7.2.8 RFC 2164
associatedName A 0.9.2342.19200300.100.1.38 RFC 4524
associatedORAddress A 1.3.6.1.4.1.453.7.2.6 RFC 2164
associatedX400Gateway A 1.3.6.1.4.1.453.7.2.3 RFC 2164
attributeMap A 1.3.6.1.4.1.11.1.3.1.1.9 RFC 4876
attributeTypes A 2.5.21.5 RFC 4512
audio A 0.9.2342.19200300.100.1.55 RFC 1274
authenticationMethod A 1.3.6.1.4.1.11.1.3.1.1.6 RFC 4876
authorityRevocationList A 2.5.4.38 RFC 4523
autonomousArea R 2.5.23.1 RFC 3672
bindTimeLimit A 1.3.6.1.4.1.11.1.3.1.1.4 RFC 4876
bitStringMatch M 2.5.13.16 RFC 4517
booleanMatch M 2.5.13.13 RFC 4517
buildingName A 0.9.2342.19200300.100.1.48 RFC 4524
businessCategory A 2.5.4.15 RFC 4519
c A 2.5.4.6 RFC 4519
c-FacsimileTelephoneNumber A 2.5.4.23.1 RFC 3671
c-InternationalISDNNumber A 2.5.4.25.1 RFC 3671
c-l A 2.5.4.7.1 RFC 3671
c-PhysicalDeliveryOffice A 2.5.4.19.1 RFC 3671
c-PostalAddress A 2.5.4.16.1 RFC 3671
c-PostalCode A 2.5.4.17.1 RFC 3671
c-PostOfficeBox A 2.5.4.18.1 RFC 3671
c-o A 2.5.4.10.1 RFC 3671
c-ou A 2.5.4.11.1 RFC 3671
c-st A 2.5.4.8.1 RFC 3671
c-street A 2.5.4.9.1 RFC 3671
c-TelephoneNumber A 2.5.4.20.1 RFC 3671
c-TelexNumber A 2.5.4.21.1 RFC 3671
cACertificate A 2.5.4.37 RFC 4523
calCalAdrURI A 1.2.840.113556.1.4.481 RFC 2739
calCalURI A 1.2.840.113556.1.4.478 RFC 2739
calCAPURI A 1.2.840.113556.1.4.480 RFC 2739
calEntry O 1.2.840.113556.1.5.87 RFC 2739
calFBURL A 1.2.840.113556.1.4.479 RFC 2739
calOtherCalAdrURIs A 1.2.840.113556.1.4.485 RFC 2739
calOtherCalURIs A 1.2.840.113556.1.4.482 RFC 2739
calOtherCAPURIs A 1.2.840.113556.1.4.484 RFC 2739
calOtherFBURLs A 1.2.840.113556.1.4.483 RFC 2739
carLicense A 2.16.840.1.113730.3.1.1 RFC 2798
caseExactIA5Match M 1.3.6.1.4.1.1466.109.114.1 RFC 4517
caseExactMatch M 2.5.13.5 RFC 4517
caseExactOrderingMatch M 2.5.13.6 RFC 4517
caseExactSubstringsMatch M 2.5.13.7 RFC 4517
caseIgnoreIA5Match M 1.3.6.1.4.1.1466.109.114.2 RFC 4517
caseIgnoreIA5SubstringsMatch M 1.3.6.1.4.1.1466.109.114.3 RFC 4517
caseIgnoreListMatch M 2.5.13.11 RFC 4517
caseIgnoreListSubstringsMatch M 2.5.13.12 RFC 4517
caseIgnoreMatch M 2.5.13.2 RFC 4517
caseIgnoreOrderingMatch M 2.5.13.3 RFC 4517
caseIgnoreSubstringsMatch M 2.5.13.4 RFC 4517
certificateExactMatch M 2.5.13.34 RFC 4523
certificateListExactMatch M 2.5.13.38 RFC 4523
certificateListMatch M 2.5.13.39 RFC 4523
certificateMatch M 2.5.13.35 RFC 4523
certificatePairExactMatch M 2.5.13.36 RFC 4523
certificatePairMatch M 2.5.13.37 RFC 4523
certificateRevocationList A 2.5.4.39 RFC 4523
certificationAuthority O 2.5.6.16 RFC 4523
certificationAuthority-V2 O 2.5.6.16.2 RFC 4523
changetype A Reserved for LDIF RFC 2849
cn A 2.5.4.3 RFC 4519
cNAMERecord A 0.9.2342.19200300.100.1.31 RFC 1274
co A 0.9.2342.19200300.100.1.43 RFC 4524
collectiveAttributeInnerArea R 2.5.23.6 RFC 3672
collectiveAttributeSpecificArea R 2.5.23.5 RFC 3672
collectiveAttributeSubentries A 2.5.18.12 RFC 3671
collectiveAttributeSubentry O 2.5.20.2 RFC 3671
collectiveExclusions A 2.5.18.7 RFC 3671
commonName A 2.5.4.3 RFC 4519
componentFilterMatch M 1.2.36.79672281.1.13.2 RFC 3687
control A Reserved for LDIF RFC 2849
country O 2.5.6.2 RFC 4519
countryName A 2.5.4.6 RFC 4519
createTimestamp A 2.5.18.1 RFC 4512
creatorsName A 2.5.18.3 RFC 4512
credentialLevel A 1.3.6.1.4.1.11.1.3.1.1.10 RFC 4876
cRLDistributionPoint O 2.5.6.19 RFC 4523
crossCertificatePair A 2.5.4.40 RFC 4523
DC A 0.9.2342.19200300.100.1.25 RFC 4519
dcObject O 1.3.6.1.4.1.1466.344 RFC 4519
defaultServerList A 1.3.6.1.4.1.11.1.3.1.1.0 RFC 4876
defaultSearchBase A 1.3.6.1.4.1.11.1.3.1.1.1 RFC 4876
defaultSearchScope A 1.3.6.1.4.1.11.1.3.1.1.12 RFC 4876
delete A Reserved for LDIF RFC 2849
deleteoldrdn A Reserved for LDIF RFC 2849
deltaCRL O 2.5.6.23 RFC 4523
deltaRevocationList A 2.5.4.53 RFC 4523
departmentNumber A 2.16.840.1.113730.3.1.2 RFC 2798
dereferenceAliases A 1.3.6.1.4.1.11.1.3.1.1.16 RFC 4876
description A 2.5.4.13 RFC 4519
destinationIndicator A 2.5.4.27 RFC 4519
device O 2.5.6.14 RFC 4519
directoryComponentsMatch M 1.2.36.79672281.1.13.7 RFC 3687
directoryStringFirstComponentMatch M 2.5.13.31 RFC 4517
displayName A 2.16.840.1.113730.3.1.241 RFC 2798
distinguishedName A 2.5.4.49 RFC 4519
distinguishedNameMatch M 2.5.13.1 RFC 4517
distinguishedNameTableEntry O 1.3.6.1.4.1.453.7.1.5 RFC 2293
distinguishedNameTableKey A 1.3.6.1.4.1.453.7.2.3 RFC 2293
dITContentRules A 2.5.21.2 RFC 4512
dITRedirect A 0.9.2342.19200300.100.1.54 RFC 1274
dITStructureRules A 2.5.21.1 RFC 4512
dmd O 2.5.6.20 RFC 2256
dmdName A 2.5.4.54 RFC 2256
dn A Reserved for LDIF RFC 2849
dnQualifier A 2.5.4.46 RFC 4519
dNSDomain O 0.9.2342.19200300.100.4.15 RFC 1274
document O 0.9.2342.19200300.100.4.6 RFC 4524
documentAuthor A 0.9.2342.19200300.100.1.14 RFC 4524
documentIdentifier A 0.9.2342.19200300.100.1.11 RFC 4524
documentLocation A 0.9.2342.19200300.100.1.15 RFC 4524
documentPublisher A 0.9.2342.19200300.100.1.56 RFC 4524
documentSeries O 0.9.2342.19200300.100.4.8 RFC 4524
documentTitle A 0.9.2342.19200300.100.1.12 RFC 4524
documentVersion A 0.9.2342.19200300.100.1.13 RFC 4524
domain O 0.9.2342.19200300.100.4.13 RFC 4524
domainComponent A 0.9.2342.19200300.100.1.25 RFC 4519
domainNameForm N 1.3.6.1.4.1.1466.345 RFC 2247
domainRelatedObject O 0.9.2342.19200300.100.4.17 RFC 4524
drink A 0.9.2342.19200300.100.1.5 RFC 4524
dSA O 2.5.6.13 RFC 2256
dSAQuality A 0.9.2342.19200300.100.1.49 RFC 1274
DUAConfigProfile O 1.3.6.1.4.1.11.1.3.1.2.5 RFC 4876
dynamicObject O 1.3.6.1.4.1.1466.101.119.2 RFC 2589
dynamicSubtrees A 1.3.6.1.4.1.1466.101.119.4 RFC 2589
e-com-seafreeze-* F N/A Allen Williams
e-com-westjet-* F N/A Matthew Key
email A 1.2.840.113549.1.9.1 RFC 3280
emailAddress A 1.2.840.113549.1.9.1 RFC 3280
employeeNumber A 2.16.840.1.113730.3.1.3 RFC 2798
employeeType A 2.16.840.1.113730.3.1.4 RFC 2798
enhancedSearchGuide A 2.5.4.47 RFC 4519
entryDN A 1.3.6.1.1.20 RFC 5020
entryTtl A 1.3.6.1.4.1.1466.101.119.3 RFC 2589
entryUUID A 1.3.6.1.1.16.4 RFC 4530
extensibleObject O 1.3.6.1.4.1.1466.101.120.111 RFC 4512
facsimileTelephoneNumber A 2.5.4.23 RFC 4519
favouriteDrink A* 0.9.2342.19200300.100.1.5 RFC 4524
fedfsAnnotation A 1.3.6.1.4.1.31103.1.12 RFC 7532
fedfsDescr A 1.3.6.1.4.1.31103.1.13 RFC 7532
fedfsFsl O 1.3.6.1.4.1.31103.1.1003 RFC 7532
fedfsFslHost A* 1.3.6.1.4.1.31103.1.9 RFC 7532
fedfsFslPort A* 1.3.6.1.4.1.31103.1.10 RFC 7532
fedfsFslTTL A* 1.3.6.1.4.1.31103.1.11 RFC 7532
fedfsFslUuid A 1.3.6.1.4.1.31103.1.8 RFC 7532
fedfsFsn O 1.3.6.1.4.1.31103.1.1002 RFC 7532
fedfsFsnTTL A 1.3.6.1.4.1.31103.1.15 RFC 7532
fedfsFsnUuid A 1.3.6.1.4.1.31103.1.4 RFC 7532
fedfsNceDN A 1.3.6.1.4.1.31103.1.14 RFC 7532
fedfsNcePrefix A* 1.3.6.1.4.1.31103.1.7 RFC 7532
fedfsNetAddr A* 1.3.6.1.4.1.31103.1.2 RFC 7532
fedfsNetPort A* 1.3.6.1.4.1.31103.1.3 RFC 7532
fedfsNfsClassChange A 1.3.6.1.4.1.31103.1.112 RFC 7532
fedfsNfsClassFileid A 1.3.6.1.4.1.31103.1.110 RFC 7532
fedfsNfsClassHandle A 1.3.6.1.4.1.31103.1.109 RFC 7532
fedfsNfsClassReaddir A 1.3.6.1.4.1.31103.1.113 RFC 7532
fedfsNfsClassSimul A 1.3.6.1.4.1.31103.1.108 RFC 7532
fedfsNfsClassWritever A 1.3.6.1.4.1.31103.1.111 RFC 7532
fedfsNfsCurrency A 1.3.6.1.4.1.31103.1.103 RFC 7532
fedfsNfsFsl O 1.3.6.1.4.1.31103.1.1004 RFC 7532
fedfsNfsGenFlagGoing A 1.3.6.1.4.1.31103.1.105 RFC 7532
fedfsNfsGenFlagSplit A 1.3.6.1.4.1.31103.1.106 RFC 7532
fedfsNfsGenFlagWritable A 1.3.6.1.4.1.31103.1.104 RFC 7532
fedfsNfsMajorVer A* 1.3.6.1.4.1.31103.1.101 RFC 7532
fedfsNfsMinorVer A* 1.3.6.1.4.1.31103.1.102 RFC 7532
fedfsNfsPath A* 1.3.6.1.4.1.31103.1.100 RFC 7532
fedfsNfsReadOrder A 1.3.6.1.4.1.31103.1.115 RFC 7532
fedfsNfsReadRank A 1.3.6.1.4.1.31103.1.114 RFC 7532
fedfsNfsTransFlagRdma A 1.3.6.1.4.1.31103.1.107 RFC 7532
fedfsNfsURI A 1.3.6.1.4.1.31103.1.120 RFC 7532
fedfsNfsValidFor A 1.3.6.1.4.1.31103.1.119 RFC 7532
fedfsNfsVarSub A 1.3.6.1.4.1.31103.1.118 RFC 7532
fedfsNfsWriteOrder A 1.3.6.1.4.1.31103.1.117 RFC 7532
fedfsNfsWriteRank A 1.3.6.1.4.1.31103.1.116 RFC 7532
fedfsNsdbContainerInfo O 1.3.6.1.4.1.31103.1.1001 RFC 7532
fedfsNsdbName A* 1.3.6.1.4.1.31103.1.5 RFC 7532
fedfsNsdbPort A* 1.3.6.1.4.1.31103.1.6 RFC 7532
fedfsUuid A 1.3.6.1.4.1.31103.1.1 RFC 7532
followReferrals A 1.3.6.1.4.1.11.1.3.1.1.5 RFC 4876
friendlyCountry O 0.9.2342.19200300.100.4.18 RFC 4524
friendlyCountryName A* 0.9.2342.19200300.100.1.43 RFC 4524
generalizedTimeMatch M 2.5.13.27 RFC 4517
generalizedTimeOrderingMatch M 2.5.13.28 RFC 4517
generationQualifier A 2.5.4.44 RFC 4519
givenName A 2.5.4.42 RFC 4519
GN A RESERVED RFC 4519
governingStructureRule A 2.5.21.10 RFC 4512
groupOfNames O 2.5.6.9 RFC 4519
groupOfUniqueNames O 2.5.6.17 RFC 4519
homePhone A 0.9.2342.19200300.100.1.20 RFC 4524
homePostalAddress A 0.9.2342.19200300.100.1.39 RFC 4524
homeTelephone A* 0.9.2342.19200300.100.1.20 RFC 4524
host A 0.9.2342.19200300.100.1.9 RFC 4524
houseIdentifier A 2.5.4.51 RFC 4519
increment A Reserved for LDIF RFC 4525
inetOrgPerson O 2.16.840.1.113730.3.2.2 RFC 2798
info A 0.9.2342.19200300.100.1.4 RFC 4524
initials A 2.5.4.43 RFC 4519
integerFirstComponentMatch M 2.5.13.29 RFC 4517
integerMatch M 2.5.13.14 RFC 4517
integerOrderingMatch M 2.5.13.15 RFC 4517
internationaliSDNNumber A 2.5.4.25 RFC 4519
janetMailbox A 0.9.2342.19200300.100.1.46 RFC 1274
JIDObject O 1.3.6.1.1.23.1 RFC 8284
jid A 1.3.6.1.1.23.2 RFC 8284
jpegPhoto A 0.9.2342.19200300.100.1.60 RFC 2798
keywordMatch M 2.5.13.33 RFC 4517
knowledgeInformation A 2.5.4.2 RFC 2256
L A 2.5.4.7 RFC 4519
labeledURI A 1.3.6.1.4.1.250.1.57 RFC 2079
labeledURIObject O 1.3.6.1.4.1.250.3.15 RFC 2079
lastModifiedBy A 0.9.2342.19200300.100.1.24 RFC 1274
lastModifiedTime A 0.9.2342.19200300.100.1.23 RFC 1274
ldapSyntaxes A 1.3.6.1.4.1.1466.101.120.16 RFC 4512
LDIFLocationURL A 1.3.6.1.4.1.16572.2.2.6 RFC 6109
LDIFLocationURLObject O 1.3.6.1.4.1.16572.2.1.1 RFC 6109
locality O 2.5.6.3 RFC 4519
localityName A 2.5.4.7 RFC 4519
mail A 0.9.2342.19200300.100.1.3 RFC 4524
mailPreferenceOption A 0.9.2342.19200300.100.1.47 RFC 1274
mailReceipt A 1.3.6.1.4.1.16572.2.2.4 RFC 6109
manager A 0.9.2342.19200300.100.1.10 RFC 4524
managedDomains A 1.3.6.1.4.1.16572.2.2.5 RFC 6109
matchingRules A 2.5.21.4 RFC 4512
matchingRuleUse A 2.5.21.8 RFC 4512
mcgamTables A 1.3.6.1.4.1.453.7.2.9 RFC 2164
mDRecord A 0.9.2342.19200300.100.1.27 RFC 1274
member A 2.5.4.31 RFC 4519
mixerGateway O 1.3.6.1.4.1.453.7.1.4 RFC 2164
mobile A 0.9.2342.19200300.100.1.41 RFC 4524
mobileTelephoneNumber A* 0.9.2342.19200300.100.1.41 RFC 4524
moddn A Reserved for LDIF RFC 2849
modifiersName A 2.5.18.4 RFC 4512
modify A Reserved for LDIF RFC 2849
modrdn A Reserved for LDIF RFC 2849
modifyTimestamp A 2.5.18.2 RFC 4512
mXRecord A 0.9.2342.19200300.100.1.28 RFC 1274
name A 2.5.4.41 RFC 4519
nameForms A 2.5.21.7 RFC 4512
namingContexts A 1.3.6.1.4.1.1466.101.120.5 RFC 4512
newrdn A Reserved for LDIF RFC 2849
newsuperior A Reserved for LDIF RFC 2849
nSRecord A 0.9.2342.19200300.100.1.29 RFC 1274
numericStringMatch M 2.5.13.8 RFC 4517
numericStringOrderingMatch M 2.5.13.9 RFC 4517
numericStringSubstringsMatch M 2.5.13.10 RFC 4517
o A 2.5.4.10 RFC 4519
objectClass A 2.5.4.0 RFC 4512
objectClasses A 2.5.21.6 RFC 4512
objectclassMap A 1.3.6.1.4.1.11.1.3.1.1.11 RFC 4876
objectIdentifierFirstComponentMatch M 2.5.13.30 RFC 4517
objectIdentifierMatch M 2.5.13.0 RFC 4517
octetStringMatch M 2.5.13.17 RFC 4517
octetStringOrderingMatch M 2.5.13.18 RFC 4517
omittedORAddressComponent O 1.3.6.1.4.1.453.7.1.3 RFC 2164
oRAddressComponentType A 1.3.6.1.4.1.453.7.2.7 RFC 2164
organization O 2.5.6.4 RFC 4519
organizationalPerson O 2.5.6.7 RFC 4519
organizationalRole O 2.5.6.8 RFC 4519
organizationalStatus A 0.9.2342.19200300.100.1.45 RFC 4524
organizationalUnit O 2.5.6.5 RFC 4519
organizationalUnitName A 2.5.4.11 RFC 4519
organizationName A 2.5.4.10 RFC 4519
otherMailbox A 0.9.2342.19200300.100.1.22 RFC 1274
ou A 2.5.4.11 RFC 4519
owner A 2.5.4.32 RFC 4519
pager A 0.9.2342.19200300.100.1.42 RFC 4524
pagerTelephoneNumber A* 0.9.2342.19200300.100.1.42 RFC 4524
pcels8021Filter O 1.3.6.1.1.9.1.54 RFC 4104
pcels8021HdrDestMACAddress A 1.3.6.1.1.9.2.50 RFC 4104
pcels8021HdrDestMACMask A 1.3.6.1.1.9.2.51 RFC 4104
pcels8021HdrPriority A 1.3.6.1.1.9.2.53 RFC 4104
pcels8021HdrProtocolID A 1.3.6.1.1.9.2.52 RFC 4104
pcels8021HdrSourceMACAddress A 1.3.6.1.1.9.2.48 RFC 4104
pcels8021HdrSourceMACMask A 1.3.6.1.1.9.2.49 RFC 4104
pcels8021HdrVLANID A 1.3.6.1.1.9.2.54 RFC 4104
pcelsActionAssociation O 1.3.6.1.1.9.1.10 RFC 4104
pcelsActionList A 1.3.6.1.1.9.2.8 RFC 4104
pcelsBitStringList A 1.3.6.1.1.9.2.24 RFC 4104
pcelsBitStringValueAuxClass O 1.3.6.1.1.9.1.45 RFC 4104
pcelsBoolean A 1.3.6.1.1.9.2.26 RFC 4104
pcelsBooleanValueAuxClass O 1.3.6.1.1.9.1.47 RFC 4104
pcelsCompoundActionAuxClass O 1.3.6.1.1.9.1.15 RFC 4104
pcelsCompoundConditionAuxClass O 1.3.6.1.1.9.1.12 RFC 4104
pcelsCompoundFilterConditionAuxClass O 1.3.6.1.1.9.1.13 RFC 4104
pcelsConditionAssociation O 1.3.6.1.1.9.1.9 RFC 4104
pcelsConditionList A 1.3.6.1.1.9.2.7 RFC 4104
pcelsConditionListType A 1.3.6.1.1.9.2.6 RFC 4104
pcelsCoSVariableAuxClass O 1.3.6.1.1.9.1.33 RFC 4104
pcelsDecisionStrategy A 1.3.6.1.1.9.2.2 RFC 4104
pcelsDestinationIPv4VariableAuxClass O 1.3.6.1.1.9.1.21 RFC 4104
pcelsDestinationIPv6VariableAuxClass O 1.3.6.1.1.9.1.22 RFC 4104
pcelsDestinationMACVariableAuxClass O 1.3.6.1.1.9.1.31 RFC 4104
pcelsDestinationPortVariableAuxClass O 1.3.6.1.1.9.1.24 RFC 4104
pcelsDestinationSAPVariableAuxClass O 1.3.6.1.1.9.1.36 RFC 4104
pcelsDSCPVariableAuxClass O 1.3.6.1.1.9.1.28 RFC 4104
pcelsElementList A 1.3.6.1.1.9.2.31 RFC 4104
pcelsEthertypeVariableAuxClass O 1.3.6.1.1.9.1.34 RFC 4104
pcelsExecutionStrategy A 1.3.6.1.1.9.2.10 RFC 4104
pcelsExpectedValueList A 1.3.6.1.1.9.2.15 RFC 4104
pcelsExpectedValueTypes A 1.3.6.1.1.9.2.18 RFC 4104
pcelsExplicitVariableAuxClass O 1.3.6.1.1.9.1.17 RFC 4104
pcelsFilterDirection A 1.3.6.1.1.9.2.56 RFC 4104
pcelsFilterEntryBase O 1.3.6.1.1.9.1.52 RFC 4104
pcelsFilterEntryList A 1.3.6.1.1.9.2.57 RFC 4104
pcelsFilterIsNegated A 1.3.6.1.1.9.2.33 RFC 4104
pcelsFilterListAuxClass O 1.3.6.1.1.9.1.55 RFC 4104
pcelsFilterListName A 1.3.6.1.1.9.2.55 RFC 4104
pcelsFilterName A 1.3.6.1.1.9.2.32 RFC 4104
pcelsFlowDirectionVariableAuxClass O 1.3.6.1.1.9.1.39 RFC 4104
pcelsFlowIdVariableAuxClass O 1.3.6.1.1.9.1.29 RFC 4104
pcelsGroup O 1.3.6.1.1.9.1.3 RFC 4104
pcelsGroupAuxClass O 1.3.6.1.1.9.1.4 RFC 4104
pcelsGroupInstance O 1.3.6.1.1.9.1.5 RFC 4104
pcelsImplicitVariableAuxClass O 1.3.6.1.1.9.1.18 RFC 4104
pcelsIntegerList A 1.3.6.1.1.9.2.25 RFC 4104
pcelsIntegerValueAuxClass O 1.3.6.1.1.9.1.46 RFC 4104
pcelsIPHdrDestAddress A 1.3.6.1.1.9.2.38 RFC 4104
pcelsIPHdrDestAddressEndOfRange A 1.3.6.1.1.9.2.39 RFC 4104
pcelsIPHdrDestMask A 1.3.6.1.1.9.2.40 RFC 4104
pcelsIPHdrDestPortEnd A 1.3.6.1.1.9.2.45 RFC 4104
pcelsIPHdrDestPortStart A 1.3.6.1.1.9.2.44 RFC 4104
pcelsIPHdrDSCPList A 1.3.6.1.1.9.2.46 RFC 4104
pcelsIPHdrFlowLabel A 1.3.6.1.1.9.2.47 RFC 4104
pcelsIPHdrProtocolID A 1.3.6.1.1.9.2.41 RFC 4104
pcelsIPHdrSourceAddress A 1.3.6.1.1.9.2.35 RFC 4104
pcelsIPHdrSourceAddressEndOfRange A 1.3.6.1.1.9.2.36 RFC 4104
pcelsIPHdrSourceMask A 1.3.6.1.1.9.2.37 RFC 4104
pcelsIPHdrSourcePortEnd A 1.3.6.1.1.9.2.43 RFC 4104
pcelsIPHdrSourcePortStart A 1.3.6.1.1.9.2.42 RFC 4104
pcelsIPHdrVersion A 1.3.6.1.1.9.2.34 RFC 4104
pcelsIPHeadersFilter O 1.3.6.1.1.9.1.53 RFC 4104
pcelsIPProtocolVariableAuxClass O 1.3.6.1.1.9.1.25 RFC 4104
pcelsIPToSVariableAuxClass O 1.3.6.1.1.9.1.27 RFC 4104
pcelsIPv4AddrList A 1.3.6.1.1.9.2.20 RFC 4104
pcelsIPv4AddrValueAuxClass O 1.3.6.1.1.9.1.41 RFC 4104
pcelsIPv6AddrList A 1.3.6.1.1.9.2.21 RFC 4104
pcelsIPv6AddrValueAuxClass O 1.3.6.1.1.9.1.42 RFC 4104
pcelsIPVersionVariableAuxClass O 1.3.6.1.1.9.1.26 RFC 4104
pcelsIsMirrored A 1.3.6.1.1.9.2.13 RFC 4104
pcelsMACAddrList A 1.3.6.1.1.9.2.22 RFC 4104
pcelsMACAddrValueAuxClass O 1.3.6.1.1.9.1.43 RFC 4104
pcelsPolicySet O 1.3.6.1.1.9.1.1 RFC 4104
pcelsPolicySetAssociation O 1.3.6.1.1.9.1.2 RFC 4104
pcelsPolicySetDN A 1.3.6.1.1.9.2.5 RFC 4104
pcelsPolicySetList A 1.3.6.1.1.9.2.3 RFC 4104
pcelsPolicySetName A 1.3.6.1.1.9.2.1 RFC 4104
pcelsPriority A 1.3.6.1.1.9.2.4 RFC 4104
pcelsReusableContainer O 1.3.6.1.1.9.1.48 RFC 4104
pcelsReusableContainerAuxClass O 1.3.6.1.1.9.1.49 RFC 4104
pcelsReusableContainerInstance O 1.3.6.1.1.9.1.50 RFC 4104
pcelsReusableContainerList A 1.3.6.1.1.9.2.28 RFC 4104
pcelsReusableContainerName A 1.3.6.1.1.9.2.27 RFC 4104
pcelsRole A 1.3.6.1.1.9.2.29 RFC 4104
pcelsRoleCollection O 1.3.6.1.1.9.1.51 RFC 4104
pcelsRoleCollectionName A 1.3.6.1.1.9.2.30 RFC 4104
pcelsRule O 1.3.6.1.1.9.1.6 RFC 4104
pcelsRuleAuxClass O 1.3.6.1.1.9.1.7 RFC 4104
pcelsRuleInstance O 1.3.6.1.1.9.1.8 RFC 4104
pcelsRuleValidityPeriodList A 1.3.6.1.1.9.2.62 RFC 4104
pcelsSequencedActions A 1.3.6.1.1.9.2.9 RFC 4104
pcelsSimpleActionAuxClass O 1.3.6.1.1.9.1.14 RFC 4104
pcelsSimpleConditionAuxClass O 1.3.6.1.1.9.1.11 RFC 4104
pcelsSNAPOUIVariableAuxClass O 1.3.6.1.1.9.1.37 RFC 4104
pcelsSNAPTypeVariableAuxClass O 1.3.6.1.1.9.1.38 RFC 4104
pcelsSourceIPv4VariableAuxClass O 1.3.6.1.1.9.1.19 RFC 4104
pcelsSourceIPv6VariableAuxClass O 1.3.6.1.1.9.1.20 RFC 4104
pcelsSourceMACVariableAuxClass O 1.3.6.1.1.9.1.30 RFC 4104
pcelsSourcePortVariableAuxClass O 1.3.6.1.1.9.1.23 RFC 4104
pcelsSourceSAPVariableAuxClass O 1.3.6.1.1.9.1.35 RFC 4104
pcelsStringList A 1.3.6.1.1.9.2.23 RFC 4104
pcelsStringValueAuxClass O 1.3.6.1.1.9.1.44 RFC 4104
pcelsValueAuxClass O 1.3.6.1.1.9.1.40 RFC 4104
pcelsValueDN A 1.3.6.1.1.9.2.12 RFC 4104
pcelsValueName A 1.3.6.1.1.9.2.19 RFC 4104
pcelsVariable O 1.3.6.1.1.9.1.16 RFC 4104
pcelsVariableDN A 1.3.6.1.1.9.2.11 RFC 4104
pcelsVariableModelClass A 1.3.6.1.1.9.2.16 RFC 4104
pcelsVariableModelProperty A 1.3.6.1.1.9.2.17 RFC 4104
pcelsVariableName A 1.3.6.1.1.9.2.14 RFC 4104
pcelsVendorValueAuxClass O 1.3.6.1.1.9.1.57 RFC 4104
pcelsVendorValueData A 1.3.6.1.1.9.2.60 RFC 4104
pcelsVendorValueEncoding A 1.3.6.1.1.9.2.61 RFC 4104
pcelsVendorVariableAuxClass O 1.3.6.1.1.9.1.56 RFC 4104
pcelsVendorVariableData A 1.3.6.1.1.9.2.58 RFC 4104
pcelsVendorVariableEncoding A 1.3.6.1.1.9.2.59 RFC 4104
pcelsVLANVariableAuxClass O 1.3.6.1.1.9.1.32 RFC 4104
pcimPolicy O 1.3.6.1.1.6.1.1 RFC 3703
pcimGroup O 1.3.6.1.1.6.1.2 RFC 3703
pcimGroupAuxClass O 1.3.6.1.1.6.1.3 RFC 3703
pcimGroupInstance O 1.3.6.1.1.6.1.4 RFC 3703
pcimRule O 1.3.6.1.1.6.1.5 RFC 3703
pcimRuleAuxClass O 1.3.6.1.1.6.1.6 RFC 3703
pcimRuleInstance O 1.3.6.1.1.6.1.7 RFC 3703
pcimRuleConditionAssociation O 1.3.6.1.1.6.1.8 RFC 3703
pcimRuleValidityAssociation O 1.3.6.1.1.6.1.9 RFC 3703
pcimRuleActionAssociation O 1.3.6.1.1.6.1.10 RFC 3703
pcimConditionAuxClass O 1.3.6.1.1.6.1.11 RFC 3703
pcimTPCAuxClass O 1.3.6.1.1.6.1.12 RFC 3703
pcimConditionVendorAuxClass O 1.3.6.1.1.6.1.13 RFC 3703
pcimActionAuxClass O 1.3.6.1.1.6.1.14 RFC 3703
pcimActionVendorAuxClass O 1.3.6.1.1.6.1.15 RFC 3703
pcimPolicyInstance O 1.3.6.1.1.6.1.16 RFC 3703
pcimElementAuxClass O 1.3.6.1.1.6.1.17 RFC 3703
pcimRepository O 1.3.6.1.1.6.1.18 RFC 3703
pcimRepositoryAuxClass O 1.3.6.1.1.6.1.19 RFC 3703
pcimRepositoryInstance O 1.3.6.1.1.6.1.20 RFC 3703
pcimSubtreesPtrAuxClass O 1.3.6.1.1.6.1.21 RFC 3703
pcimGroupContainmentAuxClass O 1.3.6.1.1.6.1.22 RFC 3703
pcimRuleContainmentAuxClass O 1.3.6.1.1.6.1.23 RFC 3703
pcimKeywords A 1.3.6.1.1.6.2.3 RFC 3703
pcimGroupName A 1.3.6.1.1.6.2.4 RFC 3703
pcimRuleName A 1.3.6.1.1.6.2.5 RFC 3703
pcimRuleEnabled A 1.3.6.1.1.6.2.6 RFC 3703
pcimRuleConditionListType A 1.3.6.1.1.6.2.7 RFC 3703
pcimRuleConditionList A 1.3.6.1.1.6.2.8 RFC 3703
pcimRuleActionList A 1.3.6.1.1.6.2.9 RFC 3703
pcimRuleValidityPeriodList A 1.3.6.1.1.6.2.10 RFC 3703
pcimRuleUsage A 1.3.6.1.1.6.2.11 RFC 3703
pcimRulePriority A 1.3.6.1.1.6.2.12 RFC 3703
pcimRuleMandatory A 1.3.6.1.1.6.2.13 RFC 3703
pcimRuleSequencedActions A 1.3.6.1.1.6.2.14 RFC 3703
pcimRoles A 1.3.6.1.1.6.2.15 RFC 3703
pcimConditionGroupNumber A 1.3.6.1.1.6.2.16 RFC 3703
pcimConditionNegated A 1.3.6.1.1.6.2.17 RFC 3703
pcimConditionName A 1.3.6.1.1.6.2.18 RFC 3703
pcimConditionDN A 1.3.6.1.1.6.2.19 RFC 3703
pcimValidityConditionName A 1.3.6.1.1.6.2.20 RFC 3703
pcimTimePeriodConditionDN A 1.3.6.1.1.6.2.21 RFC 3703
pcimActionName A 1.3.6.1.1.6.2.22 RFC 3703
pcimActionOrder A 1.3.6.1.1.6.2.23 RFC 3703
pcimActionDN A 1.3.6.1.1.6.2.24 RFC 3703
pcimTPCTime A 1.3.6.1.1.6.2.25 RFC 3703
pcimTPCMonthOfYearMask A 1.3.6.1.1.6.2.26 RFC 3703
pcimTPCDayOfMonthMask A 1.3.6.1.1.6.2.27 RFC 3703
pcimTPCDayOfWeekMask A 1.3.6.1.1.6.2.28 RFC 3703
pcimTPCTimeOfDayMask A 1.3.6.1.1.6.2.29 RFC 3703
pcimTPCLocalOrUtcTime A 1.3.6.1.1.6.2.30 RFC 3703
pcimVendorConstraintData A 1.3.6.1.1.6.2.31 RFC 3703
pcimVendorConstraintEncoding A 1.3.6.1.1.6.2.32 RFC 3703
pcimVendorActionData A 1.3.6.1.1.6.2.33 RFC 3703
pcimVendorActionEncoding A 1.3.6.1.1.6.2.34 RFC 3703
pcimPolicyInstanceName A 1.3.6.1.1.6.2.35 RFC 3703
pcimRepositoryName A 1.3.6.1.1.6.2.36 RFC 3703
pcimSubtreesAuxContainedSet A 1.3.6.1.1.6.2.37 RFC 3703
pcimGroupsAuxContainedSet A 1.3.6.1.1.6.2.38 RFC 3703
pcimRulesAuxContainedSet A 1.3.6.1.1.6.2.39 RFC 3703
person O 2.5.6.6 RFC 4519
personalSignature A 0.9.2342.19200300.100.1.53 RFC 1274
personalTitle A 0.9.2342.19200300.100.1.40 RFC 4524
photo A 0.9.2342.19200300.100.1.7 RFC 1274
physicalDeliveryOfficeName A 2.5.4.19 RFC 4519
pilotDSA O 0.9.2342.19200300.100.4.21 RFC 1274
pilotObject O 0.9.2342.19200300.100.4.3 RFC 1274
pilotOrganization O 0.9.2342.19200300.100.4.20 RFC 1274
pilotPerson O 0.9.2342.19200300.100.4.4 RFC 1274
pkiCA O 2.5.6.22 RFC 4523
pkiUser O 2.5.6.21 RFC 4523
postalAddress A 2.5.4.16 RFC 4519
postalCode A 2.5.4.17 RFC 4519
postOfficeBox A 2.5.4.18 RFC 4519
preferredDeliveryMethod A 2.5.4.28 RFC 4519
preferredLanguage A 2.16.840.1.113730.3.1.39 RFC 2798
preferredServerList A 1.3.6.1.4.1.11.1.3.1.1.2 RFC 4876
presentationAddress A 2.5.4.29 RFC 2256
presentationAddressMatch M 2.5.13.22 RFC 2252
presentMatch M 1.2.36.79672281.1.13.5 RFC 3687
printer-aliases A 1.3.18.0.2.4.1108 RFC 3712
printer-charge-info A 1.3.18.0.2.24.46.1.105 RFC 7612
printer-charge-info-uri A 1.3.18.0.2.24.46.1.106 RFC 7612
printer-charset-configured A 1.3.18.0.2.4.1109 RFC 3712
printer-charset-supported A 1.3.18.0.2.4.1131 RFC 3712
printer-color-supported A 1.3.18.0.2.4.1129 RFC 3712
printer-compression-supported A 1.3.18.0.2.4.1128 RFC 3712
printer-copies-supported A 1.3.18.0.2.4.1118 RFC 3712
printer-current-operator A 1.3.18.0.2.4.1112 RFC 3712
printer-delivery-orientation-supported A 1.3.18.0.2.4.1114 RFC 3712
printer-device-id A 1.3.18.0.2.24.46.1.101 RFC 7612
printer-device-service-count A 1.3.18.0.2.24.46.1.102 RFC 7612
printer-document-format-supported A 1.3.18.0.2.4.1130 RFC 3712
printer-finishings-supported A 1.3.18.0.2.4.1125 RFC 3712
printer-generated-natural-language-supported A 1.3.18.0.2.4.1137 RFC 3712
printer-geo-location A 1.3.18.0.2.24.46.1.107 RFC 7612
printer-info A 1.3.18.0.2.4.1139 RFC 3712
printer-ipp-features-supported A 1.3.18.0.2.24.46.1.108 RFC 7612
printer-ipp-versions-supported A 1.3.18.0.2.4.1133 RFC 3712
printer-job-priority-supported A 1.3.18.0.2.4.1110 RFC 3712
printer-job-k-octets-supported A 1.3.18.0.2.4.1111 RFC 3712
printer-location A 1.3.18.0.2.4.1136 RFC 3712
printer-make-and-model A 1.3.18.0.2.4.1138 RFC 3712
printer-media-local-supported A 1.3.18.0.2.4.1117 RFC 3712
printer-media-supported A 1.3.18.0.2.4.1122 RFC 3712
printer-more-info A 1.3.18.0.2.4.1134 RFC 3712
printer-multiple-document-jobs-supported A 1.3.18.0.2.4.1132 RFC 3712
printer-name A 1.3.18.0.2.4.1135 RFC 3712
printer-natural-language-configured A 1.3.18.0.2.4.1119 RFC 3712
printer-number-up-supported A 1.3.18.0.2.4.1124 RFC 3712
printer-output-features-supported A 1.3.18.0.2.4.1116 RFC 3712
printer-pages-per-minute A 1.3.18.0.2.4.1127 RFC 3712
printer-pages-per-minute-color A 1.3.18.0.2.4.1126 RFC 3712
printer-print-quality-supported A 1.3.18.0.2.4.1120 RFC 3712
printer-resolution-supported A 1.3.18.0.2.4.1121 RFC 3712
printer-service-person A 1.3.18.0.2.4.1113 RFC 3712
printer-sides-supported A 1.3.18.0.2.4.1123 RFC 3712
printer-stacking-order-supported A 1.3.18.0.2.4.1115 RFC 3712
printer-uri A 1.3.18.0.2.4.1140 RFC 3712
printer-uuid A 1.3.18.0.2.24.46.1.104 RFC 7612
printer-xri-supported A 1.3.18.0.2.4.1107 RFC 3712
printerAbstract O 1.3.18.0.2.6.258 RFC 3712
printerIPP O 1.3.18.0.2.6.256 RFC 3712
printerLPR O 1.3.18.0.2.6.253 RFC 3712
printerService O 1.3.18.0.2.6.255 RFC 3712
printerServiceAuxClass O 1.3.18.0.2.6.257 RFC 3712
profileTTL A 1.3.6.1.4.1.11.1.3.1.1.7 RFC 4876
protocolInformation A 2.5.4.48 RFC 2256
protocolInformationMatch M 2.5.13.24 RFC 2252
provider O 1.3.6.1.4.1.16572.2.1.2 RFC 6109
providerCertificate A 1.3.6.1.4.1.16572.2.2.2 RFC 6109
providerCertificateHash A 1.3.6.1.4.1.16572.2.2.1 RFC 6109
providerName A 1.3.6.1.4.1.16572.2.2.3 RFC 6109
providerUnit A 1.3.6.1.4.1.16572.2.2.7 RFC 6109
pseudonym A 2.5.4.65 RFC 3280
qualityLabelledData O 0.9.2342.19200300.100.4.22 RFC 1274
rdnMatch M 1.2.36.79672281.1.13.3 RFC 3687
ref A 2.16.840.1.113730.3.1.34 RFC 3296
referral 0 2.16.840.1.113730.3.2.6 RFC 3296
registeredAddress A 2.5.4.26 RFC 4519
replace A Reserved for LDIF RFC 2849
residentialPerson O 2.5.6.10 RFC 4519
RFC822LocalPart O 0.9.2342.19200300.100.4.14 RFC 4524
RFC822Mailbox A* 0.9.2342.19200300.100.1.3 RFC 4524
rFC822ToX400Mapping O 1.3.6.1.4.1.453.7.1.1 RFC 2164
roleOccupant A 2.5.4.33 RFC 4519
room O 0.9.2342.19200300.100.4.7 RFC 4524
roomNumber A 0.9.2342.19200300.100.1.6 RFC 4524
searchGuide A 2.5.4.14 RFC 4519
searchTimeLimit A 1.3.6.1.4.1.11.1.3.1.1.3 RFC 4876
secretary A 0.9.2342.19200300.100.1.21 RFC 4524
seeAlso A 2.5.4.34 RFC 4519
serialNumber A 2.5.4.5 RFC 4519
serviceAuthenticationMethod A 1.3.6.1.4.1.11.1.3.1.1.15 RFC 4876
serviceCredentialLevel A 1.3.6.1.4.1.11.1.3.1.1.13 RFC 4876
serviceSearchDescriptor A 1.3.6.1.4.1.11.1.3.1.1.14 RFC 4876
simpleSecurityObject O 0.9.2342.19200300.100.4.19 RFC 4524
singleLevelQuality A 0.9.2342.19200300.100.1.50 RFC 4524
slpServicePrinter O 1.3.18.0.2.6.254 RFC 3712
sn A 2.5.4.4 RFC 4519
sOARecord A 0.9.2342.19200300.100.1.30 RFC 1274
st A 2.5.4.8 RFC 4519
stateOrProvinceName A 2.5.4.8 RFC 2256
storedPrefixMatch M 2.5.13.41 RFC 3698
street A 2.5.4.9 RFC 4519
streetAddress A 2.5.4.9 RFC 2256
strongAuthenticationUser O 2.5.6.15 RFC 4523
structuralObjectClass A 2.5.21.9 RFC 4512
subentry O 2.5.17.0 RFC 3672
subschema O 2.5.20.1 RFC 4512
subschemaAdminSpecificArea R 2.5.23.4 RFC 3672
subschemaSubentry A 2.5.18.10 RFC 4512
subtree O 1.3.6.1.4.1.453.7.1.1 RFC 2293
subtreeMaximumQuality A 0.9.2342.19200300.100.1.52 RFC 1274
subtreeMinimumQuality A 0.9.2342.19200300.100.1.51 RFC 1274
subtreeSpecification A 2.5.18.6 RFC 3672
supportedAlgorithms A 2.5.4.52 RFC 4523
supportedApplicationContext A 2.5.4.30 RFC 2256
supportedControl A 1.3.6.1.4.1.1466.101.120.13 RFC 4512
supportedExtension A 1.3.6.1.4.1.1466.101.120.7 RFC 4512
supportedFeatures A 1.3.6.1.4.1.4203.1.3.5 RFC 4512
supportedLDAPVersion A 1.3.6.1.4.1.1466.101.120.15 RFC 4512
supportedSASLMechanisms A 1.3.6.1.4.1.1466.101.120.14 RFC 4512
surname A 2.5.4.4 RFC 4519
table O 1.3.6.1.4.1.453.7.1.2 RFC 2293
tableEntry O 1.3.6.1.4.1.453.7.1.3 RFC 2293
telephoneNumber A 2.5.4.20 RFC 4519
telephoneNumberMatch M 2.5.13.20 RFC 4517
telephoneNumberSubstringsMatch M 2.5.13.21 RFC 4517
teletexTerminalIdentifier A 2.5.4.22 RFC 4519
telexNumber A 2.5.4.21 RFC 4519
textEncodedORAddress A 0.9.2342.19200300.100.1.2 RFC 1274
textTableEntry O 1.3.6.1.4.1.453.7.1.4 RFC 2293
textTableKey A 1.3.6.1.4.1.453.7.2.1 RFC 2293
textTableValue A 1.3.6.1.4.1.453.7.2.2 RFC 2293
title A 2.5.4.12 RFC 4519
top O 2.5.6.0 RFC 4512
uddiAccessPoint A 1.3.6.1.1.10.4.19 RFC 4403
uddiAddress O 1.3.6.1.1.10.6.3 RFC 4403
uddiAddressLine A 1.3.6.1.1.10.4.13 RFC 4403
uddiAddressNameForm N 1.3.6.1.1.10.15.3 RFC 4403
uddiAuthorizedName A 1.3.6.1.1.10.4.2 RFC 4403
uddiBindingKey A 1.3.6.1.1.10.4.18 RFC 4403
uddiBindingTemplate O 1.3.6.1.1.10.6.5 RFC 4403
uddiBindingTemplateNameForm N 1.3.6.1.1.10.15.5 RFC 4403
uddiBusinessEntity O 1.3.6.1.1.10.6.1 RFC 4403
uddiBusinessEntityNameForm N 1.3.6.1.1.10.15.1 RFC 4403
uddiBusinessKey A 1.3.6.1.1.10.4.1 RFC 4403
uddiBusinessService O 1.3.6.1.1.10.6.4 RFC 4403
uddiBusinessServiceNameForm N 1.3.6.1.1.10.15.4 RFC 4403
uddiCategoryBag A 1.3.6.1.1.10.4.15 RFC 4403
uddiContact O 1.3.6.1.1.10.6.2 RFC 4403
uddiContactNameForm N 1.3.6.1.1.10.15.2 RFC 4403
uddiDescription A 1.3.6.1.1.10.4.5 RFC 4403
uddiDiscoveryURLs A 1.3.6.1.1.10.4.6 RFC 4403
uddiEMail A 1.3.6.1.1.10.4.10 RFC 4403
uddiFromKey A 1.3.6.1.1.10.4.25 RFC 4403
uddiHostingRedirector A 1.3.6.1.1.10.4.20 RFC 4403
uddiIdentifierBag A 1.3.6.1.1.10.4.14 RFC 4403
uddiInstanceDescription A 1.3.6.1.1.10.4.21 RFC 4403
uddiInstanceParms A 1.3.6.1.1.10.4.22 RFC 4403
uddiIsHidden A 1.3.6.1.1.10.4.28 RFC 4403
uddiIsProjection A 1.3.6.1.1.10.4.29 RFC 4403
uddiKeyedReference A 1.3.6.1.1.10.4.16 RFC 4403
uddiLang A 1.3.6.1.1.10.4.30 RFC 4403
uddiName A 1.3.6.1.1.10.4.4 RFC 4403
uddiOperator A 1.3.6.1.1.10.4.3 RFC 4403
uddiOverviewDescription A 1.3.6.1.1.10.4.23 RFC 4403
uddiOverviewURL A 1.3.6.1.1.10.4.24 RFC 4403
uddiPersonName A 1.3.6.1.1.10.4.8 RFC 4403
uddiPhone A 1.3.6.1.1.10.4.9 RFC 4403
uddiPublisherAssertion O 1.3.6.1.1.10.6.8 RFC 4403
uddiPublisherAssertionNameForm N 1.3.6.1.1.10.15.8 RFC 4403
uddiServiceKey A 1.3.6.1.1.10.4.17 RFC 4403
uddiSortCode A 1.3.6.1.1.10.4.11 RFC 4403
uddiTModel O 1.3.6.1.1.10.6.7 RFC 4403
uddiTModelInstanceInfo O 1.3.6.1.1.10.6.6 RFC 4403
uddiTModelInstanceInfoNameForm N 1.3.6.1.1.10.15.6 RFC 4403
uddiTModelKey A 1.3.6.1.1.10.4.12 RFC 4403
uddiTModelNameForm N 1.3.6.1.1.10.15.7 RFC 4403
uddiToKey A 1.3.6.1.1.10.4.26 RFC 4403
uddiUseType A 1.3.6.1.1.10.4.7 RFC 4403
uddiUUID A 1.3.6.1.1.10.4.27 RFC 4403
uddiv3BindingKey A 1.3.6.1.1.10.4.33 RFC 4403
uddiv3BriefResponse A 1.3.6.1.1.10.4.43 RFC 4403
uddiv3BusinessKey A 1.3.6.1.1.10.4.31 RFC 4403
uddiv3DigitalSignature A 1.3.6.1.1.10.4.35 RFC 4403
uddiv3EntityCreationTime A 1.3.6.1.1.10.4.45 RFC 4403
uddiv3EntityDeletionTime A 1.3.6.1.1.10.4.46 RFC 4403
uddiv3EntityKey A 1.3.6.1.1.10.4.44 RFC 4403
uddiv3EntityModificationTime A 1.3.6.1.1.10.4.37 RFC 4403
uddiv3EntityObituary O 1.3.6.1.1.10.6.10 RFC 4403
uddiv3EntityObituaryNameForm N 1.3.6.1.1.10.15.10 RFC 4403
uddiv3ExpiresAfter A 1.3.6.1.1.10.4.42 RFC 4403
uddiv3MaxEntities A 1.3.6.1.1.10.4.41 RFC 4403
uddiv3NodeId A 1.3.6.1.1.10.4.36 RFC 4403
uddiv3NotificationInterval A 1.3.6.1.1.10.4.40 RFC 4403
uddiv3ServiceKey A 1.3.6.1.1. 10.4.32 RFC 4403
uddiv3Subscription O 1.3.6.1.1.10.6.9 RFC 4403
uddiv3SubscriptionFilter A 1.3.6.1.1.10.4.39 RFC 4403
uddiv3SubscriptionKey A 1.3.6.1.1.10.4.38 RFC 4403
uddiv3SubscriptionNameForm N 1.3.6.1.1.10.15.9 RFC 4403
uddiv3TmodelKey A 1.3.6.1.1.10.4.34 RFC 4403
uid A 0.9.2342.19200300.100.1.1 RFC 4519
uidObject O 1.3.6.1.1.3.1 RFC 4519
uniqueIdentifier A 0.9.2342.19200300.100.1.44 RFC 4524
uniqueMember A 2.5.4.50 RFC 4519
uniqueMemberMatch M 2.5.13.23 RFC 4517
userCertificate A 2.5.4.36 RFC 4523
userClass A 0.9.2342.19200300.100.1.8 RFC 4524
userId A 0.9.2342.19200300.100.1.1 RFC 4519
userPassword A 2.5.4.35 RFC 4519
userPKCS12 A 2.16.840.1.113730.3.1.216 RFC 2798
userSecurityInformation O 2.5.6.18 RFC 4523
userSMIMECertificate A 2.16.840.1.113730.3.1.40 RFC 2798
uuidMatch M 1.3.6.1.1.16.2 RFC 4530
uuidOrderingMatch M 1.3.6.1.1.16.3 RFC 4530
version A Reserved for LDIF RFC 2849
vPIMUser O 1.3.6.1.1.11.1.1 RFC 4237
vPIMRfc822Mailbox A 1.3.6.1.1.11.2.2 RFC 4237
vPIMTelephoneNumber A 1.3.6.1.1.11.2.1 RFC 4237
vPIMSpokenName A 1.3.6.1.1.11.2.3 RFC 4237
vPIMSupportedUABehaviors A 1.3.6.1.1.11.2.4 RFC 4237
vPIMSupportedAudioMediaTypes A 1.3.6.1.1.11.2.5 RFC 4237
vPIMSupportedMessageContext A 1.3.6.1.1.11.2.6 RFC 4237
vPIMTextName A 1.3.6.1.1.11.2.7 RFC 4237
vPIMExtendedAbsenceStatus A 1.3.6.1.1.11.2.8 RFC 4237
vPIMMaxMessageSize A 1.3.6.1.1.11.2.9 RFC 4237
vPIMSubMailboxes A 1.3.6.1.1.11.2.10 RFC 4237
wordMatch M 2.5.13.32 RFC 4517
x121Address A 2.5.4.24 RFC 4519
x400ToRFC822Mapping O 1.3.6.1.4.1.453.7.1.2 RFC 2164
x500UniqueIdentifier A 2.5.4.45 RFC 4519

Attribute Description Options

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Range Registration Procedures Note
x- Private Use can not be registered
e- Reserved for Experiments, First Come First Served
All others Standards Action or Expert Review with Specification
Option Owner Reference
binary IESG RFC 4522
lang- (See [1]) IESG RFC 3866

LDAPMessage types

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Name Code Owner Reference
bindRequest 0 IESG RFC 4513; RFC 4511
bindResponse 1 IESG RFC 4513; RFC 4511
unbindRequest 2 IESG RFC 4511
searchRequest 3 IESG RFC 4511
searchResEntry 4 IESG RFC 4511
searchResDone 5 IESG RFC 4511
modifyRequest 6 IESG RFC 4511
modifyResponse 7 IESG RFC 4511
addRequest 8 IESG RFC 4511
addResponse 9 IESG RFC 4511
delRequest 10 IESG RFC 4511
delResponse 11 IESG RFC 4511
modDNRequest 12 IESG RFC 4511
modDNResponse 13 IESG RFC 4511
compareRequest 14 IESG RFC 4511
compareResponse 15 IESG RFC 4511
abandonRequest 16 IESG RFC 4511
reserved 17-18 IESG
searchResRef 19 IESG RFC 4511
reserved 20-22 IESG
extendedReq 23 IESG RFC 4511
extendedResp 24 IESG RFC 4511
intermediateResponse 25 IESG RFC 4511

resultCode values

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Range Registration Procedures Note
0-1023 Standards Action can not start with e- or x-
1024-4095 Expert Review with Specification Required can not start with e- or x-
4096-16383 First Come First Served Shall start with e-
16384 and higher Private Use Shall start with x-
Name Code Owner Reference
success 0 IESG RFC 4511
operationsError 1 IESG RFC 4511
protocolError 2 IESG RFC 4511
timeLimitExceeded 3 IESG RFC 4511
sizeLimitExceeded 4 IESG RFC 4511
compareFalse 5 IESG RFC 4511
compareTrue 6 IESG RFC 4511
authMethodNotSupported 7 IESG RFC 4511
strongerAuthRequired 8 IESG RFC 4511
reserved (partialResults) 9 IESG RFC 4511
referral 10 IESG RFC 4511
adminLimitExceeded 11 IESG RFC 4511
unavailableCriticalExtension 12 IESG RFC 4511
confidentialityRequired 13 IESG RFC 4511
saslBindInProgress 14 IESG RFC 4511
noSuchAttribute 16 IESG RFC 4511
undefinedAttributeType 17 IESG RFC 4511
inappropriateMatching 18 IESG RFC 4511
constraintViolation 19 IESG RFC 4511
attributeOrValueExists 20 IESG RFC 4511
invalidAttributeSyntax 21 IESG RFC 4511
noSuchObject 32 IESG RFC 4511
aliasProblem 33 IESG RFC 4511
invalidDNSyntax 34 IESG RFC 4511
reserved (isLeaf) 35 IESG RFC 4511
aliasDereferencingProblem 36 IESG RFC 4511
reserved 37-47 IESG
inappropriateAuthentication 48 IESG RFC 4511
invalidCredentials 49 IESG RFC 4511
insufficientAccessRights 50 IESG RFC 4511
busy 51 IESG RFC 4511
unavailable 52 IESG RFC 4511
unwillingToPerform 53 IESG RFC 4511
loopDetect 54 IESG RFC 4511
reserved 55-63 IESG
namingViolation 64 IESG RFC 4511
objectClassViolation 65 IESG RFC 4511
notAllowedOnNonLeaf 66 IESG RFC 4511
notAllowedOnRDN 67 IESG RFC 4511
entryAlreadyExists 68 IESG RFC 4511
objectClassModsProhibited 69 IESG RFC 4511
reserved (resultsTooLarge) 70 IESG RFC 4511
reserved 71-79 IESG
other 80 IESG RFC 4511
reserved (APIs) 81-90 IESG RFC 4511
reserved (LDAP APIs) 91-112
lcupResourcesExhausted 113 IESG RFC 3928
lcupSecurityViolation 114 IESG RFC 3928
lcupInvalidData 115 IESG RFC 3928
lcupUnsupportedScheme 116 IESG RFC 3928
lcupReloadRequired 117 IESG RFC 3928
canceled 118 IESG RFC 3909
noSuchOperation 119 IESG RFC 3909
tooLate 120 IESG RFC 3909
cannotCancel 121 IESG RFC 3909
assertionFailed 122 IESG RFC 4528
authorizationDenied 123 WELTMAN RFC 4370
First Come, First Serve Range 4096-16383
e-syncRefreshRequired 4096 Kurt Zeilenga; Jong Hyuk Choi RFC 4533

Bind Authentication Method

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Range Registration Procedures Note
0-1023 Standards Action can not start with e- or x-
1024-4095 Expert Review with Specification Required can not start with e- or x-
4096-16383 First Come First Served Shall start with e-
16384 and higher Private Use Shall start with x-
Method Value Owner Usage Reference
simple 0 IESG LIMITED USE RFC 4513; RFC 4511
krbv42LDAP 1 IESG OBSOLETE (See [2]) RFC 1777
krbv42DSA 2 IESG OBSOLETE (See [2]) RFC 1777
sasl 3 IESG COMMON RFC 4513; RFC 4511

LDAP Syntaxes

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Note

While a specification is required, it will not be subject to expert review.

Available Formats

Object Identifier Syntax Owner Reference
1.3.6.1.1.16.1 UUID IESG RFC 4530
1.3.6.1.4.1.1466.115.121.1.3 Attribute Type Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.6 Bit String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.7 Boolean IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.11 Country String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.12 DN IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.14 Delivery Method IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.15 Directory String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.16 DIT Content Rule Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.17 DIT Structure Rule Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.21 Enhanced Guide IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.22 Facsimile Telephone Number IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.23 Fax IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.24 Generalized Time IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.25 Guide IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.26 IA5 String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.27 Integer IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.28 JPEG IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.30 Matching Rule Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.31 Matching Rule Use Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.34 Name And Optional UID IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.35 Name Form Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.36 Numeric String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.37 Object Class Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.38 OID IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.39 Other Mailbox IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.40 Octet String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.41 Postal Address IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.44 Printable String IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.50 Telephone Number IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.51 Teletex Terminal Identifier IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.52 Telex Number IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.53 UTC Time IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.54 LDAP Syntax Description IESG RFC 4517
1.3.6.1.4.1.1466.115.121.1.58 Substring Assertion IESG RFC 4517

LDAP Search Scopes

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Range Registration Procedures Note
0-1023 Standards Action can not start with e- or x-
1024-4095 Expert Review with Specification Required can not start with e- or x-
4096-16383 First Come First Served Shall start with e-
16384 and higher Private Use Shall start with x-
Name URLString Value Owner Reference
baseObject base 0 IESG RFC 4511; RFC 4516
singleLevel one 1 IESG RFC 4511; RFC 4516
wholeSubtree sub 2 IESG RFC 4511; RFC 4516

LDAP Filter Choices

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Name Value Owner Reference
and 0 IESG RFC 4511
or 1 IESG RFC 4511
not 2 IESG RFC 4511
equalityMatch 3 IESG RFC 4511
substrings 4 IESG RFC 4511
greaterOrEqual 5 IESG RFC 4511
lessOrEqual 6 IESG RFC 4511
present 7 IESG RFC 4511
approxMatch 8 IESG RFC 4511
extensibleMatch 9 IESG RFC 4511

LDAP ModifyRequest Operations

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Range Registration Procedures Note
0-1023 Standards Action can not start with e- or x-
1024-4095 Expert Review with Specification Required can not start with e- or x-
4096-16383 First Come First Served Shall start with e-
16384 and higher Private Use Shall start with x-
Name Value Owner Reference
add 0 IESG RFC 4511
delete 1 IESG RFC 4511
replace 2 IESG RFC 4511
increment 3 IESG RFC 4525

LDAP authzid prefixes

Expert(s)

  • Rolf Sonneveld, Andrew Findlay

Reference

  • RFC 4520: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

Available Formats

Range Registration Procedures
x- Private Use
e- Reserved for Experiments, First Come First Served
All others Standards Action or Expert Review with Specification Required
Name Prefix Owner Reference
dnAuthzId dn: IESG RFC 4513
uAuthzId u: IESG RFC 4513

Contact Information

Name Contact URI Last Updated
Allen Williams allenwilliams&seafreeze.com 2009-04-10
Jong Hyuk Choi jongchoi&us.ibm.com 2005-04
Kurt Zeilenga Kurt&openldap.org 2005-04
Mark Wahl Mark.Wahl&informed-control.com 2006-11-10
Matthew Key mkey&westjet.com 2011-12-05

Footnotes

[1]

family of options

[2]

These LDAPv2-only mechanisms were deprecated in favor of the LDAPv3 SASL authentication method, specifically the GSSAPI mechanism.