Locator/ID Separation Protocol (LISP) Parameters
LISP ACT Values
- IETF Review or IESG Approval
- RFC 9301: Locator/ID Separation Protocol (LISP) Control Plane
| Value |
Action |
Description |
Reference |
| 0 |
No-Action |
The map-cache is kept alive and no packet encapsulation occurs. |
RFC 9301 |
| 1 |
Natively-Forward |
The packet is not encapsulated or dropped but natively forwarded. |
RFC 9301 |
| 2 |
Send-Map-Request |
The packet invokes sending a Map-Request. |
RFC 9301 |
| 3 |
Drop/No-Reason |
A packet that matches this map-cache entry is dropped. An ICMP Unreachable message SHOULD be sent. |
RFC 9301 |
| 4 |
Drop/Policy-Denied |
A packet matching this Map-Cache entry is dropped because the target EID is
policy-denied by the xTR or the Mapping System. |
RFC 9301 |
| 5 |
Drop/Auth-Failure |
A packet matching this Map-Cache entry is dropped because the Map-Request
for the target EID fails an authentication check by the xTR or the Mapping System. |
RFC 9301 |
| 6-7 |
Unassigned |
|
|
LISP Address Type Codes (CLOSED)
- RFC 6830: The Locator/ID Separation Protocol (LISP)
- RFC 9301: Locator/ID Separation Protocol (LISP) Control Plane
Registry closed per RFC 9301.
LISP Algorithm ID Numbers
- RFC 9301: Locator/ID Separation Protocol (LISP) Control Plane
| Name |
Number |
MAC |
KDF |
| None |
0 |
None |
None |
| HMAC-SHA-1-96-None |
1 |
RFC 2404 |
None |
| HMAC-SHA-256-128-None |
2 |
RFC 4868 |
None |
| HMAC-SHA256-128+HKDF-SHA256 |
3 |
RFC 4868 |
RFC 4868 |
| Unassigned |
4-255 |
|
|
LISP Crypto Cipher Suite
- RFC 8061: Locator/ID Separation Protocol (LISP) Data-Plane Confidentiality
LISP Canonical Address Format (LCAF) Types
- Luigi Iannone, Albert Cabellos
- RFC 8060: LISP Canonical Address Format (LCAF)
| Value |
LISP LCAF Type Name |
Reference |
| 0 |
Null Body |
RFC 8060, Section 3 |
| 1 |
AFI List |
RFC 8060, Section 3 |
| 2 |
Instance ID |
RFC 8060, Section 3 |
| 3 |
AS Number |
RFC 8060, Section 3 |
| 4 |
Unassigned |
|
| 5 |
Geo-Coordinates (DEPRECATED) |
RFC 8060, Section 3; RFC 10040 |
| 6 |
Unassigned |
|
| 7 |
NAT-Traversal |
RFC 8060, Section 3 |
| 8 |
Unassigned |
|
| 9 |
Multicast Info |
RFC 8060, Section 3 |
| 10 |
Explicit Locator Path |
RFC 8060, Section 3 |
| 11 |
Security Key |
RFC 8060, Section 3 |
| 12 |
Source/Dest Key |
RFC 8060, Section 3 |
| 13 |
Replication List Entry |
RFC 8060, Section 3 |
| 14-16 |
Unassigned |
|
| 17 |
Geo-Location |
RFC 10040, Section 7 |
| 18-254 |
Unassigned |
|
| 255 |
Vendor Specific |
RFC 9306, Section 4 |
LISP Packet Types
- RFC 9304: Locator/ID Separation Protocol (LISP): Shared Extension Message and IANA Registry for Packet Type Allocations
- RFC 9301: Locator/ID Separation Protocol (LISP) Control Plane
| Code |
Message |
Reference |
| 0 |
Reserved |
RFC 9301 |
| 1 |
LISP Map-Request |
RFC 9301 |
| 2 |
LISP Map-Reply |
RFC 9301 |
| 3 |
LISP Map-Register |
RFC 9301 |
| 4 |
LISP Map-Notify |
RFC 9301 |
| 5 |
LISP Map-Notify-Ack |
RFC 9301 |
| 6 |
LISP DDT Map-Referral (TEMPORARY - registered 2017-04-19, extension registered 2026-04-03, expires 2027-04-19) |
RFC 8111 |
| 7 |
Unassigned |
|
| 8 |
LISP Encapsulated Control Message |
RFC 9301 |
| 9-14 |
Unassigned |
|
| 15 |
LISP Shared Extension Message |
RFC 9304 |
LISP Shared Extension Message Type Sub-types
- RFC 9304: Locator/ID Separation Protocol (LISP): Shared Extension Message and IANA Registry for Packet Type Allocations
| Range |
Registration Procedures |
| 0-1023 |
Standards Action |
| 1024-4095 |
First Come First Served |
LISP-GPE Next Protocol
- Darrel Lewis, Luigi Iannone
- RFC 9305: Locator/ID Separation Protocol (LISP) Generic Protocol Extension
| Next Protocol |
Description |
Reference |
| 0x00 |
Reserved |
RFC 9305 |
| 0x01 |
IPv4 |
RFC 9305 |
| 0x02 |
IPv6 |
RFC 9305 |
| 0x03 |
Ethernet |
RFC 9305 |
| 0x04 |
NSH |
RFC 9305 |
| 0x05-0x7D |
Unassigned |
|
| 0x7E-0x7F |
Experimentation and testing |
RFC 9305 |
| 0x80-0xFD |
Unassigned (shim headers) |
|
| 0xFE-0xFF |
Experimentation and testing (shim headers) |
RFC 9305 |
LISP ECM Authentication Data Types
- Damien Saucez, Luigi Iannone
- RFC 9303: Locator/ID Separation Protocol Security (LISP-SEC)
| Number |
Name |
Reference |
| 0 |
Reserved |
RFC 9303 |
| 1 |
LISP-SEC-ECM-EXT |
RFC 9303 |
| 2-255 |
Unassigned |
|
LISP Map-Reply Authentication Data Types
- Damien Saucez, Luigi Iannone
- RFC 9303: Locator/ID Separation Protocol Security (LISP-SEC)
| Number |
Name |
Reference |
| 0 |
Reserved |
RFC 9303 |
| 1 |
LISP-SEC-MR-EXT |
RFC 9303 |
| 2-255 |
Unassigned |
|
LISP-SEC Preferred Authentication Data HMAC IDs
- Damien Saucez, Luigi Iannone
- RFC 9303: Locator/ID Separation Protocol Security (LISP-SEC)
| Number |
Name |
Reference |
| 0 |
NOPREF |
RFC 9303 |
| 1 |
AUTH-HMAC-SHA-1-96 |
RFC 2104 |
| 2 |
AUTH-HMAC-SHA-256-128 |
RFC 6234 |
| 3-65535 |
Unassigned |
|
LISP-SEC Authentication Data Key Wrap IDs
- Damien Saucez, Luigi Iannone
- RFC 9303: Locator/ID Separation Protocol Security (LISP-SEC)
LISP-SEC Authentication Data Key Derivation Function IDs
- Damien Saucez, Luigi Iannone
- RFC 9303: Locator/ID Separation Protocol Security (LISP-SEC)
Contact Information