Link Management Protocol (LMP) Parameters

Last Updated

  • 2019-03-25

Available Formats


LMP Message Type Name Space

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-127 Standards Action
128-247 Expert Review
Value Description Reference
0 Reserved
1 Config message RFC 4204
2 ConfigAck message RFC 4204
3 ConfigNack message RFC 4204
4 Hello message RFC 4204
5 BeginVerify message RFC 4204
6 BeginVerifyAck message RFC 4204
7 BeginVerifyNack message RFC 4204
8 EndVerify message RFC 4204
9 EndVerifyAck message RFC 4204
10 Test message RFC 4204
11 TestStatusSuccess message RFC 4204
12 TestStatusFailure message RFC 4204
13 TestStatusAck message RFC 4204
14 LinkSummary message RFC 4204
15 LinkSummaryAck message RFC 4204
16 LinkSummaryNack message RFC 4204
17 ChannelStatus message RFC 4204
18 ChannelStatusAck message RFC 4204
19 ChannelStatusRequest message RFC 4204
20 ChannelStatusResponse message RFC 4204
21 TraceMonitor message RFC 4207
22 TraceMonitorAck message RFC 4207
23 TraceMonitorNack message RFC 4207
24 TraceMismatch message RFC 4207
25 TraceMismatchAck message RFC 4207
26 TraceReq message RFC 4207
27 TraceReport message RFC 4207
28 TraceReqNack message RFC 4207
29 InsertTrace message RFC 4207
30 InsertTraceAck message RFC 4207
31 InsertTraceNack message RFC 4207
32 ConfirmDataChannelStatus RFC 5818
33 ConfirmDataChannelStatusAck RFC 5818
34 ConfirmDataChannelStatusNack RFC 5818
35-247 Unassigned
248-255 Private Use RFC 4204

LMP Object Class name space and Class type (C-Type)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-127 Standards Action
128-247 Expert Review
Value Description Reference
0 Reserved
1 CCID RFC 4204
2 NODE_ID RFC 4204
3 LINK_ID RFC 4204
4 INTERFACE_ID RFC 4204
5 MESSAGE_ID RFC 4204
6 CONFIG RFC 4204
7 HELLO RFC 4204
8 BEGIN_VERIFY RFC 4204
9 BEGIN_VERIFY_ACK RFC 4204
10 VERIFY_ID RFC 4204
11 TE_LINK RFC 4204
12 DATA_LINK RFC 4204
13 CHANNEL_STATUS RFC 4204
14 CHANNEL_STATUS_REQUEST RFC 4204
15-19 Unassigned
20 ERROR_CODE RFC 4204
21 TRACE RFC 4207
22 TRACE REQ RFC 4207
23-247 Unassigned
248-255 Private Use RFC 4204

CCID Object Class type name space (Value 1)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 LOCAL_CCID RFC 4204
2 REMOTE_CCID RFC 4204
3-119 Unassigned
120-127 Private Use RFC 4204

NODE_ID Object Class type name space (Value 2)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 LOCAL_NODE_ID RFC 4204
2 REMOTE_NODE_ID RFC 4204
3-119 Unassigned
120-127 Private Use RFC 4204

LINK_ID Object Class type name space (Value 3)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 IPv4 LOCAL_LINK_ID RFC 4204
2 IPv4 REMOTE_LINK_ID RFC 4204
3 IPv6 LOCAL_LINK_ID RFC 4204
4 IPv6 REMOTE_LINK_ID RFC 4204
5 Unnumbered LOCAL_LINK_ID RFC 4204
6 Unnumbered REMOTE_LINK_ID RFC 4204
7-119 Unassigned
120-127 Private Use RFC 4204

INTERFACE_ID Object Class type name space (Value 4)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 IPv4 LOCAL_INTERFACE_ID RFC 4204
2 IPv4 REMOTE_INTERFACE_ID RFC 4204
3 IPv6 LOCAL_INTERFACE_ID RFC 4204
4 IPv6 REMOTE_INTERFACE_ID RFC 4204
5 Unnumbered LOCAL_INTERFACE_ID RFC 4204
6 Unnumbered REMOTE_INTERFACE_ID RFC 4204
7-119 Unassigned
120-127 Private Use RFC 4204

MESSAGE_ID Object Class type name space (Value 5)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 MESSAGE_ID RFC 4204
2 MESSAGE_ID_ACK RFC 4204
3-119 Unassigned
120-127 Private Use RFC 4204

CONFIG Object Class type name space (Value 6)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 HELLO_CONFIG RFC 4204
2 LMP-WDM_CONFIG RFC 4209
3 BehaviorConfig RFC 6898
4-119 Unassigned
120-127 Private Use RFC 4204

HELLO Object Class type name space (Value 7)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 HELLO RFC 4204
2-119 Unassigned
120-127 Private Use RFC 4204

BEGIN_VERIFY Object Class type name space (Value 8)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 Type 1 RFC 4204
2-119 Unassigned
120-127 Private Use RFC 4204

BEGIN_VERIFY_ACK Object Class type name space (Value 9)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 Type 1 RFC 4204
2-119 Unassigned
120-127 Private Use RFC 4204

VERIFY_ID Object Class type name space (Value 10)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 Type 1 RFC 4204
2-119 Unassigned
120-127 Private Use RFC 4204

TE_LINK Object Class type name space (Value 11)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Note

These values have additional usage for the Link Identifier Type field.

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 IPv4 TE_LINK RFC 4204
2 IPv6 TE_LINK RFC 4204
3 Unnumbered TE_LINK RFC 4204
4-119 Unassigned
120-127 Private Use RFC 4204

DATA_LINK Object Class type name space (Value 12)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 IPv4 DATA_LINK RFC 4204
2 IPv6 DATA_LINK RFC 4204
3 Unnumbered DATA_LINK RFC 4204
4-119 Unassigned
120-127 Private Use RFC 4204

DATA_LINK Sub-object Class name space

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-127 Standards Action
128-247 Expert Review
C-Type Description Reference
0 Reserved
1 Interface Switching Type RFC 4204
2 Wavelength RFC 4204
3 Link_GroupId RFC 4209
4 SRLG RFC 4209
5 BER_Estimate RFC 4209
6 Optical_Protection RFC 4209
7 Total_Span_Length RFC 4209
8 Administrative_Group RFC 4209
9 Data Channel Status RFC 5818
10-247 Unassigned
248-255 Private Use RFC 4204

CHANNEL_STATUS Object Class type name space (Value 13)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 IPv4 INTERFACE_ID RFC 4204
2 IPv6 INTERFACE_ID RFC 4204
3 Unnumbered INTERFACE_ID RFC 4204
4 LINK_GROUP RFC 4209
5-119 Unassigned
120-127 Private Use RFC 4204

CHANNEL_STATUS_REQUEST Object Class type name space (Value 14)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 IPv4 INTERFACE_ID RFC 4204
2 IPv6 INTERFACE_ID RFC 4204
3 Unnumbered INTERFACE_ID RFC 4204
4-119 Unassigned
120-127 Private Use RFC 4204

ERROR_CODE Object Class type name space (Value 20)

Expert(s)

  • Dimitri Papadimitriou

Reference

  • RFC 4204: Link Management Protocol (LMP)

Available Formats

Range Registration Procedures
0-111 Standards Action
112-119 Expert Review
C-Type Description Reference
0 Reserved
1 BEGIN_VERIFY_ERROR RFC 4204
2 LINK_SUMMARY_ERROR RFC 4204
3 TRACE_ERROR RFC 4207
4 ConfirmDataChannelStatusNack RFC 5818
5-119 Unassigned
120-127 Private Use RFC 4204

TRACE Object Class name space and Class type (C-Type) (Value 21)

Reference

  • RFC 4207: Synchronous Optical Network (SONET)/Synchronous Digital Hierarchy (SDH) Encoding for Link Management Protocol (LMP) Test Messages

Available Formats

C-Type Description Reference
0 Reserved
1 Type 1 RFC 4207

TRACE REQ Object Class name space and Class type (C-Type) (Value 22)

Reference

  • RFC 4207: Synchronous Optical Network (SONET)/Synchronous Digital Hierarchy (SDH) Encoding for Link Management Protocol (LMP) Test Messages

Available Formats

C-Type Description Reference
0 Reserved
1 Type 1 RFC 4207

LMP Behavior Configuration Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6898: Link Management Protocol Behavior Negotiation and Configuration Modifications

Available Formats

Bit Number Bit Name Meaning Reference
0 S SONET/SDH Test support RFC 6898
1 D DWDM support RFC 6898
2 C Data Channel consistency check support RFC 6898
3-8152 Unassigned