Locally-Served DNS Zones

Created

  • 2011-06-10

Last Updated

  • 2025-06-16

Note

Once a zone is added to one of these subregistries, it is effectively added permanently; once an address range starts being configured as a local zone in systems on the Internet, it will be impossible to reverse those changes.

Available Formats


IPv4 Locally-Served DNS Zone Registry

Registration Procedure(s)

  • IETF Review

Reference

Available Formats

Zone Description Reference
10.IN-ADDR.ARPA RFC1918 Zone RFC 6303
16.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
17.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
18.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
19.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
20.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
21.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
22.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
23.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
24.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
25.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
26.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
27.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
28.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
29.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
30.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
31.172.IN-ADDR.ARPA RFC1918 Zone RFC 6303
168.192.IN-ADDR.ARPA RFC1918 Zone RFC 6303
0.IN-ADDR.ARPA IPv4 "THIS" NETWORK RFC 6303
127.IN-ADDR.ARPA IPv4 LOOPBACK NETWORK RFC 6303
254.169.IN-ADDR.ARPA IPv4 LINK LOCAL RFC 6303
2.0.192.IN-ADDR.ARPA IPv4 TEST-NET-1 RFC 6303
100.51.198.IN-ADDR.ARPA IPv4 TEST-NET-2 RFC 6303
113.0.203.IN-ADDR.ARPA IPv4 TEST-NET-3 RFC 6303
255.255.255.255.IN-ADDR.ARPA IPv4 BROADCAST RFC 6303
64.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
65.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
66.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
67.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
68.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
69.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
70.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
71.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
72.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
73.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
74.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
75.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
76.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
77.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
78.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
79.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
80.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
81.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
82.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
83.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
84.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
85.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
86.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
87.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
88.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
89.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
90.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
91.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
92.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
93.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
94.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
95.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
96.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
97.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
98.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
99.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
100.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
101.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
102.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
103.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
104.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
105.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
106.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
107.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
108.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
109.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
110.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
111.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
112.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
113.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
114.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
115.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
116.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
117.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
118.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
119.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
120.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
121.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
122.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
123.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
124.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
125.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
126.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793
127.100.IN-ADDR.ARPA RFC6598 Zone RFC 7793

IPv6 Locally-Served DNS Zone Registry

Registration Procedure(s)

  • IETF Review

Reference

Available Formats

Zone Description Reference
0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA IPv6 Unspecified Address RFC 6303
1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA IPv6 Loopback Address RFC 6303
D.F.IP6.ARPA IPv6 Locally Assigned Local Address RFC 6303
8.E.F.IP6.ARPA IPv6 Link Local Address RFC 6303
9.E.F.IP6.ARPA IPv6 Link Local Address RFC 6303
A.E.F.IP6.ARPA IPv6 Link Local Address RFC 6303
B.E.F.IP6.ARPA IPv6 Link Local Address RFC 6303
8.B.D.0.1.0.0.2.IP6.ARPA IPv6 Example Prefix RFC 6303

Transport-Independent Locally-Served DNS Zone Registry

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8375: Special-Use Domain 'home.arpa.'

Available Formats

Zone Description Reference
HOME.ARPA Homenet Special-Use Domain RFC 8375
RESOLVER.ARPA DNS Resolver Special-Use Domain RFC 9462
SERVICE.ARPA DNS‑SD Service Registration Protocol Special-Use Domain RFC 9665

service.arpa Subdomain

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

  • RFC 9665: Service Registration Protocol for DNS-Based Service Discovery

Available Formats

Subdomain Name Description Reference
default.service.arpa. Default domain for SRP updates RFC 9665