Licklider Transmission Protocol (LTP) Parameters

Created

  • 2008-07-17

Last Updated

  • 2022-10-25

Available Formats


LTP Extension Tags

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5326: Licklider Transmission Protocol - Specification

Available Formats

Extension Tag Meaning Reference
0x00 LTP authentication extension RFC 5327
0x01 LTP cookie extension RFC 5327
0x02-0xAF Unassigned
0xB0-0xBF Reserved RFC 5326
0xC0-0xFF Private/Experimental Use RFC 5326

LTP Ciphersuites

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5327: Licklider Transmission Protocol - Security Extensions

Available Formats

Value Ciphersuite Reference
0 HMAC-SHA1-80 RFC 5327
1 RSA-SHA256 RFC 5327
2-127 Unassigned
128-191 Reserved RFC 5327
192-254 Private/Experimental Use RFC 5327
255 NULL RFC 5327

LTP Cancel Segment Reason Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 7116: Licklider Transmission Protocol (LTP), Compressed Bundle Header Encoding (CBHE), and Bundle Protocol IANA Registries

Available Formats

Value Description Reference
0 Client service canceled session RFC 5326
1 Unreachable client service RFC 5326
2 Retransmission limit exceeded RFC 5326
3 Miscolored data received RFC 5326
4 System error caused termination RFC 5326
5 Retransmission limit exceeded RFC 5326
6-255 Unassigned

LTP Engine Numbers

Expert(s)

  • Unassigned

Reference

  • RFC 7116: Licklider Transmission Protocol (LTP), Compressed Bundle Header Encoding (CBHE), and Bundle Protocol IANA Registries

Available Formats

Range Registration Procedures
1-16383 Expert Review
268435456-4398046511103 First Come First Served for requests of up to 16384 values. Larger requests require Expert Review.
Value Description Reference
0 Reserved RFC 7116
1-16383 Unassigned
16384-2097151 Allocated to the Space Assigned Numbers Authority (SANA) for use by Consultative Committee for Space Data Systems (CCSDS) missions. RFC 7116
2097152-268435455 Reserved for Private or Experimental Use RFC 7116
268435456-268451839 Allocated to Spacely Packets, LLC to provide IPN/IP Gateway services to private sector stakeholders. Scott Johnson
268451840-268468223 Allocated to SPATIAM CORPORATION to provide DTN services for organizations. Alberto Montilla
268468224-4398046511103 Unassigned
>=4398046511104 Reserved RFC 7116

LTP Client Service Identifiers

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 7116: Licklider Transmission Protocol (LTP), Compressed Bundle Header Encoding (CBHE), and Bundle Protocol IANA Registries

Available Formats

Value Description Reference
0 Reserved RFC 5326
1 Bundle Protocol RFC 7116
2 LTP Service Data Aggregation RFC 7116
3 CCSDS File Delivery Service RFC 7116
4-16383 Allocated to the Space Assigned Numbers Authority (SANA) for use by Consultative Committee for Space Data Systems (CCSDS) missions. RFC 7116
16384-32767 Reserved for Private or Experimental Use RFC 7116
>=32768 Unassigned

Contact Information

Name Contact URI Last Updated
Alberto Montilla a.montilla&spatiam.com 2022-10-25
Scott Johnson scott&solarnetone.org 2022-10-14