Media Type Sub-Parameter Registries

Created

  • 2003-10-31

Last Updated

  • 2026-07-20

Available Formats


Sub-Parameter Registry video/mpeg4-generic, audio/mpeg4-generic and application/mpeg4-generic

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3640: RTP Payload Format for Transport of MPEG-4 Elementary Streams

Available Formats

Modes Reference
mode=generic RFC 3640
mode=CELP-cbr RFC 3640
mode=CELP-vbr RFC 3640
mode=AAC-lbr RFC 3640
mode=AAC-hbr RFC 3640
mode=rtp-midi RFC 6295

Sub-Parameter Registry for mode=rtp-midi of audio/mpeg4-generic

Registration Procedure(s)

  • See sub-registries below

Reference


j_sec Values

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

j_sec Value Reference
j_sec=none RFC 6295
j_sec=recj RFC 6295

j_update Values

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

j_update Value Reference
j_update=anchor RFC 6295
j_update=open-loop RFC 6295
j_update=closed-loop RFC 6295

render Values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

Available Formats

render Value Reference
render=unknown RFC 6295
render=synthetic RFC 6295
render=null RFC 6295

subrender Values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

Available Formats

subrender Value Reference
subrender=default RFC 6295

smf_info Values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

Available Formats

smf_info Value Reference
smf_info=ignore RFC 6295
smf_info=sdp_start RFC 6295
smf_info=identity RFC 6295

Sub-Parameter Registry for audio/rtp-midi

Registration Procedure(s)

  • See sub-registries below

Reference


j_sec Values

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

j_sec Value Reference
j_sec=none RFC 6295
j_sec=recj RFC 6295

j_update Values

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

j_update Value Reference
j_update=anchor RFC 6295
j_update=open-loop RFC 6295
j_update=closed-loop RFC 6295

render Values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

Available Formats

render Value Reference
render=unknown RFC 6295
render=synthetic RFC 6295
render=api RFC 6295
render=null RFC 6295

subrender Values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

Available Formats

subrender Value Reference
subrender=default RFC 6295

smf_info Value

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

Available Formats

smf_info Value Reference
smf_info=ignore RFC 6295
smf_info=sdp_start RFC 6295
smf_info=identity RFC 6295

Sub-Parameter Registry for video/raw

Registration Procedure(s)

  • See sub-registries below

Reference

  • RFC 4175: RTP Payload Format for Uncompressed Video

Color (sub-)sampling

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Ali Begen

Reference

  • RFC 4175: RTP Payload Format for Uncompressed Video

Available Formats

Color (sub-)sampling Reference
sampling=RGB RFC 4175
sampling=RGBA RFC 4175
sampling=BGR RFC 4175
sampling=BGRA RFC 4175
sampling=YCbCr-4:4:4 RFC 4175
sampling=YCbCr-4:2:2 RFC 4175
sampling=YCbCr-4:2:0 RFC 4175
sampling=YCbCr-4:1:1 RFC 4175
sampling=RGB+ RFC 4421
sampling=RG+B RFC 4421
sampling=R+GB RFC 4421
sampling=BGR+ RFC 4421
sampling=BG+R RFC 4421
sampling=B+GR RFC 4421

Colorimetry

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Ali Begen

Reference

  • RFC 4175: RTP Payload Format for Uncompressed Video

Available Formats

Colorimetry Reference
colorimetry=BT601-5 RFC 4175
colorimetry=BT709-2 RFC 4175
colorimetry=SMPTE240M RFC 4175

Sub-parameter Registry for application/mbox

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 4155: The application/mbox Media Type

Available Formats

Format Value Reference
format=default RFC 4155

Parameter Values for the smime-type Parameter

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Russ Housley, Sean Turner (secondary)

Reference

  • RFC 7114: Creation of a Registry for smime-type Parameter Values

Available Formats

smime-type Value Reference
authEnveloped-data RFC 8551, Section 3.2.2
certs-only RFC 8551, Section 3.2.2
CMC-Request RFC 10003, Section 5
CMC-Response RFC 10003, Section 5
compressed-data RFC 8551, Section 3.2.2
enveloped-data RFC 8551, Section 3.2.2
enveloped-x400 RFC 3854, Section 3.3.1
server-generated-key RFC 7030, Section 4.4.2
signed-data RFC 8551, Section 3.2.2
signed-receipt RFC 2634, Section 2.4
signed-x400 RFC 3854, Section 3.2.1

CMS Encapsulating Content Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Russ Housley, Sean Turner

Reference

  • RFC 7193: The application/cms Media Type

Available Formats

Name Object Identifier Reference
authData 1.2.840.113549.1.9.16.1.2 RFC 5652
compressedData 1.2.840.113549.1.9.16.1.9 RFC 3274
contentCollection 1.2.840.113549.1.9.16.1.19 RFC 4073
contentInfo 1.2.840.113549.1.9.16.1.6 RFC 5652
contentWithAttrs 1.2.840.113549.1.9.16.1.20 RFC 4073
authEnvelopedData 1.2.840.113549.1.9.16.1.23 RFC 5083
encryptedKeyPkg 2.16.840.1.101.2.1.2.78.2 RFC 6032
digestData 1.2.840.113549.1.7.5 RFC 5652
encryptedData 1.2.840.113549.1.7.6 RFC 5652
envelopedData 1.2.840.113549.1.7.3 RFC 5652
signedData 1.2.840.113549.1.7.2 RFC 5652

CMS Inner Content Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Russ Housley, Sean Turner

Reference

  • RFC 7193: The application/cms Media Type

Available Formats

Name Object Identifier Reference
firmwarePackage 1.2.840.113549.1.9.16.1.16 RFC 4108
firmwareLoadReceipt 1.2.840.113549.1.9.16.1.17 RFC 4108
firmwareLoadError 1.2.840.113549.1.9.16.1.18 RFC 4108
aKeyPackage 2.16.840.1.101.2.1.2.78.5 RFC 5958
sKeyPackage 1.2.840.113549.1.9.16.1.25 RFC 6031
trustAnchorList 1.2.840.113549.1.9.16.1.34 RFC 5914
TAMP-statusQuery 2.16.840.1.101.2.1.2.77.1 RFC 5934
TAMP-statusResponse 2.16.840.1.101.2.1.2.77.2 RFC 5934
TAMP-update 2.16.840.1.101.2.1.2.77.3 RFC 5934
TAMP-updateConfirm 2.16.840.1.101.2.1.2.77.4 RFC 5934
TAMP-apexUpdate 2.16.840.1.101.2.1.2.77.5 RFC 5934
TAMP-apexUpdateConfirm 2.16.840.1.101.2.1.2.77.6 RFC 5934
TAMP-communityUpdate 2.16.840.1.101.2.1.2.77.7 RFC 5934
TAMP-communityUpdateConfirm 2.16.840.1.101.2.1.2.77.8 RFC 5934
TAMP-seqNumAdjust 2.16.840.1.101.2.1.2.77.10 RFC 5934
TAMP-seqNumAdjustConfirm 2.16.840.1.101.2.1.2.77.11 RFC 5934
TAMP-error 2.16.840.1.101.2.1.2.77.9 RFC 5934
keyPackageReceipt 2.16.840.1.101.2.1.2.78.3 RFC 7191
keyPackageError 2.16.840.1.101.2.1.2.78.6 RFC 7191
cbor 1.2.840.113549.1.9.16.1.44 RFC 8769
cborSequence 1.2.840.113549.1.9.16.1.45 RFC 8769

Report Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Murray Kucherawy

Reference

Available Formats

Report-Type Media Type Reference Comment
tlsrpt application/tlsrpt+gzip, application/tlsrpt+json RFC 8460 Media types suitable for use with this report-type are defined in Sections 6.4, 6.5 of RFC 8460
disposition-notification message/disposition-notification RFC 8098, Section 10
disposition-notification message/global-disposition-notification RFC 6533, Section 6
delivery-status message/delivery-status RFC 3464, Section 2.1
delivery-status message/global-delivery-status RFC 6533, Section 6

Sub-Parameter Registry for application/aif+cbor and application/aif+json

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Göran Selander

Reference

  • RFC 9237: An Authorization Information Format (AIF) for Authentication and Authorization for Constrained Environments (ACE)

Available Formats

Parameter Name Description/Specification Reference
Toid URI-local-part local-part of URI RFC 9237
Tperm REST-method-set set of REST methods represented RFC 9237
Toid mqtt-topic-filter Topic Filter, as defined in Section 2.3 of RFC 9431. RFC 9431, Section 2.3
Tperm mqtt-permissions Permissions for the MQTT Client, as defined in Section 2.3 of RFC 9431. Tperm is an array of one or more text strings that each have a value of either "pub" or "sub". RFC 9431, Section 2.3
Toid CRI-local-part local-part of CRI RFC-ietf-core-href-29, Section 8.3
Toid oscore-gname OSCORE group name RFC-ietf-ace-key-groupcomm-oscore-21
Tperm oscore-gperm permissions pertaining OSCORE groups RFC-ietf-ace-key-groupcomm-oscore-21