Message Headers

Last Updated

  • 2026-05-13

Available Formats


Permanent Message Header Field Names

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Mark Baker (primary), Murray Kucherawy (backup)

Reference

Note

RFC 5504 specified that no new header fields be registered that begin with "Downgraded-". That restriction is now lifted, per RFC 6857.

Note

HTTP field name registrations have been moved to Hypertext Transfer Protocol (HTTP) Field Name Registry per RFC 9110.

Available Formats

Header Field Name Template Protocol Status Trace Reference
Accept-Language mail RFC 4021
Also-Control netnews obsoleted RFC 1849; RFC 5536
Alternate-Recipient mail RFC 4021
Approved netnews standard RFC 5536
ARC-Authentication-Results mail experimental RFC 8617
ARC-Message-Signature mail experimental RFC 8617
ARC-Seal mail experimental RFC 8617
Archive netnews standard RFC 5536
Archived-At mail standard RFC 5064
Archived-At netnews standard RFC 5064
Article-Names netnews obsoleted RFC 1849; RFC 5536
Article-Updates netnews obsoleted RFC 1849; RFC 5536
Authentication-Results mail standard RFC 8601
Auto-Submitted mail standard RFC 3834, Section 5
Autoforwarded mail RFC 4021
Autosubmitted mail RFC 4021
Base MIME obsoleted RFC 1808; RFC 2068, Section 14.11
Bcc mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.3
Body none reserved RFC 6068
Cancel-Key netnews standard RFC 8315
Cancel-Lock netnews standard RFC 8315
Cc mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.3
Comments mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.5
Comments netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Content-Alternative MIME RFC 4021
Content-Base MIME obsoleted RFC 2110; RFC 2557
Content-Description MIME RFC 4021
Content-Disposition MIME RFC 4021
Content-Duration MIME RFC 4021
Content-features MIME RFC 4021
Content-ID MIME RFC 4021
Content-Identifier mail RFC 4021
Content-Language MIME RFC 4021
Content-Location MIME RFC 4021
Content-MD5 MIME RFC 4021
Content-Return mail RFC 4021
Content-Transfer-Encoding MIME RFC 4021
Content-Translation-Type MIME standard RFC 8255
Content-Type MIME RFC 4021; RFC 9788
Control netnews standard RFC 5536
Conversion mail RFC 4021
Conversion-With-Loss mail RFC 4021
DL-Expansion-History mail RFC 4021
Date mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.1
Date netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Date-Received netnews obsoleted RFC 850; RFC 5536
Deferred-Delivery mail RFC 4021
Delivery-Date mail RFC 4021
Discarded-X400-IPMS-Extensions mail RFC 4021
Discarded-X400-MTS-Extensions mail RFC 4021
Disclose-Recipients mail RFC 4021
Disposition-Notification-Options mail RFC 4021
Disposition-Notification-To mail RFC 4021
Distribution netnews standard RFC 5536
DKIM-Signature mail standard RFC 6376
Downgraded-Bcc mail obsoleted RFC 5504; RFC 6857
Downgraded-Cc mail obsoleted RFC 5504; RFC 6857
Downgraded-Disposition-Notification-To mail obsoleted RFC 5504; RFC 6857
Downgraded-Final-Recipient mail standard RFC 6857, Section 3.1.10
Downgraded-From mail obsoleted RFC 5504; RFC 6857, Section 3.1.10
Downgraded-In-Reply-To mail standard RFC 6857, Section 3.1.10
Downgraded-Mail-From mail obsoleted RFC 5504; RFC 6857, Section 3.1.10
Downgraded-Message-Id mail standard RFC 6857, Section 3.1.10
Downgraded-Original-Recipient mail standard RFC 6857, Section 3.1.10
Downgraded-Rcpt-To mail obsoleted RFC 5504; RFC 6857
Downgraded-References mail standard RFC 6857, Section 3.1.10
Downgraded-Reply-To mail obsoleted RFC 5504; RFC 6857
Downgraded-Resent-Bcc mail obsoleted RFC 5504; RFC 6857
Downgraded-Resent-Cc mail obsoleted RFC 5504; RFC 6857
Downgraded-Resent-From mail obsoleted RFC 5504; RFC 6857
Downgraded-Resent-Reply-To mail obsoleted RFC 5504; RFC 6857
Downgraded-Resent-Sender mail obsoleted RFC 5504; RFC 6857
Downgraded-Resent-To mail obsoleted RFC 5504; RFC 6857
Downgraded-Return-Path mail obsoleted RFC 5504; RFC 6857
Downgraded-Sender mail obsoleted RFC 5504; RFC 6857
Downgraded-To mail obsoleted RFC 5504; RFC 6857
Encoding mail RFC 4021
Encrypted mail RFC 4021
Expires mail standard RFC-ietf-mailmaint-expires-06
Expires netnews standard RFC 5536
Expiry-Date mail RFC 4021
Followup-To netnews standard RFC 5536
From mail standard no RFC 6854; RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.2
From netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Generate-Delivery-Report mail RFC 4021
HP-Outer mail standard RFC 9788, Section 2.2.1
Importance mail RFC 4021
In-Reply-To mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.4
Incomplete-Copy mail RFC 4021
Injection-Date netnews standard RFC 5536
Injection-Info netnews standard RFC 5536
Keywords mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.5
Keywords netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Language mail RFC 4021
Latest-Delivery-Time mail RFC 4021
Lines netnews deprecated RFC 5536; RFC 3977
List-Archive mail RFC 4021
List-Help mail RFC 4021
List-ID mail RFC 4021
List-Owner mail RFC 4021
List-Post mail RFC 4021
List-Subscribe mail RFC 4021
List-Unsubscribe perm/list-unsubscribe mail RFC 4021
List-Unsubscribe-Post mail standard RFC 8058
Message-Context mail RFC 4021
Message-ID mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.4
Message-ID netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Message-Type mail RFC 4021
MIME-Version MIME RFC 4021
MMHS-Exempted-Address mail RFC 6477; ACP123 Appendix A1.1 and Appendix B.105
MMHS-Extended-Authorisation-Info mail RFC 6477; ACP123 Appendix A1.2 and Appendix B.106
MMHS-Subject-Indicator-Codes mail RFC 6477; ACP123 Appendix A1.3 and Appendix B.107
MMHS-Handling-Instructions mail RFC 6477; ACP123 Appendix A1.4 and Appendix B.108
MMHS-Message-Instructions mail RFC 6477; ACP123 Appendix A1.5 and Appendix B.109
MMHS-Codress-Message-Indicator mail RFC 6477; ACP123 Appendix A1.6 and Appendix B.110
MMHS-Originator-Reference mail RFC 6477; ACP123 Appendix A1.7 and Appendix B.111
MMHS-Primary-Precedence mail RFC 6477; ACP123 Appendix A1.8 and Appendix B.101
MMHS-Copy-Precedence mail RFC 6477; ACP123 Appendix A1.9 and Appendix B.102
MMHS-Message-Type mail RFC 6477; ACP123 Appendix A1.10 and Appendix B.103
MMHS-Other-Recipients-Indicator-To mail RFC 6477; ACP123 Appendix A1.12 and Appendix B.113
MMHS-Other-Recipients-Indicator-CC mail RFC 6477; ACP123 Appendix A1.12 and Appendix B.113
MMHS-Acp127-Message-Identifier mail RFC 6477; ACP123 Appendix A1.14 and Appendix B.116
MMHS-Originator-PLAD mail RFC 6477; ACP123 Appendix A1.15 and Appendix B.117
MT-Priority mail standard RFC 6758
Newsgroups netnews standard RFC 5536
NNTP-Posting-Date netnews obsoleted RFC 5536
NNTP-Posting-Host netnews obsoleted RFC 2980; RFC 5536
Obsoletes mail RFC 4021
Organization mail informational RFC 7681
Organization netnews standard RFC 5536
Original-Encoded-Information-Types mail RFC 4021
Original-From mail standard RFC 5703
Original-Message-ID mail RFC 4021
Original-Recipient perm/original-recipient mail standard RFC 3798; RFC 5337
Original-Sender netnews standard RFC 5537
Originator-Return-Address mail RFC 4021
Original-Subject mail standard RFC 5703
Path netnews standard RFC 5536
PICS-Label mail RFC 4021
Posting-Version netnews obsoleted RFC 850; RFC 5536
Prevent-NonDelivery-Report mail RFC 4021
Priority mail RFC 4021
Received mail standard yes RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.7; RFC-ietf-emailcore-rfc5321bis-43
Received-SPF mail standard RFC 7208
References mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.4
References netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Relay-Version netnews obsoleted RFC 850; RFC 5536
Reply-By mail RFC 4021
Reply-To mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.2
Reply-To netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Require-Recipient-Valid-Since mail standard RFC 7293
Resent-Bcc mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Resent-Cc mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Resent-Date mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Resent-From mail standard no RFC 6854; RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Resent-Message-ID mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Resent-Reply-To mail obsoleted no RFC-ietf-emailcore-rfc5322bis-12, Section 4.5.6
Resent-Sender mail standard no RFC 6854; RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Resent-To mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.6
Return-Path mail standard yes RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.7; RFC-ietf-emailcore-rfc5321bis-43
See-Also netnews obsoleted RFC 1849; RFC 5536
Sender mail standard no RFC 6854; RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.2
Sender netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Sensitivity mail RFC 4021
Solicitation mail RFC 3865
Subject mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.5
Subject netnews standard RFC 5536; RFC-ietf-emailcore-rfc5322bis-12
Summary netnews standard RFC 5536
Supersedes mail RFC 4021
Supersedes netnews standard RFC 5536; RFC 2156
TLS-Report-Domain mail standard RFC 8460
TLS-Report-Submitter mail standard RFC 8460
TLS-Required mail standard RFC 8689
To mail standard no RFC-ietf-emailcore-rfc5322bis-12, Section 3.6.3
User-Agent netnews standard RFC 5536; RFC 2616
VBR-Info mail standard RFC 5518
X400-Content-Identifier mail RFC 4021
X400-Content-Return mail RFC 4021
X400-Content-Type mail RFC 4021
X400-MTS-Identifier mail RFC 4021
X400-Originator mail RFC 4021
X400-Received mail RFC 4021
X400-Recipients mail RFC 4021
X400-Trace mail RFC 4021
Xref netnews standard RFC 5536

Provisional Message Header Field Names

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Mark Baker (primary), Murray Kucherawy (backup)

Reference

Note

Registration of a Provisional Message Header Field does not of itself imply any kind of endorsement by the IETF, IANA or any other body.

Note

HTTP field name registrations have been moved to Hypertext Transfer Protocol (HTTP) Field Name Registry per RFC 9110.

Available Formats

Header Field Name Template Protocol Status Trace Reference
Apparently-To prov/apparently-to mail RFC 2076
Author mail RFC 9057
CFBL-Address mail RFC 9477
CFBL-Feedback-ID mail RFC 9477
Delivered-To mail RFC 9228
EDIINT-Features mail RFC 6017
Eesst-Version mail RFC 7681
Errors-To prov/errors-to mail RFC 2076
Face prov/face mail https://quimby.gnus.org/circus/face
Face prov/face netnews https://quimby.gnus.org/circus/face
Form-Sub mail draft-levine-mailbomb-header-00
Jabber-ID prov/jabber-id mail RFC 7259
Jabber-ID prov/jabber-id netnews RFC 7259
MMHS-Authorizing-Users mail RFC 7912
Privicon mail draft-koenig-privicons-01
SIO-Label mail RFC 7444
SIO-Label-History mail RFC 7444
Wrong-Recipient prov/wrong-recipient mail draft-ietf-mailmaint-wrong-recipient-00
X-Archived-At prov/x-archived-at mail deprecated RFC 5064
X-Archived-At prov/x-archived-at netnews deprecated RFC 5064
X-Face prov/x-face mail https://purl.org/x-face-spec
X-Face prov/x-face netnews https://purl.org/x-face-spec
X-Mittente mail RFC 6109
X-PGP-Sig prov/x-pgp-sig netnews ftp://ftp.isc.org/pub/pgpcontrol/FORMAT; https://ftp.isc.org/pub/pgpcontrol/FORMAT
X-Ricevuta mail RFC 6109
X-Riferimento-Message-ID mail RFC 6109
X-TipoRicevuta mail RFC 6109
X-Trasporto mail RFC 6109
X-VerificaSicurezza mail RFC 6109

Content-Translation-Type Header Field Values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Nik Tomkinson

Reference

  • RFC 8255: Multiple Language Content Type

Available Formats

Value Description Reference
original Content in the original language RFC 8255
human Content that has been translated by a human translator or a human has checked and corrected an automated translation RFC 8255
automated Content that has been translated by an electronic agent without proofreading or subsequent correction RFC 8255