Mobile IPv4 Numbers

Last Updated

  • 2023-08-24

Available Formats


Mobile IP Message Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised

Note

Mobile IP defines a set of new control messages, sent with UDP or TCP RFC 5944 using well-known port number 434. Currently, the following are defined.

Available Formats

Value Message Types Reference
1 Registration Request RFC 5944
2 Unassigned
3 Registration Reply RFC 5944
4 Tunnel Data RFC 3519
5-6 Unassigned
7 Registration Revocation RFC 3543
8-14 Unassigned
15 Revocation Acknowledgment RFC 3543
16 Handoff Request RFC 4881
17 Handoff Reply RFC 4881
18 Regional Registration Request RFC 4857
19 Regional Registration Reply RFC 4857
20 Fast Binding Update (FBU) RFC 4988
21 Fast Binding Acknowledgment (FBAck) RFC 4988
22 Generic Notification RFC 6098
23 Generic Notification Acknowledgement RFC 6098
24 Home Test Init message RFC 6521
25 Care-of Test Init message RFC 6521
26 Home Test message RFC 6521
27 Care-of Test message RFC 6521
28-254 Unassigned
255 Message for Experimental use RFC 4064

Extensions to Mobile IP Registration Messages

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised
  • RFC 6098: Generic Notification Message for Mobile IPv4

Note

The first set consists of those Extensions which may appear only in Mobile IP control messages (those sent to and from UDP port number 434).

Available Formats

Value Name Permitted for Notification Messages (Y/N) Reference
0 One-byte Padding N RFC 5944
32 Mobile-Home Authentication Y RFC 5944
33 Mobile-Foreign Authentication Y RFC 5944
34 Foreign-Home Authentication Y RFC 5944
36 Generalized Mobile IP Authentication N RFC 4721
38 Critical Vendor/Organization Specific Extension(CVSE) N RFC 3115
40 MN-FA-KeyGen Request N RFC 3957
41 MN-FA-KeyGen Reply N RFC 3957
42 MN-HA-KeyGen Request N RFC 3957
43 MN-HA-KeyGen Reply N RFC 3957
44 UDP Tunnel Reply Extension N RFC 3519
45 FA Error Extension N RFC 4636
46 GFA IP Address Extension N RFC 4857
47 PMIPv4 Non-skippable Extension N RFC 5563
48 GRE Key Extension N RFC 6245
49 Route Optimization Extensions N RFC 6521
50 Route Optimization Data N RFC 6521
51-126 Unassigned
127 Non-skippable Extension for Experimental use N RFC 4064
128 Deprecated (2001-08-31)
129 SKIP Firewall Traversal Extension N RFC 2356
130 Encapsulating Delivery Style Extension N RFC 3024
131 Mobile Node NAI N RFC 2794
132 MN-FA Challenge Extension N RFC 4721
134 Normal Vendor/Organization Specific Extension (NVSE) N RFC 3115
136 NAI Carrying Extension N RFC 3846
137 Revocation Support N RFC 3543
138 Generalized Link Layer Address Registration Extension N RFC 4881
139 Dynamic HA Extension N RFC 4433
140 Hierarchical Foreign Agent Extension N RFC 4857
141 Replay Protection Style N RFC 4857
142 Regional Registration Lifetime Extension N RFC 4857
144 UDP Tunnel Request Extension N RFC 3519
145 Message String Extension Y RFC 4917
147 PMIPv4 Skippable Extension N RFC 5563
148 Mobile Network Extension N RFC 5177
149 Trusted Networks Configured (TNC) Extension N RFC 5265
150 Reserved
151 Service Selection Extension N RFC 5446
152 Dual Stack (DSMIPv4) Extension N RFC 5454
153 Mobile Router Route Optimization Indication N RFC 6521
154 Multipath-Extension N RFC 7629
155-254 Unassigned
255 Skippable Extension for Experimental use N RFC 4064

Mobile IP Extensions for ICMP Router Discovery messages

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised

Note

The second set consists of those extensions which may appear only in ICMP Router Discovery messages RFC 1256.

Available Formats

Value Name Reference
0 One-byte Padding (encoded with no Length nor Data field) RFC 5944
1-15 Unassigned
16 Mobility Agent Advertisement RFC 5944
17-18 Unassigned
19 Prefix-Lengths RFC 5944
20 Link-Layer Address Option Format (LLA) RFC 4988
21 New IPv4 Address RFC 4988
22 New Router Prefix Information RFC 4988
23 Unassigned
24 Challenge Extension RFC 4721
25-126 Unassigned
127 Non-skippable Adv. Extension for Experimental use RFC 4064
128-135 Unassigned
136 NAI Carrying Extension RFC 3846
137 CARD MN-AR signature option RFC 4065
138 CARD Request option RFC 4065
139 CARD Reply option RFC 4065
140 Generalized Link Layer Address Advertisement Extension RFC 4881
141-254 Unassigned
255 Skippable Adv. Extension for Experimental use RFC 4064

Extension Subtypes

Note

To conserve the type number space, extension types may have sub-types. Currently the following extensions have subtypes defined:


Generalized Authentication Extension (Value 36)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 4721: Mobile IPv4 Challenge/Response Extensions (Revised)

Available Formats

Subtype Value Name Reference
1 MN-AAA Authentication subtype RFC 4721
2 FA-FA authentication RFC 4857
3 MN-GFA authentication RFC 4857
4 MN-PAR Auth Extension RFC 4988

KeyGen Request/Reply subtypes (Value 40-43)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3957: Authentication, Authorization, and Accounting (AAA) Registration Keys for Mobile IPv4

Available Formats

Subtype Value Name Reference
1 KeyGen Request/Reply from AAA RFC 3957
7 Not to be allocated - used by early implementations

UDP Tunnel Reply Extension (Value 44)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

Available Formats

Subtype Value Name Reference
0 Regular UDP Tunnel Reply Extension RFC 3519

FA Error Extension subtypes (value 45)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 4636: Foreign Agent Error Extension for Mobile IPv4

Available Formats

Subtype Value Name Reference
0 FA Error Indication to MN RFC 4636

GRE Key Extension subtypes (value 48)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6245: Generic Routing Encapsulation (GRE) Key Extension for Mobile IPv4

Available Formats

Subtype Value Name Reference
0 GRE Key Extension RFC 6245
1-255 Unassigned

NAI Carrying Extension Sub-types (Value 136)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3846: Mobile IPv4 Extension for Carrying Network Access Identifiers

Available Formats

Subtype Value Name Reference
1 HA Identity RFC 3846
2 AAAH identity RFC 3846
3 Foreign Agent NAI (FA-NAI) RFC 4857

Dynamic HA Extension subtypes (Value 139)

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4433: Mobile IPv4 Dynamic Home Agent (HA) Assignment

Available Formats

Subtype Value Name Reference
1 Requested HA Extension RFC 4433
2 Redirected HA Extension RFC 4433

UDP Tunnel Request Extension (Value 144)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

Available Formats

Subtype Value Name Reference
0 Regular UDP Tunnel Request Extension RFC 3519

Mobile Network Extension subtypes (Value 148)

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

  • RFC 5177: Network Mobility (NEMO) Extensions for Mobile IPv4

Available Formats

Value Name Reference
0 Mobile Network Request Extension RFC 5177
1 Explicit Mode Acknowledgement Extension RFC 5177
2 Implicit Mode Acknowledgement Extension RFC 5177
3-255 Unassigned

Trusted Networks Configured (TNC) Extension subtypes (Value 149)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5265: Mobile IPv4 Traversal across IPsec-Based VPN Gateways

Available Formats

Value Name Reference
0 Trusted Networks Configured (TNC) RFC 5265
1-255 Unassigned

Multipath Extension subtypes (Value 154)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 7629: Flow-Binding Support for Mobile IP

Available Formats

Subtype Value Name Reference
0 Reserved RFC 7629
1 Multipath Extension RFC 7629
2 Flow-Binding Extension RFC 7629
3-254 Unassigned
255 Reserved RFC 7629

Code Values for Mobile IP Registration Reply Messages

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised
  • RFC 6521: Home Agent-Assisted Route Optimization between Mobile IPv4 Networks

Available Formats

Range Guideline Registration Procedures
0-8 Success Codes None
9-63 Allocation guidelines not specified None
64-127 Error Codes from the Foreign Agent Expert Review
128-192 Error Codes from the Home Agent Expert Review
193-200 Error Codes from the Gateway Foreign Agent Expert Review
201-210 Error Codes form the Correspondent Node Expert Review
211-255 Allocation guidelines not specified None

Registration successful Code Values

Registration Procedure(s)

  • None

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised

Available Formats

Value Name Reference
0 registration accepted RFC 3344
1 registration accepted, but simultaneous mobility bindings unsupported RFC 3344
2 Concurrent registration (pre-accept) RFC 6521
3-8 Unassigned

Registration denied by the foreign agent

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised

Available Formats

Value Name Reference
64 reason unspecified RFC 3344
65 administratively prohibited RFC 3344
66 insufficient resources RFC 3344
67 mobile node failed authentication RFC 3344; RFC 4721
68 home agent failed authentication RFC 3344
69 requested Lifetime too long RFC 3344
70 poorly formed Request RFC 3344
71 poorly formed Reply RFC 3344
72 requested encapsulation unavailable RFC 3344
73 reserved and unavailable RFC 3344
74 request reverse tunnel unavailable RFC 3024
75 reverse runnel is mandatory and 'T' bit not set RFC 3024
76 mobile node too distant RFC 3024
77 invalid care-of address RFC 3344
78 registration timeout RFC 3344
79 delivery style not supported RFC 3024
80 home network unreachable (ICMP error received) RFC 3344
81 home agent host unreachable (ICMP error received) RFC 3344
82 home agent port unreachable (ICMP error received) RFC 3344
83-87 Unassigned
88 home agent unreachable (other ICMP error received) RFC 3344
89 vendor-specific reason Frank Quick
90 Non-zero HA address required in Registration Request RFC 4433
91-95 Unassigned
96 nonzero_homeaddr_reqd RFC 2794
97 missing_nai RFC 2794
98 missing_home_agent RFC 2794
99 missing_homeaddr RFC 2794
100 ERROR-FA-1 RFC 3115
101 ERROR-FA-2 RFC 3115
102-103 Unassigned
104 unknown_challenge RFC 4721
105 missing_challenge RFC 4721
106 stale_challenge RFC 4721
107 MISSING_MN_FA RFC 3957
108 Error code from Foreign Agent => fa_bad_aaa_auth RFC 4721
109 Error code from Foreign Agent => ha_wrong_challenge RFC 4721
110 Error code from Foreign Agent => REPLAY_PROT_UNAVAIL RFC 4857
111 Error code from Foreign Agent => ZERO_COA_NOT_SUPP RFC 4857
112 UNKNOWN_GFA RFC 4857
113 GFA_UNREACHABLE RFC 4857
114 GFA_HOST_UNREACHABLE RFC 4857
115 GFA_PORT_UNREACHABLE RFC 4857
116 Invalid Home Agent Address RFC 5944
117-126 Unassigned
127 FA Error Code for Experimental use RFC 4064

Registration denied by the home agent

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised

Available Formats

Value Name Reference
128 reason unspecified RFC 3344
129 administratively prohibited RFC 3344
130 insufficient resources RFC 3344
131 mobile node failed authentication RFC 3344
132 foreign agent failed authentication RFC 3344
133 registration Identification mismatch RFC 3344
134 poorly formed Request RFC 3344
135 too many simultaneous mobility bindings RFC 3344
136 unknown home agent address RFC 3344
137 request reverse tunnel unavailable RFC 3024
138 reverse runnel is mandatory and 'T' bit not set RFC 3024
139 requested encapsulation unavailable RFC 3024
140 ERROR-HA-1 RFC 3115
141 ERROR-HA-2 RFC 3115
142 ERROR_HA_UDP-ENCAP_UNAVAIL RFC 3519
143 Reregister with redirected HA RFC 4433
144 Error code from Home Agent => ha_bad_aaa_auth RFC 4721
145 Error code from Home Agent => ZERO_CAREOF_ADDRESS RFC 4857
146 Error code from Home Agent => DYN_GFA_NOT_SUPP RFC 4857
147 Mobile Network Prefix operation error (HA_MOBNET_ERROR) RFC 5177
148 Mobile Router operation is not permitted (HA_MOBNET_DISALLOWED) RFC 5177
149 PMIP_UNSUPPORTED RFC 5563
150 PMIP_DISALLOWED RFC 5563
151 SERVICE_AUTHORIZATION_FAILED RFC 5446
152 MULTIPATH_NOT_ALLOWED RFC 7629
153 INVALID_FB_IDENTIFIER RFC 7629
154-191 Unassigned
192 HA Error Code for Experimental use RFC 4064

Registration denied by the gateway foreign agent

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5944: IP Mobility Support for IPv4, Revised

Available Formats

Value Name Reference
193 NO_HOME_REG RFC 4857
194 Reserved
195-200 Unassigned

Error Codes from the Correspondent Node

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 6521: Home Agent-Assisted Route Optimization between Mobile IPv4 Networks

Available Formats

Value Name Reference
201 Expired Home nonce Index RFC 6521
202 Expired Care-of nonce Index RFC 6521
203 Expired nonces RFC 6521
204-210 Unassigned

Security Parameter Index (SPI) Values for the Mobile IP Reserved SPIs

Registration Procedure(s)

  • Must be specified and approved by the MIP4 working group

Reference

  • RFC 4721: Mobile IPv4 Challenge/Response Extensions (Revised)

Available Formats

Value Name Reference
0 Reserved RFC 4721
1 Reserved RFC 4721
2 CHAP_SPI RFC 4721
3-255 Unassigned

Replay Method Identifier

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 3957: Authentication, Authorization, and Accounting (AAA) Registration Keys for Mobile IPv4

Available Formats

Replay Method Name Reference
0-1 Reserved RFC 3957
2 Timestamps RFC 3957
3 Nonces RFC 3957
4-65535 Unassigned

Generalized Link Layer Address Registration Extension Subtypes and Generalized Link Layer Address Advertisement Extension Subtypes

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4881: Low-Latency Handoffs in Mobile IPv4

Available Formats

Subtype Value Name Reference
0 Reserved RFC 4881
1 3GPP2 International Mobile Station Identity and Connection ID RFC 4881
2 3GPP International Mobile Subscriber Identity RFC 4881
3 Ethernet 48-bit MAC address RFC 4881
4 64-bit Global ID, EUI-64 RFC 4881
5 Solicited IPv4 Address RFC 4881
6 Access Point Identifier RFC 4881
7 FA IPv4 Address RFC 4881
8-255 Unassigned

Code Values for Mobile IP Handoff Reply Messages (Value 17)

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4881: Low-Latency Handoffs in Mobile IPv4

Available Formats

Value Description Reference
0 Successful Handoff RFC 4881
1 Generic Handoff Failure RFC 4881
2-255 Unassigned

Message String Extension (Value 145)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 4917: Mobile IPv4 Message String Extension

Available Formats

Subtype Value Name Reference
1 Home Agent RFC 4917
2 Foreign Agent RFC 4917

Mobile Network Acknowledgement Extension

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

  • RFC 5177: Network Mobility (NEMO) Extensions for Mobile IPv4

Available Formats

Value Name Reference
0 Success RFC 5177
1 Invalid prefix length (MOBNET_INVALID_PREFIX_LEN) RFC 5177
2 Mobile Router is not authorized for prefix (MOBNET_UNAUTHORIZED) RFC 5177
3 Forwarding setup failed (MOBNET_FWDING_SETUP_FAILED) RFC 5177
4 Home Agent cannot assign a mobile network prefix (MOBNET_UNASSIGNED) RFC 6626
5-255 Unassigned

PMIPv4 Non-skippable Extension (Value 47)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5563: WiMAX Forum / 3GPP2 Proxy Mobile IPv4

Available Formats

Value Name Reference
0 Unassigned RFC 5563
1 PMIPv4 Per-Node Authentication Method RFC 5563
2-255 Unassigned RFC 5563

PMIPv4 Skippable Extension (Value 147)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5563: WiMAX Forum / 3GPP2 Proxy Mobile IPv4

Available Formats

Value Name Reference
0 Unassigned RFC 5563
1 PMIPv4 Interface ID RFC 5563
2 PMIPv4 Device ID RFC 5563
3 PMIPv4 Subscriber ID RFC 5563
4 Access Technology Type RFC 5563
5-255 Unassigned RFC 5563

Dual Stack (DSMIPv4) Extension subtypes (Value 152)

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

Available Formats

Value Name Reference
1 IPv6 Prefix Request RFC 5454
2 IPv6 Prefix Reply RFC 5454
3 IPv6 Tunneling Mode RFC 5454

PMIPv4 Per-Node Authentication Method Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5563: WiMAX Forum / 3GPP2 Proxy Mobile IPv4

Available Formats

Value Name Reference
0 Reserved RFC 5563
1 FA-HA Authentication RFC 5563
2 IPSec Authentication RFC 5563
3-255 Unassigned

PMIPv4 Device ID Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5563: WiMAX Forum / 3GPP2 Proxy Mobile IPv4

Available Formats

Value Name Reference
0 Reserved RFC 5563
1 Ethernet MAC address RFC 5563
2 Mobile Equipment Identifier (MEID) RFC 5563
3 International Mobile Equipment Identity (IMEI) RFC 5563
4 Electronic Serial Number (ESN) RFC 5563
5-255 Unassigned

PMIPv4 Subscriber ID Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5563: WiMAX Forum / 3GPP2 Proxy Mobile IPv4

Available Formats

Value Name Reference
0 Reserved RFC 5563
1 International Mobile Subscriber Identity (IMSI) RFC 5563
2-255 Unassigned

Access Technology Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 5563: WiMAX Forum / 3GPP2 Proxy Mobile IPv4

Available Formats

Value Name Reference
0 Reserved RFC 5563
1 802.3 RFC 5563
2 802.11a/b/g RFC 5563
3 802.16e RFC 5563
4 802.16m RFC 5563
5 3GPP EUTRAN/LTE RFC 5563
6 3GPP UTRAN/GERAN RFC 5563
7 3GPP2 1xRTT/HRPD RFC 5563
8 3GPP2 UMB RFC 5563
9-255 Unassigned

IPv6 Prefix Reply Extension Codes

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

Available Formats

Code Description Reference
0 registration accepted, IPv6 to be tunneled to HoA RFC 5454
1 registration accepted, IPv6 to be tunneled to CoA RFC 5454
2-7 Unassigned (available for accept codes)
8 registration rejected, reason unspecified RFC 5454
9 registration rejected, administratively prohibited RFC 5454
10-255 Unassigned (available for reject codes)

Code Values for General Notification Messages

Expert(s)

  • Unassigned

Reference

  • RFC 6098: Generic Notification Message for Mobile IPv4

Available Formats

Range Registration Procedures Note
0 Expert Review Success Code
1-63 Expert Review
64-69 Expert Review Error Codes from the FA
70-127 Expert Review
128-133 Expert Review Error Codes from the HA
134-191 Expert Review
192-197 Expert Review Error Codes from the MN
198-255 Expert Review
Value Name Reference
0 notification accepted RFC 6098
1-63 Unassigned
64 reason unspecified RFC 6098
65 administratively prohibited RFC 6098
66 insufficient resources RFC 6098
67 mobile node failed authentication RFC 6098
68 home agent failed authentication RFC 6098
69 notification Identification mismatch RFC 6098
70-126 Unassigned
127 Reserved for Experimental Use RFC 6098
128 reason unspecified RFC 6098
129 administratively prohibited RFC 6098
130 insufficient resources RFC 6098
131 mobile node failed authentication RFC 6098
132 foreign agent failed authentication RFC 6098
133 notification Identification mismatch RFC 6098
134-190 Unassigned
191 Reserved for Experimental Use RFC 6098
192 reason unspecified RFC 6098
193 administratively prohibited RFC 6098
194 insufficient resources RFC 6098
195 foreign agent failed authentication RFC 6098
196 home agent failed authentication RFC 6098
197 notification Identification mismatch RFC 6098
198-254 Unassigned
255 Reserved for Experimental Use RFC 6098

Route Optimization Extension (Value 49)

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 6521: Home Agent-Assisted Route Optimization between Mobile IPv4 Networks

Available Formats

Subtype Value Name Reference
0 Reserved RFC 6521
1 Route Optimization Reply RFC 6521
2 Mobile-Correspondent Authentication RFC 6521
3 Care-of Address RFC 6521
4-255 Unassigned

Route Optimization Data Extension (Value 50)

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 6521: Home Agent-Assisted Route Optimization between Mobile IPv4 Networks

Available Formats

Subtype Value Name Reference
0 Reserved RFC 6521
1 Route Optimization Prefix Advertisement RFC 6521
2-255 Unassigned

Mobile Router Route Optimization Capability Extension (Value 153)

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 6521: Home Agent-Assisted Route Optimization between Mobile IPv4 Networks

Available Formats

Subtype Value Name Reference
0 Reserved RFC 6521
1 Mobile Router Route Optimization Capability RFC 6521
2-255 Unassigned

Contact Information

Name Contact URI Last Updated
Frank Quick fquick&qualcomm.com 2002-07