Media Resource Control Protocol Version 2 (MRCPv2) Parameters

Created

  • 2012-09-10

Last Updated

  • 2012-11-13

Available Formats


MRCPv2 Resource Types

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6787: Media Resource Control Protocol Version 2 (MRCPv2)

Available Formats

Resource Type Resource Description Reference
speechrecog Speech Recognizer RFC 6787
dtmfrecog DTMF Recognizer RFC 6787
speechsynth Speech Synthesizer RFC 6787
basicsynth Basic Synthesizer RFC 6787
speakverify Speaker Verifier RFC 6787
recorder Speech Recorder RFC 6787

MRCPv2 Methods and Events

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6787: Media Resource Control Protocol Version 2 (MRCPv2)

Available Formats

Name Resource Type Method/Event Reference
SET-PARAMS Generic Method RFC 6787
GET-PARAMS Generic Method RFC 6787
SPEAK Synthesizer Method RFC 6787
STOP Synthesizer Method RFC 6787
PAUSE Synthesizer Method RFC 6787
RESUME Synthesizer Method RFC 6787
BARGE-IN-OCCURRED Synthesizer Method RFC 6787
CONTROL Synthesizer Method RFC 6787
DEFINE-LEXICON Synthesizer Method RFC 6787
DEFINE-GRAMMAR Recognizer Method RFC 6787
RECOGNIZE Recognizer Method RFC 6787
INTERPRET Recognizer Method RFC 6787
GET-RESULT Recognizer Method RFC 6787
START-INPUT-TIMERS Recognizer Method RFC 6787
STOP Recognizer Method RFC 6787
START-PHRASE-ENROLLMENT Recognizer Method RFC 6787
ENROLLMENT-ROLLBACK Recognizer Method RFC 6787
END-PHRASE-ENROLLMENT Recognizer Method RFC 6787
MODIFY-PHRASE Recognizer Method RFC 6787
DELETE-PHRASE Recognizer Method RFC 6787
RECORD Recorder Method RFC 6787
STOP Recorder Method RFC 6787
START-INPUT-TIMERS Recorder Method RFC 6787
START-SESSION Verifier Method RFC 6787
END-SESSION Verifier Method RFC 6787
QUERY-VOICEPRINT Verifier Method RFC 6787
DELETE-VOICEPRINT Verifier Method RFC 6787
VERIFY Verifier Method RFC 6787
VERIFY-FROM-BUFFER Verifier Method RFC 6787
VERIFY-ROLLBACK Verifier Method RFC 6787
STOP Verifier Method RFC 6787
START-INPUT-TIMERS Verifier Method RFC 6787
GET-INTERMEDIATE-RESULT Verifier Method RFC 6787
SPEECH-MARKER Synthesizer Event RFC 6787
SPEAK-COMPLETE Synthesizer Event RFC 6787
START-OF-INPUT Recognizer Event RFC 6787
RECOGNITION-COMPLETE Recognizer Event RFC 6787
INTERPRETATION-COMPLETE Recognizer Event RFC 6787
START-OF-INPUT Recorder Event RFC 6787
RECORD-COMPLETE Recorder Event RFC 6787
VERIFICATION-COMPLETE Verifier Event RFC 6787
START-OF-INPUT Verifier Event RFC 6787

MRCPv2 Header Fields

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6787: Media Resource Control Protocol Version 2 (MRCPv2)

Available Formats

Name Resource Type Reference
Channel-Identifier Generic RFC 6787
Accept Generic RFC 2616
Active-Request-Id-List Generic RFC 6787
Proxy-Sync-Id Generic RFC 6787
Accept-Charset Generic RFC 2616
Content-Type Generic RFC 6787
Content-ID Generic RFC 2392; RFC 2046; RFC 5322
Content-Base Generic RFC 6787
Content-Encoding Generic RFC 6787
Content-Location Generic RFC 6787
Content-Length Generic RFC 6787
Fetch-Timeout Generic RFC 6787
Cache-Control Generic RFC 6787
Logging-Tag Generic RFC 6787
Set-Cookie Generic RFC 6787
Vendor-Specific Generic RFC 6787
Jump-Size Synthesizer RFC 6787
Kill-On-Barge-In Synthesizer RFC 6787
Speaker-Profile Synthesizer RFC 6787
Completion-Cause Synthesizer RFC 6787
Completion-Reason Synthesizer RFC 6787
Voice-Parameter Synthesizer RFC 6787
Prosody-Parameter Synthesizer RFC 6787
Speech-Marker Synthesizer RFC 6787
Speech-Language Synthesizer RFC 6787
Fetch-Hint Synthesizer RFC 6787
Audio-Fetch-Hint Synthesizer RFC 6787
Failed-URI Synthesizer RFC 6787
Failed-URI-Cause Synthesizer RFC 6787
Speak-Restart Synthesizer RFC 6787
Speak-Length Synthesizer RFC 6787
Load-Lexicon Synthesizer RFC 6787
Lexicon-Search-Order Synthesizer RFC 6787
Confidence-Threshold Recognizer RFC 6787
Sensitivity-Level Recognizer RFC 6787
Speed-Vs-Accuracy Recognizer RFC 6787
N-Best-List-Length Recognizer RFC 6787
Input-Type Recognizer RFC 6787
No-Input-Timeout Recognizer RFC 6787
Recognition-Timeout Recognizer RFC 6787
Waveform-URI Recognizer RFC 6787
Input-Waveform-URI Recognizer RFC 6787
Completion-Cause Recognizer RFC 6787
Completion-Reason Recognizer RFC 6787
Recognizer-Context-Block Recognizer RFC 6787
Start-Input-Timers Recognizer RFC 6787
Speech-Complete-Timeout Recognizer RFC 6787
Speech-Incomplete-Timeout Recognizer RFC 6787
Dtmf-Interdigit-Timeout Recognizer RFC 6787
Dtmf-Term-Timeout Recognizer RFC 6787
Dtmf-Term-Char Recognizer RFC 6787
Failed-URI Recognizer RFC 6787
Failed-URI-Cause Recognizer RFC 6787
Save-Waveform Recognizer RFC 6787
Media-Type Recognizer RFC 6787
New-Audio-Channel Recognizer RFC 6787
Speech-Language Recognizer RFC 6787
Ver-Buffer-Utterance Recognizer RFC 6787
Recognition-Mode Recognizer RFC 6787
Cancel-If-Queue Recognizer RFC 6787
Hotword-Max-Duration Recognizer RFC 6787
Hotword-Min-Duration Recognizer RFC 6787
Interpret-Text Recognizer RFC 6787
Dtmf-Buffer-Time Recognizer RFC 6787
Clear-Dtmf-Buffer Recognizer RFC 6787
Early-No-Match Recognizer RFC 6787
Num-Min-Consistent-Pronunciations Recognizer RFC 6787
Consistency-Threshold Recognizer RFC 6787
Clash-Threshold Recognizer RFC 6787
Personal-Grammar-URI Recognizer RFC 6787
Enroll-Utterance Recognizer RFC 6787
Phrase-ID Recognizer RFC 6787
Phrase-NL Recognizer RFC 6787
Weight Recognizer RFC 6787
Save-Best-Waveform Recognizer RFC 6787
New-Phrase-ID Recognizer RFC 6787
Confusable-Phrases-URI Recognizer RFC 6787
Abort-Phrase-Enrollment Recognizer RFC 6787
Sensitivity-Level Recorder RFC 6787
No-Input-Timeout Recorder RFC 6787
Completion-Cause Recorder RFC 6787
Completion-Reason Recorder RFC 6787
Failed-URI Recorder RFC 6787
Failed-URI-Cause Recorder RFC 6787
Record-URI Recorder RFC 6787
Media-Type Recorder RFC 6787
Max-Time Recorder RFC 6787
Trim-Length Recorder RFC 6787
Final-Silence Recorder RFC 6787
Capture-on-Speech Recorder RFC 6787
Ver-Buffer-Utterance Recorder RFC 6787
Start-Input-Timers Recorder RFC 6787
New-Audio-Channel Recorder RFC 6787
Repository-URI Verifier RFC 6787
Voiceprint-Identifier Verifier RFC 6787
Verification-Mode Verifier RFC 6787
Adapt-Model Verifier RFC 6787
Abort-Model Verifier RFC 6787
Min-Verification-Score Verifier RFC 6787
Num-Min-Verification-Phrases Verifier RFC 6787
Num-Max-Verification-Phrases Verifier RFC 6787
No-Input-Timeout Verifier RFC 6787
Save-Waveform Verifier RFC 6787
Media-Type Verifier RFC 6787
Waveform-URI Verifier RFC 6787
Voiceprint-Exists Verifier RFC 6787
Ver-Buffer-Utterance Verifier RFC 6787
Input-Waveform-URI Verifier RFC 6787
Completion-Cause Verifier RFC 6787
Completion-Reason Verifier RFC 6787
Speech-Complete-Timeout Verifier RFC 6787
New-Audio-Channel Verifier RFC 6787
Abort-Verification Verifier RFC 6787
Start-Input-Timers Verifier RFC 6787
Input-Type Verifier RFC 6787

MRCPv2 Status Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6787: Media Resource Control Protocol Version 2 (MRCPv2)

Note

The status codes are classified under Success (2XX), Client Failure (4XX), and Server Failure (5XX).

Available Formats

Code Meaning Reference
200 Success RFC 6787
201 Success with some optional header fields ignored RFC 6787
401 Method not allowed RFC 6787
402 Method not valid in this state RFC 6787
403 Unsupported header field RFC 6787
404 Illegal value for header field. This is the error for a syntax violation. RFC 6787
405 Resource not allocated for this session or does not exist RFC 6787
406 Mandatory Header Field Missing RFC 6787
407 Method or Operation Failed (e.g., Grammar compilation failed in the recognizer. Detailed cause codes might be available through a resource specific header.) RFC 6787
408 Unrecognized or unsupported message entity RFC 6787
409 Unsupported Header Field Value. This is a value that is syntactically legal but exceeds the implementation's capabilities or expectations. RFC 6787
410 Non-Monotonic or Out-of-order sequence number in request. RFC 6787
411-420 Unassigned
501 Server Internal Error RFC 6787
502 Protocol Version not supported RFC 6787
503 Unassigned
504 Message too large RFC 6787

Grammar Reference List Parameters

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6787: Media Resource Control Protocol Version 2 (MRCPv2)

Available Formats

Name Reference
weight RFC 6787

MRCPv2 Vendor-Specific Parameters

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 6787: Media Resource Control Protocol Version 2 (MRCPv2)
Name Contact Reference
No registrations at this time.