Named Information

Created

  • 2012-08-14

Last Updated

  • 2025-10-14

Available Formats


Named Information Hash Algorithm Registry

Registration Procedure(s)

  • Expert Review

Expert(s)

  • James Manger

Reference

Available Formats

ID Hash Name String Value Length Reference Status
0 Reserved RFC 6920
1 sha-256 256 bits RFC 6920 current
2 sha-256-128 128 bits RFC 6920 current
3 sha-256-120 120 bits RFC 6920 current
4 sha-256-96 96 bits RFC 6920 current
5 sha-256-64 64 bits RFC 6920 current
6 sha-256-32 32 bits RFC 6920 current
7 sha-384 384 bits FIPS 180-4 current
8 sha-512 512 bits FIPS 180-4 current
9 sha3-224 224 bits FIPS 202 current
10 sha3-256 256 bits FIPS 202 current
11 sha3-384 384 bits FIPS 202 current
12 sha3-512 512 bits FIPS 202 current
13-31 Unassigned
32 Reserved RFC 6920
33-63 Unassigned
blake2s-256 256 bits RFC 7693 current
blake2b-256 256 bits RFC 7693 current
blake2b-512 512 bits RFC 7693 current
k12-256 256 bits RFC 9861 current
k12-512 512 bits RFC 9861 current

Named Information URI Parameter Definitions

Registration Procedure(s)

  • Expert Review

Expert(s)

  • James Manger

Reference

Available Formats

Parameter Meaning Reference
ct Content Type RFC 6920