Network Service Header (NSH) Parameters
Created
- 2017-11-08
Last Updated
- 2023-11-21
Available Formats
NSH Base Header Bits
Registration Procedure(s)
- Standards Action
Reference
- RFC 8300: Network Service Header (NSH)
Available Formats
| Bit | Description | Reference |
|---|---|---|
| 2 | O (OAM) bit | RFC 8300 |
| 3 | Unassigned | |
| 16-19 | Unassigned |
NSH Version
Registration Procedure(s)
- Standards Action
Reference
- RFC 8300: Network Service Header (NSH)
Available Formats
NSH MD Types
Registration Procedure(s)
- IETF Review
Reference
- RFC 8300: Network Service Header (NSH)
Available Formats
NSH MD Class
Expert(s)
- Carlos Pignataro, Joel Halpern, Jim Guichard
Reference
- RFC 8300: Network Service Header (NSH)
Available Formats
| Range | Registration Procedures |
|---|---|
| 0x0000-0x01FF | IETF Review |
| 0x0200-0xFFF5 | Expert Review |
| Value | Meaning | Reference | Change Controller |
|---|---|---|---|
| 0x0000 | IETF Base NSH MD Class | RFC 8300 | |
| 0x0001-0x01FF | Unassigned | ||
| 0x0200 | BBF Specific NSH Metadata | https://www.broadband-forum.org/assignments | Broadband Forum |
| 0x0201-0xFFF5 | Unassigned | ||
| 0xFFF6-0xFFFE | Experimental | RFC 8300 | |
| 0xFFFF | Reserved | RFC 8300 |
NSH IETF-Assigned Optional Variable-Length Metadata Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 8300: Network Service Header (NSH)
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0x00 | Subscriber Identifier | RFC 8979 |
| 0x01 | Performance Policy Identifier | RFC 8979 |
| 0x02 | MAC and Encrypted Metadata #1 | RFC 9145 |
| 0x03 | MAC and Encrypted Metadata #2 | RFC 9145 |
| 0x04 | Forwarding Context | RFC 9263 |
| 0x05 | Tenant ID | RFC 9263 |
| 0x06 | Ingress Network Node ID | RFC 9263 |
| 0x07 | Ingress Network Interface | RFC 9263 |
| 0x08 | Flow ID | RFC 9263 |
| 0x09 | Source and/or Destination Groups | RFC 9263 |
| 0x0A | Policy ID | RFC 9263 |
| 0x0B-0xFF | Unassigned |
NSH Next Protocol
Registration Procedure(s)
- Expert Review
Expert(s)
- Carlos Pignataro, Joel Halpern, Jim Guichard
Reference
- RFC 8300: Network Service Header (NSH)
Note
If the actual assignment of the Next Protocol field allocation reaches half of the range (that is, when there are 128 unassigned values), IANA needs to alert the IESG. At that point, a new more strict allocation policy SHOULD be considered.
Available Formats
| Next Protocol | Description | Reference |
|---|---|---|
| 0x00 | None | RFC 8393 |
| 0x01 | IPv4 | RFC 8300 |
| 0x02 | IPv6 | RFC 8300 |
| 0x03 | Ethernet | RFC 8300 |
| 0x04 | NSH | RFC 8300 |
| 0x05 | MPLS | RFC 8300 |
| 0x06 | IOAM (Next protocol is an IOAM header) | RFC 9452 |
| 0x07 | SFC Active OAM | RFC 9516 |
| 0x08-0xFD | Unassigned | |
| 0xFE | Experiment 1 | RFC 8300 |
| 0xFF | Experiment 2 | RFC 8300 |
Forwarding Context Types
Registration Procedure(s)
- IETF Review
Reference
- RFC 9263: Network Service Header (NSH) Metadata Type 2 Variable-Length Context Headers
Available Formats
Flow ID Context Types
Registration Procedure(s)
- IETF Review
Reference
- RFC 9263: Network Service Header (NSH) Metadata Type 2 Variable-Length Context Headers
Available Formats
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Broadband Forum | help&broadband-forum.org | 2019-12-23 |