NSIS Signaling Layer Protocol (NSLP) Parameters

Created

  • 2010-02-03

Last Updated

  • 2011-03-16

Available Formats


QoS NSLP Message Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Value Description Reference
0x00 Reserved RFC 5974
0x01 RESERVE RFC 5974
0x02 QUERY RFC 5974
0x03 RESPONSE RFC 5974
0x04 NOTIFY RFC 5974
0x05-0xEF Unassigned
0xF0-0xFF Reserved for Experimental/Private Use RFC 5974

NSLP Message Objects

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Range Registration Procedures
1-1023 IETF Review
1024-1999 Specification Required
Value Description Reference
0x000 Reserved RFC 5974
0x001 RII RFC 5974
0x002 RSN RFC 5974
0x003 REFRESH-PERIOD RFC 5974
0x004 BOUND-SESSION-ID RFC 5974
0x005 PACKET-CLASSIFIER RFC 5974
0x006 INFO-SPEC RFC 5974
0x007 SESSION-ID-LIST RFC 5974
0x008 RSN-LIST RFC 5974
0x009 MSG-ID RFC 5974
0x00A BOUND-MSG-ID RFC 5974
0x00B QSPEC RFC 5974
0x00C NATFW_LT RFC 5973
0x00D NATFW_EXTERNAL_IP RFC 5973
0x00E NATFW_EXTERNAL_BINDING RFC 5973
0x00F NATFW_EFI RFC 5973
0x010 NATFW_INFO RFC 5973
0x011 NATFW_NONCE RFC 5973
0x012 NATFW_MSN RFC 5973
0x013 NATFW_DTINFO RFC 5973
0x014 NATFW_ICMP_TYPES RFC 5973
0x015 NODE_CAPABILITY_TUNNEL RFC 5979
0x016 SESSION_AUTH_OBJECT RFC 5981
0x017-0x7CF Unassigned
0x7D0-0x7FF Reserved for Private/Experimental Use RFC 5974
0x800-0xFFF Reserved RFC 5974

QoS NSLP Binding Codes

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Value Description Reference
0x00 Reserved RFC 5974
0x01 Tunnel and end-to-end sessions RFC 5974
0x02 Bidirectional sessions RFC 5974
0x03 Aggregate sessions RFC 5974
0x04 Dependent sessions (binding session is alive only if the other session is also alive) RFC 5974
0x05 Indicated session caused pre-emption RFC 5974
0x06-0x7F Unassigned
0x80-0x9F Reserved for Experimental/Private Use RFC 5974
0xA0-0xFF Reserved RFC 5974

NSLP Error Classes

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling
  • RFC 5973: NAT/Firewall NSIS Signaling Layer Protocol (NSLP)

Available Formats

Value Description Reference
0 Reserved RFC 5974; RFC 5973
1 Informational RFC 5974; RFC 5973
2 Success RFC 5974; RFC 5973
3 Protocol Error RFC 5974; RFC 5973
4 Transient Failure RFC 5974; RFC 5973
5 Permanent Failure RFC 5974; RFC 5973
6 QoS Model Error RFC 5974
7 Signaling session failure RFC 5973
8-15 Reserved RFC 5974; RFC 5973

Informational Error Codes

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Range Registration Procedures
0-63 IETF Review
64-127 Specification Required
Value Description Reference
0x00 Reserved RFC 5974
0x01 Unknown BOUND-SESSION-ID: the message refers to an unknown SESSION-ID in its BOUND-SESSION-ID object. RFC 5974
0x02 Route Change: possible route change occurred on downstream path. RFC 5974
0x03 Reduced refreshes not supported; full QSPEC required. RFC 5974
0x04 Congestion situation: Possible congestion situation occurred on downstream path. RFC 5974
0x05 Unknown SESSION-ID in SESSION-ID-LIST RFC 5974
0x06 Mismatching RSN in RSN-LIST RFC 5974
0x07-0x7F Unassigned
0x80-0xBF Reserved for Experimental/Private Use RFC 5974
0xC0-0xFF Reserved RFC 5974

Success Error Codes

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Range Registration Procedures
0-63 IETF Review
64-127 Specification Required
Value Description Reference
0x00 Reserved RFC 5974
0x01 Reservation successful RFC 5974
0x02 Teardown successful RFC 5974
0x03 Acknowledgement RFC 5974
0x04 Refresh successful RFC 5974
0x05-0x7F Unassigned
0x80-0xBF Reserved for Experimental/Private Use RFC 5974
0xC0-0xFF Reserved RFC 5974

Protocol Error Codes

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Range Registration Procedures
0-63 IETF Review
64-127 Specification Required
Value Description Reference
0x00 Reserved RFC 5974
0x01 Illegal message type: the type given in the Message Type field of the common header is unknown. RFC 5974
0x02 Wrong message length: the length given for the message does not match the length of the message data. RFC 5974
0x03 Bad flags value: an undefined flag or combination of flags was set in the generic flags RFC 5974
0x04 Bad flags value: an undefined flag or combination of flags was set in the message-specific flags RFC 5974
0x05 Mandatory object missing: an object required in a message of this type was missing. RFC 5974
0x06 Illegal object present: an object was present that must not be used in a message of this type. RFC 5974
0x07 Unknown object present: an object of an unknown type was present in the message. RFC 5974
0x08 Wrong object length: the length given for the object did not match the length of the object data present. RFC 5974
0x09 RESERVE received from wrong direction. RFC 5974
0x0A Unknown object field value: a field in an object had an unknown value. RFC 5974
0x0B Duplicate object present. RFC 5974
0x0C Malformed QSPEC. RFC 5974
0x0D Unknown MRI. RFC 5974
0x0E Erroneous value in the TLV object's value field. RFC 5974
0x0F Incompatible QSPEC RFC 5974
0x10-0x7F Unassigned
0x80-0xBF Reserved for Experimental/Private Use RFC 5974
0xC0-0xFF Reserved RFC 5974

Transient Failure Codes

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Range Registration Procedures
0-63 IETF Review
64-127 Specification Required
Value Description Reference
0x00 Reserved RFC 5974
0x01 No GIST reverse-path forwarding state RFC 5974
0x02 No path state for RESERVE, when doing a receiver-oriented reservation RFC 5974
0x03 RII conflict RFC 5974
0x04 Full QSPEC required RFC 5974
0x05 Mismatch synchronization between end-to-end RESERVE and intra-domain RESERVE RFC 5974
0x06 Reservation preempted RFC 5974
0x07 Reservation failure RFC 5974
0x08 Path truncated - Next peer dead RFC 5974
0x09-0x7F Unassigned
0x80-0xBF Reserved for Experimental/Private Use RFC 5974
0xC0-0xFF Reserved RFC 5974

Permanent Failure Codes

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Range Registration Procedures
0-63 IETF Review
64-127 Specification Required
Value Description Reference
0x00 Reserved RFC 5974
0x01 Internal or system error RFC 5974
0x02 Authorization failure RFC 5974
0x03-0x7F Unassigned
0x80-0xBF Reserved for Experimental/Private Use RFC 5974
0xC0-0xFF Reserved RFC 5974

QoS Model Error Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)

Available Formats

Value Description Reference
0-63 Unassigned
64-67 Reserved for Private/Experimental Use RFC 5975
68-255 Reserved RFC 5975

QoS NSLP Error Source Identifiers

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5974: NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service Signaling

Available Formats

Value Description Reference
0x0 Reserved RFC 5974
0x1 IPv4 RFC 5974
0x2 IPv6 RFC 5974
0x3 FQDN in UTF-8 RFC 5974
0x4-0xD Unassigned
0xE-0xF Reserved for Experimental/Private Use RFC 5974

NATFW NSLP Message Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5973: NAT/Firewall NSIS Signaling Layer Protocol (NSLP)

Available Formats

Value Description Reference
0x0 Reserved RFC 5973
0x1 CREATE RFC 5973
0x2 EXTERNAL RFC 5973
0x3 RESPONSE RFC 5973
0x4 NOTIFY RFC 5973

NATFW NSLP Header Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5973: NAT/Firewall NSIS Signaling Layer Protocol (NSLP)

Available Formats

Value Bit Position Description Reference
P flag 8 Section 4.1 RFC 5973
E flag 9 Section 4.1 RFC 5973
Reserved 10-15 Section 4.1 RFC 5973

NATFW Response Codes

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5973: NAT/Firewall NSIS Signaling Layer Protocol (NSLP)

Available Formats

Response Code Value Description Reference
Informational 0x01 Route change: possible route change on the outbound path. RFC 5973
Informational 0x02 Re-authentication required. RFC 5973
Informational 0x03 NATFW node is going down soon. RFC 5973
Informational 0x04 NATFW signaling session lifetime expired. RFC 5973
Informational 0x05 NATFW signaling session terminated. RFC 5973
Success 0x01 All successfully processed. RFC 5973
Protocol error 0x01 Illegal message type: the type given in the Message Type field of the NSLP header is unknown. RFC 5973
Protocol error 0x02 Wrong message length: the length given for the message in the NSLP header does not match the length of the message data. RFC 5973
Protocol error 0x03 Bad flags value: an undefined flag or combination of flags was set in the NSLP header. RFC 5973
Protocol error 0x04 Mandatory object missing: an object required in a message of this type was missing. RFC 5973
Protocol error 0x05 Illegal object present: an object was present which must not be used in a message of this type. RFC 5973
Protocol error 0x06 Unknown object present: an object of an unknown type was present in the message. RFC 5973
Protocol error 0x07 Wrong object length: the length given for the object in the object header did not match the length of the object data present. RFC 5973
Protocol error 0x08 Unknown object field value: a field in an object had an unknown value. RFC 5973
Protocol error 0x09 Invalid Flag-Field combination: An object contains an invalid combination of flags and/or fields. RFC 5973
Protocol error 0x0A Duplicate object present. RFC 5973
Protocol error 0x0B Received EXTERNAL request message on external side. RFC 5973
Transient failure 0x01 Requested resources temporarily not available. RFC 5973
Permanent failure 0x01 Authentication failed. RFC 5973
Permanent failure 0x02 Authorization failed. RFC 5973
Permanent failure 0x04 Internal or system error. RFC 5973
Permanent failure 0x06 No edge-device here. RFC 5973
Permanent failure 0x07 DId not reach the NR. RFC 5973
Signaling session failure 0x01 Session terminated asynchronously. RFC 5973
Signaling session failure 0x02 Requested lifetime is too big. RFC 5973
Signaling session failure 0x03 No reservation found matching the MRI of the CREATE request. RFC 5973
Signaling session failure 0x04 Requested policy rule denied due to policy conflict. RFC 5973
Signaling session failure 0x05 Unknown policy rule action. RFC 5973
Signaling session failure 0x06 Requested rule action not applicable. RFC 5973
Signaling session failure 0x07 NATFW_DTINFO object is required. RFC 5973
Signaling session failure 0x08 Requested value in sub_ports field in NATFW_EFI not permitted. RFC 5973
Signaling session failure 0x09 Requested IP protocol not supported. RFC 5973
Signaling session failure 0x0A Plain IP policy rules not permitted -- need transport layer information. RFC 5973
Signaling session failure 0x0B ICMP type value not permitted. RFC 5973
Signaling session failure 0x0C Source IP address range is too large. RFC 5973
Signaling session failure 0x0D Destination IP address range is too large. RFC 5973
Signaling session failure 0x0E Source L4-port range is too large. RFC 5973
Signaling session failure 0x0F Destination L4-port range is too large. RFC 5973
Signaling session failure 0x10 Requested lifetime is too small. RFC 5973
Signaling session failure 0x11 Modified lifetime is too big. RFC 5973
Signaling session failure 0x12 Modified lifetime is too small. RFC 5973

SESSION_AUTH X-Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5981: Authorization for NSIS Signaling Layer Protocols

Available Formats

Value Description Reference
0 Reserved RFC 5981
1 AUTH_ENT_ID RFC 5981
2 SESSION_ID RFC 5981
3 SOURCE_ADDR RFC 5981
4 DEST_ADDR RFC 5981
5 START_TIME RFC 5981
6 END_TIME RFC 5981
7 NSLP_OBJECT_LIST RFC 5981
8 AUTHENTICATION_DATA RFC 5981
9-127 Unassigned
128-255 Reserved for Private or Experimental Use RFC 5981

AUTH_ENT_ID (X-Type 1) SubType values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5981: Authorization for NSIS Signaling Layer Protocols

Available Formats

Value Description Reference
0 Reserved RFC 5981
1 IPV4_ADDRESS RFC 5981
2 IPV6_ADDRESS RFC 5981
3 FQDN RFC 5981
4 ASCII_DN RFC 5981
5 UNICODE_DN RFC 5981
6 URI RFC 5981
7 KRB_PRINCIPAL RFC 5981
8 X509_V3_CERT RFC 5981
9 PGP_CERT RFC 5981
10 HMAC_SIGNED RFC 5981
11-127 Unassigned
128-255 Reserved for Private or Experimental Use RFC 5981

SOURCE_ADDR (X-Type 3) SubType values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5981: Authorization for NSIS Signaling Layer Protocols

Available Formats

Value Description Reference
0 Reserved RFC 5981
1 IPV4_ADDRESS RFC 5981
2 IPV6_ADDRESS RFC 5981
3 UDP_PORT_LIST RFC 5981
4 TCP_PORT_LIST RFC 5981
5 SPI RFC 5981
6-127 Unassigned
128-255 Reserved for Private or Experimental Use RFC 5981

DEST_ADDR (X-Type 4) SubType values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5981: Authorization for NSIS Signaling Layer Protocols

Available Formats

Value Description Reference
0 Reserved RFC 5981
1 IPV4_ADDRESS RFC 5981
2 IPV6_ADDRESS RFC 5981
3 UDP_PORT_LIST RFC 5981
4 TCP_PORT_LIST RFC 5981
5 SPI RFC 5981
6-127 Unassigned
128-255 Reserved for Private or Experimental Use RFC 5981

START_TIME (X-Type 5) SubType values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5981: Authorization for NSIS Signaling Layer Protocols

Available Formats

Value Description Reference
0 Reserved RFC 5981
1 NTP_TIMESTAMP RFC 5981
2-127 Unassigned
128-255 Reserved for Private or Experimental Use RFC 5981

END_TIME (X-Type 6) SubType values

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5981: Authorization for NSIS Signaling Layer Protocols

Available Formats

Value Description Reference
0 Reserved RFC 5981
1 NTP_TIMESTAMP RFC 5981
2-127 Unassigned
128-255 Reserved for Private or Experimental Use RFC 5981