Network Time Protocol (NTP) Parameters

Created

  • 2010-03-25

Last Updated

  • 2026-08-18

Available Formats


NTP Reference Identifier Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Kurt Kristof Teichel, Miroslav Lichvar, David Venhoek

Reference

  • RFC 5905: Network Time Protocol Version 4: Protocol and Algorithms Specification
  • RFC 9748: Updating the NTP Registries

Note

Codes beginning with the character "X" are reserved for experimentation and development. IANA cannot assign them.

Available Formats

ID Clock Source Reference
GOES Geosynchronous Orbit Environment Satellite RFC 5905
GPS Global Position System RFC 5905
GAL Galileo Positioning System RFC 5905
PPS Generic pulse-per-second RFC 5905
IRIG Inter-Range Instrumentation Group RFC 5905
WWVB LF Radio WWVB Ft. Collins, CO 60 kHz RFC 5905
DCF LF Radio DCF77 Mainflingen, DE 77.5 kHz RFC 5905
HBG LF Radio HBG Prangins, HB 75 kHz RFC 5905
MSF LF Radio MSF Anthorn, UK 60 kHz RFC 5905
JJY LF Radio JJY Fukushima, JP 40 kHz, Saga, JP 60 kHz RFC 5905
LORC MF Radio LORAN C station, 100 kHz RFC 5905
TDF MF Radio Allouis, FR 162 kHz RFC 5905
CHU HF Radio CHU Ottawa, Ontario RFC 5905
WWV HF Radio WWV Ft. Collins, CO RFC 5905
WWVH HF Radio WWVH Kauai, HI RFC 5905
NIST NIST telephone modem RFC 5905
ACTS NIST telephone modem RFC 5905
USNO USNO telephone modem RFC 5905
PTB European telephone modem RFC 5905
DFM UTC(DFM) DFM A/S; Jürgen Appel

NTP Kiss-o'-Death Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Kurt Kristof Teichel, Miroslav Lichvar, David Venhoek

Reference

  • RFC 5905: Network Time Protocol Version 4: Protocol and Algorithms Specification
  • RFC 9748: Updating the NTP Registries

Note

Codes beginning with the character "X" are reserved for experimentation and development. IANA cannot assign them.

Available Formats

ID Meaning Source Reference
ACST The association belongs to a unicast server RFC 5905
AUTH Server authentication failed RFC 5905
AUTO Autokey sequence failed RFC 5905
BCST The association belongs to a broadcast server RFC 5905
CRYP Cryptographic authentication or identification failed RFC 5905
DENY Access denied by remote server RFC 5905
DROP Lost peer in symmetric mode RFC 5905
RSTR Access denied due to local policy RFC 5905
INIT The association has not yet synchronized for the first time RFC 5905
MCST The association belongs to a dynamically discovered server RFC 5905
NKEY No key found. Either the key was never installed or is not trusted RFC 5905
NTSN Network Time Security (NTS) negative-acknowledgment (NAK) RFC 8915, Section 5.7
RATE Rate exceeded. The server has temporarily denied access because the client exceeded the rate threshold RFC 5905
RMOT Alteration of association from a remote host running ntpdc. RFC 5905
STEP A step change in system time has occurred, but the association has not yet resynchronized RFC 5905

NTP Extension Field Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Kurt Kristof Teichel, Miroslav Lichvar, David Venhoek

Reference

  • RFC 5905: Network Time Protocol Version 4: Protocol and Algorithms Specification
  • RFC 5906: Network Time Protocol Version 4: Autokey Specification
  • RFC 9748: Updating the NTP Registries

Note

Field Types in the range 0xF000 through 0xFFFF, inclusive, are reserved for experimentation and development. IANA cannot assign them. Both NTS Cookie and Autokey Message Request have the same Field Type; in practice this is not a problem as the field semantics will be determined by other parts of the message.

Note

The "Reserved for historic reasons" is for differences between the original documentation and implementation of Autokey and marks the erroneous values as reserved, in case there is an implementation that used the registered values instead of what the original implementation used.

Available Formats

Field Type Meaning Reference
0x0000 Crypto-NAK; authentication failure RFC 5905
0x0002 Reserved for historic reasons RFC 9748
0x0102 Reserved for historic reasons RFC 9748
0x0104 Unique Identifier RFC 8915, Section 5.3
0x010A Network Correction RFC 10030
0x0200 No-Operation Request RFC 5906
0x0201 Association Message Request RFC 5906
0x0202 Certificate Message Request RFC 5906
0x0203 Cookie Message Request RFC 5906
0x0204 Autokey Message Request RFC 5906
0x0204 NTS Cookie RFC 8915, Section 5.4
0x0205 Leapseconds Message Request RFC 5906
0x0206 Sign Message Request RFC 5906
0x0207 IFF Identity Message Request RFC 5906
0x0208 GQ Identity Message Request RFC 5906
0x0209 MV Identity Message Request RFC 5906
0x0302 Reserved for historic reasons RFC 9748
0x0304 NTS Cookie Placeholder RFC 8915, Section 5.5
0x0402 Reserved for historic reasons RFC 9748
0x0404 NTS Authenticator and Encrypted Extension Fields RFC 8915, Section 5.6
0x0502 Reserved for historic reasons RFC 9748
0x0602 Reserved for historic reasons RFC 9748
0x0702 Reserved for historic reasons RFC 9748
0x0802 Reserved for historic reasons RFC 9748
0x0902 Reserved for historic reasons RFC 9748
0x2005 UDP Checksum Complement RFC 7821
0x8002 Reserved for historic reasons RFC 9748
0x8102 Reserved for historic reasons RFC 9748
0x8200 No-Operation Response RFC 5906
0x8201 Association Message Response RFC 5906
0x8202 Certificate Message Response RFC 5906
0x8203 Cookie Message Response RFC 5906
0x8204 Autokey Message Response RFC 5906
0x8205 Leapseconds Message Response RFC 5906
0x8206 Sign Message Response RFC 5906
0x8207 IFF Identity Message Response RFC 5906
0x8208 GQ Identity Message Response RFC 5906
0x8209 MV Identity Message Response RFC 5906
0x8302 Reserved for historic reasons RFC 9748
0x8402 Reserved for historic reasons RFC 9748
0x8502 Reserved for historic reasons RFC 9748
0x8602 Reserved for historic reasons RFC 9748
0x8702 Reserved for historic reasons RFC 9748
0x8802 Reserved for historic reasons RFC 9748
0x8902 Reserved for historic reasons RFC 9748
0xC002 Reserved for historic reasons RFC 9748
0xC102 Reserved for historic reasons RFC 9748
0xC200 No-Operation Error Response RFC 5906
0xC201 Association Message Error Response RFC 5906
0xC202 Certificate Message Error Response RFC 5906
0xC203 Cookie Message Error Response RFC 5906
0xC204 Autokey Message Error Response RFC 5906
0xC205 Leapseconds Message Error Response RFC 5906
0xC206 Sign Message Error Response RFC 5906
0xC207 IFF Identity Message Error Response RFC 5906
0xC208 GQ Identity Message Error Response RFC 5906
0xC209 MV Identity Message Error Response RFC 5906
0xC302 Reserved for historic reasons RFC 9748
0xC402 Reserved for historic reasons RFC 9748
0xC502 Reserved for historic reasons RFC 9748
0xC602 Reserved for historic reasons RFC 9748
0xC702 Reserved for historic reasons RFC 9748
0xC802 Reserved for historic reasons RFC 9748
0xC902 Reserved for historic reasons RFC 9748
0xF000-0xFFFF Reserved for Private or Experimental Use RFC 9748

Contact Information

Name Organization Contact URI Last Updated
DFM A/S https://dfm.dk 2023-05-03
Jürgen Appel DFM A/S jap&dfm.dk 2023-05-03