Open Shortest Path First (OSPF) Link Local Signalling (LLS) - Type/Length/Value Identifiers (TLV)

Created

  • 2007-01-31

Last Updated

  • 2026-05-19

Available Formats


Link Local Signalling TLV Identifiers (LLS Types)

Registration Procedure(s)

  • IETF Review

Reference

Available Formats

LLS Type Name Reference
0 Reserved RFC 5613
1 Extended Options and Flags RFC 5613
2 Cryptographic Authentication RFC 5613
3 Flooding-MPR RFC 5449
4 Metric-MPR RFC 5449
5 Path-MPR RFC 5449
6 State Check Sequence TLV RFC 5820
7 Neighbor Drop TLV RFC 5820
8 Request From TLV RFC 5820
9 Full State For TLV RFC 5820
10 Active Overlapping Relay TLV RFC 5820
11 Willingness TLV RFC 5820
12-13 Unassigned
14 MDR-Hello RFC 5614
15 MDR-DD RFC 5614
16 MDR-Metric RFC 5614
17 IPv6 MTU TLV RFC 5838
18 Local Interface ID TLV RFC 8510
19 Reverse Metric TLV RFC 9339
20 Reverse TE Metric TLV RFC 9339
21 Local Interface IPv4 Address TLV RFC 9355
22-32767 Unassigned
32768-65535 Reserved for Private Use RFC 5613

LLS Type 1 Extended Options and Flags

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Gunter Van De Velde, Peter Psenak

Reference

Available Formats

Extended Options Bit Name Reference
0x00000001 LSDB Resynchronization (LR) RFC 4811
0x00000002 Restart Signal (RS-bit) RFC 4812
0x00000004 I-bit RFC 5820
0x00000008 F-bit RFC 5820
0x00000010 B-bit RFC 9355
0x00000020 Flooding Request bit RFC 9667