Open Shortest Path First (OSPF) Parameters
OSPF Router Information (RI) TLVs
- RFC 7770: Extensions to OSPF for Advertising Optional Router Capabilities
| Range |
Registration Procedures |
Note |
| 1-32767 |
IETF Review |
|
| 32768-32777 |
Experimentation |
IANA does not assign |
| 32778-65535 |
Reserved |
IANA does not assign |
OSPF Router Functional Capability Bits
- RFC 7770: Extensions to OSPF for Advertising Optional Router Capabilities
When this registry is modified, the YANG module
iana-ospf-functional-cap-bits must be updated as defined
in RFC 10041.
| Bit Number |
Capability Name |
Reference |
| 0 |
Unreachable Link |
RFC 10041 |
| 1-31 |
Unassigned |
|
OSPF Tunnel Parameter Sub-TLVs
- RFC 9013: OSPF Advertisement of Tunnel Encapsulations
| Range |
Registration Procedures |
| 1-34999 |
Standards Action |
| 35000-65499 |
First Come First Served |
OSPF Flex-Algorithm Prefix Metric Bits
OSPF Flexible Algorithm Definition TLV Sub-TLVs
- IETF Review or IESG Approval
| Type |
Description |
Reference |
| 0 |
Reserved |
RFC 9350 |
| 1 |
Flexible Algorithm Exclude Admin Group |
RFC 9350, Section 7.1 |
| 2 |
Flexible Algorithm Include-Any Admin Group |
RFC 9350, Section 7.2 |
| 3 |
Flexible Algorithm Include-All Admin Group |
RFC 9350, Section 7.3 |
| 4 |
Flexible Algorithm Definition Flags |
RFC 9350, Section 7.4 |
| 5 |
Flexible Algorithm Exclude SRLG |
RFC 9350, Section 7.5 |
| 6 |
OSPF Exclude Minimum Bandwidth |
RFC 9843, Section 3.2.1 |
| 7 |
OSPF Exclude Maximum Delay |
RFC 9843, Section 3.2.2 |
| 8 |
OSPF Reference Bandwidth |
RFC 9843, Section 4.1.4.1 |
| 9 |
OSPF Bandwidth Threshold |
RFC 9843, Section 4.1.4.2 |
| 10 |
Flexible Algorithm Exclude Reverse Admin Group |
RFC 9917, Section 8 |
| 11 |
Flexible Algorithm Include-Any Reverse Admin Group |
RFC 9917, Section 9 |
| 12 |
Flexible Algorithm Include-All Reverse Admin Group |
RFC 9917, Section 10 |
| 13-32767 |
Unassigned |
|
| 32768-33023 |
Reserved for Experimental Use |
RFC 9350 |
| 33024-65535 |
Reserved |
RFC 9350 |
OSPF Dynamic Flooding LSA TLVs
- IETF Review or IESG Approval
- RFC 9667: Dynamic Flooding on Dense Graphs
| Type |
Description |
Reference |
| 0 |
Reserved |
RFC 9667 |
| 1 |
OSPF Area Router IDs |
RFC 9667 |
| 2 |
OSPF Flooding Path |
RFC 9667 |
| 3-32767 |
Unassigned |
|
| 32768-33023 |
Reserved for Experimental Use |
RFC 9667 |
| 33024-65535 |
Reserved |
RFC 9667 |
OSPF Link Attributes Sub-TLV Bit Values
- IETF Review or IESG Approval
- RFC 9667: Dynamic Flooding on Dense Graphs
The "L2BM" column indicates applicability to the L2 Bundle Member
Attributes sub-TLV. The options for the "L2BM" column are:
Y - This bit MAY appear in the L2 Bundle Member Attributes sub-TLV.
N - This bit MUST NOT appear in the L2 Bundle Member Attributes sub-TLV.
| Bit Number |
Description |
L2 Bundle Member Attributes (L2BM) |
Reference |
| 0 |
Local Edge Enabled for Flooding (LEEF) |
N |
RFC 9667 |