Open Shortest Path First (OSPF) Traffic Engineering TLVs

Created

  • 2003-08-29

Last Updated

  • 2025-09-16

Available Formats


Top Level Types in TE LSAs

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3630: Traffic Engineering (TE) Extensions to OSPF Version 2

Available Formats

Value Top Level Types Reference
0 Reserved RFC 3630
1 Router Address RFC 3630
2 Link RFC 3630
3 Router IPv6 Address RFC 5329
4 Link Local RFC 4203
5 Node Attribute RFC 5786
6 Optical Node Property RFC 7688
7-32767 Unassigned
32768-32777 Reserved for Experimental Use RFC 3630
32778-65535 Reserved RFC 3630

Types for sub-TLVs of Router Address TLV (Value 1)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6827: Automatically Switched Optical Network (ASON) Routing for OSPFv2 Protocols

Available Formats

Value Sub-TLV Reference
0 Reserved RFC 6827
1-11 Unassigned
12 Inter-RA Export Upward sub-TLV RFC 6827
13 Inter-RA Export Downward sub-TLV RFC 6827
14-32767 Unassigned
32768-32777 Reserved for Experimental Use RFC 6827
32778-65535 Reserved RFC 6827

Types for sub-TLVs of TE Link TLV (Value 2)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3630: Traffic Engineering (TE) Extensions to OSPF Version 2

Available Formats

Value Sub-TLV Reference
0 Reserved RFC 3630
1 Link type (1 octet) RFC 3630
2 Link ID (4 octets) RFC 3630
3 Local interface IP address (4 octets) RFC 3630
4 Remote interface IP address (4 octets) RFC 3630
5 Traffic engineering metric (4 octets) RFC 3630
6 Maximum bandwidth (4 octets) RFC 3630
7 Maximum reservable bandwidth (4 octets) RFC 3630
8 Unreserved bandwidth (32 octets) RFC 3630
9 Administrative group (4 octets) RFC 3630
10 Local and Remote TE Router ID sub-TLV RFC 6827
11 Link Local/Remote Identifiers (8 octets) RFC 4203
12 Inter-RA Export Upward sub-TLV RFC 6827
13 Inter-RA Export Downward sub-TLV RFC 6827
14 Link Protection Type (4 octets) RFC 4203
15 Interface Switching Capability Descriptor (variable) RFC 4203
16 Shared Risk Link Group (variable) RFC 4203
17 Bandwidth Constraints RFC 4124
18 Neighbor ID RFC 5329
19 Local Interface IPv6 Address RFC 5329
20 Remote Interface IPv6 Address RFC 5329
21 Remote AS Number sub-TLV RFC 5392
22 IPv4 Remote ASBR ID sub-TLV RFC 5392
23 Unconstrained TE LSP Count (sub-)TLV RFC 5330
24 IPv6 Remote ASBR ID sub-TLV RFC 5392
25 Interface Adjustment Capability Descriptor (IACD) RFC 6001
26 Extended Administrative Group RFC 7308
27 Unidirectional Link Delay RFC 7471
28 Min/Max Unidirectional Link Delay RFC 7471
29 Unidirectional Delay Variation RFC 7471
30 Unidirectional Link Loss RFC 7471
31 Unidirectional Residual Bandwidth RFC 7471
32 Unidirectional Available Bandwidth RFC 7471
33 Unidirectional Utilized Bandwidth RFC 7471
34 Port Label Restrictions RFC 7580
35 Network-to-Router TE Metric Sub-TLV RFC 8042
36 Generic Metric RFC 9843, Section 2.2
37-32767 Unassigned
32768-32777 Reserved for Experimental Use RFC 3630
32778-65535 Reserved RFC 3630

Types for sub-TLVs of TE Node Attribute TLV (Value 5)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 5786: Advertising a Router's Local Addresses in OSPF Traffic Engineering (TE) Extensions

Available Formats

Value Sub-TLV Reference
0 Reserved RFC 5786
1 Node IPv4 Local Address RFC 5786
2 Node IPv6 Local Address RFC 5786
3-4 Unassigned
5 Local TE Router ID sub-TLV RFC 6827
6-11 Unassigned
12 Inter-RA Export Upward sub-TLV RFC 6827
13 Inter-RA Export Downward sub-TLV RFC 6827
14 Connectivity Matrix RFC 7580
15-32767 Unassigned
32768-32777 Reserved for Experimental Use RFC 5786
32778-65535 Reserved RFC 5786

Types for sub-TLVs of Optical Node Property (Value 6)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7688: GMPLS OSPF Enhancement for Signal and Network Element Compatibility for Wavelength Switched Optical Networks

Available Formats

Value Length Sub-TLV Reference
0 Reserved RFC 7688
1 variable Resource Block Information RFC 7688
2 variable Resource Accessibility RFC 7688
3 variable Resource Wavelength Constraints RFC 7688
4 variable Resource Block Pool State RFC 7688
5 variable Resource Block Shared Access Wavelength Availability RFC 7688
6-65535 Unassigned

Types for sub-TLVs of OTN-TDM SCSI (Switching Capability Specific Information)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7138: Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport Networks

Available Formats

Value Sub-TLV Reference
0 Reserved RFC 7138
1 Unreserved Bandwidth for fixed containers RFC 7138
2 Unreserved/MAX Bandwidth for flexible containers RFC 7138
3-65535 Unassigned

Types for sub-TLVs of WSON-LSC SCSI (Switching Capability Specific Information)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7688: GMPLS OSPF Enhancement for Signal and Network Element Compatibility for Wavelength Switched Optical Networks

Available Formats

Value Sub-TLV Reference
0 Reserved RFC 7688
1 Available Labels RFC 7688
2 Shared Backup Labels RFC 7688
3-65535 Unassigned