Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters

Created

  • 2009-11-13

Last Updated

  • 2023-06-29

Available Formats


PA-TNC Attribute Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt

Reference

  • RFC 5792: PA-TNC: A Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC)

Available Formats

PEN Integer Name Reference
0 0 Testing RFC 5792
0 1 Attribute Request RFC 5792
0 2 Product Information RFC 5792
0 3 Numeric Version RFC 5792
0 4 String Version RFC 5792
0 5 Operational Status RFC 5792
0 6 Port Filter RFC 5792
0 7 Installed Packages RFC 5792
0 8 PA-TNC Error RFC 5792
0 9 Assessment Result RFC 5792
0 10 Remediation Instructions RFC 5792
0 11 Forwarding Enabled RFC 5792
0 12 Factory Default Password RFC 5792
0 13 SWIMA Request RFC 8412
0 14 Software Identifier Inventory RFC 8412
0 15 Software Identifier Events RFC 8412
0 16 Software Inventory RFC 8412
0 17 Software Events RFC 8412
0 18 Subscription Status Request RFC 8412
0 19 Subscription Status Response RFC 8412
0 20 Source Metadata Request RFC 8412
0 21 Source Metadata Response RFC 8412
0 0xffffffff Reserved RFC 5792

PA-TNC Error Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt

Reference

  • RFC 5792: PA-TNC: A Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC)

Available Formats

PEN Integer Name Reference
0 0 Reserved RFC 5792
0 1 Invalid Parameter RFC 5792
0 2 Version Not Supported RFC 5792
0 3 Attribute Type Not Supported RFC 5792
0 4 SWIMA_ERROR RFC 8412
0 5 SWIMA_SUBSCRIPTION_DENIED_ERROR RFC 8412
0 6 SWIMA_RESPONSE_TOO_LARGE_ERROR RFC 8412
0 7 SWIMA_SUBSCRIPTION_FULFILLMENT_ERROR RFC 8412
0 8 SWIMA_SUBSCRIPTION_ID_REUSE_ERROR RFC 8412

PA-TNC Remediation Parameters Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt

Reference

  • RFC 5792: PA-TNC: A Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC)

Available Formats

PEN Integer Name Reference
0 0 Reserved RFC 5792
0 1 URI RFC 5792
0 2 Remediation String RFC 5792

Software Data Model Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • David Waltermire, Jessica Fitzgerald-McKay

Reference

  • RFC 8412: Software Inventory Message and Attributes (SWIMA) for PA-TNC

Available Formats

PEN Integer Name Reference
0 0 ISO 2015 SWID tags using XML RFC 8412
0 1 ISO 2009 SWID tags using XML RFC 8412
0 2 Concise Software Identifier (CoSWID) RFC 9393
0 3-191 Unassigned
0 192-255 Reserved for local enterprise use RFC 8412