Protocol for Carrying Authentication for Network Access (PANA) Parameters
Created
- 2007-10-08
Last Updated
- 2012-11-15
Available Formats
Message Types
Reference
- RFC 5191: Protocol for Carrying Authentication for Network Access (PANA)
- RFC 5872: IANA Rules for the Protocol for Carrying Authentication for Network Access (PANA)
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 1-65519 | IETF Review or IESG Approval | |
| 65520-65535 | IANA does not assign | Outlined in RFC 3692 |
| Value | R flag | Abbrev | Name | Reference |
|---|---|---|---|---|
| 0 | Reserved | RFC 5191 | ||
| 1 | 0 | PCI | PANA-Client-Initiation | RFC 5191 |
| 2 | 1 | PAR | PANA-Auth-Request | RFC 5191 |
| 2 | 0 | PAN | PANA-Auth-Answer | RFC 5191 |
| 3 | 1 | PTR | PANA-Termination-Request | RFC 5191 |
| 3 | 0 | PTA | PANA-Termination-Answer | RFC 5191 |
| 4 | 1 | PNR | PANA-Notification-Request | RFC 5191 |
| 4 | 0 | PNA | PANA-Notification-Answer | RFC 5191 |
| 5 | 0 | PRY | PANA-Relay | RFC 6345 |
| 6-65519 | Unassigned | RFC 5191 | ||
| 65520-65535 | Reserved (Experimental) | RFC 5191 |
Message Flags
Registration Procedure(s)
- Standards Action or IESG Approval
Reference
- RFC 5191: Protocol for Carrying Authentication for Network Access (PANA)
- RFC 5872: IANA Rules for the Protocol for Carrying Authentication for Network Access (PANA)
Available Formats
AVP Codes
Registration Procedure(s)
- Expert Review with Specification Required, or Standards Action
Expert(s)
- Alper Yegin
Reference
- RFC 5191: Protocol for Carrying Authentication for Network Access (PANA)
- RFC 6786: Encrypting the Protocol for Carrying Authentication for Network Access (PANA) Attribute-Value Pairs
Available Formats
| Code | Attribute Name | Enc | Reference |
|---|---|---|---|
| 0 | Reserved | RFC 5191 | |
| 1 | AUTH | N | RFC 5191; RFC 6786 |
| 2 | EAP-Payload | X | RFC 5191; RFC 6786 |
| 3 | Integrity-Algorithm | N | RFC 5191; RFC 6786 |
| 4 | Key-Id | N | RFC 5191; RFC 6786 |
| 5 | Nonce | N | RFC 5191; RFC 6786 |
| 6 | PRF-Algorithm | N | RFC 5191; RFC 6786 |
| 7 | Result-Code | N | RFC 5191; RFC 6786 |
| 8 | Session-Lifetime | X | RFC 5191; RFC 6786 |
| 9 | Termination-Cause | X | RFC 5191; RFC 6786 |
| 10 | PaC-Information | N | RFC 6345; RFC 6786 |
| 11 | Relayed-Message | N | RFC 6345; RFC 6786 |
| 12 | Encryption-Encap | N | RFC 6786 |
| 13 | Encryption-Algorithm | N | RFC 6786 |
| 14-65535 | Unassigned |
Result-Code (AVP Code 7) AVP Values
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 5191: Protocol for Carrying Authentication for Network Access (PANA)
- RFC 5872: IANA Rules for the Protocol for Carrying Authentication for Network Access (PANA)
Available Formats
Termination-Cause (AVP Code 9) AVP Values
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 5191: Protocol for Carrying Authentication for Network Access (PANA)
- RFC 5872: IANA Rules for the Protocol for Carrying Authentication for Network Access (PANA)
Available Formats
Encryption-Algorithm (AVP Code 13) AVP Values
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 6786: Encrypting the Protocol for Carrying Authentication for Network Access (PANA) Attribute-Value Pairs
Available Formats
| Value | Meaning | Reference |
|---|---|---|
| 0 | Unassigned | |
| 1 | AES128_CTR | RFC 6786 |
| 2-4294967295 | Unassigned |