pNFS Layout Types
Registration Procedure(s)
- Standards Action with Expert Review
Expert(s)
- Unassigned
Reference
- RFC 8881: Network File System (NFS) Version 4 Minor Version 1 Protocol
Available Formats
| Layout Type Name | Value | RFC | How | Minor Versions |
|---|---|---|---|---|
| Reserved | 0x00000000 | RFC 8881 | ||
| LAYOUT4_NFSV4_1_FILES | 0x00000001 | RFC 8881 | N | 1 |
| LAYOUT4_OSD2_OBJECTS | 0x00000002 | RFC 5664 | L | 1 |
| LAYOUT4_BLOCK_VOLUME | 0x00000003 | RFC 5663 | L | 1 |
| LAYOUT4_FLEX_FILES | 0x00000004 | RFC 8435 | L | 1 |
| LAYOUT4_SCSI | 0x00000005 | RFC 8154 | L | 1 |
| Unassigned | 0x00000006-0x7FFFFFFF | |||
| Reserved | 0x80000000-0xFFFFFFFF | RFC 8881 |