Point-to-Point Over Ethernet (PPPoE) Parameters
Created
- 2007-03-26
Last Updated
- 2010-02-04
Available Formats
PPPoE TAG Values (16-bit values)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 4937: IANA Considerations for PPP over Ethernet (PPPoE)
Available Formats
| Value | Name | Description | Reference |
|---|---|---|---|
| 0 (0x0000) | End-Of-List | See the reference | RFC 2516 |
| 1-256 | Unassigned | ||
| 257 (0x0101) | Service-Name | See the reference | RFC 2516 |
| 258 (0x0102) | AC-Name | See the reference | RFC 2516 |
| 259 (0x0103) | Host-Uniq | See the reference | RFC 2516 |
| 260 (0x0104) | AC-Cookie | See the reference | RFC 2516 |
| 261 (0x0105) | Vendor-Specific | See the reference | RFC 2516 |
| 262 (0x0106) | Credits | See the reference | RFC 5578 |
| 263 (0x0107) | Metrics | See the reference | RFC 5578 |
| 264 (0x0108) | Sequence Number | See the reference | RFC 5578 |
| 265 (0x0109) | Credit Scale Factor | See the reference | RFC 5578 |
| 266-271 | Unassigned | ||
| 272 (0x0110) | Relay-Session-Id | See the reference | RFC 2516 |
| 273 (0x0111) | HURL | See the reference | Carrel D., Simone D., Ho C., Stoner T., "Extensions to a Method for Transmitting PPP Over Ethernet (PPPoE)", work in progress. |
| 274 (0x0112) | MOTM | See the reference | Carrel D., Simone D., Ho C., Stoner T., "Extensions to a Method for Transmitting PPP Over Ethernet (PPPoE)", work in progress. |
| 275-287 | Unassigned | ||
| 288 (0x0120) | PPP-Max-Payload | See the reference | RFC 4638 |
| 289 (0x0121) | IP_Route_Add | See the reference | Carrel D., Simone D., Ho C., Stoner T., "Extensions to a Method for Transmitting PPP Over Ethernet (PPPoE)", work in progress. |
| 290-512 | Unassigned | ||
| 513 (0x0201) | Service-Name-Error | See the reference | RFC 2516 |
| 514 (0x0202) | AC-System-Error | See the reference | RFC 2516 |
| 515 (0x0203) | Generic-Error | See the reference | RFC 2516 |
| 516-65535 | Unassigned |
PPPoE Active Discovery Code fields (8-bit values)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 4937: IANA Considerations for PPP over Ethernet (PPPoE)
Available Formats
| Code | Name | Description | Reference |
|---|---|---|---|
| 0 (0x00) | PPP Session Stage | See the reference | RFC 2516 |
| 1-6 | Unassigned | ||
| 7 (0x07) | PADO, Offer | See the reference | RFC 2516 |
| 8 | Unassigned | ||
| 9 (0x09) | PADI, Initiation | See the reference | RFC 2516 |
| 10 (0x0a) | PADG, Session-Grant | See the reference | RFC 5578 |
| 11 (0x0b) | PADC, Session-Credit Response | See the reference | RFC 5578 |
| 12 (0x0c) | PADQ, Quality | See the reference | RFC 5578 |
| 13-24 | Unassigned | ||
| 25 (0x19) | PADR, Request | See the reference | RFC 2516 |
| 26-100 | Unassigned | ||
| 101 (0x65) | PADS, Session-confirmation | See the reference | RFC 2516 |
| 102-166 | Unassigned | ||
| 167 (0xa7) | PADT, Terminate | See the reference | RFC 2516 |
| 168-210 | Unassigned | ||
| 211 (0xd3) | PADM, Message | See the reference | Carrel D., Simone D., Ho C., Stoner T., "Extensions to a Method for Transmitting PPP Over Ethernet (PPPoE)", work in progress. |
| 212 (0xd4) | PADN, Network | See the reference | Carrel D., Simone D., Ho C., Stoner T., "Extensions to a Method for Transmitting PPP Over Ethernet (PPPoE)", work in progress. |
| 213-255 | Unassigned |