Privacy Pass

Created

  • 2023-11-17

Last Updated

  • 2024-07-12

Available Formats


Privacy Pass Token Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Tommy Pauly, Chris Wood

Reference

  • RFC 9577: The Privacy Pass HTTP Authentication Scheme

Available Formats

Value Name Token Structure Token Key Encoding TokenChallenge Structure Publicly Verifiable Public Metadata Private Metadata Nk Nid Change Controller Reference Notes
0x0000 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x0001 VOPRF(P-384, SHA-384) As defined in Section 2.2 of RFC 9577. Serialized using SerializeElement (Section 2.1 of RFC 9497). As defined in Section 2.1 of RFC 9577. N N N 48 32 IETF RFC 9578, Section 5
0x0002 Blind RSA (2048-bit) As defined in Section 2.2 of RFC 9577. Serialized as a DER-encoded SubjectPublicKeyInfo (SPKI) object using the RSASSA-PSS OID RFC 5756. As defined in Section 2.1 of RFC 9577. Y N N 256 32 IETF RFC 9578, Section 6 The RSABSSA-SHA384-PSS-Deterministic and RSABSSA-SHA384-PSSZERO-Deterministic variants are supported.
0x0003-0x02A9 Unassigned
0x02AA RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x02AB-0x1131 Unassigned
0x1132 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x1133-0x2E95 Unassigned
0x2E96 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x2E97-0x3CD2 Unassigned
0x3CD3 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x3CD4-0x4472 Unassigned
0x4473 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x4474-0x5A62 Unassigned
0x5A63 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x5A64-0x6D31 Unassigned
0x6D32 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x6D33-0x7F3E Unassigned
0x7F3F RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x7F40-0x8D06 Unassigned
0x8D07 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x8D08-0x916A Unassigned
0x916B RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0x916C-0xA6A3 Unassigned
0xA6A4 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0xA6A5-0xBEAA Unassigned
0xBEAB RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0xBEAC-0xC3F2 Unassigned
0xC3F3 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0xC3F4-0xDA41 Unassigned
0xDA42 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0xDA43-0xE943 Unassigned
0xE944 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0xE945-0xF056 Unassigned
0xF057 RESERVED Random bytes Random bytes Random bytes N/A N/A N/A N/A N/A IETF RFC 9577
0xF058-0xFFFF Unassigned