Assigned Internet Protocol Numbers
Registration Procedure(s)
- IESG Approval or Standards Action
Reference
- RFC 5237: IANA Allocation Guidelines for the Protocol Field
- RFC 7045: Transmission and Processing of IPv6 Extension Headers
Note
In the Internet Protocol version 4 (IPv4) RFC 791 there is a field called "Protocol" to identify the next level protocol. This is an 8 bit field. In Internet Protocol version 6 (IPv6) RFC 8200, this field is called the "Next Header" field.
Note
Values that are also IPv6 Extension Header Types should be listed in the IPv6 Extension Header Types registry at Internet Protocol Version 6 (IPv6) Parameters.
Available Formats
| Decimal | Keyword | Protocol | IPv6 Extension Header | Reference |
|---|---|---|---|---|
| 0 | HOPOPT | IPv6 Hop-by-Hop Option | Y | RFC 8200 |
| 1 | ICMP | Internet Control Message | RFC 792 | |
| 2 | IGMP | Internet Group Management | RFC 1112 | |
| 3 | GGP | Gateway-to-Gateway | RFC 823 | |
| 4 | IPv4 | IPv4 encapsulation | RFC 2003 | |
| 5 | ST | Stream | RFC 1190; RFC 1819 | |
| 6 | TCP | Transmission Control | RFC 9293 | |
| 7 | CBT | CBT | Tony Ballardie | |
| 8 | EGP | Exterior Gateway Protocol | RFC 888; David Mills | |
| 9 | IGP | any private interior gateway (used by Cisco for their IGRP) | Internet Assigned Numbers Authority | |
| 10 | BBN-RCC-MON | BBN RCC Monitoring | Steve Chipman | |
| 11 | NVP-II | Network Voice Protocol | RFC 741; Steve Casner | |
| 12 | PUP | PUP | Boggs, D., J. Shoch, E. Taft, and R. Metcalfe, "PUP: An Internetwork Architecture", XEROX Palo Alto Research Center, CSL-79-10, July 1979; also in IEEE Transactions on Communication, Volume COM-28, Number 4, April 1980.; [XEROX] | |
| 13 | ARGUS (deprecated) | ARGUS | Robert W. Scheifler | |
| 14 | EMCON | EMCON | Bich Nguyen | |
| 15 | XNET | Cross Net Debugger | Haverty, J., "XNET Formats for Internet Protocol Version 4", IEN 158, October 1980.; Jack Haverty | |
| 16 | CHAOS | Chaos | J. Noel Chiappa | |
| 17 | UDP | User Datagram | RFC 768; Jon Postel | |
| 18 | MUX | Multiplexing | Cohen, D. and J. Postel, "Multiplexing Protocol", IEN 90, USC/Information Sciences Institute, May 1979.; Jon Postel | |
| 19 | DCN-MEAS | DCN Measurement Subsystems | David Mills | |
| 20 | HMP | Host Monitoring | RFC 869; Bob Hinden | |
| 21 | PRM | Packet Radio Measurement | Zaw-Sing Su | |
| 22 | XNS-IDP | XEROX NS IDP | "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", AA-K759B-TK, Digital Equipment Corporation, Maynard, MA. Also as: "The Ethernet - A Local Area Network", Version 1.0, Digital Equipment Corporation, Intel Corporation, Xerox Corporation, September 1980. And: "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specifications", Digital, Intel and Xerox, November 1982. And: XEROX, "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", X3T51/80-50, Xerox Corporation, Stamford, CT., October 1980.; [XEROX] | |
| 23 | TRUNK-1 | Trunk-1 | Barry Boehm | |
| 24 | TRUNK-2 | Trunk-2 | Barry Boehm | |
| 25 | LEAF-1 | Leaf-1 | Barry Boehm | |
| 26 | LEAF-2 | Leaf-2 | Barry Boehm | |
| 27 | RDP | Reliable Data Protocol | RFC 908; Bob Hinden | |
| 28 | IRTP | Internet Reliable Transaction | RFC 938; Trudy Miller | |
| 29 | ISO-TP4 | ISO Transport Protocol Class 4 | RFC 905; Robert Cole | |
| 30 | NETBLT | Bulk Data Transfer Protocol | RFC 969; David Clark | |
| 31 | MFE-NSP | MFE Network Services Protocol | Shuttleworth, B., "A Documentary of MFENet, a National Computer Network", UCRL-52317, Lawrence Livermore Labs, Livermore, California, June 1977.; Barry Howard | |
| 32 | MERIT-INP | MERIT Internodal Protocol | Hans-Werner Braun | |
| 33 | DCCP | Datagram Congestion Control Protocol | RFC 4340 | |
| 34 | 3PC | Third Party Connect Protocol | Stuart A. Friedberg | |
| 35 | IDPR | Inter-Domain Policy Routing Protocol | Martha Steenstrup | |
| 36 | XTP | XTP | Greg Chesson | |
| 37 | DDP | Datagram Delivery Protocol | Wesley Craig | |
| 38 | IDPR-CMTP | IDPR Control Message Transport Proto | Martha Steenstrup | |
| 39 | TP++ | TP++ Transport Protocol | Dirk Fromhein | |
| 40 | IL | IL Transport Protocol | Dave Presotto | |
| 41 | IPv6 | IPv6 encapsulation | RFC 2473 | |
| 42 | SDRP | Source Demand Routing Protocol | Deborah Estrin | |
| 43 | IPv6-Route | Routing Header for IPv6 | Y | Steve Deering |
| 44 | IPv6-Frag | Fragment Header for IPv6 | Y | Steve Deering |
| 45 | IDRP | Inter-Domain Routing Protocol | Sue Hares | |
| 46 | RSVP | Reservation Protocol | RFC 2205; RFC 3209; Bob Braden | |
| 47 | GRE | Generic Routing Encapsulation | RFC 2784; Tony Li | |
| 48 | DSR | Dynamic Source Routing Protocol | RFC 4728 | |
| 49 | BNA | BNA | Gary Salamon | |
| 50 | ESP | Encap Security Payload | Y | RFC 4303 |
| 51 | AH | Authentication Header | Y | RFC 4302 |
| 52 | I-NLSP | Integrated Net Layer Security TUBA | K. Robert Glenn | |
| 53 | SWIPE (deprecated) | IP with Encryption | John Ioannidis | |
| 54 | NARP | NBMA Address Resolution Protocol | RFC 1735 | |
| 55 | Min-IPv4 | Minimal IPv4 Encapsulation | RFC 2004; Charlie Perkins | |
| 56 | TLSP | Transport Layer Security Protocol using Kryptonet key management | Christer Oberg | |
| 57 | SKIP | SKIP | Tom Markson | |
| 58 | IPv6-ICMP | ICMP for IPv6 | RFC 8200 | |
| 59 | IPv6-NoNxt | No Next Header for IPv6 | RFC 8200 | |
| 60 | IPv6-Opts | Destination Options for IPv6 | Y | RFC 8200 |
| 61 | any host internal protocol | Internet Assigned Numbers Authority | ||
| 62 | CFTP | CFTP | Forsdick, H., "CFTP", Network Message, Bolt Beranek and Newman, January 1982.; Harry Forsdick | |
| 63 | any local network | Internet Assigned Numbers Authority | ||
| 64 | SAT-EXPAK | SATNET and Backroom EXPAK | Steven Blumenthal | |
| 65 | KRYPTOLAN | Kryptolan | Paul Liu | |
| 66 | RVD | MIT Remote Virtual Disk Protocol | Michael Greenwald | |
| 67 | IPPC | Internet Pluribus Packet Core | Steven Blumenthal | |
| 68 | any distributed file system | Internet Assigned Numbers Authority | ||
| 69 | SAT-MON | SATNET Monitoring | Steven Blumenthal | |
| 70 | VISA | VISA Protocol | Gene Tsudik | |
| 71 | IPCV | Internet Packet Core Utility | Steven Blumenthal | |
| 72 | CPNX | Computer Protocol Network Executive | David Mittnacht | |
| 73 | CPHB | Computer Protocol Heart Beat | David Mittnacht | |
| 74 | WSN | Wang Span Network | Victor Dafoulas | |
| 75 | PVP | Packet Video Protocol | Steve Casner | |
| 76 | BR-SAT-MON | Backroom SATNET Monitoring | Steven Blumenthal | |
| 77 | SUN-ND | SUN ND PROTOCOL-Temporary | William Melohn | |
| 78 | WB-MON | WIDEBAND Monitoring | Steven Blumenthal | |
| 79 | WB-EXPAK | WIDEBAND EXPAK | Steven Blumenthal | |
| 80 | ISO-IP | ISO Internet Protocol | Marshall T. Rose | |
| 81 | VMTP | VMTP | Dave Cheriton | |
| 82 | SECURE-VMTP | SECURE-VMTP | Dave Cheriton | |
| 83 | VINES | VINES | Brian Horn | |
| 84 | IPTM | Internet Protocol Traffic Manager | Jim Stevens[1] | |
| 85 | NSFNET-IGP | NSFNET-IGP | Hans-Werner Braun | |
| 86 | DGP | Dissimilar Gateway Protocol | M/A-COM Government Systems, "Dissimilar Gateway Protocol Specification, Draft Version", Contract no. CS901145, November 16, 1987.; Mike Little | |
| 87 | TCF | TCF | Guillermo A. Loyola | |
| 88 | EIGRP | EIGRP | RFC 7868 | |
| 89 | OSPFIGP | OSPFIGP | RFC 1583; RFC 2328; RFC 5340; John Moy | |
| 90 | Sprite-RPC | Sprite RPC Protocol | Welch, B., "The Sprite Remote Procedure Call System", Technical Report, UCB/Computer Science Dept., 86/302, University of California at Berkeley, June 1986.; Bruce Willins | |
| 91 | LARP | Locus Address Resolution Protocol | Brian Horn | |
| 92 | MTP | Multicast Transport Protocol | Susie Armstrong | |
| 93 | AX.25 | AX.25 Frames | Brian Kantor | |
| 94 | IPIP | IP-within-IP Encapsulation Protocol | John Ioannidis | |
| 95 | MICP (deprecated) | Mobile Internetworking Control Pro. | John Ioannidis | |
| 96 | SCC-SP | Semaphore Communications Sec. Pro. | Howard Hart | |
| 97 | ETHERIP | Ethernet-within-IP Encapsulation | RFC 3378 | |
| 98 | ENCAP | Encapsulation Header | RFC 1241; Robert Woodburn | |
| 99 | any private encryption scheme | Internet Assigned Numbers Authority | ||
| 100 | GMTP | GMTP | [RXB5] | |
| 101 | IFMP | Ipsilon Flow Management Protocol | Bob Hinden; November 1995, 1997. | |
| 102 | PNNI | PNNI over IP | Ross Callon | |
| 103 | PIM | Protocol Independent Multicast | RFC 7761; Dino Farinacci | |
| 104 | ARIS | ARIS | Nancy Feldman | |
| 105 | SCPS | SCPS | Robert Durst | |
| 106 | QNX | QNX | Michael Hunter | |
| 107 | A/N | Active Networks | Bob Braden | |
| 108 | IPComp | IP Payload Compression Protocol | RFC 2393 | |
| 109 | SNP | Sitara Networks Protocol | Manickam R. Sridhar | |
| 110 | Compaq-Peer | Compaq Peer Protocol | Victor Volpe | |
| 111 | IPX-in-IP | IPX in IP | CJ Lee | |
| 112 | VRRP | Virtual Router Redundancy Protocol | RFC 9568 | |
| 113 | PGM | PGM Reliable Transport Protocol | Tony Speakman | |
| 114 | any 0-hop protocol | Internet Assigned Numbers Authority | ||
| 115 | L2TP | Layer Two Tunneling Protocol | RFC 3931; Bernard Aboba | |
| 116 | DDX | D-II Data Exchange (DDX) | John Worley | |
| 117 | IATP | Interactive Agent Transfer Protocol | John Murphy | |
| 118 | STP | Schedule Transfer Protocol | Jean-Michel Pittet | |
| 119 | SRP | SpectraLink Radio Protocol | Mark Hamilton | |
| 120 | UTI | UTI | Peter Lothberg | |
| 121 | SMP | Simple Message Protocol | Leif Ekblad | |
| 122 | SM (deprecated) | Simple Multicast Protocol | Jon Crowcroft; draft-perlman-simple-multicast-03 | |
| 123 | PTP | Performance Transparency Protocol | Michael Welzl | |
| 124 | ISIS over IPv4 | Tony Przygienda | ||
| 125 | FIRE | Criag Partridge | ||
| 126 | CRTP | Combat Radio Transport Protocol | Robert Sautter | |
| 127 | CRUDP | Combat Radio User Datagram | Robert Sautter | |
| 128 | SSCOPMCE | Kurt Waber | ||
| 129 | IPLT | [Hollbach] | ||
| 130 | SPS | Secure Packet Shield | Bill McIntosh | |
| 131 | PIPE | Private IP Encapsulation within IP | Steffen Fries | |
| 132 | SCTP | Stream Control Transmission Protocol | Randall R. Stewart | |
| 133 | FC | Fibre Channel | Murali Rajagopal; RFC 6172 | |
| 134 | RSVP-E2E-IGNORE | RFC 3175 | ||
| 135 | Mobility Header | Y | RFC 6275 | |
| 136 | UDPLite | RFC 3828 | ||
| 137 | MPLS-in-IP | RFC 4023 | ||
| 138 | manet | MANET Protocols | RFC 5498 | |
| 139 | HIP | Host Identity Protocol | Y | RFC 7401 |
| 140 | Shim6 | Shim6 Protocol | Y | RFC 5533 |
| 141 | WESP | Wrapped Encapsulating Security Payload | RFC 5840 | |
| 142 | ROHC | Robust Header Compression | RFC 5858 | |
| 143 | Ethernet | Ethernet | RFC 8986 | |
| 144 | AGGFRAG | AGGFRAG encapsulation payload for ESP | RFC 9347 | |
| 145 | NSH | Network Service Header | N | RFC 9491 |
| 146 | Homa | Homa | N | HomaModule; John Ousterhout |
| 147 | BIT-EMU | Bit-stream Emulation | Y | RFC 9801 |
| 148-252 | Unassigned | Internet Assigned Numbers Authority | ||
| 253 | Use for experimentation and testing | Y | RFC 3692 | |
| 254 | Use for experimentation and testing | Y | RFC 3692 | |
| 255 | Reserved | Internet Assigned Numbers Authority |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Barry Boehm | boehm&arpa.mil | |
| Barry Howard | Howard&nmfecc.llnl.gov | |
| Bernard Aboba | bernardaµsoft.com | 1998-04 |
| Bich Nguyen | bitnguyen&gmail.com | 2023-01-09 |
| Bill McIntosh | BMcIntosh&fortresstech.com | |
| Bob Braden | braden&isi.edu | 1997-07 |
| Bob Hinden | bob.hinden&gmail.com | 2013-02-17 |
| Brian Kantor | brian&ucsd.edu | |
| CJ Lee | cj_lee&novell.com | 1997-10 |
| Charlie Perkins | perk&watson.ibm.com | 1994-10 |
| Christer Oberg | chg&bull.se | 1994-10 |
| Criag Partridge | craig&bbn.com | 1999-08 |
| Dave Cheriton | cheriton&pescadero.stanford.edu | |
| Dave Presotto | presotto&plan9.att.com | 1995-07 |
| David Clark | ddc&lcs.mit.edu | |
| David Mills | Mills&huey.udel.edu | |
| Deborah Estrin | estrin&usc.edu | |
| Dino Farinacci | dino&cisco.com | 1996-03 |
| Dirk Fromhein | df&watershed.com | |
| Gene Tsudik | tsudik&usc.edu | |
| Greg Chesson | Greg&sgi.com | |
| Guillermo A. Loyola | LOYOLA&ibm.com | |
| Hans-Werner Braun | HWB&mcr.umich.edu | |
| Harry Forsdick | Forsdick&bbn.com | |
| Howard Hart | hch&hybrid.com | |
| Internet Assigned Numbers Authority | iana&iana.org | 1995-06 |
| J. Noel Chiappa | JNC&xx.lcs.mit.edu | |
| Jack Haverty | jhaverty&oracle.com | |
| Jean-Michel Pittet | jmp&gandalf.engr.sgi.com | 1998-11 |
| Jim Stevens | jasteven&rockwellcollins.com | 2011-01-26 |
| John Ioannidis | ji&tla.org | 2015-01-06 |
| John Moy | jmoy&proteon.com | |
| John Murphy | john.m.murphy&mci.com | 1998-10 |
| John Ousterhout | john.ousterhout&gmail.com | 2024-10-24 |
| John Worley | worley&milehigh.net | 1998-06 |
| Jon Crowcroft | jon&cs.ucl.ac.uk | 1999-06 |
| Jon Postel | postel&isi.edu | |
| K. Robert Glenn | glenn&osi.ncsl.nist.gov | |
| Kurt Waber | kurt.waber&swisscom.com | 1999-08 |
| Leif Ekblad | leif&rdos.net | 2012-08-21 |
| Manickam R. Sridhar | msridhar&sitaranetworks.com | 1997-09 |
| Mark Hamilton | mah&spectralink.com | 1998-11 |
| Marshall T. Rose | mrose&dbc.mtview.ca.us | |
| Martha Steenstrup | MSteenst&bbn.com | |
| Michael Greenwald | Greenwald&scrc-stony-brook.symbolics.com | |
| Michael Hunter | mphunter&qnx.com | 1997-07 |
| Michael Welzl | michael&tk.uni-linz.ac.at | 1999-08 |
| Mike Little | little&macom4.arpa | |
| Murali Rajagopal | murali&gadzoox.com | 2000-05 |
| Nancy Feldman | nkf&vnet.ibm.com | 1997-01 |
| Peter Lothberg | roll&stupi.se | 1999-03 |
| Randall R. Stewart | rrs&lakerest.net | 2000-04 |
| Robert Cole | robert&CS.UCL.AC.UK | |
| Robert Durst | durst&mitre.org | 1997-03 |
| Robert Sautter | rsautter&acdnj.itt.com | 1999-08 |
| Robert W. Scheifler | rscheifler&comcast.net | 2015-10-06 |
| Robert Woodburn | woody&cseic.saic.com | |
| Ross Callon | rcallon&baynetworks.com | 1995-12 |
| Steffen Fries | steffen.fries&siemens.com | 2026-03-09 |
| Steve Casner | casner&isi.edu | |
| Steve Chipman | Chipman&f.bbn.com | |
| Steve Deering | deering&parc.xerox.com | 1995-03 |
| Steven Blumenthal | BLUMENTHAL&vax.bbn.com | |
| Stuart A. Friedberg | stuart&cs.wisc.edu | |
| Sue Hares | skh&merit.edu | |
| Susie Armstrong | Armstrong.wbst128&xerox.com | |
| Tom Markson | markson&osmosys.ingog.com | 1995-09 |
| Tony Ballardie | A.Ballardie&cs.ucl.ac.uk | |
| Tony Li | tony.li&tony.li | 2012-10-17 |
| Tony Przygienda | prz&siara.com | 1999-08 |
| Tony Speakman | speakman&cisco.com | 1998-01 |
| Trudy Miller | Trudy&acc.com | |
| Victor Volpe | vvolpe&smtp.microcom.com | 1997-10 |
| Wesley Craig | Wesley.Craig&terminator.cc.umich.edu | |
| William Melohn | Melohn&sun.com | |
| Zaw-Sing Su | ZSu&tsca.istc.sri. |
Footnote
| [1] | Until March 2023, value 84 was also assigned to TTP (Transaction Transport Protocol). |