Additional Information PvD Keys
Registration Procedure(s)
- Expert Review
Expert(s)
- Tommy Pauly, David Schinazi
Reference
- RFC 8801: Discovering Provisioning Domain Names and Data
Available Formats
| JSON Key | Description | Type | Example | Reference |
|---|---|---|---|---|
| identifier | PvD ID FQDN | String | "pvd.example.com." | RFC 8801 |
| expires | Date after which this object is no longer valid | RFC 3339 Date | "2020-05-23T06:00:00Z" | RFC 8801 |
| prefixes | Array of IPv6 prefixes valid for this PvD | Array of strings | ["2001:db8:1::/48", "2001:db8:4::/48"] | RFC 8801 |
| dnsZones | DNS zones searchable and accessible | Array of strings | ["example.com", "sub.example.com"] | RFC 8801 |
| noInternet | No Internet; set to "true" when the PvD is restricted. | Boolean | true | RFC 8801 |
| splitDnsClaims | Verifiable locally served domains | Array of Objects | [{ "resolver": "dns.example.net", "parent": "example.com", "subdomains": ["sub"], "algorithm": "SHA384", "salt": "abc...123" }] | RFC 9704 |
| proxies | Array of proxy dictionaries associated with this PvD | Array of dictionaries | [ { "protocol": "connect-udp", "proxy": "https://proxy.example.org/masque{?target_host,target_port}" } ] | RFC-ietf-intarea-proxy-config-13 |
| proxy-match | Array of proxy match rules, as dictionaries, associated with entries in the proxies array. | Array of dictionaries | [ { "domains": [ "*.internal.example.org" ], "proxies": [ "default_proxy" ] } ] | RFC-ietf-intarea-proxy-config-13 |
PvD Option Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 8801: Discovering Provisioning Domain Names and Data
Note
See Internet Control Message Protocol version 6 (ICMPv6) Parameters.
PvD Split DNS Claims
Registration Procedure(s)
- Expert Review
Expert(s)
- Tommy Pauly, Tirumaleswar Reddy.K, Benjamin M. Schwartz
Reference
- RFC 9704: Establishing Local DNS Authority in Validated Split-Horizon Environments
Available Formats
| JSON Key | Description | Type | Example | Reference |
|---|---|---|---|---|
| resolver | The Authentication Domain Name | String | "dns.example.net" | RFC 9704 |
| parent | The parent zone name | String | "example.com" | RFC 9704 |
| subdomains | An array containing the claimed subdomains | Array of Strings | ["sub"] | RFC 9704 |
| algorithm | The hash algorithm | String | "SHA384" | RFC 9704 |
| salt | The salt (base64url) | String | "abc...123" | RFC 9704 |
Proxy Information PvD Keys
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC-ietf-intarea-proxy-config-13: Communicating Proxy Configurations in Provisioning Domains
Available Formats
| JSON Key | Optional/Required | Description | Type | Example | Reference |
|---|---|---|---|---|---|
| protocol | required | The protocol used to communicate with the proxy | String | "connect-udp" | RFC-ietf-intarea-proxy-config-13 |
| proxy | required | String containing the URI template or host and port of the proxy, depending on the format defined by the protocol | String | "https://example.org:4443/masque/{?target_host,target_port}" | RFC-ietf-intarea-proxy-config-13 |
| mandatory | optional | An array of optional keys that client must understand and process to use this proxy | Array of Strings | ["example_key"] | RFC-ietf-intarea-proxy-config-13 |
| alpn | optional | An array of Application-Layer Protocol Negotiation protocol identifiers | Array of Strings | ["h3","h2"] | RFC-ietf-intarea-proxy-config-13 |
| identifier | optional | A string used to refer to the proxy, which can be referenced by other dictionaries, such as entries in proxy-match | String | "udp-proxy" | RFC-ietf-intarea-proxy-config-13 |
Proxy Protocol PvD Values
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC-ietf-intarea-proxy-config-13: Communicating Proxy Configurations in Provisioning Domains
Available Formats
| Proxy Protocol | Proxy Location Format | Reference | Notes |
|---|---|---|---|
| socks5 | host:port | RFC 1928 | |
| http-connect | host:port | RFC 9110, Section 9.3.6 | Standard CONNECT method, using unencrypted HTTP to the proxy |
| https-connect | host:port | RFC 9110, Section 9.3.6 | Standard CONNECT method, using TLS-protected HTTP to the proxy |
| connect-udp | URI template | RFC 9298 | |
| connect-ip | URI template | RFC 9484 | |
| connect-tcp | URI template | draft-httpbis-connect-tcp-11 |
Proxy Destination Rule PvD Keys
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC-ietf-intarea-proxy-config-13: Communicating Proxy Configurations in Provisioning Domains
Available Formats
| JSON Key | Optional/Required | Description | Type | Example | Reference |
|---|---|---|---|---|---|
| proxies | No | An array of strings that match identifier values from the top-level proxies array | Array of Strings | ["tcp-proxy", "udp-proxy"] | RFC-ietf-intarea-proxy-config-13 |
| domains | Yes | An array of FQDNs and wildcard DNS domains | Array of Strings | ["www.example.com", "*.internal.example.com"] | RFC-ietf-intarea-proxy-config-13 |
| subnets | Yes | An array of IPv4 and IPv6 addresses and subnets | Array of Strings | ["2001:db8::1", "192.0.2.0/24"] | RFC-ietf-intarea-proxy-config-13 |
| ports | Yes | An array of TCP and UDP port ranges | Array of Strings | ["80", "443", "1024-65535"] | RFC-ietf-intarea-proxy-config-13 |