Pseudowire Name Spaces (PWE3)

Created

  • 2005-12-12

Last Updated

  • 2022-12-01

Available Formats


MPLS Pseudowire Types Registry

Expert(s)

  • Stewart Bryant, Andrew Malis, Matthew Bocci

Reference

  • RFC 4446: IANA Allocations for Pseudowire Edge to Edge Emulation (PWE3)

Note

When this registry is modified, the YANG module iana-pseudowire-types must be updated as defined in RFC 9291.

Available Formats

Range Registration Procedures Note
31-1024 Expert Review
1025-4096 IETF Review
4097-32766 First Come First Served reserved for vendor proprietary extensions
32767 IETF Review
PW Type Description Reference
0x0001 Frame Relay DLCI ( Martini Mode ) RFC 4619
0x0002 ATM AAL5 SDU VCC transport RFC 4717
0x0003 ATM transparent cell transport RFC 4717
0x0004 Ethernet Tagged Mode RFC 4448
0x0005 Ethernet RFC 4448
0x0006 HDLC RFC 4618
0x0007 PPP RFC 4618
0x0008 SONET/SDH Circuit Emulation Service Over MPLS Encapsulation RFC 5143
0x0009 ATM n-to-one VCC cell transport RFC 4717
0x000A ATM n-to-one VPC cell transport RFC 4717
0x000B IP Layer2 Transport RFC 3032
0x000C ATM one-to-one VCC Cell Mode RFC 4717
0x000D ATM one-to-one VPC Cell Mode RFC 4717
0x000E ATM AAL5 PDU VCC transport RFC 4717
0x000F Frame-Relay Port mode RFC 4619
0x0010 SONET/SDH Circuit Emulation over Packet RFC 4842
0x0011 Structure-agnostic E1 over Packet RFC 4553
0x0012 Structure-agnostic T1 (DS1) over Packet RFC 4553
0x0013 Structure-agnostic E3 over Packet RFC 4553
0x0014 Structure-agnostic T3 (DS3) over Packet RFC 4553
0x0015 CESoPSN basic mode RFC 5086
0x0016 TDMoIP AAL1 Mode RFC 5087
0x0017 CESoPSN TDM with CAS RFC 5086
0x0018 TDMoIP AAL2 Mode RFC 5087
0x0019 Frame Relay DLCI RFC 4619
0x001A ROHC Transport Header-compressed Packets RFC 5795; RFC 4901
0x001B ECRTP Transport Header-compressed Packets RFC 3545; RFC 4901
0x001C IPHC Transport Header-compressed Packets RFC 2507; RFC 4901
0x001D cRTP Transport Header-compressed Packets RFC 2508; RFC 4901
0x001E ATM VP Virtual Trunk "The Use of Virtual Trunks for ATM/MPLS Control Plane Interworking Specification", MFA Forum 9.0.0, MFA Forum, February 2006.
0x001F FC Port Mode RFC 6307
0x0020-0x1000 Unassigned
0x1001 Proprietary pseudowire implementation carrying CLNP packets Christian Schmutzer
0x1002-0x7FFE Unassigned
0x7FFF Wildcard RFC 4863

Pseudowire Interface Parameters Sub-TLV type Registry

Expert(s)

  • Stewart Bryant, Andrew Malis, Matthew Bocci

Reference

  • RFC 4446: IANA Allocations for Pseudowire Edge to Edge Emulation (PWE3)

Available Formats

Range Registration Procedures Note
2-64 Expert Review
65-127 IETF Review
128-254 First Come First Served reserved for vendor proprietary extensions
255 IETF Review
Parameter ID Length Description Reference
0x01 4 Interface MTU in octets RFC 8077
0x02 4 Maximum Number of concatenated ATM cells RFC 4717
0x03 up to 82 Optional Interface Description string RFC 8077
0x04 4 CEP/TDM Payload Bytes RFC 4842
0x05 4 CEP options RFC 4842
0x06 4 Requested VLAN ID RFC 4448
0x07 6 CEP/TDM bit-rate RFC 4842
0x08 4 Frame-Relay DLCI Length RFC 4619
0x09 4 Fragmentation indicator RFC 4623
0x0A 4 FCS retention indicator RFC 4720
0x0B 4/8/12 TDM options RFC 5287
0x0C 4 VCCV parameter RFC 5085
0x0D up to 256 bytes ROHC over MPLS configuration RFC 3241 RFC 4901
0x0E 4 Number of TDMoIP AAL1 cells per packet RFC 5287
0x0F up to 256 bytes CRTP/ECRTP/IPHC HC over MPLS configuration RFC 3544 RFC 4901
0x10 4 TDMoIP AAL1 mode RFC 5287
0x11 8 or more TDMoIP AAL2 Options RFC 5287
0x12 Reserved RFC 6307
0x13 Reserved RFC 6307
0x14 Reserved RFC 6307
0x15 Reserved RFC 6307
0x16 4 Stack capability RFC 6575
0x17 4 Flow Label RFC 6391
0x18 4 PW Generic Protocol Flags RFC 6478
0x19 variable VCCV Extended CV Parameter RFC 7189
0x1A 8 E-Tree RFC 7796
0x1B variable Selective Tree Interface Parameter RFC 8338
0x1C-0xFC Unassigned
0xFD up to 8 Zte optional Supplier private interface parameters Zhu Wei
0xFE-0xFF Unassigned

Attachment Individual Identifier Type Registry

Expert(s)

  • Stewart Bryant, Andrew Malis, Matthew Bocci

Reference

  • RFC 4446: IANA Allocations for Pseudowire Edge to Edge Emulation (PWE3)

Available Formats

Range Registration Procedures Note
2-64 Expert Review
65-127 IETF Review
128-254 First Come First Served reserved for vendor proprietary extensions
255 IETF Review
AII Type Length Description Reference
0x01 4 A 32 bit unsigned number local identifier RFC 6074
0x02 variable 8 or 12 Aggregate Identifier RFC 5003
0x03 variable 1 to 33 ATM/FR Control Channel "ATM and Frame Relay to MPLS Control Plane Interworking: Client-Server", MFA Forum 10.0.0, MFA Forum, September 2006.
0x04 variable 3 to 35 ATM/FR Signaling Call Reference "ATM and Frame Relay to MPLS Control Plane Interworking: Client-Server", MFA Forum 10.0.0, MFA Forum, September 2006.
0x05 variable 2 to 30 Frame Relay Port and Connection Identifier Soft Permanent Virtual Circuit Interworking between MPLS Pseudowires and ATM, MFA Forum, work in progress (this specification is at the baseline text stage).
0x06 variable 2 to 30 ATM Port and Connection Identifier Soft Permanent Virtual Circuit Interworking between MPLS Pseudowires and ATM, MFA Forum, work in progress (this specification is at the baseline text stage).

Attachment Group Identifier (AGI) Type Registry

Expert(s)

  • Stewart Bryant, Andrew Malis, Matthew Bocci

Reference

  • RFC 4446: IANA Allocations for Pseudowire Edge to Edge Emulation (PWE3)

Available Formats

Range Registration Procedures Note
2-64 Expert Review
65-127 IETF Review
128-254 First Come First Served reserved for vendor proprietary extensions
255 IETF Review
AGI Type Length Description Reference
0x01 8 Extended Community RFC 6074

Pseudowire Status Codes Registry

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Stewart Bryant, Andrew Malis, Matthew Bocci

Reference

  • RFC 4446: IANA Allocations for Pseudowire Edge to Edge Emulation (PWE3)

Available Formats

Bit Mask Description Reference
0x00000000 Pseudowire forwarding (clear all failures) RFC 8077; RFC 4446
0x00000001 Pseudowire Not Forwarding RFC 8077; RFC 4446
0x00000002 Local Attachment Circuit (ingress) Receive Fault RFC 8077; RFC 4446
0x00000004 Local Attachment Circuit (egress) Transmit Fault RFC 8077; RFC 4446
0x00000008 Local PSN-facing PW (ingress) Receive Fault RFC 8077; RFC 4446
0x00000010 Local PSN-facing PW (egress) Transmit Fault RFC 8077; RFC 4446
0x00000020 PW Preferential Forwarding Status RFC 6870
0x00000040 PW Request Switchover Status RFC 6870

Pseudowire Associated Channel Types

Reference

  • RFC 4385: Pseudowire Emulation Edge-to-Edge (PWE3) Control Word for Use over an MPLS PSN
  • RFC 5586: MPLS Generic Associated Channel
  • RFC Errata 1940
  • RFC 7026: Retiring TLVs from the Associated Channel Header of the MPLS Generic Associated Channel
  • RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry

Note

Renamed "MPLS Generalized Associated Channel (G-ACh) Types (including Pseudowire Associated Channel Types)" and moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.


Associated Channel Header TLV Registry (DELETED)

Reference

  • RFC 5586: MPLS Generic Associated Channel
  • RFC 7026: Retiring TLVs from the Associated Channel Header of the MPLS Generic Associated Channel

Note

Registry deleted per RFC 7026.


Header Compression Over MPLS PW Control Word Packet Type

Registration Procedure(s)

  • Expert Review

Reference

  • RFC 4901: Protocol Extensions for Header Compression over MPLS

Available Formats

Packet Type Description
0 ROHC Small-CIDs
1 ROHC Large-CIDs
2 FULL_HEADER
3 COMPRESSED_TCP
4 COMPRESSED_TCP_NODELTA
5 COMPRESSED_NON_TCP
6 COMPRESSED_RTP_8
7 COMPRESSED_RTP_16
8 COMPRESSED_UDP_8
9 COMPRESSED_UDP_16
10 CONTEXT_STATE
11-15 Unassigned

MPLS VCCV Control Channel (CC) Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5085: Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for Pseudowires

Note

Bit numbering: In this sub-registry, the most significant (high order) bit is labeled Bit 7, and the least significant (low order) bit is labeled Bit 0, see parenthetical "Value".

Available Formats

Bit (Value) Description Reference
0 (0x01) Type 1: PWE3 Control Word with 0001b as first nibble (PW-ACH, see RFC 4385) RFC 5085
1 (0x02) Type 2: MPLS Router Alert Label RFC 5085
2 (0x04) Type 3: MPLS PW Label with TTL == 1 RFC 5085
3 (0x08) Type 4: GAL RFC 7708
4 (0x10) Reserved RFC 5085
5 (0x20) Reserved RFC 5085
6 (0x40) Reserved RFC 5085
7 (0x80) Reserved RFC 5085

MPLS VCCV Connectivity Verification (CV) Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5085: Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for Pseudowires

Note

Bit numbering: In this sub-registry, the most significant (high order) bit is labeled Bit 7, and the least significant (low order) bit is labeled Bit 0, see parenthetical "Value".

Available Formats

Bit (Value) Description Reference
0 (0x01) ICMP Ping RFC 5085
1 (0x02) LSP Ping RFC 5085
2 (0x04) BFD IP/UDP-encapsulated, for PW Fault Detection only RFC 5885
3 (0x08) BFD IP/UDP-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling RFC 5885
4 (0x10) BFD PW-ACH-encapsulated, for PW Fault Detection only RFC 5885
5 (0x20) BFD PW-ACH-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling RFC 5885
6 (0x40) S-BFD IP/UDP-encapsulated, for PW Fault Detection only RFC 7885
7 (0x80) S-BFD PW-ACH-encapsulated, for PW Fault Detection only RFC 7885

Pseudowire Switching Point PE sub-TLV Type

Expert(s)

  • Primary: Stewart Bryant; secondary: Matthew Bocci

Reference

Available Formats

Range Registration Procedures Note
0 IETF Review
1-64 Expert Review
65-127 IETF Review
128-254 First Come First Served reserved for vendor proprietary extensions
255 IETF Review
Type Length Description Reference
0x00 Unassigned
0x01 4 PWid of last PW segment traversed RFC 6073
0x02 variable PW Switching Point description string RFC 6073
0x03 4/16 Local IP address of PW Switching Point RFC 6073
0x04 4/16 Remote IP address of last PW Switching Point traversed or of the T-PE RFC 6073
0x05 variable FEC Element of last PW segment traversed RFC 6073
0x06 14 L2 PW address of PW Switching Point RFC 6073; RFC 7267
0x07 24 Static PW/MPLS-TP PW segment ID of last PW segment traversed RFC 6478
0x08-0xFF Unassigned

CC/CV MEP-ID TLV Registry

Reference

  • RFC 6428: Proactive Connectivity Verification, Continuity Check, and Remote Defect Indication for the MPLS Transport Profile
  • RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry

Note

Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.


PW Generic Protocol Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6478: Pseudowire Status for Static Pseudowires

Available Formats

Bit (Value) Description Reference
0 (0x0001) S-PE bypass mode RFC 6478
1-15 (0x0002-0x8000) Unassigned

L2VPN PE Stack Capabilities

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6575: Address Resolution Protocol (ARP) Mediation for IP Interworking of Layer 2 VPNs

Available Formats

Bit (Value) Description Reference
0 (0x0001) IPv6 stack capability RFC 6575
1-15 (0x0002-0x8000) Unassigned

G-ACh Advertisement Protocol Application Registry

Reference

  • RFC 7212: MPLS Generic Associated Channel (G-ACh) Advertisement Protocol
  • RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry

Note

Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.


G-ACh Advertisement Protocol TLV Registry

Reference

  • RFC 7212: MPLS Generic Associated Channel (G-ACh) Advertisement Protocol
  • RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry

Note

Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.


G-ACh Advertisement Protocol: Ethernet Interface Parameters

Reference

  • RFC 7213: MPLS Transport Profile (MPLS-TP) Next-Hop Ethernet Addressing
  • RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry

Note

Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.


VCCV Extended CV Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7189: Virtual Circuit Connectivity Verification (VCCV) Capability Advertisement for MPLS Transport Profile (MPLS-TP)

Available Formats

Bit (Value) Description Reference
Bit 0 (0x01) Independent mode for PW Fault Detection only RFC 7189
Bit 1 (0x02) Independent mode for PW Fault Detection and AC/PW Fault Status Signaling RFC 7189
Bit 2 (0x04) Coordinated mode for PW Fault Detection only RFC 7189
Bit 3 (0x08) Coordinated mode for PW Fault Detection and AC/PW Fault Status Signaling RFC 7189
Bit 4-7 (0x10-0x80) Unassigned

ICC RG Parameter Types

Expert(s)

  • Stewart Bryant, Matthew Bocci

Reference

  • RFC 7275: Inter-Chassis Communication Protocol for Layer 2 Virtual Private Network (L2VPN) Provider Edge (PE) Redundancy

Available Formats

Range Registration Procedures Note
0x0000 IETF Review
0x003B-0x1FFF Expert Review
0x2000-0x2FFF IETF Review
0x3000-0x3FFE First Come First Served Vendor Proprietary Extensions
0x3FFF IETF Review
Type Description Reference
0x0000 Unassigned
0x0001 ICC Sender Name RFC 7275
0x0002 NAK TLV RFC 7275
0x0003 Requested Protocol Version TLV RFC 7275
0x0004 Disconnect Code TLV RFC 7275
0x0005 ICC RG ID TLV RFC 7275
0x0006-0x000F Reserved RFC 7275
0x0010 PW-RED Connect TLV RFC 7275
0x0011 PW-RED Disconnect TLV RFC 7275
0x0012 PW-RED Config TLV RFC 7275
0x0013 Service Name TLV RFC 7275
0x0014 PW ID TLV RFC 7275
0x0015 Generalized PW ID TLV RFC 7275
0x0016 PW-RED State TLV RFC 7275
0x0017 PW-RED Synchronization Request TLV RFC 7275
0x0018 PW-RED Synchronization Data TLV RFC 7275
0x0019 PW-RED Disconnect Cause TLV RFC 7275
0x001A-0x002F Reserved RFC 7275
0x0030 mLACP Connect TLV RFC 7275
0x0031 mLACP Disconnect TLV RFC 7275
0x0032 mLACP System Config TLV RFC 7275
0x0033 mLACP Port Config TLV RFC 7275
0x0034 mLACP Port Priority TLV RFC 7275
0x0035 mLACP Port State TLV RFC 7275
0x0036 mLACP Aggregator Config TLV RFC 7275
0x0037 mLACP Aggregator State TLV RFC 7275
0x0038 mLACP Synchronization Request TLV RFC 7275
0x0039 mLACP Synchronization Data TLV RFC 7275
0x003A mLACP Disconnect Cause TLV RFC 7275
0x003B-0x1FFF Unassigned
0x2000 STP Connect TLV RFC 7727
0x2001 STP Disconnect TLV RFC 7727
0x2002 STP System Config TLV RFC 7727
0x2003 STP Region Name TLV RFC 7727
0x2004 STP Revision Level TLV RFC 7727
0x2005 STP Instance Priority TLV RFC 7727
0x2006 STP Configuration Digest TLV RFC 7727
0x2007 STP Topology Changed Instances TLV RFC 7727
0x2008 STP CIST Root Time TLV RFC 7727
0x2009 STP MSTI Root Time TLV RFC 7727
0x200A STP Synchronization Request TLV RFC 7727
0x200B STP Synchronization Data TLV RFC 7727
0x200C STP Disconnect Cause TLV RFC 7727
0x200D PON Connect TLV RFC 8024
0x200E PON Disconnect TLV RFC 8024
0x200F PON Configuration TLV RFC 8024
0x2010 PON State TLV RFC 8024
0x2011-0x3FFF Unassigned

PSN Tunnel Sub-TLV Name Space

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7965: LDP Extensions for Pseudowire Binding to Label Switched Path (LSP) Tunnels

Available Formats

Value Description Reference
0 Reserved RFC 7965
1 IPv4 PSN Tunnel sub-TLV RFC 7965
2 IPv6 PSN Tunnel sub-TLV RFC 7965
3-254 Unassigned
255 Reserved RFC 7965

PW Status Refresh Reduction Control Messages

Expert(s)

  • Stewart Bryant, Andrew Malis

Reference

  • RFC 8237: MPLS Label Switched Path (LSP) Pseudowire (PW) Status Refresh Reduction for Static PWs

Available Formats

Range Registration Procedures
0x00 IETF Review
0x03-0x40 Expert Review
0x41-0x7F IETF Review
0x80-0xFE Expert Review
0xFF IETF Review
Type Message Description Reference
0x00 Unassigned
0x01 Notification message RFC 8237
0x02 PW Configuration Message RFC 8237
0x03-0xFF Unassigned

PW Status Refresh Reduction Configuration Message Sub-TLVs

Expert(s)

  • Stewart Bryant, Andrew Malis

Reference

  • RFC 8237: MPLS Label Switched Path (LSP) Pseudowire (PW) Status Refresh Reduction for Static PWs

Available Formats

Range Registration Procedures
0x00 IETF Review
0x04-0x40 Expert Review
0x41-0x7F IETF Review
0x80-0xFE Expert Review
0xFF IETF Review
sub-TLV Type Description Reference
0x00 Unassigned
0x01 MPLS-TP Tunnel ID RFC 8237
0x02 PW ID Configured List RFC 8237
0x03 PW ID Unconfigured List RFC 8237
0x04-0xFF Unassigned

PW Status Refresh Reduction Notification Codes

Expert(s)

  • Stewart Bryant, Andrew Malis

Reference

  • RFC 8237: MPLS Label Switched Path (LSP) Pseudowire (PW) Status Refresh Reduction for Static PWs

Available Formats

Range Registration Procedures
0x00000000 IETF Review
0x00000008-0x00010000 Expert Review
0x00010001-0x08000000 IETF Review
0x08000001-0xFFFFFFFE Expert Review
0xFFFFFFFF IETF Review
Code Error? Description Reference
0x00000000 No Null Notification RFC 8237
0x00000001 No PW configuration mismatch RFC 8237
0x00000002 Yes PW Configuration TLV conflict RFC 8237
0x00000003 No Unknown TLV (U-Bit=1) RFC 8237
0x00000004 Yes Unknown TLV (U-Bit=0) RFC 8237
0x00000005 No Unknown Message Type RFC 8237
0x00000006 No PW configuration not supported RFC 8237
0x00000007 Yes Unacknowledged control message RFC 8237
0x00000008-0xFFFFFFFF Unassigned

PW Status Refresh Reduction Message Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8237: MPLS Label Switched Path (LSP) Pseudowire (PW) Status Refresh Reduction for Static PWs

Available Formats

Bit Position Name Description Reference
0 Unknown flag bit RFC 8237
1 Configuration flag bit RFC 8237
2-7 Unassigned

Contact Information

Name Contact URI Last Updated
Christian Schmutzer cschmutz&cisco.com 2022-03-29
Zhu Wei zhu.wei120&zte.com.cn 2016-05-09