QoS NSIS Signal Layering Protocol (NSLP) QSPEC Parameters
Created
- 2010-02-24
Last Updated
- 2010-10-06
Available Formats
Object Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
QSPEC Version
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0 | Version 0 QSPEC | RFC 5975 |
| 1-15 | Unassigned |
QSPEC Type
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
QSPEC Procedure
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
| Message Sequence Value | Object Combination Value | Description | Reference |
|---|---|---|---|
| 0 | 0 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 0 | 1 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 0 | 2 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 0 | 3-15 | Unassigned | |
| 1 | 0 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 1 | 1 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 1 | 2 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 1 | 3-15 | Unassigned | |
| 2 | 0 | QSPEC objects as specified in RFC 5975 | RFC 5975 |
| 2 | 1-15 | Unassigned | |
| 3-15 | 0-15 | Unassigned |
Parameter ID
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
| Value | Description | Reference |
|---|---|---|
| 1 | TMOD-1 | RFC 5975 |
| 2 | TMOD-2 | RFC 5975 |
| 3 | Path Latency | RFC 5975 |
| 4 | Path Jitter | RFC 5975 |
| 5 | Path PLR | RFC 5975 |
| 6 | Path PER | RFC 5975 |
| 7 | Slack Term | RFC 5975 |
| 8 | Preemption Priority & Defending Priority | RFC 5975 |
| 9 | Admission Priority | RFC 5975 |
| 10 | RPH Priority | RFC 5975 |
| 11 | Excess Treatment | RFC 5975 |
| 12 | PHB Class | RFC 5975 |
| 13 | DSTE Class Type | RFC 5975 |
| 14 | Y.1541 QoS Class | RFC 5975 |
| 15 | TMOD Extension | RFC 5976 |
| 16 | Restoration Priority | RFC 5976 |
| 17 | PHR_Resource_Request | RFC 5977 |
| 18 | PHR_Release_Request | RFC 5977 |
| 19 | PHR_Refresh_Update | RFC 5977 |
| 20 | PDR_Reservation_Request | RFC 5977 |
| 21 | PDR_Refresh_Request | RFC 5977 |
| 22 | PDR_Release_Request | RFC 5977 |
| 23 | PDR_Reservation_Report | RFC 5977 |
| 24 | PDR_Refresh_Report | RFC 5977 |
| 25 | PDR_Release_Report | RFC 5977 |
| 26 | PDR_Congestion_Report | RFC 5977 |
| 27-255 | Unassigned | |
| 256-259 | Reserved for Private/Experimental Use | RFC 5975 |
| 260-4095 | Reserved | RFC 5975 |
Y.2171 Admission Priority Parameter
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
Excess Treatment Parameter
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
Y.1541 QoS Class Parameter
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5975: QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0 | Y.1541 QoS Class 0 | RFC 5975 |
| 1 | Y.1541 QoS Class 1 | RFC 5975 |
| 2 | Y.1541 QoS Class 2 | RFC 5975 |
| 3 | Y.1541 QoS Class 3 | RFC 5975 |
| 4 | Y.1541 QoS Class 4 | RFC 5975 |
| 5 | Y.1541 QoS Class 5 | RFC 5975 |
| 6 | Y.1541 QoS Class 6 | RFC 5975 |
| 7 | Y.1541 QoS Class 7 | RFC 5975 |
| 8-63 | Unassigned | |
| 64-255 | Reserved | RFC 5975 |
Restoration Priority Field
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5976: Y.1541-QOSM: Model for Networks Using Y.1541 Quality-of-Service Classes
Available Formats
Time to Restore Field
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5976: Y.1541-QOSM: Model for Networks Using Y.1541 Quality-of-Service Classes
Available Formats
Extent of Restoration Field
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5976: Y.1541-QOSM: Model for Networks Using Y.1541 Quality-of-Service Classes
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0 | unspecified EOR | RFC 5976 |
| 1 | high priority restored at 100%; medium priority restored at 100% | RFC 5976 |
| 2 | high priority restored at 100%; medium priority restored at 80% | RFC 5976 |
| 3 | high priority restored >= 80%; medium priority restored >= 80% | RFC 5976 |
| 4 | high priority restored >= 80%; medium priority restored >= 60% | RFC 5976 |
| 5 | high priority restored >= 60%; medium priority restored >= 60% | RFC 5976 |
| 6-15 | Unassigned |