| arin_originas0 |
American Registry for Internet Numbers |
https://bitbucket.org/arin-specs/arin-rdap-originas/src/master/arin-rdap-originas.txt |
American Registry for Internet Numbers |
COMMON |
| artRecord |
.ART |
https://github.com/centralnicgroup-public/centralnic-rdap-extensions/blob/master/art-records.md |
CentralNic Ltd |
COMMON |
| autnums |
Any |
RFC 9910 |
IETF |
This extension identifier is used for INR-specific search operations. |
| autnumSearchResults |
Any |
RFC 9910 |
IETF |
This extension identifier is used for INR-specific search operations. |
| cidr0 |
Various RIRs under the NRO |
https://bitbucket.org/nroecg/nro-rdap-cidr/src/master/nro-rdap-cidr.txt |
American Registry for Internet Numbers |
COMMON |
| farv1 |
Any |
RFC 9560 |
IETF |
This extension describes version 1 of a federated authentication
method for RDAP using OAuth 2.0 and OpenID Connect. |
| fred |
CZ.NIC, z. s. p. o. |
https://fred.nic.cz/rdap-extension/ |
Jaromir Talir |
FRED is open source domain registry system that includes RDAP
server. This RDAP server provides some extended features defined in
specification. |
| geofeed1 |
Any |
RFC 9877 |
IETF |
This extension describes version 1 of a method to access the IP
geolocation feed data through RDAP. |
| icann_rdap_response_profile_0 (OBSOLETED) |
ICANN |
https://www.icann.org/gtld-rdap-profile |
ICANN |
COMMON |
| icann_rdap_response_profile_1 |
ICANN |
https://www.icann.org/en/system/files/files/rdap-response-profile-21feb24-en.pdf |
ICANN |
COMMON |
| icann_rdap_technical_implementation_guide_0 (OBSOLETED) |
ICANN |
https://www.icann.org/gtld-rdap-profile |
ICANN |
COMMON |
| icann_rdap_technical_implementation_guide_1 |
ICANN |
https://www.icann.org/en/system/files/files/rdap-technical-implementation-guide-21feb24-en.pdf |
ICANN |
COMMON |
| ips |
Any |
RFC 9910 |
IETF |
This extension identifier is used for INR-specific search operations. |
| ipSearchResults |
Any |
RFC 9910 |
IETF |
This extension identifier is used for INR-specific search operations. |
| nask |
NASK - National Research Institute |
https://www.dns.pl/NASK_extension_of_RDAP_Response |
NASK - National Research Institute |
COMMON |
| nro_rdap_profile_0 |
Any |
https://bitbucket.org/nroecg/nro-rdap-profile/raw/v1/nro-rdap-profile.txt |
NRO |
ADDRESS REGISTRIES |
| nro_rdap_profile_asn_flat_0 |
Any |
https://bitbucket.org/nroecg/nro-rdap-profile/raw/v1/nro-rdap-profile.txt |
NRO |
ADDRESS REGISTRIES |
| nro_rdap_profile_asn_hierarchical_0 |
Any |
https://bitbucket.org/nroecg/nro-rdap-profile/raw/v1/nro-rdap-profile.txt |
NRO |
ADDRESS REGISTRIES |
| paging |
Any |
RFC 8977 |
IETF |
This extension describes a best practice for result
set paging. |
| platformNS |
Any |
https://github.com/centralnicgroup-public/centralnic-rdap-extensions/blob/master/platformNS.md |
CentralNic Ltd |
COMMON |
| rdap_objectTag |
Any |
RFC 8521 |
IETF |
This extension describes a best practice for
structuring entity identifiers to enable query bootstrapping. |
| redacted |
Any |
RFC 9537 |
IETF |
This extension identifies the redacted fields in an RDAP response. |
| redirect_with_content |
Any |
https://raw.githubusercontent.com/APNIC-net/rdap-redirect-with-content/v1/apnic-rdap-redirect-with-content.txt |
Tom Harrison |
COMMON |
| regType |
Any |
https://github.com/centralnicgroup-public/centralnic-rdap-extensions/blob/master/regtype.md |
CentralNic Ltd |
COMMON |
| reliabilityAssessment |
Any |
bcsec-RDAP-RA, Version 1 |
Bertoldi Cybersecurity |
COMMON |
| reverse_search |
Any |
RFC 9536 |
IETF |
This extension identifier is used for both URI path
segments and response extensions related to the reverse
search in RDAP. |
| rirSearch1 |
Any |
RFC 9910 |
IETF |
This extension identifier is used for INR-specific search operations. |
| sorting |
Any |
RFC 8977 |
IETF |
This extension describes a best practice for result
set sorting. |
| subsetting |
Any |
RFC 8982 |
IETF |
This extension describes best practice for partial
response provisioning. |
| ttl0 |
Any |
RFC 10037 |
IETF |
This extension describes how DNS TTL values can be included in RDAP responses. |