RDAP JSON Values

Created

  • 2015-01-12

Last Updated

  • 2025-06-04

Available Formats


RDAP JSON Values

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Jasdip Singh, Scott Hollenbeck

Reference

  • RFC 9083: JSON Responses for the Registration Data Access Protocol (RDAP)
  • RFC 9537: Redacted Fields in the Registration Data Access Protocol (RDAP) Response

Available Formats

Value Type Description Registrant Reference
result set truncated due to authorization notice and remark type The list of results does not contain all results due to lack of authorization. This may indicate to some clients that proper authorization will yield a longer result set. IESG RFC 9083
result set truncated due to excessive load notice and remark type The list of results does not contain all results due to an excessively heavy load on the server. This may indicate to some clients that requerying at a later time will yield a longer result set. IESG RFC 9083
result set truncated due to unexplainable reasons notice and remark type The list of results does not contain all results for an unexplainable reason. This may indicate to some clients that requerying for any reason will not yield a longer result set. IESG RFC 9083
object truncated due to authorization notice and remark type The object does not contain all data due to lack of authorization. IESG RFC 9083
object truncated due to excessive load notice and remark type The object does not contain all data due to an excessively heavy load on the server. This may indicate to some clients that requerying at a later time will yield all data of the object. IESG RFC 9083
object truncated due to unexplainable reasons notice and remark type The object does not contain all data for an unexplainable reason. IESG RFC 9083
validated status Signifies that the data of the object instance has been found to be accurate. This type of status is usually found on entity object instances to note the validity of identifying contact information. IESG RFC 9083
renew prohibited status Renewal or reregistration of the object instance is forbidden. IESG RFC 9083
update prohibited status Updates to the object instance are forbidden. IESG RFC 9083
transfer prohibited status Transfers of the registration from one registrar to another are forbidden. This type of status normally applies to DNR domain names. IESG RFC 9083
delete prohibited status Deletion of the registration of the object instance is forbidden. This type of status normally applies to DNR domain names. IESG RFC 9083
proxy status The registration of the object instance has been performed by a third party. This is most commonly applied to entities. IESG RFC 9083
private status The information of the object instance is not designated for public consumption. This is most commonly applied to entities. IESG RFC 9083
removed status Some of the information of the object instance has not been made available and has been removed. This is most commonly applied to entities. IESG RFC 9083
obscured status Some of the information of the object instance has been altered for the purposes of not readily revealing the actual information of the object instance. This is most commonly applied to entities. IESG RFC 9083
associated status The object instance is associated with other object instances in the registry. This is most commonly used to signify that a nameserver is associated with a domain or that an entity is associated with a network resource or domain. IESG RFC 9083
active status The object instance is in use. For domain names, it signifies that the domain name is published in DNS. For network and autnum registrations, it signifies that they are allocated or assigned for use in operational networks. This maps to the "OK" status of the Extensible Provisioning Protocol (EPP) RFC 5730. IESG RFC 9083
inactive status The object instance is not in use. See "active". IESG RFC 9083
locked status Changes to the object instance cannot be made, including the association of other object instances. IESG RFC 9083
pending create status A request has been received for the creation of the object instance, but this action is not yet complete. IESG RFC 9083
pending renew status A request has been received for the renewal of the object instance, but this action is not yet complete. IESG RFC 9083
pending transfer status A request has been received for the transfer of the object instance, but this action is not yet complete. IESG RFC 9083
pending update status A request has been received for the update or modification of the object instance, but this action is not yet complete. IESG RFC 9083
pending delete status A request has been received for the deletion or removal of the object instance, but this action is not yet complete. For domains, this might mean that the name is no longer published in DNS but has not yet been purged from the registry database. IESG RFC 9083
add period status This grace period is provided after the initial registration of the object. If the object is deleted by the client during this period, the server provides a credit to the client for the cost of the registration. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) RFC 3915 'addPeriod' status. IESG RFC 8056
auto renew period status This grace period is provided after an object registration period expires and is extended (renewed) automatically by the server. If the object is deleted by the client during this period, the server provides a credit to the client for the cost of the auto renewal. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) RFC 3915 'autoRenewPeriod' status. IESG RFC 8056
client delete prohibited status The client requested that requests to delete the object MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731, Extensible Provisioning Protocol (EPP) Host Mapping RFC 5732, and Extensible Provisioning Protocol (EPP) Contact Mapping RFC 5733 'clientDeleteProhibited' status. IESG RFC 8056
client hold status The client requested that the DNS delegation information MUST NOT be published for the object. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731 'clientHold' status. IESG RFC 8056
client renew prohibited status The client requested that requests to renew the object MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731 'clientRenewProhibited' status. IESG RFC 8056
client transfer prohibited status The client requested that requests to transfer the object MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731 and Extensible Provisioning Protocol (EPP) Contact Mapping RFC 5733 'clientTransferProhibited' status. IESG RFC 8056
client update prohibited status The client requested that requests to update the object (other than to remove this status) MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731, Extensible Provisioning Protocol (EPP) Host Mapping RFC 5732, and Extensible Provisioning Protocol (EPP) Contact Mapping RFC 5733 'clientUpdateProhibited' status. IESG RFC 8056
pending restore status An object is in the process of being restored after being in the redemption period state. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) RFC 3915 'pendingRestore' status. IESG RFC 8056
redemption period status A delete has been received, but the object has not yet been purged because an opportunity exists to restore the object and abort the deletion process. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) RFC 3915 'redemptionPeriod' status. IESG RFC 8056
renew period status This grace period is provided after an object registration period is explicitly extended (renewed) by the client. If the object is deleted by the client during this period, the server provides a credit to the client for the cost of the renewal. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) RFC 3915 'renewPeriod' status. IESG RFC 8056
server delete prohibited status The server set the status so that requests to delete the object MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731, Extensible Provisioning Protocol (EPP) Host Mapping RFC 5732, and Extensible Provisioning Protocol (EPP) Contact Mapping RFC 5733 'serverDeleteProhibited' status. IESG RFC 8056
server renew prohibited status The server set the status so that requests to renew the object MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731 'serverRenewProhibited' status. IESG RFC 8056
server transfer prohibited status The server set the status so that requests to transfer the object MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731 and Extensible Provisioning Protocol (EPP) Contact Mapping RFC 5733 'serverTransferProhibited' status. IESG RFC 8056
server update prohibited status The server set the status so that requests to update the object (other than to remove this status) MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731, Extensible Provisioning Protocol (EPP) Host Mapping RFC 5732, and Extensible Provisioning Protocol (EPP) Contact Mapping RFC 5733 'serverUpdateProhibited' status. IESG RFC 8056
server hold status The server set the status so that DNS delegation information MUST NOT be published for the object. This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping RFC 5731 'serverHold' status. IESG RFC 8056
transfer period status This grace period is provided after the successful transfer of object registration sponsorship from one client to another client. If the object is deleted by the client during this period, the server provides a credit to the client for the cost of the transfer. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) RFC 3915 'transferPeriod' status. IESG RFC 8056
registration event action The object instance was initially registered. IESG RFC 9083
reregistration event action The object instance was registered subsequently to initial registration. IESG RFC 9083
last changed event action An action noting when the information in the object instance was last changed. IESG RFC 9083
expiration event action The object instance has been removed or will be removed at a predetermined date and time from the registry. IESG RFC 9083
deletion event action The object instance was removed from the registry at a point in time that was not predetermined. IESG RFC 9083
reinstantiation event action The object instance was reregistered after having been removed from the registry. IESG RFC 9083
transfer event action The object instance was transferred from one registrar to another. IESG RFC 9083
locked event action The object instance was locked (see the "locked" status). IESG RFC 9083
unlocked event action The object instance was unlocked (see the "locked" status). IESG RFC 9083
registrant role The entity object instance is the registrant of the registration. In some registries, this is known as a maintainer. IESG RFC 9083
technical role The entity object instance is a technical contact for the registration. IESG RFC 9083
administrative role The entity object instance is an administrative contact for the registration. IESG RFC 9083
abuse role The entity object instance handles network abuse issues on behalf of the registrant of the registration. IESG RFC 9083
billing role The entity object instance handles payment and billing issues on behalf of the registrant of the registration. IESG RFC 9083
registrar role The entity object instance represents the authority responsible for the registration in the registry. IESG RFC 9083
reseller role The entity object instance represents a third party through which the registration was conducted (i.e., not the registry or registrar). IESG RFC 9083
sponsor role The entity object instance represents a domain policy sponsor, such as an ICANN-approved sponsor. IESG RFC 9083
proxy role The entity object instance represents a proxy for another entity object, such as a registrant. IESG RFC 9083
notifications role An entity object instance designated to receive notifications about association object instances. IESG RFC 9083
noc role The entity object instance handles communications related to a network operations center (NOC). IESG RFC 9083
registered domain variant relation The variant names are registered in the registry. IESG RFC 9083
unregistered domain variant relation The variant names are not found in the registry. IESG RFC 9083
registration restricted domain variant relation Registration of the variant names is restricted to certain parties or within certain rules. IESG RFC 9083
open registration domain variant relation Registration of the variant names is available to generally qualified registrants. IESG RFC 9083
conjoined domain variant relation Registration of the variant names occurs automatically with the registration of the containing domain registration. IESG RFC 9083
last update of RDAP database event action An action noting when the information in the object instance in the RDAP database was last synchronized from the authoritative database (e.g. registry database). ICANN
registrar expiration event action An action noting the expiration date of the object in the registrar system. ICANN
enum validation expiration event action Association of phone number represented by this ENUM domain to registrant has expired or will expire at a predetermined date and time. CZ.NIC, z. s. p. o.
object redacted due to authorization notice and remark type The object contains redacted data due to lack of authorization. ICANN
administrative status The object instance has been allocated administratively (i.e., not for use by the recipient in their own right in operational networks). NRO
reserved status The object instance has been allocated to an IANA special-purpose address registry. NRO
jsonpath redacted expression language JSON path expression language, as defined in RFC 9535. IETF RFC 9537
Registry Domain ID redacted name Redacted domain object class “handle” member. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.handle”. ICANN ICANN gTLD RDAP Response Profile
Registry Registrant ID redacted name Redacted entity object class, with “registrant” role, “handle” member. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].handle”. ICANN ICANN gTLD RDAP Response Profile
Registrant Name redacted name Redacted entity object class, with “registrant” role, name property. When using jCard, redacting the “vcard” “fn” property. The “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='fn')][3]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Organization redacted name Redacted entity object class, with “registrant” role, organization property. When using jCard, redacting the “vcard” “org” property. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='org')]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Street redacted name Redacted entity object class, with “registrant” role, street properties. When using jCard, the “vcard” “adr” street properties (vCard “ADR-component-pobox”, “ADR-component-ext”, and “ADR-component-street”). The “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='adr')][3][:3]”. ICANN ICANN gTLD RDAP Response Profile
Registrant City redacted name Redacted entity object class, with “registrant” role, city property. When using jCard, the “vcard” “adr” locality property (vCard “ADR-component-locality”). The “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='adr')][3][3]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Postal Code redacted name Redacted entity object class, with “registrant” role, postal code property. When using jCard, the “vcard” “adr” code property (vCard “ADR-component-code”). The “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='adr')][3][5]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Phone redacted name Redacted entity object class, with “registrant” role, voice phone property. When using jCard, the “vcard” “tel” property with type “voice”. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='voice')]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Phone Ext redacted name Redacted entity object class, with “registrant” role, voice phone extension property. When using jCard, the “vcard” “tel” property extension value with type “voice”. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='voice')]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Fax redacted name Redacted entity object class, with “registrant” role, fax phone property. When using jCard, the “vcard” “tel” property with type “fax”. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='fax')]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Fax Ext redacted name Radacted entity object class, with “registrant” role, fax phone extension property. When using jCard, the “vcard” “tel” property with type “fax”. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='fax')]”. ICANN ICANN gTLD RDAP Response Profile
Registrant Email redacted name Redacted entity object class, with “registrant” role, email property. When using jCard, the “vcard” “email” property. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='email')]”. The “replacementValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='email')][3]” or using the “replacementPath” to the “vcard” “contact-uri” property. ICANN ICANN gTLD RDAP Response Profile
Registry Tech ID redacted name Redacted entity object class, with “technical” role, “handle” member. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]==’technical’)].handle”. ICANN ICANN gTLD RDAP Response Profile
Tech Name redacted name Redacted entity object class, with “technical” role, name property. When using jCard, redacting the “vcard” “fn” property. The “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]==’technical’)].vcardArray[1][?(@[0]=='fn')][3]”. ICANN ICANN gTLD RDAP Response Profile
Tech Phone redacted name Radacted entity object class, with “technical” role, voice phone property. When using jCard, the “vcard” “tel” property with type “voice”. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[1].type=='voice')]”. ICANN ICANN gTLD RDAP Response Profile
Tech Phone Ext redacted name Redacted entity object class, with “technical” role, voice phone extension property. When using jCard, the “vcard” “tel” property extension value with type “voice”. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[1].type=='voice')]”. ICANN ICANN gTLD RDAP Response Profile
Tech Email redacted name Redacted entity object class, with “technical” role, email property. When using jCard, the “vcard” “email” property. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[0]=='email')]”. The “replacementValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of RFC 9537 is “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[0]=='email')][3]” or using the “replacementPath” to the “vcard” “contact-uri” property. ICANN ICANN gTLD RDAP Response Profile

Contact Information

Name Contact URI Last Updated
CZ.NIC, z. s. p. o. tech&nic.cz 2016-03-30
ICANN globalsupport&icann.org 2019-08-02
IESG iesg&ietf.org
IETF iesg&ietf.org
NRO secretariat&nro.net 2021-01-27