Remote Direct Data Placement (RDDP)

Created

  • 2012-02-22

Last Updated

  • 2014-06-27

Available Formats


RDMAP Errors

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6580: IANA Registries for the Remote Direct Data Placement (RDDP) Protocols

Available Formats

Layer/Error-Type/Error-Code Error-Type-Name/Error-Code-Name Reference
0x0/0x0/ALL Local Catastrophic Error RFC 5040
0x0/0x1/0x00 Remote Protection Error / Invalid Steering Tag RFC 5040
0x0/0x1/0x01 Remote Protection Error / Base or bounds violation RFC 5040
0x0/0x1/0x02 Remote Protection Error / Access rights violation RFC 5040
0x0/0x1/0x03 Remote Protection Error / Steering Tag not associated with RDMAP Stream RFC 5040
0x0/0x1/0x04 Remote Protection Error / Tagged Offset wrap RFC 5040
0x0/0x1/0x09 Remote Protection Error / Steering Tag cannot be invalidated RFC 5040
0x0/0x1/0xff Remote Protection Error / Unspecified Error RFC 5040
0x0/0x2/0x05 Remote Operation Error / Invalid RDMAP version RFC 5040
0x0/0x2/0x06 Remote Operation Error / Unexpected OpCode RFC 5040
0x0/0x2/0x07 Remote Operation Error / Catastrophic error, localized to RDMAP Stream RFC 5040
0x0/0x2/0x08 Remote Operation Error / Catastrophic error, global RFC 5040
0x0/0x2/0x09 Remote Operation Error / Steering Tag cannot be Invalidated RFC 5040
0x0/0x2/0xff Remote Operation Error / Unspecified Error RFC 5040

DDP Errors

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6580: IANA Registries for the Remote Direct Data Placement (RDDP) Protocols

Available Formats

Layer/Error-Type/Error-Code Error-Type-Name/Error-Code-Name Reference
0x1/0x0/0x00 Local Catastrophic RFC 5041
0x1/0x1/0x00 Tagged Buffer Error / Invalid Steering Tag RFC 5041
0x1/0x1/0x01 Tagged Buffer Error / Base or bounds violation RFC 5041
0x1/0x1/0x02 Tagged Buffer Error / Steering Tag not associated with DDP Stream RFC 5041
0x1/0x1/0x03 Tagged Buffer Error / Tagged Offset wrap RFC 5041
0x1/0x1/0x04 Tagged Buffer Error / Invalid DDP version RFC 5041
0x1/0x2/0x01 Untagged Buffer Error / Invalid Queue Number RFC 5041
0x1/0x2/0x02 Untagged Buffer Error / Invalid Message Sequence Number - no buffer available RFC 5041
0x1/0x2/0x03 Untagged Buffer Error / Invalid Message Sequence Number - Message Sequence Number range is not valid RFC 5041
0x1/0x2/0x04 Untagged Buffer Error / Invalid Message Offset RFC 5041
0x1/0x2/0x05 Untagged Buffer Error / DDP Message too long for available buffer RFC 5041
0x1/0x2/0x06 Untagged Buffer Error / Invalid DDP version RFC 5041
0x1/0x3/ALL Reserved for use by Lower Layer Protocol RFC 5041

MPA Errors

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6580: IANA Registries for the Remote Direct Data Placement (RDDP) Protocols

Available Formats

Layer/Error-Type/Error-Code Error-Type-Name/Error-Code-Name Reference
0x2/0x0/0x01 MPA Error / TCP connection closed, terminated, or lost RFC 5044
0x2/0x0/0x02 MPA Error / MPA CRC Error RFC 5044
0x2/0x0/0x03 MPA Error / MPA Marker and ULPDU Length field mismatch RFC 5044
0x2/0x0/0x04 MPA Error / Invalid MPA Request Frame or MPA Response Frame RFC 5044
0x2/0x0/0x05 MPA Error / Local catastrophic error RFC 6581
0x2/0x0/0x06 MPA Error / Insufficient IRD resources RFC 6581
0x2/0x0/0x07 MPA Error / No matching RTR option RFC 6581

RDMAP Message Operation Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6580: IANA Registries for the Remote Direct Data Placement (RDDP) Protocols

Available Formats

RDMAP Message Operation Code Message Type Reference
0x0 RDMA Write RFC 5040
0x1 RDMA Read Request RFC 5040
0x2 RDMA Read Response RFC 5040
0x3 Send RFC 5040
0x4 Send with Invalidate RFC 5040
0x5 Send with Solicited Event RFC 5040
0x6 Send with Solicited Event and Invalidate RFC 5040
0x7 Terminate RFC 5040
0x8 Immediate Data RFC 7306
0x9 Immediate Data with Solicited Event RFC 7306
0xA Atomic Request RFC 7306
0xB Atomic Response RFC 7306
0xC-OxE Unassigned
0xF Reserved (Experimental) RFC 6580

RDMAP Message Atomic Operation Subcodes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7306: Remote Direct Memory Access (RDMA) Protocol Extensions

Available Formats

RDMAP Message Atomic Operation Subcode Atomic Operation Reference
0x0 FetchAdd RFC 7306
0x1 Reserved RFC 7306
0x2 CmpSwap RFC 7306
0x3-OxF Unassigned

SCTP Function Codes for DDP Stream Session Control

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6580: IANA Registries for the Remote Direct Data Placement (RDDP) Protocols

Available Formats

SCTP Function Code SCTP Function Name Reference
0x0001 DDP Stream Session Initiate RFC 5043
0x0002 DDP Stream Session Accept RFC 5043
0x0003 DDP Stream Session Reject RFC 5043
0x0004 DDP Stream Session Terminate RFC 5043
0x0005 Enhanced DDP Stream Session Initiate RFC 6581
0x0006 Enhanced DDP Stream Session Accept RFC 6581
0x0007 Enhanced DDP Stream Session Reject RFC 6581
0x0008-0xFFFE Unassigned
0xFFFF Reserved (Experimental) RFC 6580

RDMAP DDP Untagged Queue Numbers

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7306: Remote Direct Memory Access (RDMA) Protocol Extensions

Available Formats

RDMAP DDP Untagged Queue Number Queue Usage Description Reference
0x00000000 Queue 0 (Send operation Variants) RFC 5040
0x00000001 Queue 1 (RDMA Read Request operations) RFC 5040
0x00000002 Queue 2 (Terminate operations) RFC 5040
0x00000003 Queue 3 (Atomic Response operations) RFC 7306
0x00000004-0xFFFFFFFF Unassigned