REsource LOcation And Discovery (RELOAD)
RELOAD Overlay Algorithm Types
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Access Control Policies
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Application-ID
- Marc Petit-Huguenin (primary), Cullen Jennings (secondary)
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
| Range |
Registration Procedures |
| 1-32767 |
Standards Action |
| 32768-61440 |
Expert Review |
| Application-ID |
Application |
Reference |
| 0 |
INVALID |
RFC 6940 |
| 1-5059 |
Unassigned |
|
| 5060 |
SIP |
Reserved for use by SIP Usage |
| 5061 |
SIP |
Reserved for use by SIP Usage |
| 5062-61440 |
Unassigned |
|
| 61441-65534 |
Reserved for Private Use |
RFC 6940 |
| 65535 |
Reserved |
RFC 6940 |
RELOAD Data Kind-ID
- Marc Petit-Huguenin (primary), Cullen Jennings (secondary)
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
| Range |
Registration Procedures |
| 0x00000001-0x7fffffff |
Standards Action |
| 0x8000000-0xf0000000 |
Expert Review |
| Kind-ID |
Kind |
Reference |
| 0x0 |
INVALID |
RFC 6940 |
| 0x1 |
SIP-REGISTRATION |
RFC 7904 |
| 0x2 |
TURN-SERVICE |
RFC 6940 |
| 0x3 |
CERTIFICATE_BY_NODE |
RFC 6940 |
| 0x4 |
ACCESS-CONTROL-LIST |
RFC 8076 |
| 0x5-0x9 |
Unassigned |
|
| 0x10 |
CERTIFICATE_BY_USER |
RFC 6940 |
| 0x11-0x103 |
Unassigned |
|
| 0x104 |
REDIR |
RFC 7374 |
| 0x105 |
CoAP-REGISTRATION |
RFC 7650 |
| 0x106 |
CoAP-CACHING |
RFC 7650 |
| 0x107-0x7ffffffe |
Unassigned |
|
| 0x7fffffff |
Reserved |
RFC 6940 |
| 0x8000000-0xf0000000 |
Unassigned |
|
| 0xf0000001-0xfffffffe |
Reserved for Private Use |
RFC 6940 |
| 0xffffffff |
Reserved |
RFC 6940 |
RELOAD Data Model
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Message Codes
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Error Codes
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Overlay Link Registry
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Overlay Link Protocol Registry
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Forwarding Option Registry
- Marc Petit-Huguenin (primary), Cullen Jennings (secondary)
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
| Range |
Registration Procedures |
| 01-127 |
Standards Action |
| 128-254 |
Specification Required |
RELOAD Probe Information Type Registry
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Extensions Registry
- Marc Petit-Huguenin (primary), Cullen Jennings (secondary)
- RFC 6940: REsource LOcation And Discovery (RELOAD) Base Protocol
RELOAD Services Registry
- RFC 7374: Service Discovery Usage for REsource LOcation And Discovery (RELOAD)
CoAP Usage for RELOAD Access Control Policy
- RFC 7650: A Constrained Application Protocol (CoAP) Usage for REsource LOcation And Discovery (RELOAD)
RELOAD Diagnostics Flag
- RFC 7851: Peer-to-Peer (P2P) Overlay Diagnostics
Assignments must be accompanied by the registration of corresponding
values in the RELOAD Diagnostic Kind ID registry.
| Diagnostic Information |
Diagnostic Flag in dMFlags |
Reference |
| 0x 0000 0000 0000 0000 |
Reserved All 0s value |
RFC 7851 |
| 0x 0000 0000 0000 0001 |
Reserved First Bit |
RFC 7851 |
| 0x 0000 0000 0000 0002 |
STATUS_INFO |
RFC 7851 |
| 0x 0000 0000 0000 0004 |
ROUTING_TABLE_SIZE |
RFC 7851 |
| 0x 0000 0000 0000 0008 |
PROCESS_POWER |
RFC 7851 |
| 0x 0000 0000 0000 0010 |
UPSTREAM_BANDWIDTH |
RFC 7851 |
| 0x 0000 0000 0000 0020 |
DOWNSTREAM_ BANDWIDTH |
RFC 7851 |
| 0x 0000 0000 0000 0040 |
SOFTWARE_VERSION |
RFC 7851 |
| 0x 0000 0000 0000 0080 |
MACHINE_UPTIME |
RFC 7851 |
| 0x 0000 0000 0000 0100 |
APP_UPTIME |
RFC 7851 |
| 0x 0000 0000 0000 0200 |
MEMORY_FOOTPRINT |
RFC 7851 |
| 0x 0000 0000 0000 0400 |
DATASIZE_STORED |
RFC 7851 |
| 0x 0000 0000 0000 0800 |
INSTANCES_STORED |
RFC 7851 |
| 0x 0000 0000 0000 1000 |
MESSAGES_SENT_RCVD |
RFC 7851 |
| 0x 0000 0000 0000 2000 |
EWMA_BYTES_SENT |
RFC 7851 |
| 0x 0000 0000 0000 4000 |
EWMA_BYTES_RCVD |
RFC 7851 |
| 0x 0000 0000 0000 8000 |
UNDERLAY_HOP |
RFC 7851 |
| 0x 0000 0000 0001 0000 |
BATTERY_STATUS |
RFC 7851 |
| 0x 8000 0000 0000 0000 |
Reserved Last Bit |
RFC 7851 |
| 0x ffff ffff ffff ffff |
Reserved All 1s value |
RFC 7851 |
RELOAD Diagnostic Kind ID
- RFC 7851: Peer-to-Peer (P2P) Overlay Diagnostics
Assignments in the 0x0001 to 0x003e range must be accompanied by
the registration of corresponding values in the RELOAD Diagnostics Flag
registry.