RObust Header Compression (ROHC) Profile Identifiers

Created

  • 2001-04-23

Last Updated

  • 2023-02-03

Available Formats


Profile Identifiers

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 5795: The RObust Header Compression (ROHC) Framework

Note

There appears to be further breakdown:

In the 8 LSBs, the range 0 to 127 is reserved for IETF standard-track specifications; the range 128 to 254 is available for other specifications that meet this requirement (such as Informational RFCs). The LSB value 255 is reserved for future extensibility of the present specification.

Available Formats

Profile Identifier Usage Reference
0x0000 ROHC uncompressed RFC 5795
0xnn00 Reserved
0x0001 ROHC RTP RFC 3095
0x0101 ROHCv2 RTP RFC 5225
0xnn01 Reserved
0x0002 ROHC UDP RFC 3095
0x0102 ROHCv2 UDP RFC 5225
0xnn02 Reserved
0x0003 ROHC ESP RFC 3095
0x0103 ROHCv2 ESP RFC 5225
0xnn03 Reserved
0x0004 ROHC IP RFC 3843
0x0104 ROHCv2 IP RFC 5225
0xnn04 Reserved
0x0005 ROHC LLA RFC 4362
0x0105 ROHC LLA with R-mode RFC 3408
0xnn05 Reserved
0x0006 ROHC TCP RFC 6846
0xnn06 Reserved
0x0007 ROHC RTP/UDP-Lite RFC 4019
0x0107 ROHCv2 RTP/UDP-Lite RFC 5225
0xnn07 Reserved
0x0008 ROHC UDP-Lite RFC 4019
0x0108 ROHCv2 UDP-Lite RFC 5225
0xnn08 Reserved
0x0009-0xnn7F To be Assigned by IANA
0xnn80-0xnnFE To be Assigned by IANA
0xnnFF Reserved