Remote Procedure Call (RPC) Authentication Numbers
RPC Authentication Flavor Numbers
- RFC 5531: RPC: Remote Procedure Call Protocol Specification Version 2
For all RPC authentication flavor and authentication status numbers
to be used on the Internet, it is strongly advised that an
informational or standards-track RFC be published describing the
authentication mechanism behaviour and parameters.
New pseudo-flavor requests will be assigned from the 390000-390255
block. All other assignments will be made sequentially starting from
decimal 400000.
| Identifier String |
Flavor Name |
Value |
Description |
Reference |
| AUTH_NONE |
none |
0 |
no authentication, see RFC 1831/a.k.a. AUTH_NULL |
RFC 5531 |
| AUTH_SYS |
sys |
1 |
unix style (uid+gids), RFC 1831/a.k.a. AUTH_UNIX |
RFC 5531 |
| AUTH_SHORT |
|
2 |
short hand unix style, RFC 1831 |
RFC 5531 |
| AUTH_DH |
dh |
3 |
des style (encrypted timestamp)/a.k.a. AUTH_DES, see RFC 2695 |
RFC 5531 |
| AUTH_KERB |
krb4 |
4 |
kerberos auth, see RFC 2695 |
RFC 5531 |
| AUTH_RSA |
|
5 |
RSA authentication |
RFC 5531 |
| RPCSEC_GSS |
|
6 |
GSS-based RPC security for auth, integrity and privacy, RFC 5403 |
RFC 5531; RFC Errata 4849 |
| AUTH_TLS |
TLS |
7 |
Indicates support for RPC-over-TLS |
RFC 9289 |
|
|
8-30000 |
Unassigned |
|
| AUTH_NW |
|
30001 |
NETWARE |
RFC 5531 |
|
|
30002-199999 |
Unassigned |
|
| AUTH_SEC |
|
200000 |
TSIG NFS subcommittee |
RFC 5531 |
|
|
200001-200003 |
Unassigned |
|
| AUTH_ESV |
|
200004 |
SVr4 ES |
RFC 5531 |
|
|
200005-299999 |
Unassigned |
|
| AUTH_NQNFS |
|
300000 |
Univ. of Guelph - Not Quite NFS |
RFC 5531 |
| AUTH_GSSAPI |
|
300001 |
OpenVision (john.linn@ov.com) |
RFC 5531 |
| AUTH_ILU_UGEN |
|
300002 |
Xerox (janssen@parc.xerox.com) - ILU Unsecured Generic Identity |
RFC 5531 |
| AUTH_SPNEGO |
|
390000 |
|
RFC 5531 |
|
|
390000-390255 |
NFS 'pseudo' flavors for RPCSEC_GSS |
RFC 5531 |
|
krb5 |
390003 |
kerberos_v5 authentication, RFC 2623 |
RFC 5531 |
|
krb5i |
390004 |
kerberos_v5 with data integrity, RFC 2623 |
RFC 5531 |
|
krb5p |
390005 |
kerberos_v5 with data privacy, RFC 2623 |
RFC 5531 |
|
|
390256-199999999 |
Unassigned |
|
|
|
200000000 |
Reserved |
RFC 5531 |
|
|
200100000 |
NeXT Inc. |
RFC 5531 |
RPC Authentication Status Numbers
- RFC 5531: RPC: Remote Procedure Call Protocol Specification Version 2
For all RPC authentication flavor and authentication status numbers
to be used on the Internet, it is strongly advised that an
informational or standards-track RFC be published describing the
authentication mechanism behaviour and parameters.
| Identifier String |
Flavor Name |
Value |
Description |
Reference |
| AUTH_OK |
|
0 |
success/failed at remote end |
RFC 5531 |
| AUTH_BADCRED |
|
1 |
bad credential (seal broken) |
RFC 5531 |
| AUTH_REJECTEDCRED |
|
2 |
client must begin new session |
RFC 5531 |
| AUTH_BADVERF |
|
3 |
bad verifier (seal broken) |
RFC 5531 |
| AUTH_REJECTEDVERF |
|
4 |
verifier expired or replayed |
RFC 5531 |
| AUTH_TOOWEAK |
|
5 |
rejected for security reasons/failed locally |
RFC 5531 |
| AUTH_INVALIDRESP |
|
6 |
bogus response verifier |
RFC 5531 |
| AUTH_FAILED |
|
7 |
reason unknown/AUTH_KERB errors; deprecated. See [RFC2695] |
RFC 5531 |
| AUTH_KERB_GENERIC |
|
8 |
kerberos generic error |
RFC 5531 |
| AUTH_TIMEEXPIRE |
|
9 |
time of credential expired |
RFC 5531 |
| AUTH_TKT_FILE |
|
10 |
problem with ticket file |
RFC 5531 |
| AUTH_DECODE |
|
11 |
can't decode authenticator |
RFC 5531 |
| AUTH_NET_ADDR |
|
12 |
wrong net address in ticket/RPCSEC_GSS GSS related errors |
RFC 5531 |
| RPCSEC_GSS_CREDPROBLEM |
|
13 |
no credentials for user |
RFC 5531 |
| RPCSEC_GSS_CTXPROBLEM |
|
14 |
problem with context |
RFC 5531 |
| RPCSEC_GSS_INNER_CREDPROBLEM |
|
15 |
No credentials for multi-principal assertion inner context user |
RFC 7861 |
| RPCSEC_GSS_LABEL_PROBLEM |
|
16 |
Problem with label assertion |
RFC 7861 |
| RPCSEC_GSS_PRIVILEGE_PROBLEM |
|
17 |
Problem with structured privilege assertion |
RFC 7861 |
| RPCSEC_GSS_UNKNOWN_MESSAGE |
|
18 |
Unknown structured privilege assertion |
RFC 7861 |
RPCSEC_GSS Structured Privilege Names Registry
- RFC 7861: Remote Procedure Call (RPC) Security Version 3
The structured privilege with a zero-length name and the fifteen
additional lower case and mixed case permutations of each of 'EXPE'
and 'PRIV' are also Reserved.
Contact Information