ONC RPC Network Identifiers (netids)

Created

  • 2009-02-06

Last Updated

  • 2022-08-19

Available Formats


ONC RPC Netids (First Come First Served)

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5665: IANA Considerations for Remote Procedure Call (RPC) Network Identifiers and Universal Address Formats

Available Formats

Netid Constant Name Description and/or Reference Point of Contact Cross Reference to Uaddr Format Registry
"-" NC_NOPROTO RFC 1833, Section 4.2.3.2 of RFC 5665 1
"ticlts" NC_TICLTS The loop back connectionless transport used in System V Release 4 and other operating systems. Although this assignment is made on a First Come First Served basis and is fewer than nine characters long, the exception is authorized. See American Telephone and Telegraph Company, "UNIX System V, Release 4 Programmer's Guide: Networking Interfaces, ISBN 0139470786", 1990. 0
"ticots" NC_TICOTS The loop back connection-oriented transport used in System V Release 4 and other operating systems. See American Telephone and Telegraph Company, "UNIX System V, Release 4 Programmer's Guide: Networking Interfaces, ISBN 0139470786", 1990. Although this assignment is made on a First Come First Served basis and is fewer than nine characters long, the exception is authorized. 0
"ticotsord" NC_TICOTSORD The loop back connection-oriented with orderly-release transport used in System V Release 4 and other operating systems. See American Telephone and Telegraph Company, "UNIX System V, Release 4 Programmer's Guide: Networking Interfaces, ISBN 0139470786", 1990. 0

ONC RPC Netids (Standards Action)

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 5665: IANA Considerations for Remote Procedure Call (RPC) Network Identifiers and Universal Address Formats

Available Formats

Netid Constant Name RFC(s) and Description (if needed) Point of Contact Cross Reference to Uaddr Format Registry
"rdma" NC_RDMA RFC 8166; RFC 791 IESG 2
"rdma6" NC_RDMA6 RFC 8166; RFC 8200 IESG 3
"sctp" NC_SCTP RFC 9260; RFC 791; Section 2 of RFC 5665 IESG 2
"sctp6" NC_SCTP6 RFC 9260; RFC 8200; Section 2 of RFC 5665 IESG 3
"tcp" NC_TCP RFC 9293; RFC 791; Section 10 of RFC 1831 IESG 2
"tcp6" NC_TCP6 RFC 9293; RFC 8200; Section 10 of RFC 1831 IESG 3
"udp" NC_UDP RFC 768; RFC 791 IESG 2
"udp6" NC_UDP6 RFC 768; RFC 8200 IESG 3

Contact Information

Name Contact URI Last Updated
IESG iesg&ietf.org 2009-02-06