Routing Protocol for Low Power and Lossy Networks (RPL)
Created
- 2011-04-08
Last Updated
- 2026-04-17
Available Formats
RPL Control Codes
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Code | Description | Reference |
|---|---|---|
| 0x00 | DODAG Information Solicitation | RFC 6550 |
| 0x01 | DODAG Information Object | RFC 6550 |
| 0x02 | Destination Advertisement Object | RFC 6550 |
| 0x03 | Destination Advertisement Object Acknowledegment | RFC 6550 |
| 0x04 | P2P Discovery Reply Object | RFC 6997 |
| 0x05 | P2P Discovery Reply Object Acknowledgement | RFC 6997 |
| 0x06 | Measurement Object | RFC 6998 |
| 0x07 | Destination Cleanup Object | RFC 9009 |
| 0x08 | Destination Cleanup Object Acknowledgment | RFC 9009 |
| 0x09 | Projected DAO Request (P-DAO-REQ) | RFC 9914 |
| 0x0A | Projected DAO Request Acknowledgment (PDR-ACK) | RFC 9914 |
| 0x0B-0x7A | Unassigned | |
| 0x80 | Secure DODAG Information Solicitation | RFC 6550 |
| 0x81 | Secure DODAG Information Object | RFC 6550 |
| 0x82 | Secure Destination Advertisement Object | RFC 6550 |
| 0x83 | Secure Destination Advertisement Object Acknowledgment | RFC 6550 |
| 0x84 | Secure P2P Discovery Reply Object | RFC 6997 |
| 0x85 | Secure P2P Discovery Reply Object Acknowledgement | RFC 6997 |
| 0x86 | Secure Measurement Object | RFC 6998 |
| 0x87 | Secure Destination Cleanup Object | RFC 9009 |
| 0x88 | Secure Destination Cleanup Object Acknowledgment | RFC 9009 |
| 0x89 | Unassigned | |
| 0x8A | Consistency Check | RFC 6550 |
| 0x8B-0xFF | Unassigned |
Mode of Operation
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
- RFC 9008: Using RPI Option Type, Routing Header for Source Routes, and IPv6-in-IPv6 Encapsulation in the RPL Data Plane
Available Formats
| Value | Description | Reference |
|---|---|---|
| 0 | No Downward routes maintained by RPL | RFC 6550 |
| 1 | Non-Storing Mode of Operation | RFC 6550 |
| 2 | Storing Mode of Operation with no multicast support | RFC 6550 |
| 3 | Storing Mode of Operation with multicast support | RFC 6550 |
| 4 | P2P Route Discovery Mode of Operation | RFC 6997; RFC 9854 |
| 5 | Non-Storing Mode of Operation with ingress replication multicast support | RFC 9685 |
| 6 | Unassigned | |
| 7 | Reserved | RFC 9008; RFC 9010; RFC 9035; RFC 9914 |
RPL Control Message Options
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Value | Meaning | Reference |
|---|---|---|
| 0x00 | Pad1 | RFC 6550 |
| 0x01 | PadN | RFC 6550 |
| 0x02 | DAG Metric Container | RFC 6550 |
| 0x03 | Routing Information | RFC 6550 |
| 0x04 | DODAG Configuration | RFC 6550 |
| 0x05 | RPL Target | RFC 6550 |
| 0x06 | Transit Information | RFC 6550 |
| 0x07 | Solicited Information | RFC 6550 |
| 0x08 | Prefix Information | RFC 6550 |
| 0x09 | Target Descriptor | RFC 6550 |
| 0x0A | P2P Route Discovery | RFC 6997 |
| 0x0B | RREQ | RFC 9854 |
| 0x0C | RREP | RFC 9854 |
| 0x0D | ART | RFC 9854 |
| 0x0E | RNFD Option | RFC 9866 |
| 0x0F | Stateful Storing Mode VIO (SM-VIO) | RFC 9914 |
| 0x10 | Source-Routed Non-Storing Mode VIO (NSM-VIO) | RFC 9914 |
| 0x11 | Sibling Information Option (SIO) | RFC 9914 |
| 0x12-0xFF | Unassigned |
Objective Code Point (OCP)
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
Security Section Algorithm
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Value | Encryption/MAC | Signature | Reference |
|---|---|---|---|
| 0 | CCM with AES-128 | RSA with SHA-256 | RFC 6550 |
| 1-255 | Unassigned | Unassigned |
Security Section Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Bit Number | Capability Description | Reference |
|---|---|---|
| 0-7 | Unassigned |
Per-KIM Security Levels
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Level | KIM Value | Description | Reference |
|---|---|---|---|
| 0 | 0 | See Figure 11 | RFC 6550 |
| 1 | 0 | See Figure 11 | RFC 6550 |
| 2 | 0 | See Figure 11 | RFC 6550 |
| 3 | 0 | See Figure 11 | RFC 6550 |
| 0 | 1 | See Figure 11 | RFC 6550 |
| 1 | 1 | See Figure 11 | RFC 6550 |
| 2 | 1 | See Figure 11 | RFC 6550 |
| 3 | 1 | See Figure 11 | RFC 6550 |
| 0 | 2 | See Figure 11 | RFC 6550 |
| 1 | 2 | See Figure 11 | RFC 6550 |
| 2 | 2 | See Figure 11 | RFC 6550 |
| 3 | 2 | See Figure 11 | RFC 6550 |
| 0 | 3 | See Figure 11 | RFC 6550 |
| 1 | 3 | See Figure 11 | RFC 6550 |
| 2 | 3 | See Figure 11 | RFC 6550 |
| 3 | 3 | See Figure 11 | RFC 6550 |
DODAG Informational Solicitation (DIS) Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Bit Number | Capability Description | Reference |
|---|---|---|
| 0-7 | Unassigned |
DODAG Information Object (DIO) Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Bit Number | Capability Description | Reference |
|---|---|---|
| 0-7 | Unassigned |
Destination Advertisement Object (DAO) Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
Destination Advertisement Object (DAO) Acknowledgment Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
Consistency Check (CC) Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
| Bit Number | Capability Description | Reference |
|---|---|---|
| 0 | CC Response (R) | RFC 6550 |
| 1-7 | Unassigned |
DODAG Configuration Option Flags for MOP 0..6
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
- RFC 9008: Using RPI Option Type, Routing Header for Source Routes, and IPv6-in-IPv6 Encapsulation in the RPL Data Plane
Available Formats
RPL Target Option Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
- RFC 9010: Routing for RPL (Routing Protocol for Low-Power and Lossy Networks) Leaves
Available Formats
| Bit Number | Capability Description | Reference |
|---|---|---|
| 0 | Advertiser address in Full (F) | RFC 9010 |
| 1 | Proxy EDAR Requested (X) | RFC 9010 |
| 2-3 | P-Field (2 bits) | RFC 9685, Section 14.1; RFC 9926 |
Transit Information Option Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
Solicited Information Option Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6550: RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Available Formats
Destination Cleanup Object (DCO) Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 9009: Efficient Route Invalidation
Available Formats
Destination Cleanup Object Acknowledgment (DCO) Acknowledgment Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 9009: Efficient Route Invalidation
Available Formats
| Bit Number | Capability Description | Reference |
|---|---|---|
| 0 | DODAGID field is present (D) | RFC 9009 |
| 1-7 | Unassigned |
RPL Non-Rejection Status
Registration Procedure(s)
- IETF Review
Reference
- RFC 9010: Routing for RPL (Routing Protocol for Low-Power and Lossy Networks) Leaves
Available Formats
RPL Rejection Status
Registration Procedure(s)
- IETF Review
Reference
- RFC 9010: Routing for RPL (Routing Protocol for Low-Power and Lossy Networks) Leaves
Available Formats
RPL Option Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)
Available Formats
Projected DAO Request (P-DAO-REQ) Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)
Available Formats
Projected DAO Request Acknowledgment (PDR-ACK) Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)
| Bit Number | Capability Description | Reference |
|---|---|---|
| No registrations at this time. | ||
PDR-ACK Acceptance Status Values
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)
Available Formats
| Value | Meaning | Reference |
|---|---|---|
| 0 | Unqualified Acceptance | RFC 9914 |
| 1-63 | Unassigned |
PDR-ACK Rejection Status Values
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)
Available Formats
Via Information Options (VIO) Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)
| Bit Number | Capability Description | Reference |
|---|---|---|
| No registrations at this time. | ||
Sibling Information Option (SIO) Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 9914: Root-Initiated Routing State in the Routing Protocol for Low-Power and Lossy Networks (RPL)