Reliable Server Pooling (RSerPool) Parameters
Created
- 2008-07-25
Last Updated
- 2008-09-30
Available Formats
Aggregate Server Access Protocol (ASAP) Message Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5352: Aggregate Server Access Protocol (ASAP)
Available Formats
| Type | Message Name | Reference |
|---|---|---|
| 0x00 | Reserved | RFC 5352 |
| 0x01 | ASAP_REGISTRATION | RFC 5352 |
| 0x02 | ASAP_DEREGISTRATION | RFC 5352 |
| 0x03 | ASAP_REGISTRATION_RESPONSE | RFC 5352 |
| 0x04 | ASAP_DEREGISTRATION_RESPONSE | RFC 5352 |
| 0x05 | ASAP_HANDLE_RESOLUTION | RFC 5352 |
| 0x06 | ASAP_HANDLE_RESOLUTION_RESPONSE | RFC 5352 |
| 0x07 | ASAP_ENDPOINT_KEEP_ALIVE | RFC 5352 |
| 0x08 | ASAP_ENDPOINT_KEEP_ALIVE_ACK | RFC 5352 |
| 0x09 | ASAP_ENDPOINT_UNREACHABLE | RFC 5352 |
| 0x0a | ASAP_SERVER_ANNOUNCE | RFC 5352 |
| 0x0b | ASAP_COOKIE | RFC 5352 |
| 0x0c | ASAP_COOKIE_ECHO | RFC 5352 |
| 0x0d | ASAP_BUSINESS_CARD | RFC 5352 |
| 0x0e | ASAP_ERROR | RFC 5352 |
| 0x0f-0xff | Unassigned |
Endpoint Handlespace Redundancy Protocol (ENRP) Message Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5353: Endpoint Handlespace Redundancy Protocol (ENRP)
Available Formats
| Type | Message Name | Reference |
|---|---|---|
| 0x00 | Reserved | RFC 5353 |
| 0x01 | ENRP_PRESENCE | RFC 5353 |
| 0x02 | ENRP_HANDLE_TABLE_REQUEST | RFC 5353 |
| 0x03 | ENRP_HANDLE_TABLE_RESPONSE | RFC 5353 |
| 0x04 | ENRP_HANDLE_UPDATE | RFC 5353 |
| 0x05 | ENRP_LIST_REQUEST | RFC 5353 |
| 0x06 | ENRP_LIST_RESPONSE | RFC 5353 |
| 0x07 | ENRP_INIT_TAKEOVER | RFC 5353 |
| 0x08 | ENRP_INIT_TAKEOVER_ACK | RFC 5353 |
| 0x09 | ENRP_TAKEOVER_SERVER | RFC 5353 |
| 0x10 | ENRP_ERROR | RFC 5353 |
| 0x0b-0xff | Unassigned |
Update Action Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5353: Endpoint Handlespace Redundancy Protocol (ENRP)
Available Formats
RSerPool Parameter Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5354: Aggregate Server Access Protocol (ASAP) and Endpoint Handlespace Redundancy Protocol (ENRP) Parameters
Available Formats
| Value | Parameter Type | Reference |
|---|---|---|
| 0x0 | Reserved | RFC 5354 |
| 0x1 | IPv4 Address | RFC 5354 |
| 0x2 | IPv6 Address | RFC 5354 |
| 0x3 | DCCP Transport | RFC 5354 |
| 0x4 | SCTP Transport | RFC 5354 |
| 0x5 | TCP Transport | RFC 5354 |
| 0x6 | UDP Transport | RFC 5354 |
| 0x7 | UDP-Lite | RFC 5354 |
| 0x8 | Pool Member Selection Policy | RFC 5354 |
| 0x9 | Pool Handle | RFC 5354 |
| 0xa | Pool Element | RFC 5354 |
| 0xb | Server Information | RFC 5354 |
| 0xc | Operation Error | RFC 5354 |
| 0xd | Cookie | RFC 5354 |
| 0xe | PE Identifier | RFC 5354 |
| 0xf | PE Checksum | RFC 5354 |
| 0x10 | Opaque Transport | RFC 5354 |
| 0x11-0xfffffffe | Unassigned | |
| 0xffffffff | IETF-defined extensions | RFC 5354 |
RSerPool Error Causes
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5354: Aggregate Server Access Protocol (ASAP) and Endpoint Handlespace Redundancy Protocol (ENRP) Parameters
Available Formats
| Value | Cause Code | Reference |
|---|---|---|
| 0x0 | Unspecified Error | RFC 5354 |
| 0x1 | Unrecognized Parameter | RFC 5354 |
| 0x2 | Unrecognized Message | RFC 5354 |
| 0x3 | Invalid Values | RFC 5354 |
| 0x4 | Non-unique PE Identifier | RFC 5354 |
| 0x5 | Inconsistent Pooling Policy | RFC 5354 |
| 0x6 | Lack of Resources | RFC 5354 |
| 0x7 | Inconsistent Transport Type | RFC 5354 |
| 0x8 | Inconsistent Data/Control Configuration | RFC 5354 |
| 0x9 | Unknown Pool Handle | RFC 5354 |
| 0xa | Rejected due to security considerations | RFC 5354 |
| 0xb-0xffff | Unassigned |
RSerPool Policy Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5356: Reliable Server Pooling Policies
Available Formats
| Value | Policy | Reference |
|---|---|---|
| 0x00000000 | Reserved | RFC 5356 |
| 0x00000001 | Round Robin | RFC 5356 |
| 0x00000002 | Weighted Round Robin | RFC 5356 |
| 0x00000003 | Random | RFC 5356 |
| 0x00000004 | Weighted Random | RFC 5356 |
| 0x00000005 | Priority | RFC 5356 |
| 0x00000006-0x3fffffff | Unassigned | |
| 0x40000000 | Reserved | RFC 5356 |
| 0x40000001 | Least Used | RFC 5356 |
| 0x40000002 | Least Used with Degradation | RFC 5356 |
| 0x40000003 | Priority Least Used | RFC 5356 |
| 0x40000004 | Randomized Least Used | RFC 5356 |
| 0x40000005-0x7fffffff | Unassigned | |
| 0x80000000-0xffffffff | Reserved for Private Use | RFC 5356 |