RSVP-TE OAM Configuration Registry

Created

  • 2014-03-11

Last Updated

  • 2015-03-19

Available Formats


OAM Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7260: GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) Configuration

Available Formats

Type Description Reference
0 Unassigned
1 Ethernet OAM RFC 7369
2 Unassigned
3 MPLS OAM RFC 7487
4-255 Unassigned

OAM Sub-TLVs

Reference

  • RFC 7260: GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) Configuration
  • RFC Errata 4106

Available Formats

Range Registration Procedures Note
0-31 IETF Review Generic Sub-TLVs
32-65533 IETF Review Technology-specific Sub-TLVs
65534-65535 Reserved for Experimental Use Experimental Sub-TLVs
Type Description Reference
0 Reserved RFC 7260
1 OAM Function Flags Sub-TLV RFC 7260
2-31 Unassigned
32 Ethernet OAM Configuration Sub-TLV RFC 7369
33 MPLS OAM Configuration Sub-TLV RFC 7487
34-65533 Unassigned
65534-65535 Reserved for Experimental Use RFC 7260; RFC Errata 4106

OAM Function Flags Sub-Registry

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7260: GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) Configuration

Available Formats

Bit Number Description Reference
0 Continuity Check (CC) RFC 7260
1 Connectivity Verification (CV) RFC 7260
2 Fault Management Signal (FMS) RFC 7260
3 Performance Monitoring/Loss (PM/Loss) RFC 7260
4 Performance Monitoring/Delay (PM/Delay) RFC 7260
5 Performance Monitoring/Throughput Measurement (PM/Throughput) RFC 7260
>= 6 Unassigned

Ethernet Sub-TLVs Sub-Registry

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7369: GMPLS RSVP-TE Extensions for Ethernet Operations, Administration, and Maintenance (OAM) Configuration

Available Formats

Type Description Reference
0 Reserved RFC 7369
1 MD Name Sub-TLV RFC 7369
2 Short MA Name Sub-TLV RFC 7369
3 MEP ID Sub-TLV RFC 7369
4 Continuity Check Sub-TLV RFC 7369
5-65534 Unassigned
65535 Reserved for Experimental Use RFC 7369

MPLS OAM Configuration Sub-TLV Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7487: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using RSVP-TE

Available Formats

Type Description Reference
0 Reserved RFC 7487
1 BFD Configuration Sub-TLV RFC 7487
2 Performance Monitoring Sub-TLV RFC 7487
3 MPLS OAM FMS Sub-TLV RFC 7487
4-65532 Unassigned
65533-65534 Reserved for Experimental Use RFC 7487
65535 Reserved RFC 7487

BFD Configuration Sub-TLV Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7487: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using RSVP-TE

Available Formats

Type Description Reference
0 Reserved RFC 7487
1 BFD Identifiers Sub-TLV RFC 7487
2 Negotiation Timer Parameters Sub-TLV RFC 7487
3 BFD Authentication Sub-TLV RFC 7487
4 Traffic Class Sub-TLV RFC 7487
5-65532 Unassigned
65533-65534 Reserved for Experimental Use RFC 7487
65535 Reserved RFC 7487

Performance Monitoring Sub-TLV Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7487: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using RSVP-TE

Available Formats

Type Description Reference
0 Reserved RFC 7487
1 MPLS OAM PM Loss Sub-TLV RFC 7487
2 MPLS OAM PM Delay Sub-TLV RFC 7487
3-65532 Unassigned
65533-65534 Reserved for Experimental Use RFC 7487
65535 Reserved RFC 7487