Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Parameters
Created
- 2006-01-23
Last Updated
- 2026-08-10
Available Formats
Attributes TLV Space
Registration Procedure(s)
- IETF Review
Reference
- RFC 5420: Encoding of Attributes for MPLS LSP Establishment Using Resource Reservation Protocol Traffic Engineering (RSVP-TE)
- RFC 7570: Label Switched Path (LSP) Attribute in the Explicit Route Object (ERO)
Available Formats
| Type | Name | Allowed on LSP_ATTRIBUTES | Allowed on LSP_REQUIRED_ATTRIBUTES | Allowed on LSP Hop Attributes | Reference |
|---|---|---|---|---|---|
| 1 | Attribute Flags | Yes | Yes | Yes | RFC 5420; RFC 7570 |
| 2 | Service ID TLV | Yes | No | No | RFC 6060; RFC 7570 |
| 3 | OAM Configuration TLV | Yes | Yes | No | RFC 7260; RFC 7570 |
| 4 | WSON Processing Hop Attribute TLV | No | No | Yes | RFC 7689 |
| 5 | RTM_SET sub-object | Yes | No | No | RFC 8169 |
| 6 | ETLD | No | No | Yes | RFC 8577, Section 9.7 |
Attribute Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 5420: Encoding of Attributes for MPLS LSP Establishment Using Resource Reservation Protocol Traffic Engineering (RSVP-TE)
- RFC 7570: Label Switched Path (LSP) Attribute in the Explicit Route Object (ERO)
Available Formats
| Bit No | Name | Attribute Flags Path | Attribute Flags Resv | RRO | ERO | Reference |
|---|---|---|---|---|---|---|
| 0 | End-to-end re-routing | Yes | No | No | No | RFC 4920; RFC 5420; RFC 7570 |
| 1 | Boundary re-routing | Yes | No | No | No | RFC 4920; RFC 5420; RFC 7570 |
| 2 | Segment-based re-routing | Yes | No | No | No | RFC 4920; RFC 5420; RFC 7570 |
| 3 | LSP Integrity Required | Yes | No | No | No | RFC 4875; RFC 7570 |
| 4 | Contiguous LSP | Yes | No | Yes | No | RFC 5151; RFC 7570 |
| 5 | LSP stitching desired | Yes | No | Yes | No | RFC 5150; RFC 7570 |
| 6 | Pre-Planned LSP Flag | Yes | No | No | No | RFC 6001; RFC 7570 |
| 7 | Non-PHP behavior flag | Yes | No | Yes | No | RFC 6511; RFC 7570 |
| 8 | OOB mapping flag | Yes | No | Yes | No | RFC 6511; RFC 7570 |
| 9 | Entropy Label Capability | Yes | Yes | No | No | RFC 6790; RFC 7570 |
| 10 | OAM MEP entities desired | Yes | Yes | Yes | No | RFC 7260; RFC 7570 |
| 11 | OAM MIP entities desired | Yes | Yes | Yes | No | RFC 7260; RFC 7570 |
| 12 | SRLG Collection Flag | Yes | No | Yes | No | RFC 8001; RFC 7570 |
| 13 | Loopback | Yes | No | Yes | Yes | RFC 7571 |
| 14 | P2MP-TE Tree Re-evaluation Request | Yes | No | No | No | RFC 8149 |
| 15 | RTM_SET | Yes | Yes | No | No | RFC 8169 |
| 16 | TE Link Label | Yes | No | No | No | RFC 8577, Section 9.2 |
| 17 | LSI-D | Yes | No | No | Yes | RFC 8577, Section 9.4 |
| 18 | LSI-D-S2E | Yes | No | No | No | RFC 8577, Section 9.6 |
Session Attribute Object Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 4859: Codepoint Registry for the Flags Field in the Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Session Attribute Object
Available Formats
Record Route Object Sub-object Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 3209: RSVP-TE: Extensions to RSVP for LSP Tunnels
Available Formats
Label Sub-object Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 8577: Signaling RSVP-TE Tunnels on a Shared MPLS Forwarding Plane
- RFC Errata 5743
Available Formats
| Flag | Name | Reference |
|---|---|---|
| 0x01 | Global Label | RFC 3209 |
| 0x02 | TE Link Label | RFC 8577, Section 9.3 |
| 0x04 | Delegation Label | RFC 8577, Section 9.5 |
| 0x08 | Unassigned | |
| 0x10 | Unassigned | |
| 0x20 | Unassigned | |
| 0x40 | Unassigned | |
| 0x80 | Unassigned |
Sub-TLV Types for WSON Processing Hop Attribute TLV
Registration Procedure(s)
- Standards Action or Specification Required
Expert(s)
- Unassigned
Reference
- RFC 7689: Signaling Extensions for Wavelength Switched Optical Networks
Available Formats
Values for Wavelength Assignment Method field in WavelengthSelection Sub-TLV
Registration Procedure(s)
- Standards Action or Specification Required
Expert(s)
- Unassigned
Reference
- RFC 7689: Signaling Extensions for Wavelength Switched Optical Networks
Available Formats
RTM_SET Object Sub-Object Types
Reference
- RFC 8169: Residence Time Measurement in MPLS Networks
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-127 | IETF Review |
| 128-191 | First Come First Served |