RTP Control Protocol Extended Reports (RTCP XR) Block Type Registry

Created

  • 2003-08-29

Last Updated

  • 2026-08-04

Available Formats


RTCP XR Block Type

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Joerg Ott

Reference

  • RFC 3611: RTP Control Protocol Extended Reports (RTCP XR)

Available Formats

BT Name Reference
1 Loss RLE Report Block RFC 3611
2 Duplicate RLE Report Block RFC 3611
3 Packet Receipt Times Report Block RFC 3611
4 Receiver Reference Time Report Block RFC 3611
5 DLRR Report Block RFC 3611
6 Statistics Summary Report Block RFC 3611
7 VoIP Metrics Report Block RFC 3611
8 RTCP XR RFC 5093
9 Texas Instruments Extended VoIP Quality Block http://focus.ti.com/general/docs/bcg/bcgdoccenter.tsp?templateId=6116&navigationId=12078#42; David Lide
10 Post-repair Loss RLE Report Block RFC 5725
11 Multicast Acquisition Report Block RFC 6332
12 IDMS Report Block RFC 7272
13 ECN Summary Report RFC 6679
14 Measurement Information Block RFC 6776
15 Packet Delay Variation Metrics Block RFC 6798
16 Delay Metrics Block RFC 6843
17 Burst/Gap Loss Summary Statistics Block RFC 7004
18 Burst/Gap Discard Summary Statistics Block RFC 7004
19 Frame Impairment Statistics Summary RFC 7004
20 Burst/Gap Loss Metrics Block RFC 6958
21 Burst/Gap Discard Metrics Block RFC 7003; RFC Errata 3735
22 MPEG2 Transport Stream PSI-Independent Decodability Statistics Metrics Block RFC 6990
23 De-Jitter Buffer Metrics Block RFC 7005
24 Discard Count Metrics Block RFC 7002
25 DRLE (Discard RLE Report) RFC 7097
26 BDR (Bytes Discarded Report) RFC 7243
27 RFISD (RTP Flows Initial Synchronization Delay) RFC 7244
28 RFSO (RTP Flows Synchronization Offset Metrics Block) RFC 7244
29 MOS Metrics Block RFC 7266
30 LCB (Loss Concealment Metrics Block) RFC 7294, Section 4.1
31 CSB (Concealed Seconds Metrics Block) RFC 7294, Section 4.1
32 MPEG2 Transport Stream PSI Decodability Statistics Metrics Block RFC 7380
33 Post-Repair Loss Count Metrics Report Block RFC 7509
34 Video Loss Concealment Metric Report Block RFC 7867
35 Independent Burst/Gap Discard Metrics Block RFC 8015
36 Timing Information for QoE Metrics Calculation Block Clause 5.2 of 3GPP TS 26.522 v18.1.0; 3GPP Specifications Manager
37-254 Unassigned
255 Reserved for future extensions RFC 3611

RTCP XR PDV block - PDV type

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6798: RTP Control Protocol (RTCP) Extended Report (XR) Block for Packet Delay Variation Metric Reporting

Available Formats

Value Name Reference
0 MAPDV2 Clause 6.2.3.2 of ITU-T Rec. G.1020, RFC 6798
1 2-point PDV Clause 6.2.4 of ITU-T Rec. Y.1540, RFC 6798
2-15 Unassigned

IDMS XR Block SPST Registry

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 7272: Inter-Destination Media Synchronization (IDMS) Using the RTP Control Protocol (RTCP)

Available Formats

Value Name Reference
0 Reserved RFC 7272
1 Synchronization Client RFC 7272, Section 7
2 MSAS TS 183 063
3 SC Prime Input TS 183 063
4 SC Prime Output TS 183 063
5-15 Unassigned

RTCP XR MOS Metric block - multimedia application Calculation Algorithm

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 7266: RTP Control Protocol (RTCP) Extended Report (XR) Blocks for Mean Opinion Score (MOS) Metric Reporting

Available Formats

Name Description Type Reference
P564 ITU-T P.564 Compliant Algorithm voice ITU-T Recommendation P.564, July 2006
G107 ITU-T G.107 voice ITU-T Recommendation G.107, April 2009
TS101_329 ETSI TS 101 329-5 Annex E voice ETSI TS 101 329-5 V1.1.1
JJ201_1 TTC JJ201.1 voice TTC 201.01, "A method for speech quality assessment for Voice over IP."
G107_1 ITU-T G.107.1 voice ITU-T Recommendation G.107.1, December 2011
P862 ITU-T P.862 voice ITU-T Recommendation P.862, February 2001
P862_2 ITU-T P.862.2 voice ITU-T Recommendation P.862.2, November 2007
P863 ITU-T P.863 voice ITU-T Recommendation P.863, January 2011
P1201_1 ITU-T P.1201.1 multimedia ITU-T P.1201.1, October 2012
P1201_2 ITU-T P.1201.2 multimedia ITU-T P.1201.2, October 2012
P1202_1 ITU-T P.1202.1 video ITU-T P.1202.1, October 2012
P1202_2 ITU-T P.1202.2 video ITU-T P.1202.2, May 2013

Contact Information

Name Contact URI Last Updated
3GPP Specifications Manager 3GPPContact&3gpp.org 2026-08-04
David Lide dlide&ti.com 2007-06-01