System for Cross-domain Identity Management (SCIM) Schema URIs

Created

  • 2015-06-22

Last Updated

  • 2026-05-21

Available Formats


SCIM Schema URIs for Data Resources

Expert(s)

  • Phil Hunt, Paulo Jorge N. Correia

Reference

  • RFC 7643: System for Cross-domain Identity Management: Core Schema

Note

Registration templates should be sent to iana@iana.org and the scim@ietf.org mailing list. See RFC 7643, Section 10.3.1.

Available Formats

Range Registration Procedures
"core" and "API" schemas RFC and Expert Review Required
All other schemas Expert Review
Schema URI Name Reference
urn:ietf:params:scim:schemas:core:2.0:User User Resource RFC 7643, Section 4.1
urn:ietf:params:scim:schemas:extension:enterprise:2.0:User Enterprise User Extension RFC 7643, Section 4.3
urn:ietf:params:scim:schemas:core:2.0:Group Group Resource RFC 7643, Section 4.2
urn:ietf:params:scim:api:messages:2.0:ListResponse List/Query Response RFC 7644, Section 3.4.2; RFC 9865, Section 2
urn:ietf:params:scim:api:messages:2.0:SearchRequest POST Query Request RFC 7644, Section 3.4.3; RFC 9865, Section 2
urn:ietf:params:scim:api:messages:2.0:PatchOp PATCH Operation RFC 7644, Section 3.5.2
urn:ietf:params:scim:api:messages:2.0:BulkRequest Bulk Operations Request RFC 7644, Section 3.7
urn:ietf:params:scim:api:messages:2.0:BulkResponse Bulk Operations Response RFC 7644, Section 3.7
urn:ietf:params:scim:api:messages:2.0:Error Error Response RFC 7644, Section 3.12
urn:ietf:params:scim:schemas:core:2.0:Device Core Device Schema RFC 9944, Section 3
urn:ietf:params:scim:schemas:core:2.0:EndpointApp Endpoint Application RFC 9944, Section 6


SCIM Event URIs

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Phil Hunt, Paulo Jorge N. Correia, Danny Zollner

Reference

  • RFC 9967: System for Cross-Domain Identity Management (SCIM) Profile for Security Event Tokens (SETs)

Available Formats

Event URI Name Reference
urn:ietf:params:scim:event:feed:add Resource added to Feed Event RFC 9967, Section 2.3.1
urn:ietf:params:scim:event:feed:remove Remove resource from Feed Event RFC 9967, Section 2.3.2
urn:ietf:params:scim:event:prov:create:notice New Resource Event (notice only) RFC 9967, Section 2.4.1
urn:ietf:params:scim:event:prov:create:full New Resource Event (full data) RFC 9967, Section 2.4.1
urn:ietf:params:scim:event:prov:patch:notice Resource Patch Event (notice only) RFC 9967, Section 2.4.2
urn:ietf:params:scim:event:prov:patch:full Resource Patch Event (full data) RFC 9967, Section 2.4.2
urn:ietf:params:scim:event:prov:put:notice Resource Put Event (notice only) RFC 9967, Section 2.4.3
urn:ietf:params:scim:event:prov:put:full Resource Put Event (full data) RFC 9967, Section 2.4.3
urn:ietf:params:scim:event:prov:delete Resource Deleted Event RFC 9967, Section 2.4.4
urn:ietf:params:scim:event:prov:activate Resource Activated Event RFC 9967, Section 2.4.5
urn:ietf:params:scim:event:prov:deactivate Resource Deactivated Event RFC 9967, Section 2.4.6
urn:ietf:params:scim:event:misc:asyncresp Asynchronous Request Completion RFC 9967, Section 2.5.1