Session Description Protocol (SDP) Security Descriptions

Created

  • 2005-09-21

Last Updated

  • 2015-12-11

Available Formats


Key Methods

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams

Available Formats

Key Methods Reference
inline RFC 4568

Media Stream Transports

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams

Note

Each Media Stream Transport registry must contain a crypto-suite and session parameter registry.

Available Formats

Media Stream Transport Name Supported Key Methods Reference
SRTP inline RFC 4568

SRTP Crypto Suite Registrations

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams

Available Formats

Crypto Suite Name Reference
AES_CM_128_HMAC_SHA1_80 RFC 4568
AES_CM_128_HMAC_SHA1_32 RFC 4568
F8_128_HMAC_SHA1_80 RFC 4568
SEED_CTR_128_HMAC_SHA1_80 RFC 5669
SEED_128_CCM_80 RFC 5669
SEED_128_GCM_96 RFC 5669
AES_192_CM_HMAC_SHA1_80 RFC 6188
AES_192_CM_HMAC_SHA1_32 RFC 6188
AES_256_CM_HMAC_SHA1_80 RFC 6188
AES_256_CM_HMAC_SHA1_32 RFC 6188
AEAD_AES_128_GCM RFC 7714
AEAD_AES_256_GCM RFC 7714

SRTP Session Parameters

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams

Available Formats

Parameter Name Reference
KDR RFC 4568
UNENCRYPTED_SRTP RFC 4568
UNENCRYPTED_SRTCP RFC 4568
UNAUTHENTICATED_SRTP RFC 4568
FEC_ORDER RFC 4568
FEC_KEY RFC 4568
WSH RFC 4568