Segment Routing

Created

  • 2021-01-08

Last Updated

  • 2026-10-12

Available Formats


SRv6 Endpoint Behaviors

Reference

  • RFC 8986: Segment Routing over IPv6 (SRv6) Network Programming

Available Formats

Range Registration Procedures Note
0 Reserved Not to be allocated
1-32767 First Come First Served
32768-34815 Private Use
34816-65534 Reserved
65535 Reserved Opaque
Value Hex Endpoint Behavior Reference Change Controller
0 0x0000 Reserved RFC 8986 IETF
1 0x0001 End RFC 8986 IETF
2 0x0002 End with PSP RFC 8986 IETF
3 0x0003 End with USP RFC 8986 IETF
4 0x0004 End with PSP & USP RFC 8986 IETF
5 0x0005 End.X RFC 8986 IETF
6 0x0006 End.X with PSP RFC 8986 IETF
7 0x0007 End.X with USP RFC 8986 IETF
8 0x0008 End.X with PSP & USP RFC 8986 IETF
9 0x0009 End.T RFC 8986 IETF
10 0x000A End.T with PSP RFC 8986 IETF
11 0x000B End.T with USP RFC 8986 IETF
12 0x000C End.T with PSP & USP RFC 8986 IETF
13 0x000D End.B6.Insert draft-filsfils-spring-srv6-net-pgm-insertion-04 Pablo Camarillo
14 0x000E End.B6.Encaps RFC 8986 IETF
15 0x000F End.BM RFC 8986 IETF
16 0x0010 End.DX6 RFC 8986 IETF
17 0x0011 End.DX4 RFC 8986 IETF
18 0x0012 End.DT6 RFC 8986 IETF
19 0x0013 End.DT4 RFC 8986 IETF
20 0x0014 End.DT46 RFC 8986 IETF
21 0x0015 End.DX2 RFC 8986 IETF
22 0x0016 End.DX2V RFC 8986 IETF
23 0x0017 End.DT2U RFC 8986 IETF
24 0x0018 End.DT2M RFC 8986 IETF
25 0x0019 Reserved RFC 8986 IETF
26 0x001A End.B6.Insert.Red draft-filsfils-spring-srv6-net-pgm-insertion-04 Pablo Camarillo
27 0x001B End.B6.Encaps.Red RFC 8986 IETF
28 0x001C End with USD RFC 8986 IETF
29 0x001D End with PSP & USD RFC 8986 IETF
30 0x001E End with USP & USD RFC 8986 IETF
31 0x001F End with PSP, USP & USD RFC 8986 IETF
32 0x0020 End.X with USD RFC 8986 IETF
33 0x0021 End.X with PSP & USD RFC 8986 IETF
34 0x0022 End.X with USP & USD RFC 8986 IETF
35 0x0023 End.X with PSP, USP & USD RFC 8986 IETF
36 0x0024 End.T with USD RFC 8986 IETF
37 0x0025 End.T with PSP & USD RFC 8986 IETF
38 0x0026 End.T with USP & USD RFC 8986 IETF
39 0x0027 End.T with PSP, USP & USD RFC 8986 IETF
40 0x0028 End.MAP RFC 9433 IETF
41 0x0029 End.Limit RFC 9433 IETF
42 0x002A End with NEXT-ONLY-CSID draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
43 0x002B End with NEXT-CSID RFC 9800 IETF
44 0x002C End with NEXT-CSID & PSP RFC 9800 IETF
45 0x002D End with NEXT-CSID & USP RFC 9800 IETF
46 0x002E End with NEXT-CSID, PSP & USP RFC 9800 IETF
47 0x002F End with NEXT-CSID & USD RFC 9800 IETF
48 0x0030 End with NEXT-CSID, PSP & USD RFC 9800 IETF
49 0x0031 End with NEXT-CSID, USP & USD RFC 9800 IETF
50 0x0032 End with NEXT-CSID, PSP, USP & USD RFC 9800 IETF
51 0x0033 End.X with NEXT-ONLY-CSID draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
52 0x0034 End.X with NEXT-CSID RFC 9800 IETF
53 0x0035 End.X with NEXT-CSID & PSP RFC 9800 IETF
54 0x0036 End.X with NEXT-CSID & USP RFC 9800 IETF
55 0x0037 End.X with NEXT-CSID, PSP & USP RFC 9800 IETF
56 0x0038 End.X with NEXT-CSID & USD RFC 9800 IETF
57 0x0039 End.X with NEXT-CSID, PSP & USD RFC 9800 IETF
58 0x003A End.X with NEXT-CSID, USP & USD RFC 9800 IETF
59 0x003B End.X with NEXT-CSID, PSP, USP & USD RFC 9800 IETF
60 0x003C uDX6 (End.DX6 with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
61 0x003D uDX4 (End.DX4 with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
62 0x003E uDT6 (End.DT6 with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
63 0x003F uDT4 (End.DT4 with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
64 0x0040 uDT46 (End.DT46 with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
65 0x0041 uDX2 (End.DX2 with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
66 0x0042 uDX2V (End.DX2V with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
67 0x0043 uDT2U (End.DT2U with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
68 0x0044 uDT2M (End.DT2M with NEXT-CSID) draft-filsfils-spring-net-pgm-extension-srv6-usid-10 Pablo Camarillo
69 0x0045 End.M.GTP6.D RFC 9433 IETF
70 0x0046 End.M.GTP6.Di RFC 9433 IETF
71 0x0047 End.M.GTP6.E RFC 9433 IETF
72 0x0048 End.M.GTP4.E RFC 9433 IETF
73 0x0049 End.DTM draft-agrawal-spring-srv6-mpls-interworking-05 Pablo Camarillo
74 0x004A End.M (Mirror SID) draft-ietf-rtgwg-srv6-egress-protection-02 IETF
75 0x004B End.Replicate RFC 9524 IETF
76 0x004C End.DTMC4 RFC 10018 IETF
77 0x004D End.DTMC6 RFC 10018 IETF
78 0x004E End.DTMC46 RFC 10018 IETF
79 0x004F End.BXC draft-han-spring-srv6-underlay-tunnel-programming-02 Ran Chen
80 0x0050 End.BXC with PSP draft-han-spring-srv6-underlay-tunnel-programming-02 Ran Chen
81 0x0051 End.BXC with USP draft-han-spring-srv6-underlay-tunnel-programming-02 Ran Chen
82 0x0052 End.BXC with USD draft-han-spring-srv6-underlay-tunnel-programming-02 Ran Chen
83 0x0053 End.BXC with PSP, USP & USD draft-han-spring-srv6-underlay-tunnel-programming-02 Ran Chen
84 0x0054 End.NSH - NSH Segment RFC 9491 IETF
85 0x0055 End.T with NEXT-CSID RFC 9800 IETF
86 0x0056 End.T with NEXT-CSID & PSP RFC 9800 IETF
87 0x0057 End.T with NEXT-CSID & USP RFC 9800 IETF
88 0x0058 End.T with NEXT-CSID, PSP & USP RFC 9800 IETF
89 0x0059 End.T with NEXT-CSID & USD RFC 9800 IETF
90 0x005A End.T with NEXT-CSID, PSP & USD RFC 9800 IETF
91 0x005B End.T with NEXT-CSID, USP & USD RFC 9800 IETF
92 0x005C End.T with NEXT-CSID, PSP, USP & USD RFC 9800 IETF
93 0x005D End.B6.Encaps with NEXT-CSID RFC 9800 IETF
94 0x005E End.B6.Encaps.Red with NEXT-CSID RFC 9800 IETF
95 0x005F End.BM with NEXT-CSID RFC 9800 IETF
96 0x0060 End.LBS with NEXT-CSID RFC 9800 IETF
97 0x0061 End.XLBS with NEXT-CSID RFC 9800 IETF
98 0x0062 End.B6.Encaps.Red with NEXT-CSID, PSP & USD Pablo Camarillo Pablo Camarillo
99 0x0063 End.B6.Insert.Red with NEXT-CSID, PSP & USD Pablo Camarillo Pablo Camarillo
100 0x0064 End.PSID draft-ietf-spring-srv6-path-segment-02 Cheng Li
101 0x0065 End with REPLACE-CSID RFC 9800 IETF
102 0x0066 End with REPLACE-CSID & PSP RFC 9800 IETF
103 0x0067 End with REPLACE-CSID & USP RFC 9800 IETF
104 0x0068 End with REPLACE-CSID, PSP & USP RFC 9800 IETF
105 0x0069 End.X with REPLACE-CSID RFC 9800 IETF
106 0x006A End.X with REPLACE-CSID & PSP RFC 9800 IETF
107 0x006B End.X with REPLACE-CSID & USP RFC 9800 IETF
108 0x006C End.X with REPLACE-CSID, PSP & USP RFC 9800 IETF
109 0x006D End.T with REPLACE-CSID RFC 9800 IETF
110 0x006E End.T with REPLACE-CSID & PSP RFC 9800 IETF
111 0x006F End.T with REPLACE-CSID & USP RFC 9800 IETF
112 0x0070 End.T with REPLACE-CSID, PSP & USP RFC 9800 IETF
113 0x0071 End.M with REPLACE-CSID draft-ietf-rtgwg-srv6-egress-protection-26 Tao He
114 0x0072 End.B6.Encaps with REPLACE-CSID RFC 9800 IETF
115 0x0073 End.BM with REPLACE-CSID RFC 9800 IETF
116 0x0074 End.DX6 with REPLACE-CSID RFC 9800 IETF
117 0x0075 End.DX4 with REPLACE-CSID RFC 9800 IETF
118 0x0076 End.DT6 with REPLACE-CSID RFC 9800 IETF
119 0x0077 End.DT4 with REPLACE-CSID RFC 9800 IETF
120 0x0078 End.DT46 with REPLACE-CSID RFC 9800 IETF
121 0x0079 End.DX2 with REPLACE-CSID RFC 9800 IETF
122 0x007A End.DX2V with REPLACE-CSID RFC 9800 IETF
123 0x007B End.DT2U with REPLACE-CSID RFC 9800 IETF
124 0x007C End.DT2M with REPLACE-CSID RFC 9800 IETF
125-126 0x007D-0x007E Unassigned
127 0x007F End.B6.Encaps.Red with REPLACE-CSID RFC 9800 IETF
128 0x0080 End with REPLACE-CSID & USD RFC 9800 IETF
129 0x0081 End with REPLACE-CSID, PSP & USD RFC 9800 IETF
130 0x0082 End with REPLACE-CSID, USP & USD RFC 9800 IETF
131 0x0083 End with REPLACE-CSID, PSP, USP & USD RFC 9800 IETF
132 0x0084 End.X with REPLACE-CSID & USD RFC 9800 IETF
133 0x0085 End.X with REPLACE-CSID, PSP & USD RFC 9800 IETF
134 0x0086 End.X with REPLACE-CSID, USP & USD RFC 9800 IETF
135 0x0087 End.X with REPLACE-CSID, PSP, USP & USD RFC 9800 IETF
136 0x0088 End.T with REPLACE-CSID & USD RFC 9800 IETF
137 0x0089 End.T with REPLACE-CSID, PSP & USD RFC 9800 IETF
138 0x008A End.T with REPLACE-CSID, USP & USD RFC 9800 IETF
139 0x008B End.T with REPLACE-CSID, PSP, USP & USD RFC 9800 IETF
140 0x008C End.LBS with REPLACE-CSID RFC 9800 IETF
141 0x008D End.XLBS with REPLACE-CSID RFC 9800 IETF
142 0x008E End.DTM46 draft-ietf-spring-srv6-mpls-interworking-02 IETF
143 0x008F End.DXM4 draft-ietf-spring-srv6-mpls-interworking-02 IETF
144 0x0090 End.DXM6 draft-ietf-spring-srv6-mpls-interworking-02 IETF
145 0x0091 End.DXM2 draft-ietf-spring-srv6-mpls-interworking-02 IETF
146-149 0x0092-0x0095 Unassigned
150 0x0096 End.XU draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
151 0x0097 End.XU with PSP draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
152 0x0098 End.XU with USP draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
153 0x0099 End.XU with USD draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
154 0x009A End.XU with PSP, USP & USD draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
155 0x009B End.XU with REPPLACE-CSID draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
156 0x009C End.XU with REPPLACE-CSID & PSP draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
157 0x009D End.XU with REPPLACE-CSID & PSP & USP & USD draft-dong-spring-srv6-inter-layer-programming-04 Jie Dong
158 0x009E End.DX1 RFC 9801 IETF
159 0x009F End.DX1 with NEXT-CSID RFC 9801 IETF
160 0x00A0 End.DX1 with REPLACE-CSID RFC 9801 IETF
161 0x00A1 End.AN - SR-aware function draft-ietf-spring-sr-service-programming-10 Francois Clad
162 0x00A2 End.AS - Static proxy draft-ietf-spring-sr-service-programming-10 Francois Clad
163 0x00A3 End.AD - Dynamic proxy draft-ietf-spring-sr-service-programming-10 Francois Clad
164 0x00A4 End.AM - Masquerading proxy draft-ietf-spring-sr-service-programming-10 Francois Clad
165 0x00A5 End.AM - Masquerading proxy with NAT draft-ietf-spring-sr-service-programming-10 Francois Clad
166 0x00A6 End.AM - Masquerading proxy with Caching draft-ietf-spring-sr-service-programming-10 Francois Clad
167 0x00A7 End.AM - Masquerading proxy with NAT & Caching draft-ietf-spring-sr-service-programming-10 Francois Clad
168 0x00A8 End.M.GTP6.E.Red draft-kawakami-dmm-srv6-gtp6e-reduced-02 Yuya Kawakami
169 0x00A9 End.AN.CI.S draft-lin-spring-srv6-aware-context-indicator-04 Jiaming Ye
170 0x00AA End.AN.CI.D.A draft-lin-spring-srv6-aware-context-indicator-04 Jiaming Ye
171 0x00AB End.AN.CI.D.T draft-lin-spring-srv6-aware-context-indicator-04 Jiaming Ye
172 0x00AC End.AN.CI.D.V draft-lin-spring-srv6-aware-context-indicator-04 Jiaming Ye
173 0x00AD End.AN.CI.D.D draft-lin-spring-srv6-aware-context-indicator-04 Jiaming Ye
174-179 0x00AE-0x00B3 Unassigned
180 0x00B4 End.AS with REPLACE-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
181 0x00B5 End.AS with NEXT-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
182 0x00B6 End.AD with REPLACE-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
183 0x00B7 End.AD with NEXT-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
184 0x00B8 End.AM with REPLACE-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
185 0x00B9 End.AM with NEXT-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
186 0x00BA End.AMN with REPLACE-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
187 0x00BB End.AMN with NEXT-CSID draft-lh-spring-srv6-sfc-csid-04 Cheng Li
188 0x00BC End.B6.Insert with NEXT‑CSID draft-chen-spring-srv6-compressed-bsid-insertion-03 Ran Chen
189 0x00BD End.B6.Insert.Red with NEXT‑CSID draft-chen-spring-srv6-compressed-bsid-insertion-03 Ran Chen
190-32766 0x00BE-0x7FFE Unassigned
32767 0x7FFF The SID defined in RFC 8754 RFC 8986; RFC 8754 IETF
32768-34815 0x8000-0x87FF Reserved for Private Use RFC 8986 IETF
34816-65534 0x8800-0xFFFE Reserved RFC 8986 IETF
65535 0xFFFF Opaque RFC 8986 IETF

Segment Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Ketan Talaulikar, Matthew Bocci

Reference

  • RFC 9256: Segment Routing Policy Architecture

Available Formats

Value Description Reference
A SR-MPLS Label RFC 9256
B SRv6 SID RFC 9256
C IPv4 Prefix with optional SR Algorithm RFC 9256
D IPv6 Global Prefix with optional SR Algorithm for SR-MPLS RFC 9256
E IPv4 Prefix with Local Interface ID RFC 9256
F IPv4 Addresses for link endpoints as Local, Remote pair RFC 9256
G IPv6 Prefix and Interface ID for link endpoints as Local, Remote pair for SR-MPLS RFC 9256
H IPv6 Addresses for link endpoints as Local, Remote pair for SR-MPLS RFC 9256
I IPv6 Global Prefix with optional SR Algorithm for SRv6 RFC 9256
J IPv6 Prefix and Interface ID for link endpoints as Local, Remote pair for SRv6 RFC 9256
K IPv6 Addresses for link endpoints as Local, Remote pair for SRv6 RFC 9256
L IPv4 Node Address and Local Interface ID with optional SR Algorithm for SR-MPLS (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
M IPv4 Addresses for link endpoints as Local, Remote pair with optional SR Algorithm for SR-MPLS (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
N IPv6 Node Addresses and Interface ID for link endpoints as Local, Remote pair, with optional SR Algorithm for SR-MPLS (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
O IPv6 Addresses for link endpoints as Local, Remote pair, with optional SR Algorithm for SR-MPLS (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05

SR Policy ENLP Values

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9830: Advertising Segment Routing Policies in BGP

Available Formats

Code Point Description Reference
0 Reserved RFC 9830
1 Push an IPv4 Explicit NULL label on an unlabeled IPv4 packet but do not push an IPv6 Explicit NULL label on an unlabeled IPv6 packet RFC 9830
2 Push an IPv6 Explicit NULL label on an unlabeled IPv6 packet but do not push an IPv4 Explicit NULL label on an unlabeled IPv4 packet RFC 9830
3 Push an IPv6 Explicit NULL label on an unlabeled IPv6 packet and push an IPv4 Explicit NULL label on an unlabeled IPv4 packet RFC 9830
4 Do not push an Explicit NULL label RFC 9830
5-255 Unassigned

SR Policy Protocol-Origin

Expert(s)

  • Unassigned

Reference

  • RFC 9857: Advertisement of Segment Routing Policies Using BGP - Link State

Available Formats

Range Registration Procedures
1-250 Expert Review
251-255 Private Use
Code Point Protocol Origin Reference Change Controller
0 Reserved RFC 9857 IETF
1 PCEP RFC 9857 IETF
2 BGP SR Policy RFC 9857 IETF
3 Configuration (CLI, YANG model via NETCONF, etc.) RFC 9857 IETF
4-9 Unassigned
10 PCEP (in PCEP or when BGP-LS Producer is PCE) RFC 9857 IETF
11-19 Unassigned
20 BGP SR Policy (in PCEP or when BGP-LS Producer is PCE) RFC 9857 IETF
21-29 Unassigned
30 Configuration (CLI, YANG model via NETCONF, etc. In PCEP or when BGP-LS Producer is PCE) RFC 9857 IETF
31-250 Unassigned
251-255 Reserved for Private Use RFC 9857 IETF

Contact Information

Name Contact URI Last Updated
Cheng Li c.l&huawei.com 2025-04-25
Francois Clad fclad.ietf&gmail.com 2024-01-18
Jiaming Ye yejiaming&chinamobile.com 2025-02-28
Jie Dong jie.dong&huawei.com 2022-10-14
Pablo Camarillo pcamaril&cisco.com 2023-01-13
Ran Chen chen.ran&zte.com.cn 2026-07-22
Tao He het21&chinaunicom.cn 2026-10-12
Yuya Kawakami yuyarin&yuyarin.net 2025-02-17