Simple Two-way Active Measurement Protocol (STAMP) TLV Types

Created

  • 2020-11-19

Last Updated

  • 2026-10-02

Available Formats


STAMP TLV Types

Reference

  • RFC 8972: Simple Two-Way Active Measurement Protocol Optional Extensions

Available Formats

Range Registration Procedures
1-175 IETF Review
176-239 First Come First Served
240-251 Experimental Use
252-254 Private Use
Value Description Reference
0 Reserved RFC 8972
1 Extra Padding RFC 8972
2 Location RFC 8972
3 Timestamp Information RFC 8972
4 Class of Service RFC 8972
5 Direct Measurement RFC 8972
6 Access Report RFC 8972
7 Follow-Up Telemetry RFC 8972
8 HMAC RFC 8972
9 Destination Node IPv4 or IPv6 Address RFC 9503
10 Return Path RFC 9503
11 Micro-session ID RFC 9534
12 Reflected Test Packet Control RFC 10052
13-239 Unassigned
240-251 Reserved for Experimental Use RFC 8972
252-254 Reserved for Private Use RFC 8972
255 Reserved RFC 8972

STAMP TLV Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8972: Simple Two-Way Active Measurement Protocol Optional Extensions

Available Formats

Bit Position Symbol Description Reference
0 U Unrecognized TLV RFC 8972
1 M Malformed TLV RFC 8972
2 I Integrity check failed RFC 8972
3 C Conformant RFC 10052
4-7 Unassigned

STAMP Sub-TLV Types

Reference

  • RFC 8972: Simple Two-Way Active Measurement Protocol Optional Extensions

Available Formats

Range Registration Procedures
1-175 IETF Review
176-239 First Come First Served
240-251 Experimental Use
252-254 Private Use
Value Description TLV Used Reference
0 Reserved RFC 8972
1 Source MAC Address Location RFC 8972
2 Source EUI-48 Address Location RFC 8972
3 Source EUI-64 Address Location RFC 8972
4 Destination IP Address Location RFC 8972
5 Destination IPv4 Address Location RFC 8972
6 Destination IPv6 Address Location RFC 8972
7 Source IP Address Location RFC 8972
8 Source IPv4 Address Location RFC 8972
9 Source IPv6 Address Location RFC 8972
10 Layer 2 Address Group Reflected Test Packet Control RFC 10052
11 Layer 3 Address Group Reflected Test Packet Control RFC 10052
12-239 Unassigned
240-251 Reserved for Experimental Use RFC 8972
252-254 Reserved for Private Use RFC 8972
255 Reserved RFC 8972

STAMP Synchronization Sources

Reference

  • RFC 8972: Simple Two-Way Active Measurement Protocol Optional Extensions

Available Formats

Range Registration Procedures
1-127 IETF Review
128-239 First Come First Served
240-249 Experimental Use
250-254 Private Use
Value Description Reference
0 Reserved RFC 8972
1 NTP RFC 8972
2 PTP RFC 8972
3 SSU/BITS RFC 8972
4 GPS/GLONASS/LORAN-C/BDS/Galileo RFC 8972
5 Local free-running RFC 8972
6-239 Unassigned
240-249 Reserved for Experimental Use RFC 8972
250-254 Reserved for Private Use RFC 8972
255 Reserved RFC 8972

STAMP Timestamping Methods

Reference

  • RFC 8972: Simple Two-Way Active Measurement Protocol Optional Extensions

Available Formats

Range Registration Procedures
1-127 IETF Review
128-239 First Come First Served
240-249 Experimental Use
250-254 Private Use
Value Description Reference
0 Reserved RFC 8972
1 HW Assist RFC 8972
2 SW Local RFC 8972
3 Control Plane RFC 8972
4-239 Unassigned
240-249 Reserved for Experimental Use RFC 8972
250-254 Reserved for Private Use RFC 8972
255 Reserved RFC 8972

STAMP Return Codes

Reference

  • RFC 8972: Simple Two-Way Active Measurement Protocol Optional Extensions

Available Formats

Range Registration Procedures
1-127 IETF Review
128-239 First Come First Served
240-249 Experimental Use
250-254 Private Use
Value Description Reference
0 Reserved RFC 8972
1 Network available RFC 8972
2 Network unavailable RFC 8972
3-239 Unassigned
240-249 Reserved for Experimental Use RFC 8972
250-254 Reserved for Private Use RFC 8972
255 Reserved

Return Path Sub-TLV Types

Reference

  • RFC 9503: Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Segment Routing Networks

Available Formats

Range Registration Procedures
1-175 IETF Review
176-239 First Come First Served
240-251 Experimental Use
252-254 Private Use
Value Description Reference
0 Reserved RFC 9503
1 Return Path Control Code RFC 9503
2 Return IPv4 or IPv6 Address RFC 9503
3 SR-MPLS Label Stack of the Return Path RFC 9503
4 SRv6 Segment List of the Return Path RFC 9503
5-239 Unassigned
240-251 Reserved for Experimental Use RFC 9503
252-254 Reserved for Private Use RFC 9503
255 Reserved RFC 9503

Return Path Control Code Flags

Reference

  • RFC 9503: Simple Two-Way Active Measurement Protocol (STAMP) Extensions for Segment Routing Networks

Available Formats

Range Registration Procedures
31-12 IETF Review
11-8 First Come First Served
7-4 Experimental Use
3-0 Private Use
Value Description Reference
31 Reply Request RFC 9503
30-8 Unassigned
7-4 Reserved for Experimental Use RFC 9503
3-0 Reserved for Private Use RFC 9503