Session Traversal Utilities for NAT (STUN) Parameters

Created

  • 2008-08-01

Last Updated

  • 2024-12-20

Available Formats


STUN Methods

Expert(s)

  • Dan Wing

Reference

  • RFC 8489: Session Traversal Utilities for NAT (STUN)
  • RFC 7983: Multiplexing Scheme Updates for Secure Real-time Transport Protocol (SRTP) Extension for Datagram Transport Layer Security (DTLS)

Available Formats

Range Registration Procedures
0x000-0x07F IETF Review
0x080-0x0FF Expert Review
Value Name Reference
0x000 Reserved RFC 8489
0x001 Binding RFC 8489
0x002 Reserved; was SharedSecret prior to RFC 5389 RFC 8489
0x003 Allocate RFC 8656
0x004 Refresh RFC 8656
0x005 Unassigned
0x006 Send RFC 8656
0x007 Data RFC 8656
0x008 CreatePermission RFC 8656
0x009 ChannelBind RFC 8656
0x00A Connect RFC 6062
0x00B ConnectionBind RFC 6062
0x00C ConnectionAttempt RFC 6062
0x00D-0x07F Unassigned
0x080 GOOG-PING Jonas Oreland
0x081-0x0FF Unassigned
0x100-0xFFF Reserved (For DTLS-SRTP multiplexing collision avoidance, see RFC 7983. Cannot be made available for assignment without IETF Review.) RFC 7983

STUN Attributes

Expert(s)

  • Dan Wing

Reference

  • RFC 8489: Session Traversal Utilities for NAT (STUN)

Available Formats

Range Registration Procedures Note
0x0000-0x3FFF IETF Review comprehension-required range
0x4000-0x7FFF Expert Review comprehension-required range
0x8000-0xBFFF IETF Review comprehension-optional range
0xC000-0xFFFF Expert Review comprehension-optional range
Value Name Reference
0x0000 Reserved RFC 8489
0x0001 MAPPED-ADDRESS RFC 8489
0x0002 Reserved; was RESPONSE-ADDRESS prior to RFC 5389 RFC 8489
0x0003 Reserved; was CHANGE-REQUEST prior to RFC 5389 RFC 5780; RFC Errata 4233
0x0004 Reserved; was SOURCE-ADDRESS prior to RFC 5389 RFC 8489
0x0005 Reserved; was CHANGED-ADDRESS prior to RFC 5389 RFC 8489
0x0006 USERNAME RFC 8489
0x0007 Reserved; was PASSWORD prior to RFC 5389 RFC 8489
0x0008 MESSAGE-INTEGRITY RFC 8489
0x0009 ERROR-CODE RFC 8489
0x000A UNKNOWN-ATTRIBUTES RFC 8489
0x000B Reserved; was REFLECTED-FROM prior to RFC 5389 RFC 8489
0x000C CHANNEL-NUMBER RFC 8656
0x000D LIFETIME RFC 8656
0x000E-0x000F Reserved
0x0010 Reserved (was BANDWIDTH) RFC 8656
0x0011 Reserved
0x0012 XOR-PEER-ADDRESS RFC 8656
0x0013 DATA RFC 8656
0x0014 REALM RFC 8489
0x0015 NONCE RFC 8489
0x0016 XOR-RELAYED-ADDRESS RFC 8656
0x0017 REQUESTED-ADDRESS-FAMILY RFC 8656
0x0018 EVEN-PORT RFC 8656
0x0019 REQUESTED-TRANSPORT RFC 8656
0x001A DONT-FRAGMENT RFC 8656
0x001B ACCESS-TOKEN RFC 7635
0x001C MESSAGE-INTEGRITY-SHA256 RFC 8489
0x001D PASSWORD-ALGORITHM RFC 8489
0x001E USERHASH RFC 8489
0x001F-0x001F Unassigned
0x0020 XOR-MAPPED-ADDRESS RFC 8489
0x0021 Reserved (was TIMER-VAL) RFC 8656
0x0022 RESERVATION-TOKEN RFC 8656
0x0023 Reserved
0x0024 PRIORITY RFC 8445
0x0025 USE-CANDIDATE RFC 8445
0x0026 PADDING RFC 5780
0x0027 RESPONSE-PORT RFC 5780
0x0028-0x0029 Reserved
0x002A CONNECTION-ID RFC 6062
0x002B-0x002F Unassigned
0x0030 Reserved
0x0031-0x7FFF Unassigned
0x8000 ADDITIONAL-ADDRESS-FAMILY RFC 8656
0x8001 ADDRESS-ERROR-CODE RFC 8656
0x8002 PASSWORD-ALGORITHMS RFC 8489
0x8003 ALTERNATE-DOMAIN RFC 8489
0x8004 ICMP RFC 8656
0x8005-0x8021 Unassigned
0x8022 SOFTWARE RFC 8489
0x8023 ALTERNATE-SERVER RFC 8489
0x8024 Reserved
0x8025 TRANSACTION_TRANSMIT_COUNTER RFC 7982
0x8026 Reserved
0x8027 CACHE-TIMEOUT RFC 5780
0x8028 FINGERPRINT RFC 8489
0x8029 ICE-CONTROLLED RFC 8445
0x802A ICE-CONTROLLING RFC 8445
0x802B RESPONSE-ORIGIN RFC 5780
0x802C OTHER-ADDRESS RFC 5780
0x802D ECN-CHECK STUN RFC 6679
0x802E THIRD-PARTY-AUTHORIZATION RFC 7635
0x802F Unassigned
0x8030 MOBILITY-TICKET RFC 8016
0x8031-0xBFFF Unassigned
0xC000 CISCO-STUN-FLOWDATA Dan Wing
0xC001 ENF-FLOW-DESCRIPTION Pål-Erik Martinsen
0xC002 ENF-NETWORK-STATUS Pål-Erik Martinsen
0xC003 CISCO-WEBEX-FLOW-INFO Stefano Giorcelli
0xC004-0xC055 Unassigned
0xC056 CITRIX-TRANSACTION-ID Paras Babbar
0xC057 GOOG-NETWORK-INFO Jonas Oreland
0xC058 GOOG-LAST-ICE-CHECK-RECEIVED Jonas Oreland
0xC059 GOOG-MISC-INFO Jonas Oreland
0xC05A GOOG-OBSOLETE-1 Jonas Oreland
0xC05B GOOG-CONNECTION-ID Jonas Oreland
0xC05C GOOG-DELTA Jonas Oreland
0xC05D GOOG-DELTA-ACK Jonas Oreland
0xC05E GOOG-DELTA-SYNC-REQ Jonas Oreland
0xC05F Unassigned
0xC060 GOOG-MESSAGE-INTEGRITY-32 Jonas Oreland
0xC061-0xC06F Unassigned
0xC070 META-DTLS-IN-STUN Philipp Hancke
0xC071 META-DTLS-IN-STUN-ACKNOWLEDGEMENT Philipp Hancke
0xC072-0xFFFF Unassigned

STUN Error Codes

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8489: Session Traversal Utilities for NAT (STUN)

Available Formats

Value Name Reference
0-299 Reserved
300 Try Alternate RFC 8489
301-399 Unassigned
400 Bad Request RFC 8489
401 Unauthenticated RFC 8489
402 Unassigned
403 Forbidden RFC 8656
404 Unassigned
405 Mobility Forbidden RFC 8016
406-419 Unassigned
420 Unknown Attribute RFC 8489
421-436 Unassigned
437 Allocation Mismatch RFC 8656
438 Stale Nonce RFC 8489
439 Unassigned
440 Address Family not Supported RFC 8656
441 Wrong Credentials RFC 8656
442 Unsupported Transport Protocol RFC 8656
443 Peer Address Family Mismatch RFC 8656
444-445 Unassigned
446 Connection Already Exists RFC 6062
447 Connection Timeout or Failure RFC 6062
448-485 Unassigned
486 Allocation Quota Reached RFC 8656
487 Role Conflict RFC 8445
488-499 Unassigned
500 Server Error RFC 8489
501-507 Unassigned
508 Insufficient Capacity RFC 8656
509-699 Unassigned

Traversal Using Relays around NAT (TURN) Channel Numbers

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7983: Multiplexing Scheme Updates for Secure Real-time Transport Protocol (SRTP) Extension for Datagram Transport Layer Security (DTLS)
  • RFC 8656: Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)

Note

Values 0x0000 through 0x3FFF are not available for use, since they conflict with the STUN header.

Available Formats

Value Name Reference
0x0000-0x3FFF Reserved RFC 8656
0x4000-0x4FFF Used by TURN RFC 8656
0x5000-0xFFFF Reserved (For DTLS-SRTP multiplexing collision avoidance, see RFC 7983) RFC 7983

STUN Security Features

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8489: Session Traversal Utilities for NAT (STUN)

Available Formats

Bit Name Reference
0 Password algorithms RFC 8489
1 Username anonymity RFC 8489
2-23 Unassigned

STUN Password Algorithms

Expert(s)

  • Dan Wing

Reference

  • RFC 8489: Session Traversal Utilities for NAT (STUN)

Available Formats

Range Registration Procedures
0x0000-0x7FFF IETF Review
0x8000-0xFFFF Expert Review
Value Name Reference
0x0000 Reserved RFC 8489
0x0001 MD5 RFC 8489
0x0002 SHA-256 RFC 8489
0x0003-0xFFFF Unassigned

Contact Information

Name Contact URI Last Updated
Dan Wing danwing&gmail.com 2022-10-14
Jonas Oreland jonaso&google.com 2023-03-20
Pål-Erik Martinsen palmarti&cisco.com 2016-04-20
Paras Babbar Paras.Babbar&cloud.com 2023-12-18
Philipp Hancke phancke&meta.com 2024-12-20
Stefano Giorcelli stefanog&cisco.com 2023-12-07