Service Location Protocol Extensions, Version 2 (SLPv2)

Created

  • 2000-10

Last Updated

  • 2009-07-13

Available Formats


SLPv2 Extension IDs

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Erik Guttman

Reference

  • RFC 2608: Service Location Protocol, Version 2

Note

See RFC 2608 for the specification of SLPv2 and how it can be extended. New SLP Extensions with types in the range 2-65535 may be registered following review by a Designated Expert. Please submit new extension requests to iana&iana.org with "SVRLOC-Extension Request" in the subject field.

Available Formats

ID # Extension Name Note Contact Reference
0x0001 Attribute Missing SAs or DAs which receive a SrvReg or SrvRqst which omits an attribute which is marked 'required' in the Service Template associated with the service type MAY send this extension to warn the message sender. Erik Guttman RFC 2609
0x0002 Attribute List UAs may request and obtain attribute lists along with Service Replies. Erik Guttman RFC 3059
0x0003 Vendor Opaque Vendors may attach specific extensions to SLP messages for their own purposes. Erik Guttman RFC 3224
0x0004 Subscribe UAs request DAs inform them when services of a particular service type and scope appear or disappear. James Kempf RFC 3082
0x0005 NotifyAt DAs inform SAs what service types and scopes to multicast notifications for, and which multicast groups to use. James Kempf RFC 3082
0x0006 Mesh-enhancement DA mesh control messages are sent as extensions to DAAdvert messages between mesh-enhanced DAs. Weibin Zhao RFC 3528
0x4001 SLP Local Service Autoderegistration Extension This extension effects SrvReg messages sent from a local SA client to a SA server (as described by draft-kempf-svrloc-rfc2614bis-01). A process ID is included. The SA will deregister the service if the process ID is no longer valid. Matt Peterson none available
0x4002 Select UAs use this extension in a SrvRqst to request DAs/SAs limit the maximum number of URL entries in the corresponding SrvRply. DAs/SAs use this extension in a SrvRply to inform UAs the total number of matching URL entries. Weibin Zhao RFC 3421
0x4003 Sort UAs use this extension in a SrvRqst to request DAs/SAs sort the URL entries in the corresponding SrvRply according to to the specified sort key list. Weibin Zhao RFC 3421
0x4004-0x7FFF Unassigned

Contact Information

Name Contact URI Last Updated
Matt Peterson matt&caldera.com
James Kempf james.kempf&ericsson.com
Erik Guttman erik&spybeam.org
Weibin Zhao zwb&cs.columbia.edu